Subject: [Int-area] (REVISED) Call for adoption of draft-bonica-intarea-gre-mtu-06

From: Suresh Krishnan <[email-masked]>
Date: Tue, 9 Sep 2014 04:17:18 +0000

Hi all,
    This draft has been presented at intarea face to face meetings and 
has received a bit of discussion. This call is being initiated to 
determine whether there is WG consensus towards adoption of
draft-bonica-intarea-gre-mtu-06 as an intarea WG draft. The draft is 
available at

http://tools.ietf.org/html/draft-bonica-intarea-gre-mtu-06

Please state whether or not you're in favor of the adoption by replying 
to this email. If you are not in favor, please also state your 
objections in your response. This adoption call will complete on 2014-09-23.

Regards
Suresh & Juan Carlos

---

From: Joe Touch <[email-masked]>
Date: Tue, 09 Sep 2014 17:09:22 -0700

+1, admittedly as a co-author.

Joe

On 9/8/2014 9:17 PM, Suresh Krishnan wrote:
> _______________________________________________
> Int-area mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/int-area
>

---

From: Mikael Abrahamsson <[email-masked]>
Date: Wed, 10 Sep 2014 08:29:26 +0200 (CEST)

> objections in your response. This adoption call will complete on 2014-09-23.

I believe in compatibility between vendors, so documenting this is great. 
I am in favor of adoption.

However, RFC 2784 doesn't describe GRE over IPv6, and the above draft 
talks about GRE tunneling over IPv6 in 3.3.2.2, which as far as I can 
find, isn't documented anywhere in an RFC. Could someone please do this?

-- 
Mikael Abrahamsson    email: [email-masked]

---

From: Ross Callon <[email-masked]>
Date: Wed, 10 Sep 2014 16:33:25 +0000

I support adoption of this draft. 

I think that this draft is useful in that it documents current practice, which can be valuable in multiple ways (encourage interoperability, allow wider understanding of potential issues with current practice, ...). 

Thanks, Ross

-----Original Message-----
From: Int-area [mailto:[email-masked]] On Behalf Of Suresh Krishnan
Sent: Tuesday, September 09, 2014 12:17 AM
To: Internet Area
Subject: [Int-area] (REVISED) Call for adoption of draft-bonica-intarea-gre-mtu-06

Hi all,

Regards
Suresh & Juan Carlos

---

From: Linda Dunbar <[email-masked]>
Date: Wed, 10 Sep 2014 16:38:28 +0000

I think that this draft is very useful, especially to SFC, NVO3 WGs. Those groups are defining new encapsulation headers.  MTU issues & practices should be visible to the participants of those groups. 

Linda Dunbar

-----Original Message-----
From: Int-area [mailto:[email-masked]] On Behalf Of Suresh Krishnan
Sent: Tuesday, September 09, 2014 12:17 AM
To: Internet Area
Subject: [Int-area] (REVISED) Call for adoption of draft-bonica-intarea-gre-mtu-06

Hi all,
    This draft has been presented at intarea face to face meetings and has received a bit of discussion. This call is being initiated to determine whether there is WG consensus towards adoption of
draft-bonica-intarea-gre-mtu-06 as an intarea WG draft. The draft is available at

Please state whether or not you're in favor of the adoption by replying to this email. If you are not in favor, please also state your objections in your response. This adoption call will complete on 2014-09-23.

Regards
Suresh & Juan Carlos

---

From: "Templin, Fred L" <[email-masked]>
Date: Wed, 10 Sep 2014 19:15:30 +0000

I will say again what I said at the microphone in Toronto. We really
ought to move forward with "Tunnels in the Internet Architecture"
first so that other documents that discuss specific tunnel types
can use it as a point of departure (if necessary).

So, let's have Tunnels in the Internet Architecture brought back
onto the front burner first so that other documents that come later
can use it as a normative reference.

Thanks - Fred
[email-masked]

> Sent: Monday, September 08, 2014 9:17 PM
> To: Internet Area

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Tue, 30 Sep 2014 13:41:28 +0000

Mikael,

On Sep 10, 2014, at 2:29 AM, Mikael Abrahamsson <[email-masked]> wrote:

> I believe in compatibility between vendors, so documenting this is great. I am in favor of adoption.
> 
> However, RFC 2784 doesn't describe GRE over IPv6, and the above draft talks about GRE tunneling over IPv6 in 3.3.2.2, which as far as I can find, isn't documented anywhere in an RFC. Could someone please do this?
> 

This is a great catch.

Ron and I just posted a very short doc for specs to catch up. All comments most welcome:
https://datatracker.ietf.org/doc/draft-pignataro-intarea-gre-ipv6/?include_text=1

Thanks,

Carlos.

---

From: Jeffery Hammond <[email-masked]>
Date: Tue, 30 Sep 2014 20:07:59 +0000

I would like to see this also. Just went back and pulled the draft dated 3/5/2010 (I hope this is the latest one draft-touch-intarea-tunnels-01). It would be a good starting point. As this will only continue to grow and a central base and description would be nice.
	Other than I.P. in I.P. (GTP) and IPSec what other tunneling technologies would be considered?

Jeff Hammond
Samsung System Engineer

-----Original Message-----
From: Int-area [mailto:[email-masked]] On Behalf Of Templin, Fred L
Sent: Wednesday, September 10, 2014 2:16 PM
To: Suresh Krishnan; Internet Area
Subject: Re: [Int-area] (REVISED) Call for adoption of draft-bonica-intarea-gre-mtu-06

I will say again what I said at the microphone in Toronto. We really ought to move forward with "Tunnels in the Internet Architecture"
first so that other documents that discuss specific tunnel types can use it as a point of departure (if necessary).

So, let's have Tunnels in the Internet Architecture brought back onto the front burner first so that other documents that come later can use it as a normative reference.

Thanks - Fred

> Please state whether or not you're in favor of the adoption by 
> replying to this email. If you are not in favor, please also state 
> your objections in your response. This adoption call will complete on 2014-09-23.
> 
> Regards
> Suresh & Juan Carlos
> 
> 
> 
>

---

From: "Templin, Fred L" <[email-masked]>
Date: Tue, 30 Sep 2014 21:34:24 +0000

Hi Jeff,

> From: Int-area [mailto:[email-masked]] On Behalf Of Jeffery Hammond
> Sent: Tuesday, September 30, 2014 1:08 PM
> To: 'Internet Area'
> 	I would like to see this also. Just went back and pulled the draft dated 3/5/2010 (I hope this is the latest one draft-touch-
> intarea-tunnels-01). It would be a good starting point. As this will only continue to grow and a central base and description would be
> nice.

Agreed.

> 	Other than I.P. in I.P. (GTP) and IPSec what other tunneling technologies would be considered?

There are lots and lots of them; way more than just GRE. Some kinds that operate
over UDP/IP are in some ways more flexible than just IP-in-IP since  the network
is so ossified around TCP and UDP. But, we should be able to come up with a set
of BCP recommendations that apply to all tunnel types.

Thanks - Fred