Subject: [Int-area] FW: Google Statistics for IPv6 adoption.

From: Khaled Omar <[email-masked]>
Date: Sat, 15 Apr 2017 14:57:06 +0000

-----Original Message-----
From: Khaled Omar [mailto:[email-masked]] 
Sent: Saturday, April 15, 2017 3:09 PM
To: int-area
Cc: intarea-ads; intarea-chairs; ietf
Subject: Google Statistics for IPv6 adoption.

Hi all,

Please check out this link that shows the statistics of the IPv6 adoption over the past 10 years maybe it will make you believe what was said earlier.

 https://www.google.com/intl/en/ipv6/statistics.html

Recent IPv6 adoption (April, 2017) is:
14.83% Native - 0.03% 6to4 - 14.87% Total

Best regards,

Khaled Omar

---

From: Tom Herbert <[email-masked]>
Date: Sat, 15 Apr 2017 08:58:25 -0700

> Please check out this link that shows the statistics of the IPv6 adoption over the past 10 years maybe it will make you believe what was said earlier.
If you carefully at those graphs it's obvious that there has been
exponential growth of IPv6 over the past ten years and we're still on
the exponential part of the curve. The data does not support the idea
that design, implementation, and deployment of another IP version is
needed to solve the problem of IPv6 adoption.

Tom

> _______________________________________________
> Int-area mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/int-area

---

From: Khaled Omar <[email-masked]>
Date: Sat, 15 Apr 2017 16:08:35 +0000

Hi Tom,

If there growth will be about 5% for each year, then the full migration will be accomplished after 17 years, during this period, internet hosts will face the division problem and will not have full access to all resources, which mean the internet will be worse.

Using IPv10 during this 17 years can be the solution, if the growth of IPv6 will grow rapidly, then IPv10 will disappear automatically after all hosts are using IPv6, and all Internet hosts will be automatically IPv6 hosts instead of IPv10 hosts, no intervention will be required.

Best Regards,

-----Original Message-----
From: Tom Herbert [mailto:[email-masked]] 
Sent: Saturday, April 15, 2017 5:58 PM
To: Khaled Omar
Cc: [email-masked]
Subject: Re: [Int-area] FW: Google Statistics for IPv6 adoption.

> Please check out this link that shows the statistics of the IPv6 adoption over the past 10 years maybe it will make you believe what was said earlier.
If you carefully at those graphs it's obvious that there has been exponential growth of IPv6 over the past ten years and we're still on the exponential part of the curve. The data does not support the idea that design, implementation, and deployment of another IP version is needed to solve the problem of IPv6 adoption.

Tom

---

From: Tom Herbert <[email-masked]>
Date: Sat, 15 Apr 2017 12:43:19 -0700

> Using IPv10 during this 17 years can be the solution, if the growth of IPv6 will grow rapidly, then IPv10 will disappear automatically after all hosts are using IPv6, and all Internet hosts will be…
Again, you seem eager to completely disregard the realities of
deploying a new protocol on the Internet. You said yourself that IPv10
requires changes to all hosts and routers. That is a _huge_ deal and
such an undertaken would take _longer_ to deploy than just get IPv6
universally deployed. All hosts and routers support IPv6 at this
point, continued adoption is a matter of enabling the protocol in
networks.

Khaled, you obviously have a lot energy and passion for the problem,
but there's simply no logic and no data that supports an IPv10
protocol. I'd suggest you look more closely into current IPv6
deployment issues and see if there's problems there you might want to
tackle.

Tom