Subject: Re: [Int-area] WG Adoption Call: Extended Ping (Xping)

From: Ron Bonica <[email-masked]>
Date: Thu, 27 Apr 2017 18:52:39 +0000

Hi Carlos,

Thanks for the review. 

Regarding comment 1), I agree completely.

I didn't know that there were any other utilities called "Extended Ping". Could you send me a pointer.

I never liked the name XPING, anyway.  Can you suggest a better name?  Maybe "probe"?

The following also come to mind:

- ahoy
- hola
- ciao 

But maybe they are too cute?

                                  Ron

> 
> Message: 1
> Date: Sun, 23 Apr 2017 01:24:23 +0000
> From: "Carlos Pignataro (cpignata)" <[email-masked]>
> To: Wassim Haddad <[email-masked]>
> Cc: "[email-masked]" <[email-masked]>, "[email-masked]"
> 	<[email-masked]>
> Subject: Re: [Int-area] WG Adoption Call: Extended Ping (Xping)
> Message-ID: <[email-masked]>
> Content-Type: text/plain; charset="utf-8"
> 
> Hi,
> 
> This document aims at addressing a real operational problem, describing a
> very useful approach.
> 
> I support its adoption by Int-area.
> 
> That said, three comments:
> 
>   1.  Given the generally applicable tool it describes, an ?Implementation
> Status? Section [RFC 7942] ought to be included.
>   2.  The name ?extended ping? and short name ?xping? are currently used
> by other tools and methods. Is this *the* extended ping? Or a different
> name?
>   3.  I send a few comments on the next detail-level to the authors directly.
> 
> Thanks!
> 
> ? Carlos.
>

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Thu, 27 Apr 2017 20:29:24 +0000

Hi, Ron,

Anytime!

“Extended Ping” is the name for the interactive version of the ping utility. A search engine seems to find a bunch of others (it is a natural extension for a name :-)

This particular utility seems to have less commonality to `ping` than to an atomic query for remote operational state. For example, in a topology like A-----IPv4_only_net-----B, where B has an IPv6 interface. If xping is sent as an ICMPv4, querying for an IPv6 interface, will it return “Up” even though there is no IP connectivity to that interface?

If so, that’s less a probe and more a get_interface_state.

That could otherwise be two different reports, one for path connectivity and the other for interface state, without agglutinating them or mixing AFs.

I must say though that I actually really like the salutation-themed naming. Konnichiwa is perhaps too long… Yo? Hey? Too informal… :-) It is a sort-of AYU (Are You Up?)

— Carlos.

> On Apr 27, 2017, at 2:52 PM, Ron Bonica <[email-masked]> wrote:
> 
> Hi Carlos,
> 
> Thanks for the review. 
> 
> _______________________________________________
> Int-area mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/int-area