Subject: [Int-area] Stopping IPv10 Discussion.

From: Khaled Omar <[email-masked]>
Date: Sun, 2 Apr 2017 14:04:38 +0000

Dear all,

Thanks for your constructive and destructive opinions, of course it is not a waste of time, but what is not interesting is that some people participates on the discussion and they even not interested on it, so why you participate if you think it is a bad, not applicable, waste of time, etc.

What is funny is that some people think there is no problem at all and he still think after more than 17 years that IPv6 will dominate on the internet traffic soon and new clients will not have a problem accessing all resources on the internet, so how can I keep discussing with these views that is based on wrong facts! I cannot keep convincing people who insists that what shines in the morning is the moon not the sun.

So please let's stop the IPv10 menial discussion that makes no progress, or even no suggestions offered or a respectful replacement solution for that problem and waits for the Chairs decision because I'm busy now with KHALED Routing Protocol (KRP) and want to finish it soon as I'm not expecting participants from the IETF and this new EGP is almost done with 90% of its completion.

Thanks all,

---

From: Khaled Omar <[email-masked]>
Date: Sun, 2 Apr 2017 16:46:58 +0000

Yes, forget about my proposals, I don't need them to be discussed by the ietf, chairs, or any group.

-----Original Message-----
From: Ted Lemon [mailto:[email-masked]] 
Sent: Sunday, April 2, 2017 4:49 PM
To: Khaled Omar
Subject: Re: [Int-area] Stopping IPv10 Discussion.

If you are interested in doing real work with the IETF, you should pay a little bit of respect to our culture.   The IETF culture is an egalitarian culture.   Our motto is "We do not believe in kings or presidents. We believe in rough consensus and running code."

The idea of naming a protocol "Khaled's Protocol" is simply not something that could ever happen within the IETF.   If you want to invent "Khaled's Protocol," the IETF is not the place to invent it.   Protocols developed (not invented!) in the IETF are developed _by the IETF_, not by Khaled or by Ted.

When you talk about waiting for the working group chairs to make a decision, you are misunderstanding the process.   Working group chairs do not make decisions.   Working group chairs try to figure out what the decision is that has been made by the group.   So if everybody but one person in the group says "this is a bad idea," then the working group chairs have no choice in the matter: they have to say no.

The IETF as a whole has actually paid you a great deal of respect, although I'm sure it does not feel that way.   Christian read your draft carefully.   That is unusual: normally nobody reads an individual submission unless there is some belief within the working group that it is a good idea.   He did it because you've been so disrespectful of the IETF process.   Ironically, this is another part of the IETF culture: sometimes being disrespectful, as you have been, is the right thing to do: it gets people to consider your ideas when being respectful isn't working.

But the limit of this approach is that your idea has to be convincing.   When people take a close look at it, it has to stand up to inspection, and it has to be something that others become enthusiastic about supporting.   That has not happened here.   Several senior IETF participants have given you their time and their respect, but the outcome has been that your ideas were not convincing to them.

You can take this in one of three ways.   First, you can simply decide that we are bad people who are being unfair to you.   It would be a shame if you did that, because that would prevent you from participating in the IETF.   Second, you can give up on the IETF.   I think that would be a shame too.  

Your third option is to learn to approach the IETF with humility.   Do not assume that you are smarter than the people you are talking to.   Do not assume that your idea is better.   Do not assume that we are not in favor of your idea because we are bad people, or because we do not like you.   Instead, listen to the criticism and learn from it.   Change your ideas in response to the criticism.   If you think the criticism is wrong, be ready to explain why it is wrong, and have data to back up what you are saying.

The IETF tries very hard to be inclusive, and we are enthusiastic about helping new participants to learn how to join in our activities.   If you are willing to meet us halfway, it can be a very good relationship.   But you can never be a prince here.   The best you can hope for is to be one of us.