Subject: Re: [Int-area] Google Statistics for IPv6 adoption.

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Sat, 15 Apr 2017 23:20:56 +0200

Stats are always a reference, but if you look only to a single data set, you will have a broken view.

Look at the data of the mobile operators in many countries, that only deliver IPv6 connectivity, such as US, India, few EU countries, now Japan, or even wireline providers in every continent of the world, that have IPv6 penetration figures much higher than what Google average is showing.

For those that work every day deploying IPv6 since many years ago, we have seen a trend change, the light at the end of the tunnel, already a few years ago.

Regards,
Jordi

-----Mensaje original-----
De: Int-area <[email-masked]> en nombre de Khaled Omar <[email-masked]>
Responder a: <[email-masked]>
Fecha: sábado, 15 de abril de 2017, 19:52
Para: Christopher Morrow <[email-masked]>
CC: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Asunto: Re: [Int-area] Google Statistics for IPv6 adoption.

    Hi Christopher,
     
    'what was said earlier' - citation requested.
     
    What I said means that since I wrote the IPv10 I-D on Google blogger, I wrote that the deployment of IPv6 is about 5% of the Internet traffic, and I got responses from some IETF members Just claiming that this is a wrong percentage and
     the real exceeds 60% and gave me some examples of mobile providers’ statistics.
     
    So, this Google statistics confirms what I had said earlier because I got this percent from some online statistics that belongs to the IP address assignment process.
     
    I would like to thank Google for the efforts made to make this measurements and provide a respectful and real statistics that describes the recent situation so we can make decisions based on it.
     
    Best Regards,
     
    Khaled Omar 

    From: [email-masked] [mailto:[email-masked]]
    On Behalf Of Christopher Morrow
    Sent: Saturday, April 15, 2017 7:16 PM
    To: Khaled Omar
    Cc: int-area; intarea-ads; ietf; intarea-chairs
    Subject: Re: Google Statistics for IPv6 adoption.

    On Sat, Apr 15, 2017 at 9:09 AM, Khaled Omar <[email-masked]> wrote:
    
    Hi all,
    
    Please check out this link that shows the statistics of the IPv6 adoption over the past 10 years maybe it will make you believe what was said earlier.

    
    'what was said earlier' - citation requested.

     https://www.google.com/intl/en/ipv6/statistics.html
    
    Recent IPv6 adoption (April, 2017) is:
    14.83% Native - 0.03% 6to4 - 14.87% Total
    
    Best regards,
    
    Khaled Omar

    

    _______________________________________________
    Int-area mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/int-area

**********************************************
IPv4 is over
Are you ready for the new Internet ?
http://www.consulintel.es
The IPv6 Company

This electronic message contains information which may be privileged or confidential. The information is intended to be for the use of the individual(s) named above. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, including attached files, is prohibited.

---

From: Khaled Omar <[email-masked]>
Date: Sun, 16 Apr 2017 01:31:03 +0000

Hi Jordi,

Internet is a global network that covers the whole world (of course it is known by all), a single host that resides in one region should access resources everywhere, it will be a shame when this one host can access only resources from the same IP version that he uses.

It is good that IPv6 is deployed on the most well-known websites (such as Google, Facebook, etc.) but that doesn't mean that the Internet is only websites, there are many other resources (services), eventually all must be assigned an IP address.

The case is to allow IPv4 only hosts to communicate with IPv6 only hosts (for 6-to-6 and 4-to-4 is not the problem), so deploying a solution for that division problem should be introduced ASAP or the Internet will have a bad reputation due to the separation between hosts.

The IETF should take that responsibility over the shoulder, because think about those with IPv6 only address, they can access only 15% of the Internet, will they have to wait some other years to be able to access everything on the Internet, I don't think they should do that.

Anyway, I think the solution is on your hands now, the decision to publish it is not my responsibility, but I'm sure a solution will be found for this problem regardless it will be IPv10 or something else.

Best Regards,

Khaled Omar

-----Original Message-----
From: ietf [mailto:[email-masked]] On Behalf Of JORDI PALET MARTINEZ
Sent: Saturday, April 15, 2017 11:21 PM
To: [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [Int-area] Google Statistics for IPv6 adoption.

Regards,
Jordi

-----Mensaje original-----
De: Int-area <[email-masked]> en nombre de Khaled Omar <[email-masked]> Responder a: <[email-masked]>
Fecha: sábado, 15 de abril de 2017, 19:52
Para: Christopher Morrow <[email-masked]>
CC: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Asunto: Re: [Int-area] Google Statistics for IPv6 adoption.

    Hi Christopher,

     

    Best Regards,
     
    Khaled Omar 

     
    
    Hi all,

     

    

    
    Best regards,
    
    Khaled Omar

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Sun, 16 Apr 2017 10:32:30 +0200

And actually, in general, nobody complains that any hosts in IPv4 is not able to access resources at IPv6 hosts. This is why we have the transition mechanism, that are being deployed in parallel to the IPv6 deployment.

Nobody is so crazy to just deploy IPv6 and do not provide those transition mechanisms.

If that happens, clearly is the fault of somebody that doesn’t know how to do his job. This can happen exactly the same if your protocol becomes approved and some folks don’t update their hosts or routers to comply with your protocol, right?

Saludos,
Jordi

-----Mensaje original-----
De: Khaled Omar <[email-masked]>
Responder a: <[email-masked]>
Fecha: domingo, 16 de abril de 2017, 3:31
Para: "[email-masked]" <[email-masked]>
CC: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Asunto: RE: [Int-area] Google Statistics for IPv6 adoption.

    Hi Jordi,

    

    
    Best Regards,
    
    Khaled Omar
    
    -----Original Message-----
    From: ietf [mailto:[email-masked]] On Behalf Of JORDI PALET MARTINEZ
    Sent: Saturday, April 15, 2017 11:21 PM
    To: [email-masked]; [email-masked]; [email-masked]; [email-masked]
    Subject: Re: [Int-area] Google Statistics for IPv6 adoption.

    
    
    Regards,
    Jordi

    -----Mensaje original-----
    De: Int-area <[email-masked]> en nombre de Khaled Omar <[email-masked]> Responder a: <[email-masked]>
    Fecha: sábado, 15 de abril de 2017, 19:52
    Para: Christopher Morrow <[email-masked]>
    CC: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
    Asunto: Re: [Int-area] Google Statistics for IPv6 adoption.
    
        Hi Christopher,

         

        Best Regards,
         
        Khaled Omar 

         
        
        Hi all,

         

        

        
        Best regards,
        
        Khaled Omar

---

From: [email-masked]
Date: Sun, 16 Apr 2017 14:06:29 +0200

Jordi,

> And actually, in general, nobody complains that any hosts in IPv4 is not able to access resources at IPv6 hosts. This is why we have the transition mechanism, that are being deployed in parallel to…

This is not true.
The plan was for a short period where hosts were dual stack and then as soon as IPv6 was everywhere, turn IPv4 off.
That's not where we are. I would expect the number of  IPv6 only networks and services to grow. Possibly without IPv4 support at all, or where the cost and responsibility of legacy support will be pushed out towards the IPv4 only users.

> If that happens, clearly is the fault of somebody that doesn’t know how to do his job. This can happen exactly the same if your protocol becomes approved and some folks don’t update their hosts or…

The transition has turned out to be a real pain.
I understand the problem Khaled set out to solve.
Unfortunately his solution is not practical nor deployable.
And we have in fact tried many of the same flavours of solution before.
Given Khaled's apparent non-interest in two-way communication I wouldn't imagine any number of emails would help in that regard.

Best regards,
Ole

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Sun, 16 Apr 2017 15:05:35 +0200

I agree that that was the plan (and it is in the medium term), but my response is to Khaled specific point that seems to say (I understood that at least) that only 15% can access (now) to IPv6-only.

Regards,
Jordi

-----Mensaje original-----
De: ietf <[email-masked]> en nombre de <[email-masked]>
Responder a: <[email-masked]>
Fecha: domingo, 16 de abril de 2017, 14:06
Para: <[email-masked]>
CC: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Asunto: Re: [Int-area] Google Statistics for IPv6 adoption.

    Jordi,

    This is not true.

    
    Best regards,
    Ole

---

From: Khaled Omar <[email-masked]>
Date: Sun, 16 Apr 2017 15:15:27 +0000

Hi Ole,

That's true.

> > If that happens, clearly is the fault of somebody that doesn’t know how to do his job. This can happen exactly the same if your protocol becomes approved and some folks don’t update their hosts o…

That's right, and there should be a place like the IETF that should organize this process until all technology companies prepare the updates and there should be a flag day for the deployment,
If a host still not updated, will not gain access to the Internet until updating the OS.

Best regards,

Khaled Omar

-----Original Message-----
From: ietf [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Sunday, April 16, 2017 2:06 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [Int-area] Google Statistics for IPv6 adoption.

Jordi,

This is not true.

Best regards,
Ole

---

From: Khaled Omar <[email-masked]>
Date: Sun, 16 Apr 2017 15:18:47 +0000

Jordi,

> I agree that that was the plan (and it is in the medium term), but my response is to Khaled specific point that seems to say (I understood that at least) that only 15% can access (now) to IPv6-only.

Think about when the percentage will be 50%, it will be a real division for the internet for both IPv4 only and IPv6 only hosts.

Best regards,

Khaled Omar

-----Original Message-----
From: ietf [mailto:[email-masked]] On Behalf Of JORDI PALET MARTINEZ
Sent: Sunday, April 16, 2017 3:06 PM
To: [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [Int-area] Google Statistics for IPv6 adoption.

Regards,
Jordi

-----Mensaje original-----
De: ietf <[email-masked]> en nombre de <[email-masked]> Responder a: <[email-masked]>
Fecha: domingo, 16 de abril de 2017, 14:06
Para: <[email-masked]>
CC: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Asunto: Re: [Int-area] Google Statistics for IPv6 adoption.

    Jordi,

    This is not true.

    
    Best regards,
    Ole

---

From: Steve Crocker <[email-masked]>
Date: Sun, 16 Apr 2017 13:02:25 -0400

There was a flag day for the transition from NCP to TCP/IP.  There will never be another flag day.  Any transition solution, whether from IPv4 to IPv6 or a successor protocol elsewhere on the stack, has to be designed to permit overlap and interoperability during the very long period when both the old and new protocols will be operating.

Further, there will have to be two incentives at work for the transition to succeed.  One is in favor of the the new protocol.  The other is against the old protocol.  If the former is missing, the new protocol won’t be adopted.  If the latter is missing, the old protocol will persist indefinitely.

To repeat: there will never be another flag day.  If this is one of your assumptions, step back and think about the problem again.

Steve

> On Apr 16, 2017, at 11:15 AM, Khaled Omar <[email-masked]> wrote:
>

---

From: Dave Crocker <[email-masked]>
Date: Sun, 16 Apr 2017 10:25:49 -0700

On 4/16/2017 10:02 AM, Steve Crocker wrote:
>   Any transition solution, whether from IPv4 to IPv6 or a successor 
> protocol elsewhere on the stack, has to be designed to permit overlap 
> and interoperability during the very long period when both the old and 
> new protocols will be operating.

Given the amount of time any Internet-scale transition must/will take, 
the term 'transition' is tending to be problematic, because it 
encourages of tone of temporariness.

When the scale is one or more decades -- as we seem to be seeing 
regularly -- the better model is long-term dual-stack with 
interoperability support (gateways and tunnels.)

> Further, there will have to be two incentives at work for the transition 
> to succeed.

+1, but the challenge is figuring out who to incentivize and making sure 
the incentives are powerful and real (and usually immediate.)  We all 
have a tendency to imagine incentives that are convenient to our goals, 
whereas those doing the uptake often prove remarkably uncooperative to 
our view...

d/
-- 
Dave Crocker
Brandenburg InternetWorking
bbiw.net