Subject: Re: [Int-area] Google Statistics for IPv6 adoption.

From: Christopher Morrow <[email-masked]>
Date: Sat, 15 Apr 2017 13:15:30 -0400

On Sat, Apr 15, 2017 at 9:09 AM, Khaled Omar <[email-masked]>
wrote:

> Hi all,
>
> Please check out this link that shows the statistics of the IPv6 adoption
> over the past 10 years maybe it will make you believe what was said earlier.
>

'what was said earlier' - citation requested.

>
>  https://www.google.com/intl/en/ipv6/statistics.html
>
> Recent IPv6 adoption (April, 2017) is:
> 14.83% Native - 0.03% 6to4 - 14.87% Total
>
> Best regards,
>
> Khaled Omar

---

From: Khaled Omar <[email-masked]>
Date: Sat, 15 Apr 2017 17:52:23 +0000

Hi Christopher,

> 'what was said earlier' - citation requested.

What I said means that since I wrote the IPv10 I-D on Google blogger, I wrote that the deployment of IPv6 is about 5% of the Internet traffic, and I got responses from some IETF members Just claiming that this is a wrong percentage and the real exceeds 60% and gave me some examples of mobile providers’ statistics.

So, this Google statistics confirms what I had said earlier because I got this percent from some online statistics that belongs to the IP address assignment process.

I would like to thank Google for the efforts made to make this measurements and provide a respectful and real statistics that describes the recent situation so we can make decisions based on it.

Best Regards,

Khaled Omar

From: [email-masked] [mailto:[email-masked]] On Behalf Of Christopher Morrow
Sent: Saturday, April 15, 2017 7:16 PM
To: Khaled Omar
Cc: int-area; intarea-ads; ietf; intarea-chairs
Subject: Re: Google Statistics for IPv6 adoption.

On Sat, Apr 15, 2017 at 9:09 AM, Khaled Omar <[email-masked]<mailto:[email-masked]>> wrote:
Hi all,

Please check out this link that shows the statistics of the IPv6 adoption over the past 10 years maybe it will make you believe what was said earlier.

Best regards,

Khaled Omar

---

From: Jared Mauch <[email-masked]>
Date: Sat, 15 Apr 2017 14:47:20 -0400

There is not a correlation between this graph and traffic the way you purport hence the [missing citation] aspect of the discussion. An enterprise actually moves less traffic than a consumer on a per user basis, so if a home is IPv6 enabled and runs a lot of YouTube, Netflix, etc the bits per IP are not equal. 

Enterprise, eyeball and wholesale networks have vastly different traffic characteristics. If you use the Alexa top 1000 or 1 million you see many IPv6 enabled sites as they are hosted on cloudflare which dual stacks by default vs other CDNs that don't. 

Using one datapoint, an ad network (google) is helpful to understand what browser users might look like but a set top box without a browser may move significantly more bits and not be apparent at all in the IPv6 stats at google. 

Hope this helps. 

Jared Mauch

> On Apr 15, 2017, at 1:52 PM, Khaled Omar <[email-masked]> wrote:
> 
> Hi Christopher,
>  
> On Sat, Apr 15, 2017 at 9:09 AM, Khaled Omar <[email-masked]> wrote:
> Hi all,
>

---

From: Tobias Fiebig <[email-masked]>
Date: Fri, 21 Apr 2017 13:31:15 -0700

Heho, On Sat, Apr 15, 2017 at 02:47:20PM -0400, Jared Mauch wrote:
> ... 
>
> Using one datapoint, an ad network (google) is helpful to
> understand what browser users might look like but a set top box
> without a browser may move significantly more bits and not be
> apparent at all in the IPv6 stats at google. 

I would like to chim in on that point. Actually google has a strong
bias for IPv6 adoption in devices speaking to google. While natural,
this really skews the numbers: The BigN (Google (YouTube), Facebook,
Akamai, Cloudflare, Netflix etc.) account for a major part of
overall traffic, especially in access networks. 

Incidentily, most of these orgs have deployed v6 on the server side.
Hence, as soon as an access network rolls out v6, the traffic share
of v6 skyrockets, as a major portion of the remotes causing most
traffic well... support v6.

However, this observation does not hold for the heavy tail of the
Internet. Actually, I am currently investigating other datasources,
that are not biased towards end-users and "BigN" content providers;
There, v6 adoption for the heavy tail actually ranges more in the
field of 1%...

With best Regards,
Tobias Fiebig

-- 
Tobias Fiebig                      building MAR, 4th floor, room 4.003
Fachgebiet INET - Sekr. MAR 4-4        phone: +49 162 243 205 2
Technische Universität Berlin         gpg-fp: 21A9 91EB 4971 ED48 001E
Marchstrasse 23 - 10587 Berlin                FBBC B6AF 3CD8 59A2 795B