Subject: [Int-area] Request for a mailing list to IPmix I-D.

From: Khaled Omar <[email-masked]>
Date: Fri, 29 Sep 2017 10:47:50 +0000

Hi Suresh,

As you can see, many people are discussing IPmix through the internet area WG, so it will be better if we create a mailing list specifically for the IPmix discussion so we can let the discussion more focused and we can know the number of participants and if there will be consensus or not.

Thanks in advance,

Khaled Omar

---

From: Suresh Krishnan <[email-masked]>
Date: Fri, 29 Sep 2017 12:12:23 -0400

Hi Khaled,

> On Sep 29, 2017, at 6:47 AM, Khaled Omar <[email-masked]> wrote:
> 
> Hi Suresh,
>  

Can you please write up a concise description of the problem you are trying to solve? I have seen the discussion, and it does not look like people discussing IPmix but rather people pondering the future of IP.

Regards
Suresh

---

From: Khaled Omar <[email-masked]>
Date: Fri, 29 Sep 2017 16:31:57 +0000

Hi Suresh,

The problem I'm trying to solve is to overcome the depletion of IPv4 address space and the lack of implementing IPv6 , this will cause the IPv6 only hosts not to be able to access the whole internet as there will be IPv6 only hosts (18% of the Internet traffic) against the domination of IPv4 only hosts (82% of the Internet traffic),

IPmix allows IPv6 only hosts to communicate to IPv4 only hosts and vice versa, and this will allow the coexistence of both version without any separation or division on the Internet

Best Regards,

Khaled Omar

From: Suresh Krishnan [mailto:[email-masked]]
Sent: Friday, September 29, 2017 6:12 PM
To: Khaled Omar
Cc: intarea-ads; int-area
Subject: Re: Request for a mailing list to IPmix I-D.

Hi Khaled,

On Sep 29, 2017, at 6:47 AM, Khaled Omar <[email-masked]<mailto:[email-masked]>> wrote:

Hi Suresh,

Regards
Suresh

---

From: Suresh Krishnan <[email-masked]>
Date: Fri, 29 Sep 2017 12:47:07 -0400

Hi Khaled,

> On Sep 29, 2017, at 12:31 PM, Khaled Omar <[email-masked]> wrote:
> 
> Hi Suresh,
>  
> The problem I’m trying to solve is to overcome the depletion of IPv4 address space and the lack of implementing IPv6 , this will cause the IPv6 only hosts not to be able to access the whole internet as there will be IPv6 only hosts (18% of the Internet traffic) against the domination of IPv4 only hosts (82% of the Internet traffic),

The part that is not clear is why you believe IPv10 will be any more successful or quicker to widespread deployment than IPv6. Can you share your thoughts?

> IPmix allows IPv6 only hosts to communicate to IPv4 only hosts and vice versa, and this will allow the coexistence of both version without any separation or division on the Internet

NAT64 (RFC6146) already allows "IPv6 only hosts to communicate to IPv4 only hosts and vice versa”.

Regards
Suresh

---

From: Khaled Omar <[email-masked]>
Date: Fri, 29 Sep 2017 16:53:03 +0000

Hi Suresh,

> The part that is not clear is why you believe IPv10 will be any more successful or quicker to widespread deployment than IPv6. Can you share your thoughts?

The deployment of IPv10 is a software development process, this can be accomplished by technology companies in a short time, there will be no dependence on enterprises’ users who didn’t migrate to IPv6 till now and this migration took so much time without full migration.

From: Suresh Krishnan [mailto:[email-masked]]
Sent: Friday, September 29, 2017 6:47 PM
To: Khaled Omar
Cc: int-area
Subject: Re: Request for a mailing list to IPmix I-D.

Hi Khaled,

On Sep 29, 2017, at 12:31 PM, Khaled Omar <[email-masked]<mailto:[email-masked]>> wrote:

Hi Suresh,

Regards
Suresh

---

From: Tom Herbert <[email-masked]>
Date: Fri, 29 Sep 2017 10:20:49 -0700

On Fri, Sep 29, 2017 at 9:53 AM, Khaled Omar
<[email-masked]> wrote:
> Hi Suresh,
>
>
>
>> The part that is not clear is why you believe IPv10 will be any more
>> successful or quicker to widespread deployment than IPv6. Can you share your
>> thoughts?
>
>
>
> The deployment of IPv10 is a software development process, this can be
> accomplished by technology companies in a short time, there will be no
> dependence on enterprises’ users who didn’t migrate to IPv6 till now and
> this migration took so much time without full migration.
>
Khaled,

Probably all hardware supports IPv6, continued IPv6 deployment is a
software problem or more aptly it is an infrastructure and management
problem.

Regarding this statement: "this can be accomplished by technology
companies in a short time" -- I see no technical basis for this claim.
Since the initial posting of the IPv10, I and and others have asked
several times for an implementation. Have you started on one? Without
even a prototype it's highly unlikely that technology companies, many
of which of representation on this list, are going to put any stock in
your arguments about how easy the protocol is to develop and deploy.
They're certainly aren't going to take resources off of IPv6 or more
tangible projects based on unqualified statements like this.

Tom

> The problem I’m trying to solve is to overcome the depletion of IPv4 address
> space and the lack of implementing IPv6 , this will cause the IPv6 only
> hosts not to be able to access the whole internet as there will be IPv6 only
> hosts (18% of the Internet traffic) against the domination of IPv4 only
> hosts (82% of the Internet traffic),
>
>
>
> The part that is not clear is why you believe IPv10 will be any more
> successful or quicker to widespread deployment than IPv6. Can you share your
> thoughts?
>
>
>
>
>
> IPmix allows IPv6 only hosts to communicate to IPv4 only hosts and vice
> versa, and this will allow the coexistence of both version without any
> separation or division on the Internet
>
>
>
> _______________________________________________
> Int-area mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/int-area
>

---

From: Khaled Omar <[email-masked]>
Date: Fri, 29 Sep 2017 17:32:55 +0000

-----Original Message-----
From: Khaled Omar 
Sent: Friday, September 29, 2017 7:32 PM
To: 'Tom Herbert'
Subject: RE: [Int-area] Request for a mailing list to IPmix I-D.

Hi Tom.

> Regarding this statement: "this can be accomplished by technology companies in a short time" -- I see no technical basis for this claim.

The technical basis is to allow encapsulation of both versions in the same L3 packet header.

> Since the initial posting of the IPv10, I and and others have asked several times for an implementation.

Yes, this have to be tested because theoritically it works fine and I'm not a software developer to test it by myself.

Khaled

-----Original Message-----
From: Tom Herbert [mailto:[email-masked]]
Sent: Friday, September 29, 2017 7:21 PM
To: Khaled Omar
Cc: Suresh Krishnan; int-area
Subject: Re: [Int-area] Request for a mailing list to IPmix I-D.

On Fri, Sep 29, 2017 at 9:53 AM, Khaled Omar <[email-masked]> wrote:
>> successful or quicker to widespread deployment than IPv6. Can you 
>> share your thoughts?
>
>
>
> dependence on enterprises’ users who didn’t migrate to IPv6 till now 
> and this migration took so much time without full migration.
>
Khaled,

Probably all hardware supports IPv6, continued IPv6 deployment is a software problem or more aptly it is an infrastructure and management problem.

Regarding this statement: "this can be accomplished by technology companies in a short time" -- I see no technical basis for this claim.
Since the initial posting of the IPv10, I and and others have asked several times for an implementation. Have you started on one? Without even a prototype it's highly unlikely that technology companies, many of which of representation on this list, are going to put any stock in your arguments about how easy the protocol is to develop and deploy.
They're certainly aren't going to take resources off of IPv6 or more tangible projects based on unqualified statements like this.

Tom

> On Sep 29, 2017, at 12:31 PM, Khaled Omar 
> The problem I’m trying to solve is to overcome the depletion of IPv4 
> address space and the lack of implementing IPv6 , this will cause the
> IPv6 only hosts not to be able to access the whole internet as there 
> will be IPv6 only hosts (18% of the Internet traffic) against the 
> domination of IPv4 only hosts (82% of the Internet traffic),
>
>
>
> successful or quicker to widespread deployment than IPv6. Can you 
> share your thoughts?
>
>
>
>
>
> IPmix allows IPv6 only hosts to communicate to IPv4 only hosts and 
> vice versa, and this will allow the coexistence of both version 
> without any separation or division on the Internet
>
>
>

---

From: Tom Herbert <[email-masked]>
Date: Fri, 29 Sep 2017 10:44:53 -0700

> Yes, this have to be tested because theoritically it works fine and I'm not a software developer to test it by myself.
The statement "theoritically it works fine" is another unqualified
statement that won't convince anyone.

If there's no plan for running code then maybe this work, as well as a
discussion about the long term plan for IP, belong  in IRTF?

Thanks,
Tom

---

From: Stewart Bryant <[email-masked]>
Date: Fri, 29 Sep 2017 19:17:23 +0100

On 29/09/2017 18:44, Tom Herbert wrote:
> maybe this work, as well as a

I think IRTF would be a fine place to put work on the long term 
evolution of the Internet.

Stewart

---

From: Khaled Omar <[email-masked]>
Date: Fri, 29 Sep 2017 20:46:21 +0000

What to do with the IRTF to discuss an I-D?

-----Original Message-----
From: Stewart Bryant [mailto:[email-masked]] 
Sent: Friday, September 29, 2017 8:17 PM
To: Tom Herbert; Khaled Omar
Cc: int-area
Subject: Re: [Int-area] FW: Request for a mailing list to IPmix I-D.

> discussion about the long term plan for IP, belong  in IRTF?

I think IRTF would be a fine place to put work on the long term evolution of the Internet.

Stewart

---

From: Alexandre Petrescu <[email-masked]>
Date: Sat, 30 Sep 2017 10:07:31 +0200

Le 29/09/2017 à 18:47, Suresh Krishnan a écrit :
> Hi Khaled,
> 
>> On Sep 29, 2017, at 12:31 PM, Khaled Omar <[email-masked] 
>> <mailto:[email-masked]>> wrote:
>>
>> Hi Suresh,
> successful or quicker to widespread deployment than IPv6. Can you share 
> your thoughts?
> 

I think I agree.

NAT64 may have some advantages, have a user base, but it may also have 
some drawbacks.

The same about DNS64 RFC6147.

If I remember correctly, NAT64, and/or DNS64, maye have been worked in 
the v6ops WG?

Was it considered to bring this work to v6ops?

Alex

---

From: Alexandre Petrescu <[email-masked]>
Date: Sat, 30 Sep 2017 10:30:29 +0200

Le 29/09/2017 à 19:32, Khaled Omar a écrit :
> 
> -----Original Message----- From: Khaled Omar Sent: Friday, September
>  29, 2017 7:32 PM To: 'Tom Herbert' Subject: RE: [Int-area] Request 
> for a mailing list to IPmix I-D.
> 
> Hi Tom.
> 

Well, there are multiple ways to encapsulate versions of IP in a same
packet header.

One is to use IP-in-IP encapsulation.  You could do IPvx-in-IPv6.

Another is to multiplex with a number below IP.  For example, you have
an EtherType for IPv4 and another EtherType for IPv6.  The EtherType
field is in an Ethernet header which is below IP.  You could see
EtherType quickly if you download the free tool 'wireshark'.  You dont
have to be a software developper to do that.  Architects use wireshark
extensively.

Another one is to use an IPv6 Extension Header called "Routing Header".
  You could put an IPv4 destination address _and_ an IPv6 destination
address in the same Routing Header.  As a result, the packet would be
travelling to IPv4 Computers and to IPv6 Computers too.

That said, I agree with you that that the technical basis is to allow
encapsulate versions of IP in a same packet header.

I would also rather say: the technical issue is how to use different
versions of IP in a same IP packet.

>> several times for an implementation.
> 
> Yes, this have to be tested because theoretically it works fine

I agree with you.  Many concepts are first imagined in someone's  mind,
then sketched with a pencil on a paper, and discussed.  These concepts
work fine theoretically.

> and I'm not a software developer to test it by myself.

You are not.  But can you make their job easy?

Me too I can sketch a concept car on paper, but I doubt any manufacturer
will ever make one :-)  Because I dont know how to make cars.

Alex

---

From: Khaled Omar <[email-masked]>
Date: Sat, 30 Sep 2017 11:36:00 +0000

Hi Alex,

> only hosts and vice versa”.

As mentioned on the draft, NAT64 requires so much translations binding in addition to getting the DNS64 involved in the communication process that’s why NAT64 is not widespread.

Khaled

-----Original Message-----
From: Int-area [mailto:[email-masked]] On Behalf Of Alexandre Petrescu
Sent: Saturday, September 30, 2017 10:08 AM
To: [email-masked]
Subject: Re: [Int-area] Request for a mailing list to IPmix I-D.

Le 29/09/2017 à 18:47, Suresh Krishnan a écrit :
>> <[email-masked] <mailto:[email-masked]>> wrote:
>>
>> Hi Suresh,

I think I agree.

NAT64 may have some advantages, have a user base, but it may also have some drawbacks.

If I remember correctly, NAT64, and/or DNS64, maye have been worked in the v6ops WG?

Alex

---

From: Khaled Omar <[email-masked]>
Date: Sat, 30 Sep 2017 11:39:37 +0000

>> You are not.  But can you make their job easy?

I cannot do everything by myself, that’s why I'm discussing with the IETF to make a group of participants working together to achieve the same purpose which is IPmix.

Khaled

-----Original Message-----
From: Int-area [mailto:[email-masked]] On Behalf Of Alexandre Petrescu
Sent: Saturday, September 30, 2017 10:30 AM
To: [email-masked]
Subject: Re: [Int-area] FW: Request for a mailing list to IPmix I-D.

Le 29/09/2017 à 19:32, Khaled Omar a écrit :
> 29, 2017 7:32 PM To: 'Tom Herbert' Subject: RE: [Int-area] Request for 
> a mailing list to IPmix I-D.
> 
> Hi Tom.
> 

Well, there are multiple ways to encapsulate versions of IP in a same packet header.

Another is to multiplex with a number below IP.  For example, you have an EtherType for IPv4 and another EtherType for IPv6.  The EtherType field is in an Ethernet header which is below IP.  You could see EtherType quickly if you download the free tool 'wireshark'.  You dont have to be a software developper to do that.  Architects use wireshark extensively.

Another one is to use an IPv6 Extension Header called "Routing Header".
  You could put an IPv4 destination address _and_ an IPv6 destination address in the same Routing Header.  As a result, the packet would be travelling to IPv4 Computers and to IPv6 Computers too.

That said, I agree with you that that the technical basis is to allow encapsulate versions of IP in a same packet header.

I would also rather say: the technical issue is how to use different versions of IP in a same IP packet.

> Yes, this have to be tested because theoretically it works fine

I agree with you.  Many concepts are first imagined in someone's  mind, then sketched with a pencil on a paper, and discussed.  These concepts work fine theoretically.

Me too I can sketch a concept car on paper, but I doubt any manufacturer will ever make one :-)  Because I dont know how to make cars.

Alex

---

From: Tom Herbert <[email-masked]>
Date: Sat, 30 Sep 2017 09:42:51 -0700

> encapsulate versions of IP in a same packet header.
This does not justify the statements that this protocol can be
developed and deployed in a short time by technology companies.
Deploying anything at Internet scale is hard, developing and deploying
a new IP version is at least an order of magnitude harder. Even if you
were to just change the version number of IPv4 and make no other
changes to the protocol, it still would be a stunning amount of work
that touches a myriad of devices and systems. End hosts need to change
several ways, NIC HW needs to change to support protocol specific
features, routers and switches need to be able to deal with new
version which most likely will require hardware changes, middleboxes
and firewalls need to deal with this, security needs to be fully
considered. Monitoring and diagnostic tools need to change, management
and administration need changes. But, on top of all that, there's no
magic switch that can turn up this new IP version on all hosts and
routers on the Internet instantaneously so we need to implement more
backoffs like happy eyeballs. Sorry, there is just no easy path here;
if there were it would have been applied to IPv6 long ago...

> will ever make one :-)  Because I dont know how to make cars.
IETF is "rough consensus and running code". It's incumbent on the
advocates of a proposed protocol to push for both of these. There's no
concept that protocol experts bring their protocols to IETF and then
throw over the wall to the protocol developers who happily go off and
implement the spec. If you don't have the skills for implementation,
then please find someone else to work with who can do it for you.

Tom

---

From: Khaled Omar <[email-masked]>
Date: Sat, 30 Sep 2017 16:54:25 +0000

Hi Tom,

I agree with most of what you have said, but changing the way of encapsulation is not a hard work for running a code for all network devices and hosts to be able to understand the new packet.

There is difference between deploying IPv6 and implementing IPv6, IPv6 was deployed in almost all OSs and network devices in a short time, but implementing IPv6 by enterprises' users is the problem because there is a dependence on them, they have to do it by themselves.

For IPmix, there is only deployment process that will be done by technology companies, and enterprises' users will do nothing, they will keep using their version of IP and regardless of the version they are using, they will be able to access 100% of the Internet.

Regarding running a code, there is no problem in that, a wg of people will make things easier than letting only one do it by himself, collaboration is requested.

Khaled

-----Original Message-----
From: Int-area [mailto:[email-masked]] On Behalf Of Tom Herbert
Sent: Saturday, September 30, 2017 6:43 PM
To: Alexandre Petrescu
Cc: [email-masked]
Subject: Re: [Int-area] FW: Request for a mailing list to IPmix I-D.

> encapsulate versions of IP in a same packet header.
This does not justify the statements that this protocol can be developed and deployed in a short time by technology companies.
Deploying anything at Internet scale is hard, developing and deploying a new IP version is at least an order of magnitude harder. Even if you were to just change the version number of IPv4 and make no other changes to the protocol, it still would be a stunning amount of work that touches a myriad of devices and systems. End hosts need to change several ways, NIC HW needs to change to support protocol specific features, routers and switches need to be able to deal with new version which most likely will require hardware changes, middleboxes and firewalls need to deal with this, security needs to be fully considered. Monitoring and diagnostic tools need to change, management and administration need changes. But, on top of all that, there's no magic switch that can turn up this new IP version on all hosts and routers on the Internet instantaneously so we need to implement more backoffs like happy eyeballs. Sorry, there is just no easy path here; if there were it would have been applied to IPv6 long ago...

> I agree with you.  Many concepts are first imagined in someone's  
> mind, then sketched with a pencil on a paper, and discussed.  These 
> concepts work fine theoretically.
>
> Me too I can sketch a concept car on paper, but I doubt any 
> manufacturer will ever make one :-)  Because I dont know how to make cars.
>
IETF is "rough consensus and running code". It's incumbent on the advocates of a proposed protocol to push for both of these. There's no concept that protocol experts bring their protocols to IETF and then throw over the wall to the protocol developers who happily go off and implement the spec. If you don't have the skills for implementation, then please find someone else to work with who can do it for you.

Tom

---

From: Andrew Sullivan <[email-masked]>
Date: Sat, 30 Sep 2017 12:59:40 -0400

Hi,

The fact that this topic won't go away from this list in which I am
otherwise interested gives us a pragmatic reason to give it its own
list.  Can we please do that so that I can stop hearing about this
visit from either the Bad Idea Fairy or the Late Idea Fairy?

Best regards,

A
-- 
Andrew Sullivan
[email-masked]

---

From: Alexandre Petrescu <[email-masked]>
Date: Sat, 30 Sep 2017 20:43:41 +0200

Khaled,

Le 30/09/2017 à 13:36, Khaled Omar a écrit :
> As mentioned on the draft, NAT64 requires so much translations

Why NAT64 requires translation?

> binding in addition to getting the DNS64 involved in the
> communication process that’s why NAT64 is not widespread.

NAT64 is not very widespread, but there is running code for it.

Running code is a really great thing.

Alex

> 
> Khaled
> 
> -----Original Message----- From: Int-area
> [mailto:[email-masked]] On Behalf Of Alexandre Petrescu 
> Sent: Saturday, September 30, 2017 10:08 AM To: [email-masked] 
>>> <[email-masked]
>>> Hi Suresh, The problem I’m trying to solve is to overcome the
>>> depletion of IPv4 address space and the lack of implementing IPv6
>>> , this will cause the IPv6 only hosts not to be able to access
>>> the whole internet as there will be IPv6 only hosts (18% of the
>>> Internet traffic) against the domination of IPv4 only hosts (82%
>>> of the Internet traffic),
>> 
>> The part that is not clear is why you believe IPv10 will be any
>> more successful or quicker to widespread deployment than IPv6. Can
>> you share your thoughts?
>> 
>>> IPmix allows IPv6 only hosts to communicate to IPv4 only hosts
>>> and vice versa, and this will allow the coexistence of both
>>> version without any separation or division on the Internet
>> 
>> Regards Suresh
>> _______________________________________________ Int-area mailing
>> list [email-masked] 
> _______________________________________________ Int-area mailing
> list [email-masked]

---

From: Alexandre Petrescu <[email-masked]>
Date: Sat, 30 Sep 2017 20:46:11 +0200

Le 30/09/2017 à 13:39, Khaled Omar a écrit :
> I cannot do everything by myself, that’s why I'm discussing with the 
> IETF to make a group of participants working together to achieve the 
> same purpose which is IPmix.

But before one can dream of getting a group, one must meet people at
IETF face-to-face meetings.

Do you plan to come to IETF face-to-face meetings?  The next one is in a
country in Asia, in November.

Alex

---

From: Khaled Omar <[email-masked]>
Date: Sat, 30 Sep 2017 18:51:52 +0000

-----Original Message-----
From: Khaled Omar 
Sent: Saturday, September 30, 2017 8:51 PM
To: 'Alexandre Petrescu'
Subject: RE: [Int-area] Request for a mailing list to IPmix I-D.

Alex,

> Why NAT64 requires translation?

How a destination IPv4 will understand an IPv6 packet without translation by statically configured binding!!

Khaled

-----Original Message-----
From: Alexandre Petrescu [mailto:[email-masked]]
Sent: Saturday, September 30, 2017 8:44 PM
To: Khaled Omar
Cc: int-area
Subject: Re: [Int-area] Request for a mailing list to IPmix I-D.

Khaled,

> binding in addition to getting the DNS64 involved in the communication 
> process that’s why NAT64 is not widespread.

Alex

>>> depletion of IPv4 address space and the lack of implementing IPv6 , 
>>> this will cause the IPv6 only hosts not to be able to access the 
>>> whole internet as there will be IPv6 only hosts (18% of the Internet
>>> traffic) against the domination of IPv4 only hosts (82% of the 
>>> Internet traffic),
>> 
>> _______________________________________________ Int-area mailing list 
>> [email-masked] https://www.ietf.org/mailman/listinfo/int-area
>> 
> 
> _______________________________________________ Int-area mailing list 
> [email-masked] https://www.ietf.org/mailman/listinfo/int-area
>

---

From: Khaled Omar <[email-masked]>
Date: Sat, 30 Sep 2017 18:53:33 +0000

> But before one can dream of getting a group, one must meet people at IETF face-to-face meetings.

> Do you plan to come to IETF face-to-face meetings?  The next one is in a country in Asia, in November.

It will be my pleasure to meet all of you face-to-face and I hope to be able to attend the next IETF meeting.

-----Original Message-----
From: Alexandre Petrescu [mailto:[email-masked]] 
Sent: Saturday, September 30, 2017 8:46 PM
To: Khaled Omar
Cc: int-area
Subject: Re: [Int-area] FW: Request for a mailing list to IPmix I-D.

> same purpose which is IPmix.

But before one can dream of getting a group, one must meet people at IETF face-to-face meetings.

Do you plan to come to IETF face-to-face meetings?  The next one is in a country in Asia, in November.

Alex

---

From: Alexandre Petrescu <[email-masked]>
Date: Sat, 30 Sep 2017 20:59:06 +0200

Tom,

Le 30/09/2017 à 18:42, Tom Herbert a écrit :
>> That said, I agree with you that that the technical basis is to 
>> allow encapsulate versions of IP in a same packet header.
>> 
> Deploying anything at Internet scale is hard,

I agree putting anything at Internet scale is hard.  Internet is a large
system.

People who try the migration from IPv4 to IPv6 are not dumb.  They try
very hard.  Yet, it takes decades.  That is explained by the fact that
Internet is already very large.  It is not as simple as the 1980
migration from NCP to TCP protocol, which happened in months.  The
Internet was much smaller at that time.

There is absolutely no expectation that some new IP-v-something can be
any more successful than what IPv6 already achieved at Internet scale.
Such expectation can be qualified as foolish.

[...]
> End hosts need to change several ways, NIC HW needs to change to 
> support protocol specific features, routers and switches need to be 
> able to deal with new version [...]

I agree.

But I would like to understand whether the proposal (no name) may work
without modifying all the intermediary routers.  If all intermediary
routers must be modified to support it, then (proposal) can not work.

Also, some of the most widespread deployments of IPv6 do _not_ modify
the intermediary routers: they are tunnelled in IPv4.

So maybe this (proposal) could also be a tunnelled overlay network.

But we'd need running code to see it :-)

[...]
> advocates of a proposed protocol to push for both of these. There's 
> no concept that protocol experts bring their protocols to IETF and 
> then throw over the wall to the protocol developers who happily go 
> off and implement the spec. If you don't have the skills for 
> implementation, then please find someone else to work with who can do
> it for you.

I fully agree.

Alex

---

From: Tom Herbert <[email-masked]>
Date: Sat, 30 Sep 2017 12:24:26 -0700

Alexandre,

> routers must be modified to support it, then (proposal) can not work.
Then that would end up tunneling the new protocol over IPv6 and IPv4.
But we already can tunnel both v4 and v6 over v4 and v6 in all
combinations. And as pointed out NAT64 can do protocol translations to
have hosts running different version be able to communicate.

> So maybe this (proposal) could also be a tunnelled overlay network.
Sure it could be, but what is the value of it? If you want to tunnel
there are already enough encapsulations and translations to cover the
various combinations.

Tom