Subject: Re: [Int-area] Intdir early review of draft-ietf-intarea-probe-00

From: Jean-Michel Combes <[email-masked]>
Date: Mon, 6 Nov 2017 13:09:08 +0100

Hi Ron,

2017-10-31 17:45 GMT+01:00 Ron Bonica <[email-masked]>:

> Hi Jean-Michel,
>
>
>
> The semantic of this utility is to probe exactly one interface at a time.
> If multiple interfaces satisfy query’s match conditions, Probe can’t
> provide a response.
>
>
>
> I agree that Probe could set the A bit if all of the interfaces are
> active. But what should it do if one interface is active and the other is
> not?
>
>
<JMC>

Your opinion differs from my opinion because, IMHO, yours is mainly based
on the "probed interface resides on the probed node" (i.e., it is possible
to identify some interfaces are active and some not) and mine is mainly
based on the "probed interface doesn't reside on the probed node" (i.e.,
ARP/NC allows only to identify active interfaces).
Correct?

Best regards,

JMC.

</JMC>

>
>
>
>                                                        Ron
>
>
>
> >
> > <JMC>
> > Question:
> > Why the A-bit is not set when Code Field is equal to Multiple Interfaces
> > Satisfy Query (3) and the L-bit is clear? Question: Same question when
> L-bit is
> > set. </JMC>
> >
> > <snip>
> >
> [RB ]
>
> Error code 3 (Multiple Interfaces Satisfy Query) means that they query is
> ambiguous. Or, on other words, that two or more interfaces satisfy the
> match conditions specified by the query. So, we can't set the A, F, S or E
> bits because we don't know which interface the user is asking about.
>
>
>
> <JMC>
>
> But, even if this is ambiguous, IMHO, all the interfaces are active =>
> A-bit should be set
>
> And Error Code 3 returned to probing interface raises this is ambiguous.
> Now, I am OK that F, S and E should be cleared to avoid any confusion
> between the different interfaces.
>
>
>
> Did I miss something?
>
> </JMC>
>
> <snip>
>
>
>
> Best regards,
>
> JMC.
>

---

From: Ron Bonica <[email-masked]>
Date: Mon, 6 Nov 2017 18:49:21 +0000

Jean-Michel,

I understand that Probe addresses two operational needs. One need is to probe the local node and the other is to probe a directly connected node. But in either case, Probe semantics must be consistent.

Probe queries the status of exactly one interface. Regardless of whether the L-bit is set or clear, if two interface satisfy the Extended Echo Request Match criteria, the Extended Echo Reply must return an error code (3). Returning any information beyond that would be risky. For example, assume that both interfaces are active, one is running IPv4 only and the other is running IPv6 only? What would the Extended Echo Reply return?

                                                                                         Ron

From: Jean-Michel Combes [mailto:[email-masked]]
Sent: Monday, November 6, 2017 7:09 AM
To: Ron Bonica <[email-masked]>
Cc: [email-masked]
Subject: Re: [Int-area] Intdir early review of draft-ietf-intarea-probe-00

Hi Ron,

2017-10-31 17:45 GMT+01:00 Ron Bonica <[email-masked]<mailto:[email-masked]>>:
Hi Jean-Michel,

The semantic of this utility is to probe exactly one interface at a time. If multiple interfaces satisfy query’s match conditions, Probe can’t provide a response.

I agree that Probe could set the A bit if all of the interfaces are active. But what should it do if one interface is active and the other is not?

<JMC>

Your opinion differs from my opinion because, IMHO, yours is mainly based on the "probed interface resides on the probed node" (i.e., it is possible to identify some interfaces are active and some not) and mine is mainly based on the "probed interface doesn't reside on the probed node" (i.e., ARP/NC allows only to identify active interfaces).
Correct?
Best regards,
JMC.

</JMC>

                                                                                                                   Ron

> Satisfy Query (3) and the L-bit is clear? Question: Same question when L-bit is
> set. </JMC>
>
> <snip>
>
[RB ]

Error code 3 (Multiple Interfaces Satisfy Query) means that they query is ambiguous. Or, on other words, that two or more interfaces satisfy the match conditions specified by the query. So, we can't set the A, F, S or E bits because we don't know which interface the user is asking about.

<JMC>
But, even if this is ambiguous, IMHO, all the interfaces are active => A-bit should be set
And Error Code 3 returned to probing interface raises this is ambiguous.
Now, I am OK that F, S and E should be cleared to avoid any confusion between the different interfaces.

Did I miss something?
</JMC>

<snip>

Best regards,
JMC.

---

From: Jean-Michel Combes <[email-masked]>
Date: Wed, 8 Nov 2017 17:55:08 +0100

Hi Ron,

OK. I understand your point.

Best regards,

JMC.

2017-11-06 19:49 GMT+01:00 Ron Bonica <[email-masked]>:

> Jean-Michel,
>
>
>
> I understand that Probe addresses two operational needs. One need is to
> probe the local node and the other is to probe a directly connected node.
> But in either case, Probe semantics must be consistent.
>
>
>
> Probe queries the status of exactly one interface. Regardless of whether
> the L-bit is set or clear, if two interface satisfy the Extended Echo
> Request Match criteria, the Extended Echo Reply must return an error code
> (3). Returning any information beyond that would be risky. For example,
> assume that both interfaces are active, one is running IPv4 only and the
> other is running IPv6 only? What would the Extended Echo Reply return?
>
>
>
>
>                           Ron
>
>
>
>
>
> *From:* Jean-Michel Combes [mailto:[email-masked]]
> *Sent:* Monday, November 6, 2017 7:09 AM
> *To:* Ron Bonica <[email-masked]>
> *Cc:* [email-masked]
> *Subject:* Re: [Int-area] Intdir early review of
> draft-ietf-intarea-probe-00
>
>
>
> Hi Ron,
>
>
>