Subject: [Int-area] I-D Action: draft-ietf-intarea-frag-fragile-06.txt

From: [email-masked]
Date: Tue, 29 Jan 2019 10:18:39 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Internet Area Working Group WG of the IETF.

        Title           : IP Fragmentation Considered Fragile
        Authors         : Ron Bonica
                          Fred Baker
                          Geoff Huston
                          Robert M. Hinden
                          Ole Troan
                          Fernando Gont
	Filename        : draft-ietf-intarea-frag-fragile-06.txt
	Pages           : 25
	Date            : 2019-01-29

Abstract:
   This document describes IP fragmentation and explains how it reduces
   the reliability of Internet communication.

   This document also proposes alternatives to IP fragmentation and
   provides recommendations for developers and network operators.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-intarea-frag-fragile/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-intarea-frag-fragile-06
https://datatracker.ietf.org/doc/html/draft-ietf-intarea-frag-fragile-06

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-intarea-frag-fragile-06

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 30 Jan 2019 08:40:39 +1300

Reviewing this version, I noticed the absence of one mitigation that we should probably be recommending.

- in section 4.4. "Stateless Load Balancers" add the remark that balancers that use *only* the IPv6 Source Address, IPv6 Destination Address and IPv6 Flow Label (when it is non-zero) work perfectly on fragmented traffic.

- in section 7. "Recommendations" add a subsection "To Load Balancer Developers and Operators" saying that load balancers (including ECMP/LAG) SHOULD be designed and configured to use *only* the IPv6 Source Address, IPv6 Destination Address and IPv6 Flow Label (when it is non-zero).

Regards
   Brian Carpenter