Subject: Re: [Int-area] New Version Notification for draft-sarathchandra-tactile-internet-00.txt

From: Chathura Sarathchandra <[email-masked]>
Date: Fri, 25 Jun 2021 13:49:12 +0000

Dear all,

Please find below our new draft submission on Tactile Internet Service Requirements.

This draft introduces tactile internet use cases and service requirements potentially to be used as input for further discussions and/or to be directly addressed by IETF.

Comments and feedback are warmly welcome!

Best regards,
Chathura

-----Original Message-----
From: [email-masked] <[email-masked]> 
Sent: 25 June 2021 14:28
To: Chathura Sarathchandra <[email-masked]>; Mona Ghassemian <[email-masked]>; Morteza Kheirkhah <[email-masked]>
Subject: New Version Notification for draft-sarathchandra-tactile-internet-00.txt

A new version of I-D, draft-sarathchandra-tactile-internet-00.txt
has been successfully submitted by Chathura Sarathchandra and posted to the IETF repository.

Name:		draft-sarathchandra-tactile-internet
Revision:	00
Title:		Tactile Internet Service Requirements
Document date:	2021-06-25
Group:		Individual Submission
Pages:		11
URL:            https://www.ietf.org/archive/id/draft-sarathchandra-tactile-internet-00.txt
Status:         https://datatracker.ietf.org/doc/draft-sarathchandra-tactile-internet/
Htmlized:       https://datatracker.ietf.org/doc/html/draft-sarathchandra-tactile-internet

Abstract:
   The Tactile Internet refers to a new communication and networking
   paradigm, which can provide low-latency, reliable and secure
   transmission for real-time information such as control, touch, and
   sensing/actuation in emerging tactile internet applications like
   teleoperation, immersive virtual reality,and haptics communications.
   The main goal of this document is: 1) to briefly introduce tactile
   internet background and typical applications; 2) to identify
   potential service requirements that can be addressed at the IETF or
   researched at the IRTF.

The IETF Secretariat

---

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 25 Jun 2021 15:03:14 +0100

Hi Chathura,

Your draft is an interesting piece of work.

Three places you could go to look for support...

You might want to advertise it on the SARAH mailing list (subscribe via
https://www.jiscmail.ac.uk/cgi-bin/webadmin?SUBED1=SARAH&A=1). This mailing
list is a research-oriented forum for discussing work concerned with changes
to addressing and routing in the Internet specifically to facilitate new
services that have varied traffic delivery requirements.

The "Application Aware Networking" (APN) effort is a new drive at the edge
of the IETF to produce a way to mark traffic in the Internet so that it may
be given different handling (routing, queuing, etc.) by the routers. There
is a mailing list at https://www.ietf.org/mailman/listinfo/apn and we are
planning a first meeting at IETF-111 next month
(https://www.ietf.org/how/meetings/111/).

The TEAS working group (https://datatracker.ietf.org/wg/teas/about/) is
working on "Network Slicing". One purpose of slicing is to produce a
partition of a network's resources in order to support enhanced connectivity
services (enhanced VPNs) that facilitate services like those you describe.
See https://datatracker.ietf.org/doc/draft-ietf-teas-ietf-network-slices/
and https://datatracker.ietf.org/doc/draft-ietf-teas-enhanced-vpn/ for more
information.

Best regards,
Adrian

-----Original Message-----
From: Int-area <[email-masked]> On Behalf Of Chathura
Sarathchandra
Sent: 25 June 2021 14:49
To: [email-masked]
Cc: Mona Ghassemian <[email-masked]>
Subject: Re: [Int-area] New Version Notification for
draft-sarathchandra-tactile-internet-00.txt

Dear all,

Please find below our new draft submission on Tactile Internet Service
Requirements.

This draft introduces tactile internet use cases and service requirements
potentially to be used as input for further discussions and/or to be
directly addressed by IETF.

Best regards,
Chathura

-----Original Message-----
From: [email-masked] <[email-masked]> 
Sent: 25 June 2021 14:28
To: Chathura Sarathchandra <[email-masked]>; Mona
Ghassemian <[email-masked]>; Morteza Kheirkhah
<[email-masked]>
Subject: New Version Notification for
draft-sarathchandra-tactile-internet-00.txt

A new version of I-D, draft-sarathchandra-tactile-internet-00.txt
has been successfully submitted by Chathura Sarathchandra and posted to the
IETF repository.

Name:		draft-sarathchandra-tactile-internet
Revision:	00
Title:		Tactile Internet Service Requirements
Document date:	2021-06-25
Group:		Individual Submission
Pages:		11
URL:
https://www.ietf.org/archive/id/draft-sarathchandra-tactile-internet-00.txt
Status:
https://datatracker.ietf.org/doc/draft-sarathchandra-tactile-internet/
Htmlized:
https://datatracker.ietf.org/doc/html/draft-sarathchandra-tactile-internet

Abstract:

The IETF Secretariat

_______________________________________________
Int-area mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/int-area

---

From: Dirk Trossen <[email-masked]>
Date: Fri, 25 Jun 2021 14:20:39 +0000

Hi Chathura,

Interesting draft, indeed, to start a discussion here on this list. Adrian's responded with a piece I'd also recommended, namely the SARAH list, where this contribution may well contribute to possible discussions on addressing and routing aspects related to the Tactile Internet. 

Apart from that, I wonder about the degree of dynamicity that you foresee in your scenarios (of Section 4)? The use case draft in the COIN RG (https://datatracker.ietf.org/doc/draft-irtf-coinrg-use-cases/) outlines an entertainment use case with a personalized and interactive nature, where dynamic relations, e.g., between (parts of the) performers and (parts of the) audience are foreseen. The tactile notion is not emphasized here, leading to higher acceptable latencies maybe (although when mixing distributed music, you are still down at few ms latency). But it's the dynamic relations that I wanted to point out, which pose additional requirements. This may also be the case for industrial use cases, BTW. Maybe something to consider as a possible dimension?

Best,

Dirk

-----Original Message-----
From: Int-area [mailto:[email-masked]] On Behalf Of Chathura Sarathchandra
Sent: 25 June 2021 15:49
To: [email-masked]
Cc: Mona Ghassemian <[email-masked]>
Subject: Re: [Int-area] New Version Notification for draft-sarathchandra-tactile-internet-00.txt

Dear all,

Best regards,
Chathura

-----Original Message-----
From: [email-masked] <[email-masked]> 
Sent: 25 June 2021 14:28
To: Chathura Sarathchandra <[email-masked]>; Mona Ghassemian <[email-masked]>; Morteza Kheirkhah <[email-masked]>
Subject: New Version Notification for draft-sarathchandra-tactile-internet-00.txt

Abstract:

The IETF Secretariat

---

From: Chathura Sarathchandra <[email-masked]>
Date: Mon, 28 Jun 2021 16:24:22 +0000

Hi Adrian,

Thank you for your suggestions on potential places we can get support from. We will proceed accordingly.

Best regards,
Chathura

-----Original Message-----
From: Adrian Farrel <[email-masked]> 
Sent: 25 June 2021 15:03
To: Chathura Sarathchandra <[email-masked]>; [email-masked]
Cc: Mona Ghassemian <[email-masked]>
Subject: RE: [Int-area] New Version Notification for draft-sarathchandra-tactile-internet-00.txt

Hi Chathura,

You might want to advertise it on the SARAH mailing list (subscribe via https://www.jiscmail.ac.uk/cgi-bin/webadmin?SUBED1=SARAH&A=1). This mailing list is a research-oriented forum for discussing work concerned with changes to addressing and routing in the Internet specifically to facilitate new services that have varied traffic delivery requirements.

The "Application Aware Networking" (APN) effort is a new drive at the edge of the IETF to produce a way to mark traffic in the Internet so that it may be given different handling (routing, queuing, etc.) by the routers. There is a mailing list at https://www.ietf.org/mailman/listinfo/apn and we are planning a first meeting at IETF-111 next month (https://www.ietf.org/how/meetings/111/).

The TEAS working group (https://datatracker.ietf.org/wg/teas/about/) is working on "Network Slicing". One purpose of slicing is to produce a partition of a network's resources in order to support enhanced connectivity services (enhanced VPNs) that facilitate services like those you describe.
See https://datatracker.ietf.org/doc/draft-ietf-teas-ietf-network-slices/
and https://datatracker.ietf.org/doc/draft-ietf-teas-enhanced-vpn/ for more information.

Best regards,
Adrian

-----Original Message-----
From: Int-area <[email-masked]> On Behalf Of Chathura Sarathchandra
Sent: 25 June 2021 14:49
To: [email-masked]
Cc: Mona Ghassemian <[email-masked]>
Subject: Re: [Int-area] New Version Notification for draft-sarathchandra-tactile-internet-00.txt

Dear all,

Best regards,
Chathura

-----Original Message-----
From: [email-masked] <[email-masked]>
Sent: 25 June 2021 14:28
To: Chathura Sarathchandra <[email-masked]>; Mona Ghassemian <[email-masked]>; Morteza Kheirkhah <[email-masked]>
Subject: New Version Notification for

Abstract:

The IETF Secretariat

---

From: Chathura Sarathchandra <[email-masked]>
Date: Mon, 28 Jun 2021 16:25:39 +0000

Hi Dirk,

Thanks for the suggested additional dimension for the use cases.  The use case referenced is an interesting one indeed (user interactivity and personalization added on top of https://www.kcl.ac.uk/news/the-worlds-first-5g-low-latency-3-way-distributed-orchestra-at-kcl)! Could not find a link however to haptic communication aspect. Maybe can provide a haptic experience that is in sync with music for users who are disabled and can't perceive audio and/or video? 

By dynamicity do you mean how different user profiles and user interactions are taken into consideration, in multi-user scenarios? And how the resulting user-specific information (of the same experience) being transferred to users  (audio-video-haptic) ? If yes, certainly it is another dimension of the use cases, e.g., Entertainment (gaming), Training (training simulations). For example, in scenarios where virtual simulation environments used for training, where multiple users act upon the same virtual objects, the information received by individual 'trainee users' may differ due to 1) user preferences (e.g., with haptic feedback vs without) 2) individual user's perception (e.g.., audio, video haptic) of objects and actions/events within the virtual environment (e.g., based on viewpoint, distance to objects/events, and properties of virtual objects [different users may receive different haptic feedback depending on the type of actions performed], experiences may differ per each user). Moreover, the trainer (human or virtual) may choose to provide corresponding feedback (using audio-visual or audio-visual-haptic mediums) to an individual or a group/subset of trainees in real-time. Such an experience must be provided while meeting stringent latency requirements imposed by haptic. We may add the aforementioned aspects related to dynamicity into the use cases in the next version of the draft.

Best regards,
Chathura

-----Original Message-----
From: Dirk Trossen <[email-masked]> 
Sent: 25 June 2021 15:21
To: Chathura Sarathchandra <[email-masked]>; [email-masked]
Cc: Mona Ghassemian <[email-masked]>
Subject: RE: New Version Notification for draft-sarathchandra-tactile-internet-00.txt

Hi Chathura,

Best,

Dirk

-----Original Message-----
From: Int-area [mailto:[email-masked]] On Behalf Of Chathura Sarathchandra
Sent: 25 June 2021 15:49
To: [email-masked]
Cc: Mona Ghassemian <[email-masked]>
Subject: Re: [Int-area] New Version Notification for draft-sarathchandra-tactile-internet-00.txt

Dear all,

Best regards,
Chathura

-----Original Message-----
From: [email-masked] <[email-masked]> 
Sent: 25 June 2021 14:28
To: Chathura Sarathchandra <[email-masked]>; Mona Ghassemian <[email-masked]>; Morteza Kheirkhah <[email-masked]>
Subject: New Version Notification for draft-sarathchandra-tactile-internet-00.txt

Abstract:

The IETF Secretariat

---

From: Dirk Trossen <[email-masked]>
Date: Tue, 29 Jun 2021 09:23:31 +0000

Hi Chathura,

Please see inline. I'm also CCing the SARAH list where some members may have comments on this draft, too. 

Best,

Dirk

-----Original Message-----
From: Chathura Sarathchandra [mailto:[email-masked]] 
Sent: 28 June 2021 18:26
To: Dirk Trossen <[email-masked]>; [email-masked]
Cc: Mona Ghassemian <[email-masked]>; Morteza Kheirkhah <[email-masked]>; Renan Krishna <[email-masked]>
Subject: RE: New Version Notification for draft-sarathchandra-tactile-internet-00.txt

Hi Dirk,

Thanks for the suggested additional dimension for the use cases.  The use case referenced is an interesting one indeed (user interactivity and personalization added on top of https://www.kcl.ac.uk/news/the-worlds-first-5g-low-latency-3-way-distributed-orchestra-at-kcl)! 
[DOT] AFAIK the KCL demonstration was focused on audio sync, not haptic.

Could not find a link however to haptic communication aspect. Maybe can provide a haptic experience that is in sync with music for users who are disabled and can't perceive audio and/or video?
[DOT] The COIN RG case does not talk about haptics, specifically. But it's mainly linked into music and theatre performance but more 'haptic performances' could be in scope, too.

By dynamicity do you mean how different user profiles and user interactions are taken into consideration, in multi-user scenarios? And how the resulting user-specific information (of the same experience) being transferred to users  (audio-video-haptic) ? If yes, certainly it is another dimension of the use cases, e.g., Entertainment (gaming), Training (training simulations). For example, in scenarios where virtual simulation environments used for training, where multiple users act upon the same virtual objects, the information received by individual 'trainee users' may differ due to 1) user preferences (e.g., with haptic feedback vs without) 2) individual user's perception (e.g.., audio, video haptic) of objects and actions/events within the virtual environment (e.g., based on viewpoint, distance to objects/events, and properties of virtual objects [different users may receive different haptic feedback depending on the type of actions performed], experiences may differ per each user). Moreover, the trainer (human or virtual) may choose to provide corresponding feedback (using audio-visual or audio-visual-haptic mediums) to an individual or a group/subset of trainees in real-time. Such an experience must be provided while meeting stringent latency requirements imposed by haptic. We may add the aforementioned aspects related to dynamicity into the use cases in the next version of the draft.
[DOT] Indeed, it's the dynamics of user interactions, particularly when moving towards multi-modal interactions; surely this will depend on the intended dynamicity of the interaction as well (e.g., going beyond lecture style of interaction). This also may bring in aspects of multi-flow synchronization, which need to be coordinated, too. 

Best regards,
Chathura

-----Original Message-----
From: Dirk Trossen <[email-masked]>
Sent: 25 June 2021 15:21
To: Chathura Sarathchandra <[email-masked]>; [email-masked]
Cc: Mona Ghassemian <[email-masked]>
Subject: RE: New Version Notification for draft-sarathchandra-tactile-internet-00.txt

Hi Chathura,

Best,

Dirk

-----Original Message-----
From: Int-area [mailto:[email-masked]] On Behalf Of Chathura Sarathchandra
Sent: 25 June 2021 15:49
To: [email-masked]
Cc: Mona Ghassemian <[email-masked]>
Subject: Re: [Int-area] New Version Notification for draft-sarathchandra-tactile-internet-00.txt

Dear all,

Best regards,
Chathura

-----Original Message-----
From: [email-masked] <[email-masked]>
Sent: 25 June 2021 14:28
To: Chathura Sarathchandra <[email-masked]>; Mona Ghassemian <[email-masked]>; Morteza Kheirkhah <[email-masked]>
Subject: New Version Notification for draft-sarathchandra-tactile-internet-00.txt

Abstract:

The IETF Secretariat

[Banner]

[Banner]<https://www.interdigital.com/features/sustainability-in-a-wireless-world>

Sustainability in a Wireless World: Research dedicated to understanding the impact of our technologies on the planet.<https://www.interdigital.com/features/sustainability-in-a-wireless-world>
This e-mail is intended only for the use of the individual or entity to which it is addressed, and may contain information that is privileged, confidential and/or otherwise protected from disclosure to anyone other than its intended recipient. Unintended transmission shall not constitute waiver of any privilege or confidentiality obligation. If you received this communication in error, please do not review, copy or distribute it, notify me immediately by email, and delete the original message and any attachments. Unless expressly stated in this e-mail, nothing in this message or any attachment should be construed as a digital or electronic signature.

---

From: Behcet Sarikaya <[email-masked]>
Date: Tue, 29 Jun 2021 10:09:02 -0500

To Intarea chairs,

I was glancing through the mails on this draft and related ones.
It seems like the issue discussed is or very similar to those already being
discussed in IRTF.
So spend WG time on this?

Behcet

On Tue, Jun 29, 2021 at 4:23 AM Dirk Trossen <[email-masked]>
wrote:

> Cc: Mona Ghassemian <[email-masked]>; Morteza Kheirkhah
> <[email-masked]>; Renan Krishna
> <[email-masked]>
> Subject: RE: New Version Notification for
> Thanks for the suggested additional dimension for the use cases.  The use
> case referenced is an interesting one indeed (user interactivity and
> personalization added on top of
> https://www.kcl.ac.uk/news/the-worlds-first-5g-low-latency-3-way-distributed-orchestra-at-kcl)!
>
> Could not find a link however to haptic communication aspect. Maybe can
> provide a haptic experience that is in sync with music for users who are
> disabled and can't perceive audio and/or video?
> [DOT] The COIN RG case does not talk about haptics, specifically. But it's
> mainly linked into music and theatre performance but more 'haptic
> performances' could be in scope, too.
>
> By dynamicity do you mean how different user profiles and user
> interactions are taken into consideration, in multi-user scenarios? And how
> the resulting user-specific information (of the same experience) being
> transferred to users  (audio-video-haptic) ? If yes, certainly it is
> another dimension of the use cases, e.g., Entertainment (gaming), Training
> (training simulations). For example, in scenarios where virtual simulation
> environments used for training, where multiple users act upon the same
> virtual objects, the information received by individual 'trainee users' may
> differ due to 1) user preferences (e.g., with haptic feedback vs without)
> 2) individual user's perception (e.g.., audio, video haptic) of objects and
> actions/events within the virtual environment (e.g., based on viewpoint,
> distance to objects/events, and properties of virtual objects [different
> users may receive different haptic feedback depending on the type of
> actions performed], experiences may differ per each user)
>  . Moreover, the trainer (human or virtual) may choose to provide
> corresponding feedback (using audio-visual or audio-visual-haptic mediums)
> to an individual or a group/subset of trainees in real-time. Such an
> experience must be provided while meeting stringent latency requirements
> imposed by haptic. We may add the aforementioned aspects related to
> dynamicity into the use cases in the next version of the draft.
> [DOT] Indeed, it's the dynamics of user interactions, particularly when
> moving towards multi-modal interactions; surely this will depend on the
> intended dynamicity of the interaction as well (e.g., going beyond lecture
> style of interaction). This also may bring in aspects of multi-flow
> synchronization, which need to be coordinated, too.
>
> Best regards,
> Chathura
>
> Subject: RE: New Version Notification for
> Interesting draft, indeed, to start a discussion here on this list.
> Adrian's responded with a piece I'd also recommended, namely the SARAH
> list, where this contribution may well contribute to possible discussions
> on addressing and routing aspects related to the Tactile Internet.
>
> Apart from that, I wonder about the degree of dynamicity that you foresee
> in your scenarios (of Section 4)? The use case draft in the COIN RG (
> https://datatracker.ietf.org/doc/draft-irtf-coinrg-use-cases/) outlines
> an entertainment use case with a personalized and interactive nature, where
> dynamic relations, e.g., between (parts of the) performers and (parts of
> the) audience are foreseen. The tactile notion is not emphasized here,
> leading to higher acceptable latencies maybe (although when mixing
> distributed music, you are still down at few ms latency). But it's the
> dynamic relations that I wanted to point out, which pose additional
> requirements. This may also be the case for industrial use cases, BTW.
> Maybe something to consider as a possible dimension?
>
> Best,
>
> Dirk
>
> To: Chathura Sarathchandra <[email-masked]>;
> Mona Ghassemian <[email-masked]>; Morteza Kheirkhah
> [Banner]<
> https://www.interdigital.com/features/sustainability-in-a-wireless-world>
>
> Sustainability in a Wireless World: Research dedicated to understanding
> the impact of our technologies on the planet.<
> https://www.interdigital.com/features/sustainability-in-a-wireless-world>
> This e-mail is intended only for the use of the individual or entity to
> which it is addressed, and may contain information that is privileged,
> confidential and/or otherwise protected from disclosure to anyone other
> than its intended recipient. Unintended transmission shall not constitute
> waiver of any privilege or confidentiality obligation. If you received this
> communication in error, please do not review, copy or distribute it, notify
> me immediately by email, and delete the original message and any
> attachments. Unless expressly stated in this e-mail, nothing in this
> message or any attachment should be construed as a digital or electronic
> signature.
>