Subject: [Int-area] Comments on "per-app networking considerations" draft

From: "Yiannis Yiakoumis" <[email-masked]>
Date: Tue, 15 Jun 2021 11:48:41 +0000

Late on the game, but wanted to share some thoughts on Tommy's and Lorenzo's draft on per-app networking ( https://datatracker.ietf.org/doc/html/draft-per-app-networking-considerations ).

First of all, having a dedicated document that discusses per-app network considerations and the implications with privacy and neutrality is great help, as we can focus such discussion here and separate it from technical mechanisms that try to offer solutions in these areas.

A category abstraction is definitely interesting and has its merits. With regards to privacy, it reduces the information revealed to the network (subject to generic enough categories). With regards to neutrality, it addresses - up to a certain extent - concerns around user choice and competition (i.e., if all gaming apps experience similar network behavior, there is not much competitive advantage to be earned). With regards to implementation, if we assume there is a centralized authority for categorization, there is potential to simplify provisioning of such services across different administrative domains (especially for E2E services like latency SLAs which would benefit from a multi-domain enforcement). And with regards to incentives, it's necessary for services where a pay-per-use model doesn't work well (e.g., zero-rating).

The big challenge with category-based differentiation is definition and enforcement of categorization. There is significant experience from Europe's zero-rating implementation, where regulators approved category-based zero-rating, and more than 30 network operators implemented it (based on DPI). In my experience, a decentralized approach (where each operator defines categories themselves, and enforces them through a heavyweight implementation process like DPI) doesn't work well, especially for smaller apps that don't have the resources to work with operators, and end-up being in a bigger disadvantage when their large competitors participate in such programs.  As a reference point, we've seen 10% success rate and 8-months average integration time for an eligible music streaming company to participate in Europe's music zero-rating programs, when the most popular apps were available in most of them from the very beginning (more details on this here).

A good step forward would be to define a metric around time/cost to participate, and what advances would help reduce this. Tommy/Lorenzo --- what are your thoughts on category definitions? Have you seen any other paradigm we could follow/re-use in terms of category definitions and eligibility? Could Apple/Play stores playing a role in such an effort?

I think the document would benefit from explicitly mentioning incentives of different stakeholders, and what mitigation mechanisms exist to align incentives with protections of privacy and neutrality. For example, a gaming zero-rating category incentivizes operators to ensure that only "gaming traffic" would go through there, otherwise there is an incentive for users/apps to mark their traffic as gaming to get a free ride. In contrast, in a low-latency category operators can use a pay-per-use pricing structure, and therefore not care much about what traffic goes over it.

In that direction, another approach to mitigate neutrality and privacy considerations (especially for pay-per-use types of services like QoS) is a user-based approach. The only thing that needs to be communicated is the desire of a user to forward a packet through a certain path. In that sense it can be application-agnostic, and therefore address all concerns around both privacy and net neutrality.

I see that the document has expired. Is there interest to continue the effort in follow-up meetings?

Best,

Yiannis

Yiannis .

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Tue, 15 Jun 2021 07:29:40 -0500

For what it's worth,

On Tue, Jun 15, 2021 at 6:49 AM Yiannis Yiakoumis <[email-masked]>
wrote:

> Late on the game, but wanted to share some thoughts on Tommy's and
> Lorenzo's draft on per-app networking (
> https://datatracker.ietf.org/doc/html/draft-per-app-networking-considerations
>  ).
>
> First of all, having a dedicated document that discusses per-app network
> considerations and the implications with privacy and neutrality is great
> help, as we can focus such discussion here and separate it from technical
> mechanisms that try to offer solutions in these areas.
>
> A category abstraction is definitely interesting and has its merits. With
> regards to privacy, it reduces the information revealed to the network
> (subject to generic enough categories). With regards to neutrality, it
> addresses - up to a certain extent - concerns around user choice and
> competition (i.e., if all gaming apps experience similar network behavior,
> there is not much competitive advantage to be earned). With regards to
> implementation, if we assume there is a centralized authority for
> categorization, there is potential to simplify provisioning of such
> services across different administrative domains (especially for E2E
> services like latency SLAs which would benefit from a multi-domain
> enforcement). And with regards to incentives, it's necessary for services
> where a pay-per-use model doesn't work well (e.g., zero-rating).
>
> The big challenge with category-based differentiation is definition and
> enforcement of categorization. There is significant experience from
> Europe's zero-rating implementation, where regulators approved
> category-based zero-rating, and more than 30 network operators implemented
> it (based on DPI). In my experience, a decentralized approach (where each
> operator defines categories themselves, and enforces them through a
> heavyweight implementation process like DPI) doesn't work well, especially
> for smaller apps that don't have the resources to work with operators, and
> end-up being in a bigger disadvantage when their large competitors
> participate in such programs.  As a reference point, we've seen 10% success
> rate and 8-months average integration time for an eligible music streaming
> company to participate in Europe's music zero-rating programs, when the
> most popular apps were available in most of them from the very beginning
> (more details on this here).
>
> A good step forward would be to define a metric around time/cost to
> participate, and what advances would help reduce this. Tommy/Lorenzo ---
> what are your thoughts on category definitions? Have you seen any
> other paradigm we could follow/re-use in terms of category definitions and
> eligibility? Could Apple/Play stores playing a role in such an effort?
>
> I think the document would benefit from explicitly mentioning incentives
> of different stakeholders, and what mitigation mechanisms exist to align
> incentives with protections of privacy and neutrality. For example, a
> gaming zero-rating category incentivizes operators to ensure that only
> "gaming traffic" would go through there, otherwise there is an incentive
> for users/apps to mark their traffic as gaming to get a free ride. In
> contrast, in a low-latency category operators can use a pay-per-use pricing
> structure, and therefore not care much about what traffic goes over it.
>
> In that direction, another approach to mitigate neutrality and privacy
> considerations (especially for pay-per-use types of services like QoS) is a
> user-based approach. The only thing that needs to be communicated is the
> desire of a user to forward a packet through a certain path. In that sense
> it can be application-agnostic, and therefore address all concerns around
> both privacy and net neutrality.
>

I hope so, very much.

Tommy said, during the meeting, "Tommy: 3 different legs: one belongs to
IAB for the overall architecture, one is still research in solution space,
that's trust between those nodes; and here: what are we doing today? tools
we have, ways we think are bad to use those tools". That was in response to
a question I asked, so Tommy thought there are definitely topics from the
presentation that are in scope for the IETF.

I said (in Jabber, but it's in the minutes at
https://datatracker.ietf.org/meeting/110/materials/minutes-110-intarea-01)
that "this would make a smashing topic for an INTAREA interim meeting
before IETF 111,* if the charter allows it.*", but I don't know if anyone
ever said that the charter allowed it.

Is INTAREA the place we should be talking about this? If not, where?

Best,

Spencer

> Best,
> Yiannis
>
>
> Yiannis .
>
> _______________________________________________
> Int-area mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/int-area
>

---

From: Lorenzo Colitti <[email-masked]>
Date: Tue, 15 Jun 2021 23:46:31 +0900

> (more details on this here).

That's a good point. I think it would definitely be useful to note in the
draft that categories can sometimes be difficult to define, coordinate, and
enforce.

> eligibility? Could Apple/Play stores playing a role in such an effort?

I think categories/manual review/abuse reporting in app stores could play a
role here, as could on-device analysis of app behaviour and traffic
patterns. That said - the intent of this draft is not to stray too far into
solution space; the primary intent is to call attention to the implications
of per-app networking, and I think that's valuable in itself. The idea is
that while designing solutions may be a lot more work, at least having a
document that says, "here are the implications" will help provide food for
thought for folks considering implementing these practices.

I think the document would benefit from explicitly mentioning incentives of
> different stakeholders, and what mitigation mechanisms exist to align

It's true that if apps can simply announce themselves to be whatever
category they believe is going to give them better treatment, then they
have an incentive to do so. We might want to put some text into the draft
about this, and noting that possible ways to make this work would be using
trusted/neutral third parties, or with existing business relationships
(roughly equivalent, if you will, to a finer-grained way of doing QoS
signalling). I think it might be difficult to word that text in a way that
is technical enough and concrete enough for an IETF draft though; there's a
risk that it would be either too vague or too specific. Think you could
suggest something?

> both privacy and net neutrality.

Are you envisaging that the user would make these selections manually? That
seems very difficult to explain to users. Perhaps I don't understand?

> effort in follow-up meetings?

We definitely want to continue to update the document and seek adoption if
there is interest in the WG.

---

From: "Yiannis Yiakoumis" <[email-masked]>
Date: Thu, 17 Jun 2021 09:30:06 +0000

On Tue, Jun 15, 2021 at 7:46 AM, Lorenzo Colitti < [email-masked] > wrote:

> 
> On Tue, Jun 15, 2021 at 8:49 PM Yiannis Yiakoumis < gyiakoumis@ gmail. com
> ( [email-masked] ) > wrote:
> 
> 
>> participate in such programs.  As a reference point, we've seen 10%
>> success rate and 8-months average integration time for an eligible music
>> streaming company to participate in Europe's music zero-rating programs,
>> when the most popular apps were available in most of them from the very
>> beginning (more details on this here).
>> 
>> 
> 
> 
> 
> draft that categories can sometimes be difficult to define, coordinate,
> and enforce.
> 
> 
> 
> 
>> what are your thoughts on category definitions? Have you seen any other
>> paradigm we could follow/re-use in terms of category definitions and
> I think categories/manual review/abuse reporting in app stores could play
> a role here, as could on-device analysis of app behaviour and traffic
> patterns. That said - the intent of this draft is not to stray too far
> into solution space; the primary intent is to call attention to the
> implications of per-app networking, and I think that's valuable in itself.
> The idea is that while designing solutions may be a lot more work, at
> least having a document that says, "here are the implications" will help
> provide food for thought for folks considering implementing these
> practices.
> 
> 
> 
> 

Agreed that this document shouldn't go into solution space. This doesn't prevent us from having some high-level metrics/goals that would have directly impact the projected implications, and help evaluate whether a solution is good or not down the road.

>> contrast, in a low-latency category operators can use a pay-per-use
>> pricing structure, and therefore not care much about what traffic goes
>> over it.
>> 
>> 
> 
> 
> 
> is technical enough and concrete enough for an IETF draft though; there's
> a risk that it would be either too vague or too specific. Think you could
> suggest something?
> 
> 
> 
> 

It feels that this is too important (and with strong ramifications on the overall architecture) to ignore. If categories require strong definition (i.e, they dictate if an application is eligible to participate), then a neutral authority can be essential to protect both privacy and neutrality. This is not necessary If categories are loose (i.e., they define network characteristics but any application could participate subject to cost/caps etc). I could attempt to add some text on the draft if it is of interest.

>> considerations (especially for pay-per-use types of services like QoS) is
>> a user-based approach. The only thing that needs to be communicated is the
> Are you envisaging that the user would make these selections manually?
> That seems very difficult to explain to users. Perhaps I don't understand?
> 
> 
> 
> 
> 

Yes, I think there are ways to get the user involved on the selection process. User experience is a UI/UX problem which there are ways to solve. One way to structure this is as a low-latency permission in your phone OS (similar to location, camera, etc); a developer can ask for this permission and a user can simply approve/deny/revoke. It is straight forward for the users and familiar as a workflow. A few of us have been thinking along these lines and we do have early implementations that do this.

> there is interest in the WG.

Great to hear and looking forward to the discussion!

Yiannia