Subject: Re: [Int-area] New Version Notification for draft-lhan-problems-requirements-satellite-net-00.txt

From: Stewart Bryant <[email-masked]>
Date: Fri, 9 Jul 2021 07:32:04 +0100

Unfortunately LI is not our call.

I know the IETF finds it an anathema but it is an unspoken (in IETF) reality of the telecommunications industry.

The concept of a huge number of highly portable, highly directional, microwave links that are then relayed opaquely to a foreign country is going to delight some agencies and give heartburn to their colleagues in other parts of the same agency cluster.

I think that we can all postulate how this would (will) be solved in a mega-cluster owned by a large ITU region 2 country, or a particularly large Asian country but I assume we want to design a global / universal system rather than one that will otherwise inevitably be partitioned due to geo-political security concerns.

Stewart

Sent from my iPad

> On 8 Jul 2021, at 23:22, Lin Han <[email-masked]> wrote:
> 
> 
> Hesham,
>  
> Thanks for the answer.
> I don’t have too many concerns for this regard, and it may be out the scope of the draft.
>  
> Satellite to ground station communication needs license for its spectrum in different country and LI is feasible.
> But ISL is between satellites. LI may not be a feasible requirement: 1) Satellites are in out space that is not belonging to any country, so I doubt any country can have such legal requirement for ISL. 2) ISL use laser that is not a spectrum controlled by any country or organization. 3) LI for ISL is so costly and seems not likely. You need to get FCC or other organization’s approve for the new orbit to launch a new satellite and its orbit is very close to the existing satellite, this itself is almost impossible. I don’t see any other feasible way you can do LI for ISL if laser is used for ISL.
>  
> Regards
>  
> Lin
>  
>  
> From: Hesham ElBakoury <[email-masked]> 
> Sent: Thursday, July 8, 2021 10:57 AM
> To: Lin Han <[email-masked]>
> Cc: Stewart Bryant <[email-masked]>; [email-masked]; [email-masked]; [email-masked]; UTTARO, JAMES <[email-masked]>; [email-masked]
> Subject: Re: [Int-area] New Version Notification for draft-lhan-problems-requirements-satellite-net-00.txt
>  
> I think LI means Lawful Intercept.
> It is a security issue. I recall seeing some ETSI documents about it.
>  
> Hesham
>  
> On Thu, Jul 8, 2021, 10:52 AM Lin Han <[email-masked]> wrote:
> Hi, Stewart,
>  
> What does “LI” stand for?
> ISL is not mature enough for real adoption.
> The academia research suggested to use laser instead of microwave. When laser is used for ISL, there should not have spectrum license issue, I don’t see the ITU or USA has spectrum allocation for the frequency of laser (400THz~700THz).
>  
> Lin
>  
> From: Stewart Bryant <[email-masked]> 
> Sent: Thursday, July 8, 2021 7:19 AM
> To: Hesham ElBakoury <[email-masked]>
> Cc: Stewart Bryant <[email-masked]>; Lin Han <[email-masked]>; [email-masked]; [email-masked]; [email-masked]; UTTARO, JAMES <[email-masked]>; [email-masked]
> Subject: Re: [Int-area] New Version Notification for draft-lhan-problems-requirements-satellite-net-00.txt
>  
> The thing that worries me about iSL is whether the inability to do LI will prohibit licensing in some countries.
>  
> - Stewart
>  
>  
>  
> 
> On 7 Jul 2021, at 03:51, Hesham ElBakoury <[email-masked]> wrote:
>  
> Mark Handley published the paper "Using ground relays for low-latency wide-area routing in megaconstellations" to show that even if we do not have ISL we can use ground terminals to route traffic with better latency than fiber links.
>  
> Thanks
> Hesham
>  
>  
> On Tue, Jul 6, 2021, 10:08 AM Lin Han <[email-masked]> wrote:
> Hi, Jim
> 
> I don't have clear answer.
> What I can guess now is that most of current technologies (with enhancement) can be used, but some new technologies might be needed to solve the satellite specific issues, such as fast mobility, frequent topology changes, constraints in satellite power, security in open space, etc.
> It is up to the community to decide what new technologies and what new protocols will be developed.
> 
> Regards
> 
> Lin
> 
> 
> -----Original Message-----
> From: UTTARO, JAMES <[email-masked]> 
> Sent: Tuesday, July 6, 2021 7:20 AM
> To: Lin Han <[email-masked]>; [email-masked]; [email-masked]; [email-masked]
> Cc: [email-masked]
> Subject: RE: New Version Notification for draft-lhan-problems-requirements-satellite-net-00.txt
> 
> Lin,
> 
>         Are you suggesting that the current set of protocols can be used with or without enhancements or is the uniqueness of the satellite network require new protocol(s) to address the architecture you have laid out.. 
> 
> Thanks,
>         Jim Uttaro
> 
> -----Original Message-----
> From: Idr <[email-masked]> On Behalf Of Lin Han
> Sent: Saturday, July 03, 2021 8:41 PM
> To: [email-masked]; [email-masked]; [email-masked]
> Cc: [email-masked]
> Subject: [Idr] FW: New Version Notification for draft-lhan-problems-requirements-satellite-net-00.txt
> 
> Hi, 
> 
> This draft analyzed the problems and requirements for the satellite network when it is integrated with Internet by current routing technologies. 
> It may be relevant and interesting to internet, BGP, IGP. The further solution proposals may also come from different groups including research initiative SARAH.
> 
> Look forwarding to discussion and comments.
> 
> Thanks
> 
> Lin
> 
> -----Original Message-----
> From: [email-masked] <[email-masked]> 
> Sent: Saturday, July 3, 2021 5:07 PM
> To: Lin Han <[email-masked]>; Richard Li <[email-masked]>
> Subject: New Version Notification for draft-lhan-problems-requirements-satellite-net-00.txt
> 
> 
> A new version of I-D, draft-lhan-problems-requirements-satellite-net-00.txt
> has been successfully submitted by Lin Han and posted to the IETF repository.
> 
> Name:           draft-lhan-problems-requirements-satellite-net
> Revision:       00
> Title:          Problems and Requirements of Satellite Constellation for Internet
> Document date:  2021-07-03
> Group:          Individual Submission
> Pages:          32
> URL:            https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Furldefense.com%2Fv3%2F__https%3A%2F%2Fnam11.safelinks.protection.outlook.com%2F%3Furl%3Dhttps*3A*2F*2Fwww.ietf.org*2Farchive*2Fid*2Fdraft-lhan-problems-requirements-satellite-net-00.txt%26amp%3Bdata%3D04*7C01*7Clin.han*40futurewei.com*7C495bb2e109a743748f6108d93e7fa6f8*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C0*7C637609540278583772*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000%26amp%3Bsdata%3DqoFJMo63iQsH8W9iTaP5Vx*2F4OjIhXHoY*2BrdbcM*2FMntM*3D%26amp%3Breserved%3D0__%3BJSUlJSUlJSUlJSUlJSUlJSUlJSUlJQ!!BhdT!xvPiP9_hbkTD5NSajUzwqMhYGZLdFbSjp8NUTJ6PMxLHqI6tW_E4RbgGabg%24&amp;data=04%7C01%7Clin.han%40futurewei.com%7Cc54df16138144c7ed23408d940893b44%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637611780428304372%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=xeP%2BMuWGk%2By8UtK8K9Oinjvk50jBp%2FuZQ2
>  rC8uHaH2M%3D&amp;reserved=0 
> Status:         https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Furldefense.com%2Fv3%2F__https%3A%2F%2Fnam11.safelinks.protection.outlook.com%2F%3Furl%3Dhttps*3A*2F*2Fdatatracker.ietf.org*2Fdoc*2Fdraft-lhan-problems-requirements-satellite-net*2F%26amp%3Bdata%3D04*7C01*7Clin.han*40futurewei.com*7C495bb2e109a743748f6108d93e7fa6f8*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C0*7C637609540278583772*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000%26amp%3Bsdata%3Dr81hJUdFIvaZlm8DQYVBq3vMdC8x7SeExjqIZyE765g*3D%26amp%3Breserved%3D0__%3BJSUlJSUlJSUlJSUlJSUlJSUlJQ!!BhdT!xvPiP9_hbkTD5NSajUzwqMhYGZLdFbSjp8NUTJ6PMxLHqI6tW_E4pUhPs_o%24&amp;data=04%7C01%7Clin.han%40futurewei.com%7Cc54df16138144c7ed23408d940893b44%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637611780428304372%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=v2TL2s8B1%2B5s5jd90eOoX9mFhF1Onrl5H1t3ANih2ZM%3D&amp;re
>  served=0 
> Html:           https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Furldefense.com%2Fv3%2F__https%3A%2F%2Fnam11.safelinks.protection.outlook.com%2F%3Furl%3Dhttps*3A*2F*2Fwww.ietf.org*2Farchive*2Fid*2Fdraft-lhan-problems-requirements-satellite-net-00.html%26amp%3Bdata%3D04*7C01*7Clin.han*40futurewei.com*7C495bb2e109a743748f6108d93e7fa6f8*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C0*7C637609540278583772*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000%26amp%3Bsdata%3DYGLcf4XbKhOQwcFj4iFyYrmEpbi3yKt8BcPeVQvaua0*3D%26amp%3Breserved%3D0__%3BJSUlJSUlJSUlJSUlJSUlJSUlJQ!!BhdT!xvPiP9_hbkTD5NSajUzwqMhYGZLdFbSjp8NUTJ6PMxLHqI6tW_E4oLMB6mk%24&amp;data=04%7C01%7Clin.han%40futurewei.com%7Cc54df16138144c7ed23408d940893b44%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637611780428304372%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=mNQ9LrmFNNJKJomi3ocawbPYPt96UIntbZQN2vtsafY%3D&am
>  p;reserved=0 
> Htmlized:       https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Furldefense.com%2Fv3%2F__https%3A%2F%2Fnam11.safelinks.protection.outlook.com%2F%3Furl%3Dhttps*3A*2F*2Fdatatracker.ietf.org*2Fdoc*2Fhtml*2Fdraft-lhan-problems-requirements-satellite-net%26amp%3Bdata%3D04*7C01*7Clin.han*40futurewei.com*7C495bb2e109a743748f6108d93e7fa6f8*7C0fee8ff2a3b240189c753a1d5591fedc*7C1*7C0*7C637609540278593776*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000%26amp%3Bsdata%3Djl23CFSMjAbFnPCvHABeVeAKmOH1ODaq1q7U2BfH*2FQU*3D%26amp%3Breserved%3D0__%3BJSUlJSUlJSUlJSUlJSUlJSUlJSU!!BhdT!xvPiP9_hbkTD5NSajUzwqMhYGZLdFbSjp8NUTJ6PMxLHqI6tW_E4fYkRUn0%24&amp;data=04%7C01%7Clin.han%40futurewei.com%7Cc54df16138144c7ed23408d940893b44%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637611780428304372%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=iolNgYArNpDQlaMX7Xd6hYc7vuSOxdxkeXboUnBD988%3D&a
>  mp;reserved=0 
> 
> 
> Abstract:
>    This document presents the detailed analysis about the problems and
>    requirements of satellite constellation used for Internet.  It starts
>    from the satellite orbit basics, coverage calculation, then it
>    estimates the time constraints for the communications between
>    satellite and ground-station, also between satellites.  How to use
>    satellite constellation for Internet is discussed in details
>    including the satellite relay and satellite networking.  The problems
>    and requirements of using traditional network technology for
>    satellite network integrating with Internet are finally outlined.
> 
> 
> 
> 
> The IETF Secretariat
> 
> 
> _______________________________________________
> Idr mailing list
> [email-masked]
> https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Furldefense.com%2Fv3%2F__https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fidr__%3B!!BhdT!xvPiP9_hbkTD5NSajUzwqMhYGZLdFbSjp8NUTJ6PMxLHqI6tW_E4Z0Dk4O4%24&amp;data=04%7C01%7Clin.han%40futurewei.com%7Cc54df16138144c7ed23408d940893b44%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637611780428314367%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=UC0XpJ%2FtkgXxnU9yJazLK7kMtL0X94PfeVFSeaqMaYE%3D&amp;reserved=0 
> 
> _______________________________________________
> Int-area mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/int-area
> _______________________________________________
> Int-area mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/int-area
>

---

From: Stewart Bryant <[email-masked]>
Date: Fri, 9 Jul 2021 07:43:18 +0100

Do others find it annoying that when you reply to an int area message that includes the SARAH list they have to then approve their own message?

S

---

From: Brian Carpenter <[email-masked]>
Date: Fri, 9 Jul 2021 19:24:37 +1200

>
> The IETF position on LI is not exactly that it's anathema, but that we
> will not standardise *any* intercept techniques, legal or otherwise. RFC
> 2804.
>
>
> Regards,
>     Brian Carpenter
>     (via tiny screen & keyboard)
>
> On Fri, 9 Jul 2021, 18:33 Stewart Bryant, <[email-masked]>
> wrote:
>
> I know the IETF finds it an anathema but it is an unspoken (in IETF)
> reality of the telecommunications industry.
>
> The concept of a huge number of highly portable, highly directional,
> microwave links that are then relayed opaquely to a foreign country is
> going to delight some agencies and give heartburn to their colleagues in
> other parts of the same agency cluster.
>
> I think that we can all postulate how this would (will) be solved in a
> mega-cluster owned by a large ITU region 2 country, or a particularly large
> Asian country but I assume we want to design a global / universal system
> rather than one that will otherwise inevitably be partitioned due to
> geo-political security concerns.
>
> Stewart
>
> Sent from my iPad
>
>
>

---

From: Lin Han <[email-masked]>
Date: Fri, 9 Jul 2021 16:57:17 +0000

Hi, Alexander and all

Thanks for the info and comments for LI.
After reading RFC 3924 and "LI from ETSI", my feeling is that the scope of LI for satellite networking will be pretty big and easy to be confusing, so I would think there should have a sperate draft talking about it. The current draft will add reference to it.

Comments?

Lin

From: Alexander Vainshtein <[email-masked]>
Sent: Friday, July 9, 2021 8:02 AM
To: Brian Carpenter <[email-masked]>; Stewart Bryant <[email-masked]>
Cc: Lin Han <[email-masked]>; [email-masked]; INT Area <[email-masked]>; [email-masked]; UTTARO, JAMES <[email-masked]>; [email-masked]
Subject: Re: [EXTERNAL] Re: [Int-area] New Version Notification for draft-lhan-problems-requirements-satellite-net-00.txt

Brian, Stewart and all,
RFC 2804  notwithstanding, IETF has published RFC 3924<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Frfc3924&data=04%7C01%7Clin.han%40futurewei.com%7C33a7fde993294a82e37f08d942ea8b2f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637614397424639764%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=CeckOIzWQoHoi3AAQamkMr1hPHRgOU5Jjvvqsxg%2B3Dk%3D&reserved=0>  on Cisco LI Architecture.
This is not a formal contradiction, since 3924 has been published as Informational.
Can this be used as a precedent?

Get Outlook for Android<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Faka.ms%2FAAb9ysg&data=04%7C01%7Clin.han%40futurewei.com%7C33a7fde993294a82e37f08d942ea8b2f%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637614397424649756%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=6p8IBI%2F9PCrbIs%2B7mVx547Ni%2Fr5ogB7bnknj4x2ZVnA%3D&reserved=0>

________________________________
From: rtgwg <[email-masked]<mailto:[email-masked]>> on behalf of Brian Carpenter <[email-masked]<mailto:[email-masked]>>
Sent: Friday, July 9, 2021, 10:25
To: Stewart Bryant
Cc: Lin Han; [email-masked]<mailto:[email-masked]>; INT Area; [email-masked]<mailto:[email-masked]>; UTTARO, JAMES; [email-masked]<mailto:[email-masked]>
Subject: [EXTERNAL] Re: [Int-area] New Version Notification for draft-lhan-problems-requirements-satellite-net-00.txt

The IETF position on LI is not exactly that it's anathema, but that we will not standardise *any* intercept techniques, legal or otherwise. RFC 2804.

Regards,
    Brian Carpenter

On Fri, 9 Jul 2021, 18:33 Stewart Bryant, <[email-masked]<mailto:[email-masked]>> wrote:
Unfortunately LI is not our call.

Stewart

Sent from my iPad

Notice: This e-mail together with any attachments may contain information of Ribbon Communications Inc. and its Affiliates that is confidential and/or proprietary for the sole use of the intended recipient. Any review, disclosure, reliance or distribution by others or forwarding without express permission is strictly prohibited. If you are not the intended recipient, please notify the sender immediately and then delete all copies, including any attachments.

Notice: This e-mail together with any attachments may contain information of Ribbon Communications Inc. and its Affiliates that is confidential and/or proprietary for the sole use of the intended recipient. Any review, disclosure, reliance or distribution by others or forwarding without express permission is strictly prohibited. If you are not the intended recipient, please notify the sender immediately and then delete all copies, including any attachments.

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 10 Jul 2021 15:51:55 +1200

Alexander,

As the tracker shows, that RFC was published in the Independent Submission stream, not the IETF stream. There are indeed many cases of non-IETF protocols being published as Informational RFCs, but today that would always be in the Independent stream. The "status of this memo" section is then 
quite explicit, e.g.:
https://www.rfc-editor.org/rfc/rfc8799.html#name-status-of-this-memo

That is of course a precedent. 

Regards
   Brian Carpenter

On 10-Jul-21 03:02, Alexander Vainshtein wrote:
> Brian, Stewart and all,
> RFC 2804  notwithstanding, IETF has published RFC 3924 <https://datatracker.ietf.org/doc/html/rfc3924>  on Cisco LI Architecture.
> Get Outlook for Android <https://aka.ms/AAb9ysg>
> 
> ------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
> *From:* rtgwg <[email-masked]> on behalf of Brian Carpenter <[email-masked]>
> *Sent:* Friday, July 9, 2021, 10:25
> *To:* Stewart Bryant
> *Cc:* Lin Han; [email-masked]; INT Area; [email-masked]; UTTARO, JAMES; [email-masked]
> *Subject:* [EXTERNAL] Re: [Int-area] New Version Notification for draft-lhan-problems-requirements-satellite-net-00.txt
> 
>     The IETF position on LI is not exactly that it's anathema, but that 
we will not standardise *any* intercept techniques, legal or otherwise. RFC 2804.
>     On Fri, 9 Jul 2021, 18:33 Stewart Bryant, <[email-masked] 
<mailto:[email-masked]>> wrote:
>         The concept of a huge number of highly portable, highly directional, microwave links that are then relayed opaquely to a foreign country 
is going to delight some agencies and give heartburn to their colleagues in other parts of the same agency cluster.