Subject: Re: ARP, MCAP, signature

From: "Hattig, Myron" <[email-masked]>
Date: Tue, 12 Jan 1999 12:55:08 -0800

Venkata,

> So, for my understanding, we are still going to have a
> signature field for reassembly purposes.

Without bridges there is no problem that I am aware of.

> And it is very likely to pose a problem in the bridged
> environment as said above.

Yes.

> Then shouldn't we consider resolving the signature
> issue in the bridged environment  now itself.

If possible, yes. It may be impossible if the solution
depends on undefined portions of another spec.

> My concern is if we cannot rely on the BusId generating
> a unique number seem tobe scary;  For instance
> taking 16 bits from EUI-64 won't produce unique numbers,

Yes.

> so I  am worried at the possibility of increasing the
> the number of signature  bits to tackle
> bridged environment.

I think increasing the number of signature bits would be the
wrong solution.

> Or do we have to look at Gasp header ?

Upon reflection, I guess the best solution is to look at the GASP
all the time and possibly remove the signature field from the link
frag header, or call the signature field reserved as Kenji suggested.
Maybe part of Kenji's proposal I missed is to always use the source
node Id in the GASP header. This would be a workable solution.

-myron

---

From: Venkata Tanikella <[email-masked]>
Date: Tue, 12 Jan 1999 13:02:43 -0800

Myron,
Looking at GASP headers, and taking the nodeid from there looks fine to me;
I am relatively uneducated on GASP; Could you please give some pointers as
to how I can get information on it or forward any information that you have ?
I am presuming GASP is only relevant in a bridged environment;
If that is true in a non-bridged environment we still need a signature and
it has to be valid isn't it ?

If that is false, is it that Ip1394 can't be used on existing 1394-1995
(With Async stream support) networks?

regards,
Venkat