Subject: Mtu related issue

From: BHAVESH R PATHAK <[email-masked]>
Date: Mon, 25 Jan 1999 15:01:40 -0530

Dear everyone,
I have got following doubt.

draft-ietf-ip1394-ipv4-12.txt does not enforce that IP over 1394
should be implemented as,
type- 1) native IP over 1394 or,
type- 2) emulation of ehternet or token ring over 1394. And ip over this
         emulation.

If choice is left to the implementation, following interoperability
problem may arise.

    -------------                      ----------------
   | Native IP   |                     | Non-native IP |
   --------------                      ----------------
      |   | IP_mtu = 512 - x              |    | IP_mtu = Ether_mtu - y
      |   |                               |    |
      |   |                               |    |
      |   |                               |    |
     --------------                    ---------------
    | type-1       |                  |  type-2       |
    |implementation|                  |implementation |
    | (Node-1)     |                  | (Node-2)      |
    ---------------                    ---------------
       | link_level_mtu = 512                | link_level_mtu = 512
       |                                     |
       |                                     |
       |                                     |
       |      1394 bus (100 Mbps)            |
       ---------------------------------------

 In the above figure, mtu for the IP is reduced by "x" and "y"
 (actual value of this is not required for this discussion)
 so that IP datagram can fit in the 512 byte long 1394 packet.

 - data transmission from Node-1 to Node-2 will be fine.

 - But, when data is transmitted from Node-2 to Node-1, and if the
   data_length is greater then IP_mtu (at node-1), IP will discard the data
   because it will not expect any packet having length greater then
   IP_mtu.

 So, I think that standard should specify which one of above two approach
 should be adopted for implementation of IP over 1394.

 with regards,
 bhavesh

---

From: Kenji Fujisawa <[email-masked]>
Date: Mon, 25 Jan 1999 18:59:36 +0900

> should be adopted for implementation of IP over 1394.

draft-ietf-ip1394-ipv4-12.txt
:  For either of these reasons, the maximum data payload transmissible
:  between IP-capable nodes MAY be less than the 1500 octet maximum
:  transmission unit (MTU) specified by this document. This requires that
:  the encapsulation format also permit 1394 link-level fragmentation and
:  reassembly of IP datagrams.

Best Regards,

Kenji Fujisawa