Subject: DHCP cost

From: Yves Bausch <[email-masked]>
Date: Mon, 11 Jan 1999 17:43:06 +0100

Dear Everyone,

I am looking for some information on IP over 1394: Is there any existing
evaluation of the implementation cost for DHCP servers / clients in 1394
IP-capable nodes? Does it make sense to have many DHCP servers with a DHCP
server election function [as in VESA Home Network (draft)]?

Thank you.

Regards,

Yves

Yves Bausch
Societe Europeenne des Satellites
Tel +352 710725-210
Fax +352 710725-482

---

From: Kenji Fujisawa <[email-masked]>
Date: Tue, 12 Jan 1999 10:37:48 +0900

>Is there any existing
>IP-capable nodes?

I'm not sure what kind of answer you expect.
The 'implementation cost' will depend on the situation.

If you implement all of the DHCP, it will be much work.
If you have a DHCP implementation for Ethernet, the modification
will not be a hard task.
Actually, I modified DHCP for BSD, it was a work of several days.

>Does it make sense to have many DHCP servers with a DHCP

RFC2131 says,
:  3. The client receives one or more DHCPOFFER messages from one or more
:     servers.  The client may choose to wait for multiple responses.
:     The client chooses one server from which to request configuration
:     parameters, based on the configuration parameters offered in the
:     DHCPOFFER messages.

I don't know any specific server election function.
Would you teach me how can I get the documents?

Best Regards,

Kenji Fujisawa