Subject: Re: MCAP descriptor question

From: OSAKABE Yoshio <[email-masked]>
Date: Mon, 25 Jan 1999 16:46:50 +0900

At 07:55 99/01/25 +0100, Bernecker Herbert wrote:
> Hallo IP1394ers,

You can know them from "tcode" in packet header.

>
> I have a question about the MCAP group address descriptor format.
> How i can differentiate between asynchronous and isochronous streams ?
> There is only a field for the channel.
>                              1                   2                   3
>           0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
>          +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>          |  length     |      type       |         reserved              |
>          +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>          |  expiration |    channel      |    speed      |   reserved    |
>          +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>          |                            bandwith                           |
>          +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>          |                         group_address                         |
>          + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + +
>          |                                                               |
>          +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>
>
> Regards.
>
>  Herbert Bernecker
>
>
Best regards,

===============================================================
=  OSAKABE, Yoshio
=  i.LINK Development Laboratory
=  Platform Software Development Center
=  Sony Corporation  Headquarters, Building 3, 4th Floor
=  6-7-35, Kitashinagawa, Shinagawa-ku, Tokyo, 141-0001 Japan
=  Tel: +81-(0)3-5448-6592,  Fax: +81-(0)3-5448-4327
=  mailto:[email-masked]
=  mailto:[email-masked] (private)
===============================================================

---

From: Kenji Fujisawa <[email-masked]>
Date: Mon, 25 Jan 1999 18:29:35 +0900

Osakabe-san,

>You can know them from "tcode" in packet header.

The 'tcode' for both asynchronous and isochronous streams are
the same, 0x0a.

>> How i can differentiate between asynchronous and isochronous streams ?

The original question is how to identify asynchronous or isochronous
from an MCAP descriptor.
We may use a 'bandwith' field.

draft-ietf-ip1394-ipv4-12.txt
:    bandwidth: This field SHALL be zero; it is allocated in the group
:    address descriptor to accommodate future extensions to MCAP that
:    specify quality of service and utilize the isochronous capabilities
:    of Serial Bus.

But we are not sure whether a group_address is enough to identify
the 'flow'. We may need
        Sender Address,
        Receiver Address,
        Protocol,
        Sender Port-number,
        Receiver Port-number,
        and some other information.

In such case, we need to define other MCAP descriptor type.

These are out of scope of the current specification.

Best Regards,

Kenji Fujisawa

---

From: OSAKABE Yoshio <[email-masked]>
Date: Mon, 25 Jan 1999 18:33:19 +0900

> The 'tcode' for both asynchronous and isochronous streams are

Fujisawa-san,

Sorry, "asynchronous stream" use "A" too. The former mail
is my fault. Thank you for correction.