Subject: Re: Signature/Asynch write vs. Asynch stream

From: "Henroid, Andrew D" <[email-masked]>
Date: Tue, 19 Jan 1999 12:39:02 -0800

> -----Original Message-----
> From: Michael D. Johas Teener [mailto:[email-masked]]
> Sent: Tuesday, January 19, 1999 10:36 AM
> To: [email-masked]
> Subject: Signature/Asynch write vs. Asynch stream
>
>
> I disagree, although you can talk me out of it:
>
> One major reason to use asynch writes (vs. asynch streams) is to take
> advantage of the direct memory mapped addressing ... in an OpenHCI
> environment, the writes would go directly to some direct mapped
> section of system memory (i.e., some portion of the buffer control is
> in the source node). In this case, *ALL* of the 1394 packet header is
> lost after the packet is written to memory (just like all the PCI
> control info is lost after a PCI memory write completes).
>
> I think this means you have to count on the GASP header *all*
> the time.

I believe you are talking about OHCIs physical request
capability whereby the OHCI controller handles async
operations automatically to PC physical memory.  This is
pretty much useless for IP/1394 since you don't get an
interrupt or any notification that a packet has arrived.

For async writes the main async receive interface is what
you must use.  (It does generate an interrupt on receive and
can be instructed to leave packet headers on)

The async stream receive interface (just the isoch receive
interface) can also be instructed to leave packet headers
on, so there is no problem here.

-Andy

---

From: Venkata Tanikella <[email-masked]>
Date: Tue, 19 Jan 1999 15:51:00 -0800

>interrupt or any notification that a packet has arrived.

Yes, And even if there is a controller that provides a notification on
physical write, such mechanism can not be used for Ip1394 unicast *FIFO*
address for
multiple IP packets would be addressed to the same *FIFO* all the time and
one can not ensure that packets are not overwritten when a physical mapping
is used.

-Venkat