Subject: Re: Unit Directory

From: "Hattig, Myron" <[email-masked]>
Date: Tue, 12 Jan 1999 10:32:03 -0800

Kenji,

> >Use concatenation of EtherType and ARP Hardware Type
> >for Unit_Sw_version. EtherType identifes either IPv4
> >or IPv6, the 1394 hardware Type (0x18) provides further
> >identification to the specs we are producing.
>
> I think that a hardware type can be found by bus_info_block
> and just an EtherType is enough.
> One octet reserved field may be used to identify a future revision.

The hardware type is not found in the bus_info_block.

I can live with the value just being the EtherType. The extra bits
can be reserved, so if something like the hardware type is needed
later it can be added.

I don't see the need to add any addition items to this unit directory.
If individual implementations wish to add addition info, they can do
so in an implementation specific manner with implementation specific info.

-myron

---

From: Kenji Fujisawa <[email-masked]>
Date: Wed, 13 Jan 1999 10:19:43 +0900

This is not important issue, just clarify my intention.

>The hardware type is not found in the bus_info_block.

I thought hardware type can be derived from the 'bus_name' value.

:  The first quadlet contains the string "1394" in ASCII as
:  the bus_name value required by the CSR Architecture.

Kenji Fujisawa