Subject: Re: ARP, MCAP, signature

From: "Wooten, David" <[email-masked]>
Date: Wed, 13 Jan 1999 08:51:55 -0600

The source ID in the asynch write packet is going to be the same as in the
GASP header.  In both cases, the source ID will indicate how to get
information back to the source of the packet.  The ID will be unique on any
bus.  The ID might not be unique across a network in that, when used on
another bus, the ID might refer to a different device.  This means that when
passing the 'address' of a device to another device (on the same bus or on a
remote bus) send the GUID of the device and not its source ID.  Then have
the recipient resolve the GUID into a 'handle' (otherwise known as a source
ID) by sending an ARP like packet.

David Wooten

> -----Original Message-----
> From: Hattig, Myron [mailto:[email-masked]]
> Sent: Tuesday, January 12, 1999 7:37 PM
> To: [email-masked]
> Subject: Re: ARP, MCAP, signature
>
>
> Venkata,
>
> > There were objections that one does not want to look at link
> > level headers, but given the benefits, I feel it is worth it.
>
> I don't mind throwing architectural purity out the window,
> but I'm not sure extracting the source id from the 1394 async
> write packet solves the problem because I'm not sure the
> bridge will ensure the 10 bit bus ids it generates are
> unique across the entire 1394 network.
>
> For now we would not be functionally worse off, just architecturally,
> by extracting the source node ID from the 1394 async write packet
> header.
>
> > [ I also could not see how
> > a unique id could be generated without using either of "1394
> > Node Id" or
> > "EUI-64", or an "Ip address" (which is not preffered being a
> > higher layer
> > entity?) ;  Node Id Register won't work with legacy problems;
> >  EUI-64 or Ipaddress need more bits; ]
>
> The only option I see, that I really hate, is to put the
> entire EUI-64 in the link frag header. Yuk!! Adding 48 bits
> to link frag headers is ridiculous given the concerns
> we had about the current 64 bits of link fragment header.
>
> -myron
>

---

From: Kenji Fujisawa <[email-masked]>
Date: Thu, 14 Jan 1999 00:19:38 +0900

Thank you for clarifying.

Wooten, David wrote:
> another bus, the ID might refer to a different device.

For reassembly purpose, uniqueness at a given recipient is enough.
So source ID is sufficient as a signature.

Kenji Fujisawa