Subject: RE: [ipcdn] pktcMtaDevRealmName

From: "Jean-Francois Mule" <[email-masked]>
Date: Thu, 17 Feb 2005 17:51:07 -0700

Hi Randy,

   Sorry for the delay in responding to your email.
   Inline.

Jean-François 

> -----Original Message-----
> From: Randy Presuhn [mailto:[email-masked]] 
> Sent: Tuesday, January 25, 2005 8:38 PM
> To: Ipcdn (E-mail)
> Subject: [ipcdn] pktcMtaDevRealmName
> 
> 
> Hi -
> 
> I think the use of SnmpAdminString for pktcMtaDevRealmName
> might need some more thought.  The language about "all capitals"
> and search operations using upper-case ASCII doesn't mesh
> too well with SnmpAdminString.
> 
> Whether it makes any sense at all will depend on
> whether Kerberos will ever permit realm names which are
> not upper-case ASCII.

  How about changing the syntax to DisplayString?
  This would address your point and align the mib object syntax with the kerberos type.

Any comments from others on this before we make the change?
Jean-François 

>  For several writing systems, there is
> no upper-case/lower-case distinction.  Chinese, Thai, Cambodian, and
> Japanese are just a few examples.  Even for languages written 
> with the Roman
> alphabet, there are problems.  German "?" (which supposedly 
> cannot be capitalized, and
> > should be transformed to "SS") is a classic example.
> >
> > If they're trying to future-proof things, they should take a
> > careful look at
> > http://www.unicode.org/versions/Unicode4.0.0/ch05.pdf#G21180
> > as well as http://www.unicode.org/reports/tr15/, since they
> > really should
> > nail down which normalization form as well.  (Actually, the 
> choice of
> > normalization form is something we should have done in the 
> definition
> > of SnmpAdminString, but no one else wanted to touch the issue then.)
> >
> > My advice, not knowing what the future of Kerberos will be 
> and how it
> > will handle comparison of non-ascii realm names, is to just 
> make this
> > object a DisplayString, and to spell out exactly what
> > characters are permitted.
> >
> > Randy
> 
> 
> 
> _______________________________________________
> IPCDN mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ipcdn
> 
> 

_______________________________________________
IPCDN mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipcdn

---

From: "Randy Presuhn" <[email-masked]>
Date: Tue, 22 Feb 2005 14:16:59 -0800

Hi -

> From: "Jean-Francois Mule" <[email-masked]>
> To: "Randy Presuhn" <[email-masked]>; "Ipcdn (E-mail)" <[email-masked]>
> Sent: Thursday, February 17, 2005 4:51 PM
> Subject: RE: [ipcdn] pktcMtaDevRealmName
...
>   This would address your point and align the mib object syntax with the kerberos type.
...

This would be OK with me.  It wouldn't hurt to add some text to the
BEHAVIOUR explaining that the kerberos type is limited to ASCII,
so that well-meaning folks who want to help the cause of internationalization
aren't led astray, and so that other MIB reviewers understand why it
isn't SnmpAdminString.

Randy