Subject: (IPng 6967) Re: IPV6_MULTICAST_HOPS

From: Richard Draves <[email-masked]>
Date: Tue, 22 Dec 1998 15:04:17 -0800

> >The draft says
> >      The interpretation of the argument is the same
> >      as for the IPV6_UNICAST_HOPS option:
> >         x < -1:        return an error of EINVAL
> >         x == -1:       use kernel default
> >         0 <= x <= 255: use x
> >         x >= 256:      return an error of EINVAL
> >         If IPV6_MULTICAST_HOPS is not set, the default is 1
> >         (same as IPv4 today)
>   In a "real" BSD, that kernel default might also come from a 
> sysctl variable.
> In a MS world, it might be a registry entry. The idea is that 
> the system's
> default should be configurable (e.g., by a sysadmin).

To clarify: my understanding is that if IPV6_MULTICAST_HOPS is not set on a
socket, then the Hop Limit in outgoing multicast packets will be 1. If I set
IPV6_MULTICAST_HOPS to -1, then then Hop Limit in outgoing multicast packets
will be some default value (depending on sysctl in BSD, the registry in NT,
and the contents of received RAs - and calculated when the packet is sent,
not when IPV6_MULTICAST_HOPS is set to -1) and this default value can be
something other than 1.

Thanks,
Rich
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Craig Metz <[email-masked]>
Date: Tue, 22 Dec 1998 13:43:37 -0500

In message <4D0A23B3F74DD111ACCD00805F31D8100AF819A3@RED-MSG-50>, you write:
>socket, then the Hop Limit in outgoing multicast packets will be 1.

  I thought that the hop limit is the system (kernel) default, which might or
might not be 1. I haven't looked at this part of the API in a couple of years,
so I could very well be wrong.

									-Craig