Subject: (IPng 7405) KAME stable release 19990412

From: Kazu Yamamoto (山本和彦) <[email-masked]>
Date: Mon, 12 Apr 1999 18:40:52 +0900

As usual, KAME Project has released "stable" packages of IPv6/IPsec
network code for FreeBSD 2.2.8/3.1(New!), NetBSD 1.3.3, and BSD/OS
3.1.

These packages are free of charge but absolutely no warranty. They are
avaiable from the following web site:

	http://www.kame.net/

NOTE: IF YOU GAIN ACCESS TO THIS WEB PAGE OVER IPv6, THE TURTLE WILL
DANCE.

--Kazu, KAME Project

--from here
The following is the RELNOTE file.

			 RELNOTES of KAME kit

			     KAME Project

		     $Date: 1999/04/12 02:39:05 $

Here is a summary of differences between KAME stable 19990131 and 19990412.

<<IPv4>>
- Fixed mbuf leaks and other mbuf-related twists.

<<IPv6>>
- Fixed mbuf leaks and other mbuf-related twists.
- Rate limit for icmp6 redirect.
- Reject overlapping fragment on reception.
- More spec-conformant source address selection for NA output.
- MINCLSIZE is decreased to force drivers to give cluster mbuf.
- (FreeBSD 3.1) cisco HDLC support for sppp device.
- (BSDI) merged `goto ours' hack using the routing table from KAME for
  FreeBSD.
- ND6 reachable time is now recomputed in at least two hours even if
  no router advertisement is received.
- Changed to use ND based MTU instead of the link's physical MTU
  when detecting whether the packet should be fragmented.

<<IPv6 API>>
- setsockopt(IPV6_{UNI,MULTI}CAST_HOPS) now behaves as described in spec.
- Fixed libinet6 in order to support a lot of interfaces(e.g. over 100
  gifs can be configured).

<<IPsec>>
- Avoid corrupted packet on tcp retransmission.
- Fixed a bug in IPsec header size computation for MTU consideration.
- esp_output() now takes care of both IPv4 and IPv6 (used to be separate).
- Fix memory leakage in IPsec tunnel decapsulation.
- (NetBSD) tcp4/6 takes care about IPsec header size in MSS computation.

<<Userland>>
- traceroute6 supports source route (-g).
- -c specifies alternate configuration file path for rtadvd.
- Bug fixes and enhancements of bgpd.
- Additions of several manpages.

<<Others>>
- ports/pkgsrc: upgraded base version for many items in the collection.
- ports/pkgsrc additions: wbd, squid, ethereal
- ports/pkgsrc removals: im

--to here
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Nobuo Okabe <[email-masked]>
Date: Wed, 14 Apr 1999 17:04:07 +0900

Hi there,

I'm pleased to announce TAHI Project that is joint effort
to provide verification technology for IPv6.
We are working with KAME project and WIDE project.

We have opened conformance test report about KAME-19990412-stable
at our web site:
	http://www.tahi.org/report/

kazu> As usual, KAME Project has released "stable" packages of IPv6/IPsec
kazu> network code for FreeBSD 2.2.8/3.1(New!), NetBSD 1.3.3, and BSD/OS
kazu> 3.1.
kazu> 
kazu> These packages are free of charge but absolutely no warranty. They are
kazu> avaiable from the following web site:
kazu> 
kazu> 	http://www.kame.net/
kazu> 
kazu> NOTE: IF YOU GAIN ACCESS TO THIS WEB PAGE OVER IPv6, THE TURTLE WILL
kazu> DANCE.
kazu> 
kazu> --Kazu, KAME Project

Thanks,

Nobuo Okabe