Subject: IPv6 -over-IPv4 tunnel.

From: "shankar" <[email-masked]>
Date: Wed, 02 Aug 2000 18:29:26 +0600

Hi folks,

cant we treat the IPv4 layer incase of IPv6/IPv4 nodes as a 
tunnel interface, with the local, remote IPv4 addresses as the 
tunnel configurations i.e. can we apply the new tunnel mib 2667
to this concept of tunneling. 

here a tunnel interface will be created, and the IPv6 routing table will have
the IPv4 encap also as a interface. 

does that sound ok ?

tia
shankar
-------------------------------------------------
Make webveda your permanent address like i have.
Get 15 MB Free space only at http://www.webveda.com
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: "Dave Thaler" <[email-masked]>
Date: Wed, 2 Aug 2000 17:02:52 -0700

Yes, that was one of the intents of RFC 2667.

-Dave

-----Original Message-----
From: shankar [mailto:[email-masked]]
Sent: Wednesday, August 02, 2000 8:29 AM
To: [email-masked]
Subject: IPv6 -over-IPv4 tunnel.

Hi folks,

here a tunnel interface will be created, and the IPv6 routing table will
have
the IPv4 encap also as a interface. 

does that sound ok ?

tia
shankar

---

From: Murali Krishna Ch <[email-masked]>
Date: Thu, 3 Aug 2000 15:20:33 +0530

For IPv6 configured tunneling, this approach is clear.
But for Automatic Tunneling, I have a point here:
How does IPv6 differantiate between Automatic and configured tunnlling?
For Automatic Tunnelling the Destination v4 Address is fetched from the IPv4-compatibl-ipv6
address and in this case, there is no meaning of configuring the tunnel end points.
The point boils down to - how to identify rcving/xmitting interface index for Automatic Tunneling.

murali.

-----Original Message-----
From:	Dave Thaler [SMTP:[email-masked]]
Sent:	Thursday, August 03, 2000 5:33 AM
To:	[email-masked]; [email-masked]
Subject:	RE: IPv6 -over-IPv4 tunnel.

-Dave

-----Original Message-----
From: shankar [mailto:[email-masked]]
Sent: Wednesday, August 02, 2000 8:29 AM
To: [email-masked]
Subject: IPv6 -over-IPv4 tunnel.

Hi folks,

does that sound ok ?

tia
shankar
 << File: ATT00005.html >>