Subject: IPv6 Source Routing

From: "Youngjune Lee Gwon" <[email-masked]>
Date: Tue, 22 Aug 2000 12:31:36 -0700

I have some unclarity in IPv6 Source Route option. So, I decide to comment to this list for help.

In IPv6, routing header with n addresses will do the source route functionality. What will be the usual 
process to get intermediate addresses that may fill Address[1] ... Address[n] field in IPv6 routing header?
In other words, does IPv6 provide functions that dynamically obtain intermediate nodes (for strict/loose 
source route) in case of one node sending IPv6 packets to another using IPv6 source routing?

Also, is IPv6 in charge of explicitly listing such intermediate nodes in source routing? If so, how?

Any comments from IPv6 source routing and routing header knowledgeable person should be very helpful 
for my purpose.  You can send your comment privately to me in case of ipng subscribers feeling bothered 
by uninterested topic.

Thank you very much,

Youngjune Gwon
Research Engineer
NTT DoCoMo USA Research Labs

---

From: JINMEI Tatuya / 神明達哉<[email-masked]>
Date: Fri, 25 Aug 2000 12:18:52 +0900

>>>>> On Tue, 22 Aug 2000 12:31:36 -0700, 
>>>>> "Youngjune Lee Gwon" <[email-masked]> said:

> process to get intermediate addresses that may fill Address[1] ... Address[n] field in IPv6 routing header?

(I may misunderstand your question, but)
Basically, the sender (an application or an operator) should specify
all the intermediate nodes by hand.

> source route) in case of one node sending IPv6 packets to another using IPv6 source routing?

No.

> Also, is IPv6 in charge of explicitly listing such intermediate
> nodes in source routing?

No.

					JINMEI, Tatuya
					Communication Platform Lab.
					Corporate R&D Center, Toshiba Corp.
					[email-masked]
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------