Subject: RE: Revised IPng Working Group Charter

From: Thomas Eklund <[email-masked]>
Date: Mon, 9 Oct 2000 13:48:58 +0200

I would like to see a "IPv6 router requirements" on the charts.

Other important stuff is to define a MIB for mobileIPv6.

Rgz
 -- Thomas

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Bob Hinden
> Sent: Thursday, October 05, 2000 6:19 PM
> To: Thomas Narten; [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: Revised IPng Working Group Charter
> 
> 
> Thomas, Erik,
> 
> Attached is the revised charter for the IPng working group.  
> Updating the 
> charter was agreed to at the Grenoble and Minneapolis working group 
> meetings.  This version has been discussed on the ipng 
> mailing list and at 
> the Adelaide IETF meeting.
> 
> The charter includes changing the name of the working group 
> to the "IP 
> Version 6 Working Group", but will keep the acronym of 
> "ipngwg".  This will 
> avoid having to rename all current internet drafts.
> 
> Bob Hinden / Steve Deering
> 
> --------------------------------------------------------------
> ---------------
> 
> IP Version 6 Working Group (ipngwg)  *** note: change of name 
> but not acronym
> 
> Chair(s):
> 
>     Bob Hinden <[email-masked]>
>     Steve Deering <[email-masked]>
> 
> Document Editor
> 
>     Bob Hinden ([email-masked])
> 
> Internet Area Director(s):
> 
>     Thomas Narten <[email-masked]>
>     Erik Nordmark <[email-masked]>
> 
> Internet Area Advisor:
> 
>     Thomas Narten <[email-masked]>
> 
> Mailing Lists:
> 
>     General Discussion:[email-masked]
>     To Subscribe: [email-masked]
>     In Body: in body: subscribe ipng
>     Archive: ftp://playground.sun.com/pub/ipng/mail-archive
> 
> Description of Working Group:
> 
>     IP version 6 or IPv6 (also formerly known as IP Next 
> Generation or IPng)
>     is intended to support the continued growth of the 
> Internet, both in
>     size and capabilities, by offering a greatly increased IP 
> address space
>     and other enhancements over IPv4.  The working group was 
> originally
>     chartered to implement the recommendations of the IPng 
> Area Directors
>     as outlined at the July 1994 IETF meeting and in "The 
> Recommendation
>     for the IP Next Generation Protocol," RFC1752, January 
> 1995.  Most of
>     the tasks in that original charter have been completed, 
> and the core
>     IPv6 protocol specifications are now on the IETF standards track.
>     The working group's ongoing responsibilities are as follows:
> 
>      - Complete work from the original charter and follow-on work, as
>        outlined below.
> 
>      - Keep all IPv6 working group documents moving along 
> publication /
>        standardization track.
> 
>      - Serve as a review board and body of competence and 
> coordination for
>        IPv6 architectural issues that span multiple IETF 
> working groups.
> 
>      - Provide a home for IPv6-related work that doesn't fit 
> in an existing
>        IETF working group and doesn't merit a working group 
> of its own.
> 
>      - Provide technical input to ICANN, Internet Address 
> Registries, and
>        IANA with regard to IPv6 address allocation policies 
> and procedures.
> 
>      - Provide technical input and review to IANA with regard to IPv6
>        protocol and parameter assignments.
> 
>     The list of the working group's current work items is as follows:
> 
>      - Revise ICMPv6 spec (scope-exceeded err, no error to redirect,
>        editorial)
>      - Revise Generic Tunneling spec (add bidirectional tunnels)
>      - Update Basic and Advanced API specs
>      - Complete Scoped Address Architecture spec and any 
> necessary revisions
>        to other working group drafts required to properly 
> implement support
>        for IPv6 address scoping
>      - Complete work on recommended address-selection algorithms
>      - Work on new solutions to site-multihoming problems, 
> possibly including
>        both host-based and router-based solutions.
>      - Complete work on local IPv6 networking as part of IPv6 
> plug-and-play
>      - Complete work on privacy extensions to stateless 
> address configuration
>      - Document IPv6 renumbering model
>      - Complete the GSE Analysis document
>      - Complete the Inverse Neighbor Discovery spec
>      - Complete the IPv6 Node Information Queries spec
>      - Complete MIB specs as required by any working group 
> protocol specs
> 
>     New work items not listed above require the approval of 
> the working
>     group and Internet Area directors before they will be 
> taken on by the
>     working group.
> 
>     The working group would welcome contributions on the 
> following topics
>     (this is not an exhaustive list):
> 
>      - Flow label standardization
>      - Solutions to other multihoming issues, beyond those specific to
>        site-multihoming
>      - Integration of autoconfiguration, mobility, DNS, 
> service discovery
>        and other technologies to enhance IPv6 plug-and-play
>      - IPv6 dial-up issues relating to address assignment, 
> use of Neighbor
>        Discovery, etc. (not including AAA work)
>      - Specifications for IPv6 over additional media
>      - Extending MLD to include functionality of IGMPv3
>      - Host use of anycast; TCP use of anycast
>      - Support for multi-link subnets (single subnet spans 
> multiple links)
>      - Scope-name discovery
>      - IPv6 protocol extensions to accommodate mobile 
> wireless networks.
> 
> Goals and Milestones:
> 
>   Aug 2000    Complete MLD MIB and submit for Proposed Standard
> 
>   Sep 2000    Complete privacy extensions specification and submit for
>               Proposed Standard
> 
>   Nov 2000    Completed revision of GSE Analysis document and resubmit
>               for Informational
> 
>   Sep 2000    Complete the Inverse Neighbor Discovery specification
>               and submit for Proposed Standard
> 
>   Sep 2000    Complete IPv6 Multihoming with Route 
> Aggregation and submit
>               for Informational.
> 
>   Dec 2000    Update ICMP document and resubmit for Draft Standard
> 
>   Dec 2000    Update Generic Tunneling specification and resubmit for
>               Proposed Standard
> 
>   Nov 2000    Complete updates to Basic and Advanced API 
> specifications
>               and submit for Informational
> 
>   Dec 2000    Complete Scoped Address Architecture and submit 
> for Proposed
>               Standard
> 
>   Dec 2000    Compete Address Selection specification and 
> submit for Proposed
>               Standard
> 
>   Dec 2000    Complete Local IPv6 Networking Specification 
> and submit for
>               Proposed Standard
> 
>   Dec 2000    Complete the IPv6 Node Information Queries specification
>               and submit for Proposed Standard
> 
>   Mar 2001    Complete IPv6 renumbering model document and submit for
>               Informational
> 
> --------------------------------------------------------------
> ---------------
> 
> --------------------------------------------------------------------
> IETF IPng Working Group Mailing List
> IPng Home Page:                      http://playground.sun.com/ipng
> FTP archive:                      ftp://playground.sun.com/pub/ipng
> Direct all administrative requests to [email-masked]
> --------------------------------------------------------------------

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Bob Hinden <[email-masked]>
Date: Mon, 09 Oct 2000 23:12:08 -0700

Thomas,

>I would like to see a "IPv6 router requirements" on the charts.

Thanks.

>Other important stuff is to define a MIB for mobileIPv6.

This should be done in the Mobile IP w.g. who is developing Mobile IPv6.

Bob