Subject: Re:

From: "manivannan Muniandi" <[email-masked]>
Date: 4 Oct 2000 13:28:08 -0000

Hi,
         I have the following doubt in IPv6 addressing and forwarding.

As IPv6 supports hierarchical routing, here also do we have 'longest match' concept? If so, Can I use the same PATERCIA Algrithm for routing table?

Can I have two host on the same lan having different Prefixes? If so, how the forwarding works?

Regards,
Vannan

_________________________________________________
Get Your Free Email At, http://www.rediffmail.com

For fabulous shopping deals visit: http://www.rediff.co.in/shopping/index.html

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Bob Hinden <[email-masked]>
Date: Wed, 04 Oct 2000 12:23:53 -0700

Manivannan,

>As IPv6 supports hierarchical routing, here also do we have 'longest 
>match' concept? If so, Can I use the same PATERCIA Algrithm for routing table?

Yes, IPv6 routing works just like IPv4.  All type of longest match lookup 
algorithms are fine.

>Can I have two host on the same lan having different Prefixes? If so, how 

Yes, the node would need to sent the packet to a router that knew about 
both prefixes.

Bob