Subject: Re: wrt: draft-blanchet-ipngwg-testadd-00.txt

From: Alain Durand <[email-masked]>
Date: Wed, 06 Jun 2001 11:22:51 -0700

At 09:25 AM 5/12/2001 -0400, Marc Blanchet wrote:
>- As Robert was saying about my draft, there is two issues:
>  + do we agree on the idea of the draft?
>   if yes, then find one address space which is the best one for that 
> purpose. I don't care which one, I just proposed one. Any advice is 
> appreciated.  For the sake of generality, we might want to reserve a 
> range that is similar to a TLA, so that anyone would be able to use it 
> for examples involving TLAs.
>   if no, then forget the draft.
>
>What is the opinion of the group?

I would like to say that I like Marc's idea a lot. It is like the 555 area 
code in the movies.
It looks real, but everybody knows it's fake.
Carving address space from something already allocated to a customer,
as kre pointed out, is a bad idea. However, 3fffe:ff00::/24 has not been 
allocated to anyone.
Thus, it looks ok to me.

The only one who can complain is Bob Fink, steward of the 6bone 3ffe::/16 
prefix.

I'm going to use this in 
draft-ietf-ngtrans-introduction-to-ipv6-transition-07.txt
every times I need to give an example of an IPv6 address.

         - Alain.

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Bill Manning <[email-masked]>
Date: Wed, 6 Jun 2001 11:50:05 -0700 (PDT)

% I would like to say that I like Marc's idea a lot. It is like the 555 area 
% code in the movies.
% It looks real, but everybody knows it's fake.
% Carving address space from something already allocated to a customer,
% as kre pointed out, is a bad idea. However, 3fffe:ff00::/24 has not been 
% allocated to anyone.
% Thus, it looks ok to me.
% 
% The only one who can complain is Bob Fink, steward of the 6bone 3ffe::/16 
% prefix.
% 
% I'm going to use this in 
% draft-ietf-ngtrans-introduction-to-ipv6-transition-07.txt
% every times I need to give an example of an IPv6 address.
% 
%          - Alain.

	Strong Objections to this tactic.  If you want a 6bone prefix,
	you should follow the process. Hijacking is bad form. I'm
	sure Bob would be amenable to making the delegation, but
	asking is appropriate.

-- 
--bill

---

From: Alain Durand <[email-masked]>
Date: Wed, 06 Jun 2001 12:08:06 -0700

>         sure Bob would be amenable to making the delegation, but

This is the reason why I had Cced Bob to this thread.

Bob:
- do you think it would be appropriate to use a 6bone ptla for that purpose?
- what should be the formal process to follow?
- would you have any preferences? 3ffe:ff00::/24, 3ffe:5550::/28, anything 
else?

         - Alain.

---

From: Marc Blanchet <[email-masked]>
Date: Wed, 06 Jun 2001 17:48:07 -0400

there was suggestion to not use 3ffe::/16 space so that it can be later 
(humm, do not know how many years...) reclaimed and reused as part of the 
001b/3 current addressing architecture.  So may be something out of 
2000::/3 is the right thing, I don't know, and actually, I don't care. My 
point was to reserve a space, any space, for documentation/examples/... 
purposes.

Marc.

---

From: Robert Elz <[email-masked]>
Date: Thu, 07 Jun 2001 15:59:50 +0700

Date:        Wed, 06 Jun 2001 11:22:51 -0700
    From:        Alain Durand <[email-masked]>
    Message-ID:  <5.1.0.14.0.20010606111548.03c015d0@jurassic>

  | I would like to say that I like Marc's idea a lot. It is like the 555 area 
  | code in the movies.
  | It looks real, but everybody knows it's fake.

Yes, that's exactly what should be done (pity 555 doesn't exist anywhere
but in the US, in AU it used to be a perfectly valid number - phone numbers
now are 8 digits, and US 555's are just 7, so at least that issue went away).

That seems to be an irrelevance, which shouldn't be wasting the time on
the list (555 numbers in AU) - I don't think it is however, unless it has
the unfortunate effect of leading to a bunch of "my funniest 555 story"
messages, which I hope it won't.   That's because...

  | Carving address space from something already allocated to a customer,
  | as kre pointed out, is a bad idea.

Yes, but I was trying to say more than that.   It should not only not
be taken from space allocated to a customer, it should also not be
taken from space that potentially could be allocated to a customer.
That is, not from any address block set aside for that purpose.

And ...

  | However, 3fffe:ff00::/24 has not been allocated to anyone.

that one, and even the "prettier" 3ffe:0555 (or 3ffe:5550 or
3ffe:5555 or something) from your later message are in the
"could be allocated" category.

We want a number that is trivially easy to recognise and filter, not
a number (like the rfc1918 set -where there was little choice of course)
that only "experts" can tell is not a valid number.

That is, I think we should do as much as we can to decrease the risk that
any random person getting a box, and following its accompanying doc, will
naïvely just configure the addresses in the examples, and then wonder why
it doesn't work.   The config process on the box needs to be able to
immediately say "That isn't a valid address block, contact your ISP to
obtain addresses to use" or something when it sees an attempt to config
the magic address.

kre

ps: and I made a similar reply to Bob's message on the 6bone list where
he asked the 6bone people about setting aside a piece of the 6bone addr
space.

---

From: Marc Blanchet <[email-masked]>
Date: Thu, 07 Jun 2001 08:42:28 -0400

At/À 15:59 2001-06-07 +0700, Robert Elz you wrote/vous écriviez:
...cut...

>"could be allocated" category.

but anything outside of 2000::/3 has _no_ structure defined,
so choosing something outside of 2000::/3 is worst.

>that only "experts" can tell is not a valid number.

(but only "experts" will filter anyway, no?

Marc.

---

From: Bill Manning <[email-masked]>
Date: Thu, 7 Jun 2001 21:02:56 -0700 (PDT)

What you seem to be asking for is something like the v4
	delegation 192.0.2.0/24.  It was set aside for documentation.

	My thought is/was that we might reuse the 5f:: prefix that
	predates the 6bone.

% 
% there was suggestion to not use 3ffe::/16 space so that it can be later 
% (humm, do not know how many years...) reclaimed and reused as part of the 
% 001b/3 current addressing architecture.  So may be something out of 
% 2000::/3 is the right thing, I don't know, and actually, I don't care. My 
% point was to reserve a space, any space, for documentation/examples/... 
% purposes.
% 
% Marc.
% 
% At/À 12:08 2001-06-06 -0700, Alain Durand you wrote/vous écriviez:
% >At 11:50 AM 6/6/2001 -0700, Bill Manning wrote:
% >
% >>         Strong Objections to this tactic.  If you want a 6bone prefix,
% >>         you should follow the process. Hijacking is bad form. I'm
% >>         sure Bob would be amenable to making the delegation, but
% >>         asking is appropriate.
% >
% >This is the reason why I had Cced Bob to this thread.
% >
% >Bob:
% >- do you think it would be appropriate to use a 6bone ptla for that purpose?
% >- what should be the formal process to follow?
% >- would you have any preferences? 3ffe:ff00::/24, 3ffe:5550::/28, anything 
% >else?
% >
% >         - Alain.
% >
% >--------------------------------------------------------------------
% >IETF IPng Working Group Mailing List
% >IPng Home Page:                      http://playground.sun.com/ipng
% >FTP archive:                      ftp://playground.sun.com/pub/ipng
% >Direct all administrative requests to [email-masked]
% >--------------------------------------------------------------------
% 
%

---

From: "JIM FLEMING" <[email-masked]>
Date: Thu, 7 Jun 2001 23:32:29 -0500

In my opinion, 10.x.x.x from IPv4 is widely recognized as local space. Why
waste more IPv4
space on special purpose addresses ?

Now that "IPv8-style" addressing is being more
widely used***, one might consider....

2002:10.x.x.x:0000:0000:10.x.x.x:0000

For IPv16...the more popular examples may be...

FEED:10.x.x.x:0000
CAFE:10.x.x.x:0000
BABE:10.x.x.x:0000
BEEF:10.x.x.x:0000

Jim Fleming
http://www.unir.com/images/architech.gif
http://www.unir.com/images/address.gif
http://www.unir.com/images/headers.gif
http://www.ntia.doc.gov/ntiahome/domainname/130dftmail/unir.txt
http://msdn.microsoft.com/downloads/sdks/platform/tpipv6/start.asp

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of [email-masked]
Sent: Thursday, May 31, 2001 1:17 PM
To: [email-masked]; [email-masked]
Subject: Re: IPv6 @ interim meeting

*** ------------------------------------------------
>	as a temporary measure I have configured tunnel to IIJ Palo Alto device.
>	the IPv6 prefix for the meeting room is 3ffe:507:1ff::/64.
>
>	it would be, of course, better to have ipv6 prefix from microsoft
>	research :-)

	today we've got a router operated by MS research guys, using 6to4.
	so my router have went away.
	2002:836b:2505:5::/64

itojun
-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Bill Manning
Sent: Thursday, June 07, 2001 11:03 PM
To: Marc Blanchet
Cc: Alain Durand; Bill Manning; [email-masked]; [email-masked]
Subject: Re: wrt: draft-blanchet-ipngwg-testadd-00.txt

%
% >- do you think it would be appropriate to use a 6bone ptla for that
purpose?
% >- would you have any preferences? 3ffe:ff00::/24, 3ffe:5550::/28,
anything

---

From: Robert Elz <[email-masked]>
Date: Fri, 08 Jun 2001 16:06:22 +0700

Date:        Thu, 07 Jun 2001 08:42:28 -0400
    From:        Marc Blanchet <[email-masked]>
    Message-ID:  <[email-masked]>

  | but anything outside of 2000::/3 has _no_ structure defined,
  | so choosing something outside of 2000::/3 is worst.

No, there is structure defined at both ends of the address space already,
0000::/whatever already has the IPv4 , and ::1 addresses in it.  FE00::/7
already has multicast, and link locals, and stuff.

We can easily define another small (as small or big as needed) piece
at either end there, almost as easily as we can define a piece inside
the 2000::/3 space (perhaps not quite as easily, as the former requires
an RFC, and the latter just a registry entry - but what you're writing
will become an RFC anyway won't it?  So, your doc can be the one that
makes the assignment, then it can be incorporated in the next rev of
the IPv6 addressing doc, whenever that happens).

  | (but only "experts" will filter anyway, no?

Yes, but that's the idea.   If the address is well defined enough, the
filtering can be in the code, rather than in the user's configuration.
Then only the experts need to do it, and everyone reaps the benefit.

kre

---

From: Robert Elz <[email-masked]>
Date: Fri, 08 Jun 2001 17:04:14 +0700

Date:        Thu, 7 Jun 2001 21:02:56 -0700 (PDT)
    From:        Bill Manning <[email-masked]>
    Message-ID:  <[email-masked]>

  | 	My thought is/was that we might reuse the 5f:: prefix that
  | 	predates the 6bone.

That's a possibility, if we can reserve it forever (though I assume
you mean 5f00:: and not the 005f:: that you wrote...).

It doesn't have to be at the ends of the address space, I just have
a tendency to prefer it there to leave all the big unused middle free.

kre

---

From: Bill Manning <[email-masked]>
Date: Fri, 8 Jun 2001 07:11:35 -0700 (PDT)

% 
%     Date:        Thu, 7 Jun 2001 21:02:56 -0700 (PDT)
%     From:        Bill Manning <[email-masked]>
%     Message-ID:  <[email-masked]>
% 
%   | 	My thought is/was that we might reuse the 5f:: prefix that
%   | 	predates the 6bone.
% 
% That's a possibility, if we can reserve it forever (though I assume
% you mean 5f00:: and not the 005f:: that you wrote...).

	Yes.  And thats always been a problem w/ the way
	IPv6 addresses are written.  When do you pad and where?

% It doesn't have to be at the ends of the address space, I just have
% a tendency to prefer it there to leave all the big unused middle free.

	It would be an easier choice if:

		) the addressing formats actually gel'ed.
		) we do this before the IESG hands off the task
		  of addressing formats to the RIRs.

% 
% kre
%

---

From: Robert Elz <[email-masked]>
Date: Fri, 15 Jun 2001 21:46:23 +0700

There doesn't seem to be anything happening one way or the other,
with regard to picking a prefix for this purpose.

So, I am going to make a specific proposal, and then let it be
shot down if it isn't liked ... otherwise at least there will
be something that can be used.    Please, if you are going to
object to this, give reasons (that should be obvious) and suggest
an alternative.

The suggestion is FE::/9

That uses the rest of the FE:: space after the link & site locals have
their share.   It is big enough that it is possible to make examples of
TLA looking things, far enough out of the way of any real likely address
allocation that the future world should never need to make exceptions
to work around it, and easily recognisable as a special address, just
like the various local formats, and multicast.

kre

---

From: Robert Elz <[email-masked]>
Date: Fri, 15 Jun 2001 21:54:24 +0700

Date:        Fri, 15 Jun 2001 21:46:23 +0700
    From:        Robert Elz <[email-masked]>
    Message-ID:  <[email-masked]>

  | The suggestion is FE::/9

Ugh - I corrected Bill Manning for making that mistake a week or two
ago, and then I go and do it!!

I meant, of course, to suggest using FE00::/9 ...

kre

---

From: Dave Marquardt <[email-masked]>
Date: 15 Jun 2001 09:54:28 -0500

"kre" == Robert Elz <[email-masked]> writes:
kre> The suggestion is FE::/9

Don't you mean FE00::/9?  FE::/9 is 00FE::/9, isn't it?
-- 
Dave Marquardt
Sun Microsystems, Inc.
Austin, TX
+1 512 401-1077