Subject: RE: Where's the BEEF ?

From: "SESVOLD, DALE" <[email-masked]>
Date: Mon, 11 Jun 2001 07:12:33 -0500

Would this force all stack developers and application developers to support
more parsing methods?  Does this make sense?

D

-----Original Message-----
From: JIM FLEMING [mailto:[email-masked]]
Sent: Thursday, June 07, 2001 11:32 PM
To: Bill Manning; Marc Blanchet
Cc: Alain Durand; [email-masked]; [email-masked]
Subject: Where's the BEEF ?

In my opinion, 10.x.x.x from IPv4 is widely recognized as local space. Why
waste more IPv4
space on special purpose addresses ?

Now that "IPv8-style" addressing is being more
widely used***, one might consider....

2002:10.x.x.x:0000:0000:10.x.x.x:0000

For IPv16...the more popular examples may be...

FEED:10.x.x.x:0000
CAFE:10.x.x.x:0000
BABE:10.x.x.x:0000
BEEF:10.x.x.x:0000

Jim Fleming
http://www.unir.com/images/architech.gif
http://www.unir.com/images/address.gif
http://www.unir.com/images/headers.gif
http://www.ntia.doc.gov/ntiahome/domainname/130dftmail/unir.txt
http://msdn.microsoft.com/downloads/sdks/platform/tpipv6/start.asp

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of [email-masked]
Sent: Thursday, May 31, 2001 1:17 PM
To: [email-masked]; [email-masked]
Subject: Re: IPv6 @ interim meeting

*** ------------------------------------------------
>	as a temporary measure I have configured tunnel to IIJ Palo Alto
device.
>	the IPv6 prefix for the meeting room is 3ffe:507:1ff::/64.
>
>	it would be, of course, better to have ipv6 prefix from microsoft
>	research :-)

	today we've got a router operated by MS research guys, using 6to4.
	so my router have went away.
	2002:836b:2505:5::/64

itojun
-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Bill Manning
Sent: Thursday, June 07, 2001 11:03 PM
To: Marc Blanchet
Cc: Alain Durand; Bill Manning; [email-masked]; [email-masked]
Subject: Re: wrt: draft-blanchet-ipngwg-testadd-00.txt

 	What you seem to be asking for is something like the v4
	delegation 192.0.2.0/24.  It was set aside for documentation.

	My thought is/was that we might reuse the 5f:: prefix that
	predates the 6bone.

%
% there was suggestion to not use 3ffe::/16 space so that it can be later
% (humm, do not know how many years...) reclaimed and reused as part of the
% 001b/3 current addressing architecture.  So may be something out of
% 2000::/3 is the right thing, I don't know, and actually, I don't care. My
% point was to reserve a space, any space, for documentation/examples/...
% purposes.
%
% Marc.
%
% At/À 12:08 2001-06-06 -0700, Alain Durand you wrote/vous écriviez:
% >At 11:50 AM 6/6/2001 -0700, Bill Manning wrote:
% >
% >>         Strong Objections to this tactic.  If you want a 6bone prefix,
% >>         you should follow the process. Hijacking is bad form. I'm
% >>         sure Bob would be amenable to making the delegation, but
% >>         asking is appropriate.
% >
% >This is the reason why I had Cced Bob to this thread.
% >
% >Bob:
% >- do you think it would be appropriate to use a 6bone ptla for that
purpose?
% >- what should be the formal process to follow?
% >- would you have any preferences? 3ffe:ff00::/24, 3ffe:5550::/28,
anything
% >else?
% >
% >         - Alain.
% >
% >--------------------------------------------------------------------
% >IETF IPng Working Group Mailing List
% >IPng Home Page:                      http://playground.sun.com/ipng
% >FTP archive:                      ftp://playground.sun.com/pub/ipng
% >Direct all administrative requests to [email-masked]
% >--------------------------------------------------------------------
%
%

--
--bill
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: "JIM FLEMING" <[email-masked]>
Date: Mon, 11 Jun 2001 08:51:14 -0500

In any stack I have ever worked with, the addresses are
already in binary. I am not sure what "parsing" means in
that context.

As for the 2002 IPv8-style encapsulation trick...that is now a given...
http://msdn.microsoft.com/downloads/sdks/platform/tpipv6/start.asp

As for education....many people now know about IPv4 dotted quads...
...therefore...they can easily learn...

2002:10.9.8.7:0000:0000:10.1.2.3:0000

...the 10s sort of jump out as "local" addresses
the hex 0000s indicate "legacy" and the 2002 follows 2001 a space oddysey...

Jim Fleming

-----Original Message-----
From: JIM FLEMING [mailto:[email-masked]]
Sent: Thursday, June 07, 2001 11:32 PM
To: Bill Manning; Marc Blanchet
Cc: Alain Durand; [email-masked]; [email-masked]
Subject: Where's the BEEF ?

Jim Fleming

-----Original Message-----

device.
-----Original Message-----

%