Subject: NAT-PT for linux

From: Ravikanth Samprathi <[email-masked]>
Date: Wed, 06 Jun 2001 20:40:26 -0700

Hi,
I have a small question about NAT-PT that is
implemented for linux. I am hoping you would provide
with the feedback.
In the install-document of NAT-PT, they say that the
NAT-PT is running in the border gateway and,
dns server for ipv4 is running in a machine ipv4-stub and,
dns server for ipv6 is running in another machine in ipv6-stub.
My question is the following:-
Is it possible that the dns servers for both ipv4 and ipv6 to
run in the same border gateway as the NAT-PT?
Or in other words,
Can we run, NAT-PT, ipv4-dns-server and ipv6-dns-server
in the same border gateway??
And can we have NAT-PT's dns-alg use the ipv4 and ipv6
dns servers from the servers running the same border
gateway machine?
Thank you,
Hope you will answer my question.
Thanx,
ravi

---

From: Rob Austein <[email-masked]>
Date: Thu, 07 Jun 2001 13:55:36 -0400

Date: Wed, 06 Jun 2001 20:40:26 -0700
   From: Ravikanth Samprathi <[email-masked]>

   My question is the following:- Is it possible that the dns servers
   for both ipv4 and ipv6 to run in the same border gateway as the
   NAT-PT?  Or in other words, Can we run, NAT-PT, ipv4-dns-server and
   ipv6-dns-server in the same border gateway??  And can we have
   NAT-PT's dns-alg use the ipv4 and ipv6 dns servers from the servers
   running the same border gateway machine?

Yes.  One has to pay careful attention to which piece of DNS code ends
up processing which packets, but InterNetShare's "AER" implementation
has two-faced DNS and the DNS-ALG all running on the NAT-PT box.

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------