Subject: Re: fragmentation in IPv6

From: "JORDI PALET MARTINEZ" <[email-masked]>
Date: Tue, 5 Jun 2001 22:05:51 +0200

In the other way, if this happens, the fragmentation will be carried out at the link layer, if I'm not wrong ?

Thanks and best regards,

Jordi Palet
Consulintel

http://www.consulintel.es
Tel: 91 151 81 99 - Fax: 91 151 81 98

----- Original Message -----
From: <JINMEI Tatuya / $B?@L@C#:H (B <[email-masked]>)>
To: "Sridhar Gurivireddy" <[email-masked]>
Cc: <[email-masked]>
Sent: Tuesday, June 05, 2001 3:35 AM
Subject: Re: fragmentation in IPv6

> >>>>> On Mon, 04 Jun 2001 17:20:13 -0500,
> >>>>> Sridhar Gurivireddy <[email-masked]> said:
>
> > even if fragmentation done only at the source,
> >  it may have this problem because,.....
> >  say IP header(with extensions) is of size 4k!!!!!
> > it's framented for the first time.....
> > you get three pieces..
> > yu add header to each piece...
> > each piece is now again >4k...
> > so, fragmentation again....
> > Does this problem occur..
>
> Yes, when the unfragmentable part of a packet is larger than the path
> MTU, fragmentation fails and you cannot send the packet.  However,
> (at least through my operation experiences) we've never cared about
> the problem, since we've not seen any practical usage of such a pakcet
> with a long unfragmentale part.
>
> JINMEI, Tatuya
> Communication Platform Lab.
> Corporate R&D Center, Toshiba Corp.
> [email-masked]
> --------------------------------------------------------------------
> IETF IPng Working Group Mailing List
> IPng Home Page:                      http://playground.sun.com/ipng
> FTP archive:                      ftp://playground.sun.com/pub/ipng
> Direct all administrative requests to [email-masked]
> --------------------------------------------------------------------
>
>

-----------------------------------------------------------------------------------------------------------
La UE se encamina a IPv6: www.ipv6tf.org
Más información de IPv6 en www.consulintel.es/ipv6
Contrate con nosotros sus productos de Telefonica

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Sreeram Vankadari <[email-masked]>
Date: Tue, 05 Jun 2001 21:08:50 -0700

True, but not all the L2 protocols support fragmentation.
Ethernet 802.3 ARPA, LLC etc.. don't support fragmentation.

Sreeram Vankadari

---

From: Ignatios Souvatzis <[email-masked]>
Date: Wed, 6 Jun 2001 12:36:47 +0200

On Tue, Jun 05, 2001 at 10:05:51PM +0200, JORDI PALET MARTINEZ wrote:

> In the other way, if this happens, the fragmentation will be carried
> out at the link layer, if I'm not wrong ?

Yes, that is required of link layers with limits. E.g., an ARCnet driver
will use the ARCnet packet header standard to split the packets and reassemble
them at the receiving end.

Note that this process is invisible to IPv6!

Regards,
	-is

---

From: Ignatios Souvatzis <[email-masked]>
Date: Wed, 6 Jun 2001 12:37:39 +0200

> Ethernet 802.3 ARPA, LLC etc.. don't support fragmentation.

Yes, but their MTU is bigger than 1280 bytes.

	-is