Subject: IEEE Base Spec out for Review

From: Jim Bound <[email-masked]>
Date: Wed, 18 Jul 2001 15:17:54 -0400 (EDT)

Hi Folks,

See attached pointer and please review.  This is it folks.  This will be
the base api.

I was at U.S. Navy and other Department of Defense IPv6 seminar last week
as IPv6 Forum Chair of the Technical Directorate (wearing that hat) and
other talks by IPv6 vendors shipping IPv6 products (e.g. Compaq, Cisco,
IBM, Sun, HP).  One of the talks was by Sendmail.Inc they complained big
time about us changing the base API and were totally correct.  I have
gotten this complaint from others too doing public domain software that is
used in the market.  Also several ISVs have voiced concerns.  We must take
this work attached and move it forward.  Future or other extensions can be
developed but the base API is now done and the authors will start editing
once this mail thread has some time on the list.  But lets wrap this up
before the London IETF meeting.

We all owe Jack McCann a big thanks for working the IEEE efforts. This was
a lot of work.

Thanks

/jim

-------------------------------

Web Page URL:

Jim
http://www.opengroup.org/austin/login.html

Login Name: ieee.balloter  (note: this is case sensitive)
Password: ieeedraft4  (note: this is case sensitive)

regards
Andrew

> -----Original Message-----
> From: Andrew Josey [mailto:[email-masked]]
> Sent: Wednesday, July 18, 2001 3:09 AM
> To: Bound, Jim
> Cc: [email-masked]; McCann, John
> Subject: Austin Group Status
> 
> 
> Hello Jim
> 
> Jack McCann asked me to touch base with you regarding the
> Austin Group specifications. Draft 7 is now available
> on the web site since June 15, and is the proposed final
> text draft. We will not be making any further normative
> changes and will be submitting this draft to the standards
> approval boards , targeting approval in September.
> Any further issues beyond this point will go into the bucket
> for consideration for Technical Corrigendum number 1.
> best regards
> Andrew
> 
> 
> -----
> Andrew Josey                                The Open Group
> Director, Server Platforms                  Apex Plaza,Forbury Road,
> Email: [email-masked]                Reading,Berks.RG1 
> 1AX,England
> Tel:   +44 118 9508311 ext 2250             Fax: +44 118 9500110
> Mobile: +44 774 015 5794
> 

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: [email-masked]
Date: Thu, 19 Jul 2001 08:16:59 +0900

>used in the market.  Also several ISVs have voiced concerns.  We must take

	sorry, just to clarify - what part of change do you mean by
	"got complaint about *changing* the base API"?  there were a couple
	of changes since RFC2553...

itojun

---

From: Jim Bound <[email-masked]>
Date: Thu, 19 Jul 2001 00:51:23 -0400 (EDT)

they were talking all the way back to rfc2133....not just 2553.  mostly
the get* stuff we kept changing.  

/jim

---

From: Jim Bound <[email-masked]>
Date: Thu, 19 Jul 2001 00:52:09 -0400 (EDT)

also they implemented the model where AF_INET6 is used to for both v6 and
v4mapped.

/jim