Subject: RE: Proxy announcement !

From: "Peter Hedman N (ECS)" <[email-masked]>
Date: Thu, 5 Jul 2001 10:53:04 +0200

Hi,
Perhaps we haven't been defining the context "cellular" clear enough, but the intention was to start of without technologies such as WLAN and Bluetooth, and only handle those with larger cell sizes and coverage. This almost always implies some type of billing mechanisms to it as the architecture and bandwidth is considered to be more expensive.

Regards,
Peter

-----Original Message-----
From: Claude Castelluccia [mailto:[email-masked]]
Sent: den 5 juli 2001 09:58
To: Hesham Soliman (ERA)
Cc: [email-masked]
Subject: Re: Proxy announcement !

Hello , 

This is a very interesting draft but I would suggest to change the title. 
Something like "Minimum IPv6 Functionality for a 3GPP Host" would 
be more accurate... 
Some of the sections are very specific to the 3GPP architecture and can not 
be generalized to Cellular hosts (that could used IEEE802.11, Bluetooth, blabla types 
of networks..) 

Regards, 
Claude. 

"Hesham Soliman (ERA)" wrote: 

All, 

A new draft on IPv6 Cellular hosts requirements was submitted today. 
Until it's announced, you can view it here: 

http://standards.ericsson.net/Hesham/draft-manyfolks-ipv6-cellular-host-00.txt <http://standards.ericsson.net/Hesham/draft-manyfolks-ipv6-cellular-host-00.txt>  

I'm doing this for Jari (one of the author) as he's away. 

Cheers, 
Hesham 
-------------------------------------------------------------------- 
IETF IPng Working Group Mailing List 
IPng Home Page:                     http://playground.sun.com/ipng <http://playground.sun.com/ipng>  
FTP archive:                     ftp://playground.sun.com/pub/ipng <ftp://playground.sun.com/pub/ipng>  
Direct all administrative requests to [email-masked] 
--------------------------------------------------------------------

-- 

----------------------------------------

Claude CASTELLUCCIA, INRIA Rhone-Alpes  

ph:  +33 4.76.61.52.15 (fax: 52.52)

http://www.inrialpes.fr/planete/ <http://www.inrialpes.fr/planete/> 

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: George Tsirtsis <[email-masked]>
Date: Thu, 5 Jul 2001 05:03:26 -0400

I share Claude's point..."cellular" is too generic..you really mean "3G
cellular". Other than that, I think the draft is useful as an Informational
document.

George

-----Original Message-----
From: Peter Hedman N (ECS) [mailto:[email-masked]]
Sent: Thursday, July 05, 2001 9:53 AM
To: 'Claude Castelluccia'
Cc: [email-masked]
Subject: RE: Proxy announcement !

Hi,
Perhaps we haven't been defining the context "cellular" clear enough, but
the intention was to start of without technologies such as WLAN and
Bluetooth, and only handle those with larger cell sizes and coverage. This
almost always implies some type of billing mechanisms to it as the
architecture and bandwidth is considered to be more expensive.

Regards,
Peter

-----Original Message-----
From: Claude Castelluccia [mailto:[email-masked]]
Sent: den 5 juli 2001 09:58
To: Hesham Soliman (ERA)
Cc: [email-masked]
Subject: Re: Proxy announcement !

Hello , 

This is a very interesting draft but I would suggest to change the title. 
Something like "Minimum IPv6 Functionality for a 3GPP Host" would 
be more accurate... 
Some of the sections are very specific to the 3GPP architecture and can not 
be generalized to Cellular hosts (that could used IEEE802.11, Bluetooth,
blabla types 
of networks..) 

Regards, 
Claude. 

All, 

http://standards.ericsson.net/Hesham/draft-manyfolks-ipv6-cellular-host-00.t
xt
<http://standards.ericsson.net/Hesham/draft-manyfolks-ipv6-cellular-host-00.
txt>  

Cheers, 
Hesham 
-------------------------------------------------------------------- 
IETF IPng Working Group Mailing List 
IPng Home Page:                     http://playground.sun.com/ipng
<http://playground.sun.com/ipng>  
FTP archive:                     ftp://playground.sun.com/pub/ipng
<ftp://playground.sun.com/pub/ipng>  
Direct all administrative requests to [email-masked] 
--------------------------------------------------------------------

--

---

From: [email-masked]
Date: Thu, 5 Jul 2001 13:30:23 +0300

Hi Claude,

> This is a very interesting draft but I would suggest to 
> change the title. Something like "Minimum IPv6 Functionality 
> for a 3GPP Host" would be more accurate... 
>
> Some of the sections are very specific to the 3GPP architecture 
> and can not be generalized to Cellular hosts (that could used 
> IEEE802.11, Bluetooth, blabla types of networks..) 

We had some discussion between the authors on this topic. 
Our first title was "Min IPv6 Functionality for a Wireless 
Host" but we realized that this would be misleading because
of the reason you mention above.

Cellular was chosen to denote wireless hosts using licensed
bands, like 2.5G and 3G.  We do try to define what we mean by
cellular host in the introduction:

   For the purposes of this draft, a cellular host is considered to be
   a terminal which uses an air interface to connect to a cellular
   access network (i.e. - GPRS, UMTS, CDMA2000) in order to provide
   IPv6 connectivity to an IP network.  The functionality to provide
   IPv6 connectivity is outlined in this draft.

A side note: we needed to specify quite a few exceptions for 
hosts connecting to 3GPP networks because those specifications 
are the most specified.  Since some of those specs are already
completed, and are already being implemented for deployment
later this year (in some cases), we felt that we needed to point
them out for implementors.

thanks,
John

---

From: [email-masked]
Date: Thu, 5 Jul 2001 13:33:48 +0300

Hi George,

> I share Claude's point..."cellular" is too generic..you 
> really mean "3G cellular". Other than that, I think the 
> draft is useful as an Informational document.

There is consideration for 2.5G hosts as well (GSM terminals
connecting to GPRS [2nd generation] networks.  

For me, cellular is TDMA, CDMA, GSM, PCS, WCDMA, CDMA2000, etc.
Wireless is Bluetooth, WLAN, etc.

Should we define this better?

best regards,
John

---

From: George Tsirtsis <[email-masked]>
Date: Thu, 5 Jul 2001 07:13:35 -0400

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Thursday, July 05, 2001 11:34 AM
To: [email-masked]; [email-masked];
[email-masked]
Cc: [email-masked]
Subject: RE: Proxy announcement !

Hi George,

GT> But John, surely you do not mean that a 2G GSM/PCS phone is now expected
to support the protocols in this draft.... In fact the draft has nothing to
do with the access technologies listed above...it only makes sense in the
context of 2.5/3G *architecture*, don't you think? 

George

---

From: [email-masked]
Date: Thu, 5 Jul 2001 14:51:05 +0300

Hi George,

> GT> But John, surely you do not mean that a 2G GSM/PCS phone 
> is now expected to support the protocols in this draft.... 
> In fact the draft has nothing to do with the access technologies 
> listed above...it only makes sense in the context of 2.5/3G 
> *architecture*, don't you think? 

Exactly.  The air interface is not the important point - it is
the cellular access network that places certain considerations
to what the cellular host needs to support (if it wants to use
IPv6).  

With respect to this draft, our intention was to aid implementors
who are adding IPv6 stacks to cellular hosts.  Not all cell 
phones will connect to the Internet, so they don't need this.
As there will be many IPv6-enabled cellular hosts (phones with
data connections, for example), we want to make sure that they
use IPv6 correctly and want to insure interoperability.

br,
John

---

From: Phil Roberts <[email-masked]>
Date: Thu, 5 Jul 2001 14:12:48 -0400

Hi,

I have a bunch of comments on the document inline which I'll send to the
authors offlist to
avoid clutter.  But I have some general comments for the list.  Something
like this is definitely
needed and for multiple purposes so good job for making a start of it.

1.  What is the intention of this document?  If it is purely guidelines for
implementors it
should probably be redone as guidelines for implementors of IP v6 nodes in
3gpp networks.  If
it's input to SDOs there needs to be some rework identifying recommendations
that are
different from what has already been done or is being considered.  The
document doesn't seem
to work well for either as written.  This document has a lot of good
material for both but
seemed to go back and forth between the two goals.

2.  For each of the above is the intention to educate the SDOs or the IETF?

3.  A decision probably needs to be made about what kind of host is being
considered.  Again
sometimes it seems the text is for hosts that will operate only in a
cellular network and
sometimes for hosts that will operate between a cellular network and another
kind of network.
The requirements for these two kinds of hosts could be quite different.

4.  I think there was some concern at the interim meeting about the apparent
3gpp intent to
limit cellular devices 1) to a single global address and 2) to being a host
and having no
possibility for a router function.

Phil

> From: Hesham Soliman (ERA) [mailto:[email-masked]]
> Sent: Wednesday, July 04, 2001 9:56 AM
> To: [email-masked]
> Subject: Proxy announcement !
> 
> 
> All, 
> 
> http://standards.ericsson.net/Hesham/draft-manyfolks-ipv6-cell
> ular-host-00.txt
>

---

From: [email-masked]
Date: Fri, 6 Jul 2001 09:30:10 +0300

Hi Phil,

> I have a bunch of comments on the document inline which I'll 
> send to the authors offlist to avoid clutter.  But I have some 
> general comments for the list.  Something like this is definitely

Thanks.  I'll respond to your points - my remarks are my own
thoughts - I'm not trying to speak for the other authors.

> 1.  What is the intention of this document?  If it is purely 
> guidelines for implementors it should probably be redone as 
> guidelines for implementors of IP v6 nodes in 3gpp networks.  If
> it's input to SDOs there needs to be some rework identifying 
> recommendations that are different from what has already been 
> done or is being considered.  The document doesn't seem
> material for both but seemed to go back and forth between the two 
> goals.

I'd first suggest that some of the folks who will be implementing
IPv6 in in 3G phones (for example) may not be familiar with the 
IETF, so that it might be helpful to have this kind of document. 
Additionally, we want to insure that as mass produced devices
(some with limited upgradability) hit the market, these devices
work & interoperate with each other and the Internet.

Secondly, I think this should be an IETF document.  Other SDOs have
their own way of handling contributions, so I think that 
clarifications on requirement language, etc. should be handled
in specific contributions to those SDOs, not in an Internet draft.

> 2.  For each of the above is the intention to educate the 

Yes to both.  At the recent IPNGWG interim meeting in Seattle,
there were lots of questions related to what with the handsets
implement and support - so hopefully this addresses some of 
those issues.  As far as other educating other SDOs, the 
best way forward (IMO) is to ensure that this is an IETF-style
document, and make clarifications in contributions to the
other SDOs

> 
> 3.  A decision probably needs to be made about what kind of 
> host is being considered.  Again sometimes it seems the text 
> is for hosts that will operate only in a cellular network and
> sometimes for hosts that will operate between a cellular 
> network and another kind of network. The requirements for 
> these two kinds of hosts could be quite different.

Definately.  We are trying to scope this document so that 
the minimum set is related to what will only operate via
a cellular network.  However, we felt that we should discuss
when certain functionality might be needed, even if not
directly supported by the cellular network.  This is one
part of the document that we know needs more work.

> 4.  I think there was some concern at the interim meeting 
> about the apparent 3gpp intent to limit cellular devices 1) 
> to a single global address and 2) to being a host
> and having no possibility for a router function.

First, cellular terminals can have more than one global
address, at least in 3GPP.  Additional addresses can be
assigned, as a terminal opens additional PDP-contexts.  
However, it is not currently the ability to assign a prefix
to a device.  This was identified as an issue in Seattle,
and I think there is some process to bring this issue up
with 3GPP.  

Anyhow, I think that router functionality in a cellular
terminal should be documented in a seperate document.

Thanks for the comments - probably it would be good to 
address some of these issues face-to-face in London.

cheers,
John

---

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Tue, 10 Jul 2001 18:31:08 +0200

Hi Phil, 

	I'm not an "official" author of the draft but let me 
	address a couple of your points below in addition to
	John's comments.

> seemed to go back and forth between the two goals.
	=> The intention was to address the implementation requirements
	for IP cellular hosts, so that excludes GSM terminals for example. 
	The intention was not to make it specific to 3GPP since most of the 
	reasons behind the requirements are not 3GPP specific. These are
	the ones mentioned in the introduction (limited power, BW, memory ...etc).
	However, since 3GPP is the only system currently mandating 
	IPv6 in the architecture, in some cases exception were made 
	for such architecture. By exception I mean evaluating whether 
	a certain function is needed i such architecture. Of course 
	the same can be done in future for other architectures mandating 
	IPv6. 

> 2.  For each of the above is the intention to educate the SDOs or the IETF?
	=> Cellular hosts implementors mainly ;) 
	Interoperability is necessary and we wanted to make sure there is 
	some kind of agreement on the implementation requirements 
	as well as make sure nothing new will break the existing IPv6
	standards.

> The requirements for these two kinds of hosts could be quite different.
	=> The functionality requirement is scenario-based. For example a host
	with more than one interface (in a 3GPP network) will need to 
	implement more of the MIPv6 spec than a host with a certain interface. 
	Rather than limiting that host architectures, the intention was to go 
	through each function and mention when it is a MUST, SHOULD or MAY
	depending on the use case. 
	But maybe that should be clarified a bit more in the doc. ?

> possibility for a router function.
	=> I'm not sure if the draft has anything related to this particular 
	point. The 3GPP architecture may of course change to fix 
	these limitaitons above (I certainly hope so), but I don't see 
	that these particular cases will impact the draft. 

	Thanks, 
	Hesham

---

From: Phil Roberts <[email-masked]>
Date: Tue, 10 Jul 2001 13:03:07 -0400

Hi,

   thanks for the comments.  I think this document is trying to
do too much.

   It seems like a document focussed on recommendations for implementors
of IP v6 in devices for 3gpp networks could useful right away (or at
least one hopes).  It could be split into sections for devices that would
only operate in a 3gpp network and devices that would operate in a 3gpp
network and other networks.  This would assume some knowledge of the
standards as they exist today.

   I think there is room for another document that provides recommendations
for the use of IP v6 in 3g networks.  The 3gpp standards will continue to
evolve and the more IPv6 that is present in them, the more guidance about
how
to make the best use of it might be appreciated.  3gpp2 is still very
nascent
from my understanding and would also be a customer for such a document.

   There is good material for both of these kinds of customers in the
existing
document and material that would go in both, but I think focussing a little
more would be helpful to the readers and also in moving the documents
forward
quickly.

Phil

> Sent: Tuesday, July 10, 2001 12:31 PM
> To: 'Phil Roberts'; [email-masked]
> host is being
> network and another
> about the apparent