Subject: RE: ipv6 header checksum

From: Jung Cyndi-ACJ099 <[email-masked]>
Date: Tue, 24 Jul 2001 17:48:08 -0500

Another reason for eliminating the IPv6 header checksum was that since IPSEC was
required, that the AH would protect the IPv6 header from corruption, and that a
checksum would be redundant.  Also perhaps some naive idea that the data links
were be error-free, or could detect their own errors - leaving only the more frequent
problem of packets corrupted while sitting in the memory of some intermediate node.

Cyndi

-----Original Message-----
From: Kastenholz, Frank [mailto:[email-masked]]
Sent: Tuesday, July 24, 2001 8:09 AM
To: Ignatios Souvatzis; Sean Lin
Cc: [email-masked]
Subject: Re: ipv6 header checksum

At 04:27 AM 7/24/01 -0400, Ignatios Souvatzis wrote:

>On Tue, Jul 24, 2001 at 04:42:37PM +1200, Sean Lin wrote: 
>
>>     As we all know, there's no ipv6 header checksum field. Therefore, 
>> for routers forwarding packets, the checksum of ipv6 packets cannot be 
>> calculated? Which means that ipv6 routers will generally have a faster 
>> throughput compared to a similar ipv4 router (assuming there's no 
>> extension headers and option headers)? 
>
>Yes. That's the reason it was designed that way. 

For software based forwarding engines, you are correct.

However, most if not all high-speed routers one encounters
today use silicon-based (ASICs and/or FPGAs) forwarders.
The nice thing about silicon is that lots of stuff can be
done in parallel. The IPv4 header checksum can be, and is,
calculated in parallel with the other header checks, etc,
that are going on. Thus, it takes 0.000000.... additional
time. If IPv6 had a header checksum, it too would be 
calculated in 0.00000... additional time.

Frank Kastenholz

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: [email-masked]
Date: Wed, 25 Jul 2001 10:55:12 +0100

> you're aware that IPv6 has bigger headers, and additionally 
> more likely
> to be variable length, than IPv4?

I'm aware that IPv6 has a *fixed-length*, streamlined header.

Cheers,

Mat.

---

From: [email-masked]
Date: Wed, 25 Jul 2001 10:55:12 +0100

Cheers,

Mat.

---

From: [email-masked]
Date: Wed, 25 Jul 2001 10:55:12 +0100

Cheers,

Mat.