Subject: RE: Anycast address

From: "Dave Thaler" <[email-masked]>
Date: Sat, 21 Jul 2001 21:29:55 -0700

Sreeram Vankadari writes:
> > > now 2000::0/128 becomes the anycast address assigned to that
> interface.
> > > Suppose if there are multiple routers attached to that ethernet
> interface,
> > > and a packet comes with a destination address of 2000::/128 which
> > > router will respond to that packet.  (2000::/128 is an automatic
> anycast
> > > address assigned to all the ipv6 routers attached to that
ethernet)
> >
> > Technically "any" one of them would be legal, but the answer that
makes
> the most sense is "the first one that the packet reaches" (i.e. the
one
> closest to the source).
> 
> That is correct.  But how does the receiving router know that it is
the
> closest
> router to the source.

It doesn't.  The first router that sees the packet will respond.
The others won't see it.

-Dave
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Sreeram Vankadari <[email-masked]>
Date: Fri, 20 Jul 2001 18:20:59 -0700

Dave Thaler wrote:
> 
> Sreeram Vankadari [mailto:[email-masked]] writes:
> > Suppose the ipv6 prefix assigned to an interface is 2000::1234:5678/96.
> 
> First of all, RFC 2373 mandates that all 2000 addreses (and most others) are required to have 64-bit interface identifiers, so the prefix in question would have to be 2000::/64 (a /96 is illegal).  (Also keep in mind that you can assign many prefixes to the same interface.)
> 
> So I'll assume it's a typo and you meant:
> "Suppose the IPv6 prefix 2000::/64 is assigned to an interface."

Okay.
> 
> > now 2000::0/128 becomes the anycast address assigned to that interface.
> > Suppose if there are multiple routers attached to that ethernet interface,
> > router will respond to that packet.  (2000::/128 is an automatic anycast
> > address assigned to all the ipv6 routers attached to that ethernet)
> 
> Technically "any" one of them would be legal, but the answer that makes the most sense is "the first one that the packet reaches" (i.e. the one closest to the source).

That is correct.  But how does the receiving router know that it is the closest
router to the source.

Sreeram.