Subject: FW: I-D ACTION:draft-stewart-tsvwg-sctpipv6-00.txt

From: [email-masked]
Date: Wed, 4 Jul 2001 10:30:34 +0300

Hi all,

For those of you not aware, there is a new transport level 
protocol, SCTP.  This protocol supports transport level
multihoming, by allowing endpoints to exchanging IP addresses
in the association intitialization messages.

This can cause some problems by allowing IP addresses to
escape their scope, thus introducing the possibilities for
some black holes.

I'm not sure if Randy Stewart is subscribed or not (primary
author of SCTP), but if he isn't, I can field some questions
about SCTP (if they aren't too tough!) ...

Just a small deployment note - SCTP should start seeing some
deployment later this year in 3G networks, as a signaling 
bearer for some radio access protocols, so it would be a 
good idea to try make sure that this issue is nailed down.

thanks,
John

> 	Title		: IPv6 addressing and Stream Control 
> 			  Transmission Protocol
> 	Author(s)	: R. Stewart, S. Deering
> 	Filename	: draft-stewart-tsvwg-sctpipv6-00.txt
> 	Pages		: 
> 	Date		: 02-Jul-01
> 	
> Stream Control Transmission Protocol [RFC2960] provides transparent
> multi-homing to its upper layer users. This multi-homing is
> accomplished through the passing of address parameters in the
> initial setup message used by SCTP. In an IPv4 network all addresses
> are passed with no consideration for their scope and routeablility.
> In a IPv6 network special considerations MUST be made to properly
> bring up associations between SCTP endpoints that have IPv6
> [RFC2460] addresses bound within their association.  This document
> defines those considerations and enumerates general rules
> that an SCTP endpoint MUST use in formulating both the INIT and
> INIT-ACK chunks.
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-stewart-tsvwg-sctpipv6-00.txt
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Randall Stewart <[email-masked]>
Date: Mon, 23 Jul 2001 09:41:41 -0500

Hi John:

to answer a question..

> about SCTP (if they aren't too tough!) ...

Yes, I do subscribe but I am currently in a email burial (I
am at least 6 feet under :-0) and I don't think I will 
be able to work my way out until next week... sigh..

I will try to catch up but your help is always appreciated :)

R

-- 
Randall R. Stewart
[email-masked] 815-342-5222 (cell phone)