Subject: Re: Thank you..

From: Pekka Savola <[email-masked]>
Date: Wed, 18 Jul 2001 10:25:07 +0300 (EEST)

On 18 Jul 2001, Prema M P wrote:
> Scenario 1:
>                              Node 2
>                                 | 1480
>              1300               |
>     --- Router -------------------------
>                         |
>                         | 1480
>                      Node 1
>
>   Is Node1 be able to send pkts of size 1480 to Node2 or Router ??

Yes.

Traffic back from Router is at most 1300 bytes long, though.

> Scenario 2:
>                 Node 3                               Node 2
>               1500 |                                    | 1480
>                    |      1500        1500              |
>  ------------------------------Router -------------------------
>                                                 |
>                                                 | 1300
>                                              Node 1
>
> If node3 needs to send pkts to node 1, will Node 1 (IP layer) be able to
> receive pkts of size 1500 ??
> or If there is fragmentation, what will be the fragmented packets size??

Node1 can receive the packets unfragmented.

Additional scenario 3:

                 Node 3                               Node 2
               1500 |                                    | 1480
                    |      1500        1300              |
  ------------------------------Router -------------------------
                                                 |
                                                 | 1500
                                              Node 1

Now, if Node3 tries to send to Node1, Path MTU discovery happens and Node3
will only send with MTU of 1300. Or if there is fragmentation, it is done
by end nodes with fragmentation header.  If Node2 wanted to communicate
with Node3 or Node1, MTU of 1480 would be used to that direction, and 1300
or 1500 back, respectively.

-- 
Pekka Savola                 "Tell me of difficulties surmounted,
Netcore Oy                   not those you stumble over and fall"
Systems. Networks. Security.  -- Robert Jordan: A Crown of Swords

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Prema M P <[email-masked]>
Date: 18 Jul 2001 12:41:04 IST

Hi,

Thanks for the info,

I would appreciate if the following scenario's are explained :

Scenario 1:

                             Node 2
                                | 1480
             1300               |
    --- Router -------------------------
                        |
                        | 1480
                     Node 1

   Node 1 MTU - 1480
   Node 2 MTU - 1480
   Router (i/f) - 1300

Scenario 2:

                Node 3                               Node 2
              1500 |                                    | 1480
                   |      1500        1500              |
 ------------------------------Router -------------------------
                                                |
                                                | 1300
                                             Node 1

	Node 1 MTU - 1300
 	Node 2 MTU - 1480
	Node 3 MTU - 1500
	Router(i/f - node 3 side ) - 1500
	Router(i/f - node 1 & 2 side ) - 1500

Thanks

---

From: Pekka Savola <[email-masked]>
Date: Sat, 21 Jul 2001 09:37:53 +0300 (EEST)

> I would appreciate if the following scenario's are explained :

You already asked the same question less than week ago and it was
answered; I guess it was lost..

>   Is Node1 be able to send pkts of size 1480 to Node2 or Router ??

Yes.  Yes.

>                 Node 3                               Node 2

Yes, is able to send and receive.