Subject: RE: Cellular host requirements, 01 & next steps

From: Delecki Andrew-Y10658 <[email-masked]>
Date: Tue, 25 Sep 2001 12:47:56 -0400

Hi all,

Appendix A of the draft, uses text from 3GPP TS 23.060, Clause 9.2.1.1 without any criticism.

This text specifies non-compliant with respect to RFC 2462 implementation of the stateless address autoconfiguration, which received heavy criticism from IPNG folks during joint 3GPP-IETF meeting in Seattle (May 31, 2001).

The draft represents merely compilation of texts from various sources without any effort to make it consistent across all relevant specifications.

At present form, it doesn't represent any valid concept for cellular IPv6 hosts as it absorbs without any criticism deviant implementations of the fundamental concept of IPv6: stateless address autoconfiguration.

Andrew Delecki

Motorola

-----Original Message-----
From: Jari Arkko [mailto:[email-masked]]
Sent: Monday, September 24, 2001 11:08 PM
To: [email-masked]
Subject: Cellular host requirements, 01 & next steps

Hello,

I'd like to announce that we have produced a new version
of the cellular host requirements draft. Before it makes
to the official I-D directories you can access it at

http://standards.ericsson.net/hesham/draft-manyfolks-ipv6-cellular-host-01.txt

We appreciate all the input we've gotten on the draft,
and have tried to take it all in account in this new
version. Further input would also be much appreciated,
so keep those comments coming!

Also, I'd like to ask the groups' opinion on how to
proceed with this work. On a technical level, I feel
that most people seem to agree on the main issues
though some work of course remains.

However, in London we didn't actually decide what to
do with this draft.

Basically, we'd be interested in getting this work on
Standards Track and get it finalized as soon as possible.
There is an opportunity for IPv6 in a very large number
of hosts, starting from the release 5 of 3GPP. I think
we should seize that opportunity - and in a consistent,
interoperable manner towards the rest of the IPv6 Internet.
One way of helping this to happen is to have an RFC whose
support can be required from the terminal devices. How
can we get there in the best possible way? Can we get this
as an official work item in the WG?

Jari Arkko
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: "Jari Arkko" <[email-masked]>
Date: Thu, 4 Oct 2001 03:13:45 +0300

RE: Cellular host requirements, 01 & next stepsHi Andrew,

> Appendix A of the draft, uses text from 3GPP TS
> 23.060, Clause 9.2.1.1 without any criticism.

Yes we do reference the current 3GPP specs. We
are also quite aware of the criticism of the specs, and
we support the process on making the 3GPP specifications
better.

However, there already is a design team in place
in this WG to produce such improvement proposals.
Are you aware of this effort? Design team, can
you comment on how you are proceeding?

But back to our draft. The 3GPP specifications come
in "Releases", and the improvements affect only the future
releases, not the old ones. Also, appendix A
is there for information - to avoid the need to find the
3GPP specs - and to allow us to explain the special
case under 2.5.1 and 2.6.1. (We propably should
have made clearer that there's a difference to the
IPv6 standard way.)

The purpose of our draft is primarily to describe
what cellular hosts in general need to do wrt
IPv6. In addition to this, we want to provide
concrete examples on particular cellular
networks and their problems, insofar as that
information exists today. The example part is
more like "here's how your run IPv6 on X" rather
than "let's design the best possible Y to run
IPv6".

However, you are right in the sense that 
we should propably more clearly highlight the
issue in the draft, and indicate that the
specific examples that apply to 3GPP are
relevant for a particular version (Release 99),
and future versions may have a different situation.

Hope this clarifies the situation,

Jari

---

From: Alexandru Petrescu <[email-masked]>
Date: Thu, 04 Oct 2001 15:54:21 +0200

> Appendix A of the draft, uses text from 3GPP TS 23.060, Clause 9.2.1.1

The funniest thing of the 3GPP "stateless autoconf" is that GGSN
provides the "unique interface identifier" (an equivalent of an EUI-64)
to the mobile as if the mobile would not know its own unique ID.

OTOH, I can understand this if 3GPP considers there'll be a sort
of "tunnel" between mobile and GGSN, like in PPP.  But in that
case they just can't state this is stateless autoconf.

Alex

---

From: Mattias Pettersson <[email-masked]>
Date: Thu, 04 Oct 2001 16:38:42 +0200

> to the mobile as if the mobile would not know its own unique ID.

The reason for this, AFAIK, is to get rid of DAD on the GGSN side. If
the GGSN hands out IDs from a pool it can easily keep control of what
IDs are unused and DAD becomes a simple task.

On the other hand, if the GGSN was to do real DAD, it would have to scan
a probably *huge* address space to detect collisions, as the GGSN is the
only node that knows all the addresses used since the terminals never
talk directly to each other.

/Mattias

---

From: Alexandru Petrescu <[email-masked]>
Date: 04 Oct 2001 20:11:40 +0200

> IDs are unused and DAD becomes a simple task.

Mattias, thank you for your remarks.

It looks to me that the whole autoconf/DAD idea has been designed with
a shared medium in mind.  However, I understand this "shareness" at
level 3, and not lower.  It's probably possible to design a 3GPP L2
under IP that makes an "unshared" L1/2 look like a "shared" media to
IP.

Alex