Subject: RE: Request to Advance "Default Address Selection for IPv6"

From: "Hesham Soliman (EPA)" <[email-masked]>
Date: Wed, 3 Oct 2001 11:15:47 +1000

Hi, 

	I'm resending this mail, I think it's still applicable to
	the latest version. This was sent after the Seattle
	meeting. 

	Hesham

	-----Original Message-----
	From:	Erik Nordmark [SMTP:[email-masked]]
	Sent:	Tuesday, 5 June 2001 12:23
	To:	Hesham Soliman  (ERA)
	Cc:	[email-masked]
	Subject:	RE: W.G. Last Call on "Default Address Selection for
IPv6" 

	> Rich, 
	> 
	> Based on our private discussion in Seattle,  think it would 
	> be useful to add a sending rule for mapped addresses 
	> as follows:
	> 
	> - If the destination address is an IPv4-mapped IPv6 address, and
	> - If the host is an IPv6-only host
	> the source address MUST be an IPv6-translated address. 

	I think this makes sense as long as we preface it very clearly with
		Nodes that implement SIIT (does not apply to other nodes)
...

	Without that preface adding these rules will do nothing but adding
confusion.

	  Erik

	-----Original Message-----
	From:	Hesham Soliman  (ERA) [SMTP:[email-masked]]
	Sent:	Tuesday, 5 June 2001 8:40
	To:	[email-masked]
	Subject:	RE: W.G. Last Call on "Default Address Selection for
IPv6" 

	Rich, 

	Based on our private discussion in Seattle,  think it would 
	be useful to add a sending rule for mapped addresses 
	as follows:

	- If the destination address is an IPv4-mapped IPv6 address, and
	- If the host is an IPv6-only host
	the source address MUST be an IPv6-translated address. 

	Comments ?

	Hesham

> -----Original Message-----
> From:	Bob Hinden [SMTP:[email-masked]]
> Sent:	Tuesday, 2 October 2001 9:46
> To:	[email-masked]; [email-masked]
> Cc:	[email-masked]; [email-masked]
> Subject:	Request to Advance "Default Address Selection for IPv6"
> 
> Erik, Thomas,
> 
> The chairs of the IP Next Generation working group, on behalf of the 
> working group, request that the following document be published as a 
> Proposed Standard:
> 
> 	Title		: Default Address Selection for IPv6
> 	Author(s)	: R. Draves
> 	Filename	: draft-ietf-ipngwg-default-addr-select-06.txt
> 	Pages		: 22
> 	Date		: 28-Sep-01
> 
> A working group last call for this document was completed on June 7, 
> 2001.  The "-06" draft was produced in response to comments made during
> the 
> w.g. last call and subsequent discussion.  The document was discussed at 
> the London IETF and the w.g. agreed advancing it to Proposed Standard once
> 
> the new draft was published.
> 
> Bob Hinden / Steve Deering
> IPng Working Group Co-Chairs
> 
> --------------------------------------------------------------------
> IETF IPng Working Group Mailing List
> IPng Home Page:                      http://playground.sun.com/ipng
> FTP archive:                      ftp://playground.sun.com/pub/ipng
> Direct all administrative requests to [email-masked]
> --------------------------------------------------------------------
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: "Richard Draves" <[email-masked]>
Date: Fri, 5 Oct 2001 16:07:13 -0700

Oops, I missed your comment when doing 06.
I'm not sure I understand it correctly.
Are you suggesting another paragraph in section 3?

Thanks,
Rich

-----Original Message-----
From: Hesham Soliman (EPA) [mailto:[email-masked]] 
Sent: Tuesday, October 02, 2001 6:16 PM
To: [email-masked]
Cc: Richard Draves
Subject: RE: Request to Advance "Default Address Selection for IPv6"

Hi, 
-----Original Message----- 
From:   Erik Nordmark [SMTP:[email-masked]] 
Sent:   Tuesday, 5 June 2001 12:23 
To:     Hesham Soliman  (ERA) 
Cc:     [email-masked] 
Subject:        RE: W.G. Last Call on "Default Address Selection for
IPv6" 
I think this makes sense as long as we preface it very clearly with 
        Nodes that implement SIIT (does not apply to other nodes) ... 
Without that preface adding these rules will do nothing but adding
confusion. 
  Erik 
-----Original Message----- 
From:   Hesham Soliman  (ERA) [SMTP:[email-masked]] 
Sent:   Tuesday, 5 June 2001 8:40 
To:     [email-masked] 
Subject:        RE: W.G. Last Call on "Default Address Selection for
IPv6" 
Rich, 

-----Original Message----- 
From:   Bob Hinden [SMTP:[email-masked]] 
Sent:   Tuesday, 2 October 2001 9:46 
To:     [email-masked]; [email-masked] 
Cc:     [email-masked]; [email-masked] 
Subject:        Request to Advance "Default Address Selection for IPv6" 
Erik, Thomas, 

the London IETF and the w.g. agreed advancing it to Proposed Standard
once

---

From: "Hesham Soliman (EPA)" <[email-masked]>
Date: Mon, 8 Oct 2001 12:35:28 +1000

> Are you suggesting another paragraph in section 3?
	=> I guess you could add something in section 3, 
	but it should also be obvious in one of the rules. 
	So to explain my comment better, the rule would 
	specify that if the dst address is an IPv4-mapped 
	IPv6 address, and the node is an IPv6-only node
	then the src address selected should be an IPv4-translated
	IPv6 address. 

	As Erik mentioned in the mail I included below, we would have 
	to add a comment specifynig that this is for nodes 
	that implement SIIT to avoid confusion. 
	I'm sorry if I didn't include other comments but I couldn't find 
	any other responses. If someone else commented please 
	restate your comment.

	Does that make sense ? 

	Thanks, 
	Hesham.

---

From: "Hesham Soliman (EPA)" <[email-masked]>
Date: Tue, 9 Oct 2001 13:46:25 +1000

> I just took another look at RFC 2765. I believe that for SIIT to work,
> when an IPv6-only node sends to an IPv4-mapped address (so it is sending
> an IPv6 packet with an IPv4-mapped source address, as opposed to using the
> IPv4-mapped address in the API and sending an IPv4 packet), then it must
> use an IPv4-translatable source address. Anything else will just not work
> when the packet gets to the SIIT box.
>  
> So to my mind, this feels more like a section 3 requirement. It's not a
> matter of the IPv6-only node *preferring* to use an IPv4-translatable
> source address. Instead, if there is no IPv4-translatable source address
> available, then the IPv6-only node should *fail* to send to the
> IPv4-mapped destination address.
> 
	=> I see, so section 3 is ok then. But just for my understanding
	are you saying that in this case you would basically bypass
	the src address selection rules ?
>  
> But I don't understand Erik's comment that this only applies to nodes that
> implement SIIT. Why does it not apply to all IPv6-only nodes sitting
> behind a SIIT box?
>  
	=> I thought that if an IPv6-only node gets an IPv4-mapped 
	address for the dst node then it must use an IPv4-translatable 
	IPv6 src address. 
	If the network does not support SIIT then it must not return 
	an IPv4-mapped address to the IPv6 node (in the DNS reply 
	....etc). This seems to be inline with what you say above.
	But I don't know if this requirement on IPv4-mapped addresses
	is mentioned anywhere, for example is there anything 
	in NAT-PT that disallows the use of a mapped address 
	for the NAT-PT box ? I think that should be disallowed 
	to avoid confusion in the end hosts.

	I hope this helps.

	Thanks,
	Hesham

> 	Sent: Sunday, October 07, 2001 7:35 PM
> 	To: Richard Draves
> 	From: Hesham Soliman (EPA) [
> <mailto:[email-masked]>] 
> 	        Filename        :
> draft-ietf-ipngwg-default-addr-select-06.txt 
> 	        Pages           : 22 
> 	        Date            : 28-Sep-01 
> 	IPng Home Page:
> <http://playground.sun.com/ipng> 
> 	FTP archive:
> <ftp://playground.sun.com/pub/ipng>