Subject: RE: ICMPv6 rate limiting factor

From: "Richard Draves" <[email-masked]>
Date: Mon, 29 Oct 2001 22:42:48 -0800

Well the traceroute implementation we use around here limits how fast it
sends out probes, to no more than one a second. From your comment I take
it not everyone does this?

Rich

> -----Original Message-----
> From: Pekka Savola [mailto:[email-masked]] 
> Sent: Monday, October 29, 2001 10:24 PM
> To: Richard Draves
> Cc: Lori Napoli; [email-masked]
> Subject: RE: ICMPv6 rate limiting factor
> 
> 
> On Mon, 29 Oct 2001, Richard Draves wrote:
> > The Microsoft implementation limits to two errors per 
> second, just for 
> > this reason.
> 
> That is only good enough if you assume the tracerouter is 
> over 500ms away, 
> because traceroute by default sends out three probes..
> 
> I've commented on the new ICMP draft that this issue should 
> be taken into consideration, and apparently it will, as the 
> draft didn't progress at IETF51.
> 
> B.t.w. Linux uses a token bucket mechanism here and is not affected.
> 
> B.t.w.2. Cisco implementation is(/was) also broken, another 
> issue I mentioned here and on [email-masked], they promised 
> they'd be working on it.
> 
> > > -----Original Message-----
> > > From: Lori Napoli [mailto:[email-masked]]
> > > Sent: Monday, October 29, 2001 6:59 PM
> > > To: [email-masked]
> > > Subject: ICMPv6 rate limiting factor
> > > 
> > > 
> > > RFC 2463 states that it is a MUST to limit the rate of ICMPv6
> > > error messages that are sent.  Traceroute is a utility that 
> > > relies on ICMP error messages.  One of the parameters for 
> > > traceroute is the number of probes
> > > that are sent for each hopcount.   RFC 2463 gives an example 
> > > of 1 second as
> > > a conservative default if timer based rate limiting was 
> > > implemented.   If
> > > this is used,  traceroute won't receive a reply for each 
> > > probe if multiple probes are sent for each hopcount since 
> > > some will be supressed due to the rate limiting factor.  What 
> > > are other implementations doing in regard to ICMPv6 rate limits?
> > > 
> > > Thanks
> > > Lori
> > > 
> > > 
> > > 
> --------------------------------------------------------------------
> > > IETF IPng Working Group Mailing List
> > > IPng Home Page:                      
> http://playground.sun.com/ipng
> > > FTP archive:               
>        ftp://playground.sun.com/pub/ipng
> > > Direct all administrative requests to 
> [email-masked]
> > > 
> --------------------------------------------------------------------
> > > 
> > --------------------------------------------------------------------
> > IETF IPng Working Group Mailing List
> > IPng Home Page:                      http://playground.sun.com/ipng
> > FTP archive:                      ftp://playground.sun.com/pub/ipng
> > Direct all administrative requests to [email-masked]
> > --------------------------------------------------------------------
> > 
> 
> -- 
> Pekka Savola                 "Tell me of difficulties surmounted,
> Netcore Oy                   not those you stumble over and fall"
> Systems. Networks. Security.  -- Robert Jordan: A Crown of Swords
> 
> 
> 
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Pekka Savola <[email-masked]>
Date: Tue, 30 Oct 2001 08:46:57 +0200 (EET)

> it not everyone does this?

True.  A quick look at Linux and BSD implementations show that they don't 
rate-limit the sent packets.

It's nice to get a full traceroute of 10 hops <30ms each in less than a 
second :-)

---

From: Jun-ichiro itojun Hagino <[email-masked]>
Date: Tue, 30 Oct 2001 18:05:45 +0900

>rate-limit the sent packets.

	false stetement.  BSD implementations do rate-limit icmp6 messages.

itojun

---

From: Pekka Savola <[email-masked]>
Date: Tue, 30 Oct 2001 12:42:17 +0200 (EET)

> 	false stetement.  BSD implementations do rate-limit icmp6 messages.

I should have phrased that better, perhaps.

The context was: "does traceroute6 limit the rate it sends UDP (/ICMP) 
packets?".

For both Linux and BSD, the answer is "no."  By default, the packets are
sent as fast as traceroute6 gets the responses back, basically.

Sending ICMP6 error messages in reaction to these is different, which are 
indeed rate-limited.

---

From: Bill Sommerfeld <[email-masked]>
Date: Tue, 30 Oct 2001 13:37:52 -0500

> it not everyone does this?

Most of traceroute implementations I've seen are "self clocking",
sending out the next probe when they get back a response to the
previous one.

						- Bill