Subject: ATM,IP, and the Future!------send again with plain text!

From: "Xingang Liang" <[email-masked]>
Date: Thu, 18 Oct 2001 10:36:27 +0800

Permit me to send again with plain text,Sorry!

Hi,my friends!
My questions are as follow:
           Why does the IP technology become the new cosset of God instead of ATM?From the perspective of packet-switching technology,IP and ATM belong to the same category,that is ,they all use the packet (datagram in IP and cell in ATM) to transmit traffic.Besides,IP can not provide the same QoS service as ATM,which use the VCs to provide perfect performance and can reach very high speed.Many business operators have owned a great deal of ATM devices.If we choose the IP,how should we deal with the remaining ATM switch and routers?How should we replace the backbone of Internet,which is equipped with ATM technology?
           I know IP will be the must trend of network development,including Internet and Mobile network(3G),and I know IP can bring a lot of benefits to our lives.But just as we ever claimed that ATM would dominate the whole net world,the same question confronts us that will IP also be the best and dominate the whole world? 
           Perhaps we should take a careful thinking about the necessacity of IP replacing ATM.We should pay more attention to the question "What technology will dominate the network after IP and how should we deal with it?"
           I hope you,my friends,can give some comparision of IP vs ATM---so that we can find the must,and some predicts of the future--so that we can find the best!
          Welcome any comments and say sorry to whom I bothered with my questions!
          Thank you!

BR

Xingang Liang
Standardization Department
Mobile Communication R&D Center
China Academy of Telecommunication Technology(CATT)
No.40,Xueyuan Road
Beijing,China
100083
Tel:+8610 62304422EXT225
Fax:+8610 62303127
Mailto:[email-masked]
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Robert Elz <[email-masked]>
Date: Thu, 18 Oct 2001 12:43:32 +0700

Date:        Thu, 18 Oct 2001 10:36:27 +0800
    From:        "Xingang Liang" <[email-masked]>
    Message-ID:  <[email-masked]>

  | From the perspective of packet-switching technology,IP and ATM belong
  | to the same category,that is ,they all use the packet

This is the mistake in your reasoning.   ATM is more like ethernet, which
both do packets, ...  (or even SONET, or HDLC, or ...).

IP also uses packets (as does UDP, CLNP, ...) they do end to end transmission,
using whatever underlying layer happens to be available (including ATM).

If you wanted to, you could ask why ATM didn't take over the world, and
drive out all the ethernet, and everything else - if it had, then perhaps
(and just perhaps) people could run applications directly over ATM.  But
as long as there are other technologies being used, a protocol that can
run over all of them is required, so those who are connected to ATM can
communicate with those connected to ethernets, and other link layers.

Comparing IP to ATM just makes no sense.

kre

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 18 Oct 2001 08:47:08 +0200

We can say it another way - ATM is a point-to-point technology tied to
specific types of hardware. IP is an end-to-end technology that is
independent of types of hardware. These are simply different roles.
ATM will continue to be used, for example, between IP routers inside
carrier networks. But it is IP that carries data from computer to computer,
running across Ethernet, ATM, modems, and many other hardware layers
on the way. That is why IP (especially IPv6) is the future.

   Brian

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Brian E Carpenter 
Distinguished Engineer, Internet Standards & Technology, IBM 
On assignment at the IBM Zurich Laboratory, Switzerland
Board Chairman, Internet Society http://www.isoc.org

---

From: Greg Daley <[email-masked]>
Date: Thu, 18 Oct 2001 17:05:01 +1000

> on the way. That is why IP (especially IPv6) is the future.

	I think it is important to remember that ATM is a network too,
	like IP, and is not just a link technology.

	Functionally, though, I think that the issue is more one of
	"connection oriented" to "connectionless".  The flexibility of
	the connectionless packet switched network has allowed existing
	media to be used at the link layer.
	
	In many cases, this has allowed IP's uptake where ATM has not
	been able to be deployed.

		Greg Daley

---

From: "Xingang Liang" <[email-masked]>
Date: Thu, 18 Oct 2001 15:34:36 +0800

Ok,Let's look at the problem in another way!
Just as Greg said,the connectionlessness of IP takes a lot of advantages than ATM,which is connection-oriented,I agree with this point!
But when you  compare the flexibility,you should remember whatever network you use,the service that they provide is the most important!
Even though ATM is not as flexible as IP, it can provide a guaranteed QoS,while can IP provide the same QoS?
Perhaps someone will say there are many solutions to strengthen the IP QoS,such as RSVP,Diffserv,and so on.
But implementing these solutions in IP network may be a more complexible thing!
When we send a packet outward,we don't know the path it takes.We don't know whether there are routers that don't support RSVP or Diffserv,
we don't know whether there are ATM switches on the path,we don't know whether there are other types of networks on the way!How should we 
provide the QoS using IP?One way is that we strengthen the network to guarantee every node supports for specific QoS solutions!How about guaranteeing ?
Just like RSVP:before we send the data packet,we first use the RSVP packet to find the right path!The other way is that since we can't guarantee the middle path,we can do something in end applications to guarantee the QoS,for example,we can configure the packet-sending procedure to be finished until we receive reply from the other end node.But whichever way you take,won't you find them more complexible???
Network is stupid,it just provides transportation like service that is simple!we can't demand too much from it!
I don't mean that we should use ATM,not IP.I just want to find out when we design or choose a protocol as a widespread acceptance,what features we should pay attention to and what criterion we should take.ATM,IP and what is the future after IP?
Welcome any comments and say sorry to those whom I bothered with my question!

Xingang 
BR

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 18 Oct 2001 11:33:38 +0200

Greg, in theory I agree that ATM is a network, but in my experience
it is actually used as a point to point technology. The reason for
that is the one you give: connectionless just works better.

  Brian

---

From: Greg Daley <[email-masked]>
Date: Fri, 19 Oct 2001 10:05:24 +1000

> that is the one you give: connectionless just works better.

	Indeed, this illustrates the flexibility of IP.

	ATM will continue to be used by IP as a point to point 
	medium but alternative link layer strategies may in
	future (now??) marginalise this role.

		Greg

---

From: Greg Daley <[email-masked]>
Date: Fri, 19 Oct 2001 10:37:28 +1000

Hi Xingang,

	I'm not really in a position to comment on IP QoS strategies.
	All I can state is that my belief is that QoS relies on 
	2 things:

	* End to end support of QoS within the network.

	* Interoperable standards between vendor equipment.

	You may know that in the past ATM networks suffered because
	of a lack in either of these areas.  I believe though that 
	this was symptomatic of early development of the technology.

	Similarly, providing IP QoS is something which is still evolving.

	This does not prevent subsets of the Internet from developing
	forwarding gurarantees and policies in anticipation of these
	developments, but I believe the IETF's traffic engineering,
	diffserv and mpls working groups are working on such issues now.

		Greg