Subject: Question on draft-ietf-ipngwg-rfc2096-update-00

From: Qing Li <[email-masked]>
Date: Tue, 8 Jan 2002 12:06:40 -0800

The inetCidrRouteTable refers to the node's routing
table, not the forwarding table inside the kernel
(such as FreeBSD), is that correct?

If the router participates in multiple routing domains
then this table should contain routing info from
multiple routing tables, is that so?

   Qing

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Qing Li <[email-masked]>
Date: Tue, 8 Jan 2002 19:01:48 -0800

On 08 Jan 2002, Qing Li wrote:

> >If the router participates in multiple 
> >routing domains then this table should 
> >contain routing info from multiple routing 
> >tables, is that so? 
> 
> If I understand your question, 
> ipCidrRouteTable already shows the origin of a 
> route installed in the FIB, see 
> ipCidrRouteProto. 
> 

My question was incorrectly worded. I meant to 
say if the ipCidrRouteTable represents the RIB 
then does that imply this table is the 
conglomeration of all the RIBs of the participated
routing protocols.

    Qing