Subject: RE: Comments to date on "IPv6 Host to Router Load Sharing"

From: "Michel Py" <[email-masked]>
Date: Mon, 21 Jan 2002 21:02:59 -0800

> Bob Hinden wrote:
> There is considerable current practice that disputes this.  The
> specific case that this draft addresses (host to router traffic)
> is very widely deployed using protocols such as VRRP and Cisco's
> HSRP.  The advantage of distributing the load over multiple
> routers is that it takes advantage of the resources that are
> available and insures that the backup is working when it is
> needed.  Backup systems that are not being used have a nasty 
> habit of not working when they are needed.

As a rule of thumb, I prohibit backup systems that are not in use for
the very reason mentioned above. When running a mission-critical
network, the reasons behind using a load-sharing system is not to save
money. If one is using HSRP, one does buy the hardware that can run a
full load on a single network (and some safety net). The rationale
behind running HSRP routers is NOT to run 50% of the load on two 1/2
size routers, but to make sure that the backup system will kick in real
time whenever one needs it.

I fully concur with Bob here in saying that:

1. Backup systems that are not being used have a nasty habit of not
working when they are needed.

2. Doubling the hardware and have a load-balanced system (that will most
of the time run below 50%) is small potatoes compared to "discovering"
that your backup does not work when your primary fails.

Michel.

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Tue, 29 Jan 2002 16:54:51 +0100

> Is it just the absense of such a knob to the administator 
  > that is lacking?
  > Or is there a need to have a rich set of preferences? (RFC 
  > 1256 has 256
  > different values vs. router preferences has only 3 values).

=> My 2 cents on the preference values:
It's not only that there is only 3 values, but 
that these values may be used across different 
administrative domains (multihomed hosts). They
need to be consistently defined so 'good' in
ISP X domain is roughly the same as 'good'
in ISP Y's domain. How can we do that ?
Maybe some concrete definitions ?

Hesham

---

From: Bob Hinden <[email-masked]>
Date: Wed, 30 Jan 2002 17:25:35 -0800

Hesham,

>Maybe some concrete definitions ?

It's a hard problem.  Routing has exactly the same problem and I don't 
think they ever came up with an automatic way to deal with this.  The best 
that may be possible is to have a manual mapping between domain X and 
domain Y.  This was one of the reasons why there is a separation between 
intra-domain and inter-domain routing.  There wasn't a good way to do an 
automatic mapping between metrics from one domain to another.

Bob

---

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Thu, 31 Jan 2002 11:05:51 +0100

Bob,

  > automatic mapping between metrics from one domain to another.

=> I agree with your analysis and conclusion with one
clarification: Two domains may decide to agree on 
certain mappings as long as they have control 
over the devices that receive this information.
I.e. router_x and router_y. 

However, in this case we have a scenario where 
a 'host' is receiving the equivalent of link
state information from 2 different routers
that happened to be geographically adjacent. 
The 2 different domains may not even be aware
of each others existence, let alone have some 
agreement. This is obviously a wireless case.

I haven't been giving a lot of thought to 
a solution, but I can think of 2 possible
options:

1.Have concrete definition of preferences
  and increase the ranges (from 3 to 100?)
  so that a host can roughly compare between
  two preferences from 2 routers in different
  domains.

2. Specify clearly in the draft that this 
   solution is only useful for a host 
   connected to 2 routers in the same 
   administrative domain. At least in this
   case the host would know whether it 
   should rely on the preference values 
   or ignore them (presumably the host is 
   aware that it's connected to different
   admin domains...somehow)

3. Have some way of showing the host that
   the two domains are in agreement about 
   the meaning of the preferences. 

I'm leaning towards 2 above.
I think it's the easiest way. Anyhow, 
other groups (seamoby) are considering 
capability discovery for routers and I
suspect that there will be many more
parameters to be added. To me, 'preference'
seems to aggregate several parameters
(huge!) without explicityly stating 
them and the weight of each parameter.

Cheers,
Hesham

---

From: Bob Hinden <[email-masked]>
Date: Thu, 31 Jan 2002 19:20:58 -0800

Hesham,

Another approach is add text to make it clear that when there are multiple 
administrative domains involved that the preferences can only be compared 
it they are being set in the same manner.  I don't think there is any 
simple automatic way of doing this (and I think we would want to avoid some 
sort of policy certificates....).

This is probably another reason why only a few preference values are needed.

Bob