Subject: IPv6 Addr/Prefix clarification

From: [email-masked] (Irina Dayal)
Date: Wed, 23 Jan 2002 09:33:08 -0500

I am new here so please excuse the trivial questions. I did trawl the archives but could not find a definitive answer.

1) Is it safe to assume that all IPv6 prefixes will be between 16 and 64 bits long?  The current allocation of IPv6 prefixes seems to require Aggregatable Global Unicast Addresses, which restricts the prefixes to this range.

2) Is it possible for two hosts with the same interface ID (lower 64 bits) to have different prefixes (upper 64 bits) in their addresses?  The v6 standards indicate that the interface ID does not always have global scope, so the answer appears to be yes. 

Thank you for reading...

Irina
-- 

__________________________________________________________________
Your favorite stores, helpful shopping tools and great gift ideas. Experience the convenience of buying online with Shop@Netscape! http://shopnow.netscape.com/

Get your own FREE, personal Netscape Mail account today at http://webmail.netscape.com/

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Keith Moore <[email-masked]>
Date: Wed, 23 Jan 2002 11:02:40 -0500

> 1) Is it safe to assume that all IPv6 prefixes will be between 16 and 64 bits
> long?

no.  because nothing requires a site to use the lower 64 bits as an 
interface ID - a site is free to subnet that space if it wishes.
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Francis Dupont <[email-masked]>
Date: Wed, 23 Jan 2002 16:58:07 +0100

In your previous mail you wrote:

   1) Is it safe to assume that all IPv6 prefixes will be between 16
  and 64 bits long?  The current allocation of IPv6 prefixes seems to
  require Aggregatable Global Unicast Addresses, which restricts the
  prefixes to this range.
   
=> if this seems to be safe today you may *not* assume this will
remain safe in the future, conclusion: this is not safe.

   2) Is it possible for two hosts with the same interface ID (lower
  64 bits) to have different prefixes (upper 64 bits) in their
  addresses?  The v6 standards indicate that the interface ID does not
  always have global scope, so the answer appears to be yes.
   
=> yes, I know at least 10 boxes with the 1 interface ID and near
the same number with 2. But I believe there are hundreds or thousands...
(BTW only a small fraction of them are hosts (i.e. not routers))

Regards

[email-masked]

---

From: "Jim Fleming" <[email-masked]>
Date: Wed, 23 Jan 2002 08:42:59 -0800

From: "Keith Moore" <[email-masked]>
To: "Irina Dayal" <[email-masked]>
Cc: <[email-masked]>
Sent: Wednesday, January 23, 2002 8:02 AM
Subject: Re: IPv6 Addr/Prefix clarification 

> interface ID - a site is free to subnet that space if it wishes.

The right 64 bits are also useful for carrying data. That allows up
to 16 bytes to be carried in the bloated 40 byte header. The length
of the data can be carried in 4 bits of the unused 20-bits in the first word.
This leaves 16 bits for the XOR StarGate value, which is the bit difference
of the StarGate at each end of the IPv4 tunnel. Packets flowing on the
legacy IPv4 Internet do not have the StarGate values of the end-points,
just the bits that differ. When a packet arrives, you know your value so
you and XOR it with the incoming value and derive the value at the
other end.

Jim Fleming
http://www.RepliGate.net