Subject: LIN6 & MIPv6

From: Abdul Basit <[email-masked]>
Date: Fri, 27 Sep 2002 01:06:38 -0500 (CDT)

Hi,

 I was just reading the LIN6 (Location independent networking)
draft ( http://www.lin6.net/draft/draft-teraoka-ipng-lin6-01.txt),
I wonder if LIN6 solves every problem of MIPv6 , then what
are its limitations , i thought of like in LIN6 , if a mobile node's
DNS name resolves in two LIN6 generalized address then what it will pick ?

 I am just curious if in future work will be proceed with LIN6
or MIPv6 ?

- basit

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Masahiro =Rhythm Drive= Ishiyama <[email-masked]>
Date: Sat, 28 Sep 2002 16:54:33 +0900

>>>>> On Fri, 27 Sep 2002 01:06:38 -0500 (CDT), Abdul Basit <[email-masked]> said:

 > DNS name resolves in two LIN6 generalized address then what it will pick ?

	Well, it depends on a resolver the node uses.  Such
	configuration, assigning multiple different LIN6 generalized IDs
	to one FQDN, is usually intended for load-balancing, so I think
	it is not so important issue which one will be picked.

masahiro

---

From: Abdul Basit <[email-masked]>
Date: Sun, 29 Sep 2002 23:03:20 -0500 (CDT)

Hi,

 I was trying to setup up a proxy arp kind of thing for IPv6 host
here is the scenario

interface: eth0 	   interface: tap0
 ------------  via TUN/TAP  -------------
 |ipv6-1    | <-----------> |           | ------> [[[[ internet6]]]]]
 |          |		    | maryo     |
 |----------		    |___________|
ipv6-1 runs                 runs usagi 16sept02
vanilla linux 2.4.19

maryo can ping6 outside ipv6 hosts perfectly.
maryo has following interface(s):
eth0, tap0,ngc-maryo ...

nag-maryo(tunnel mode sit) : assigned 3ffe:8271:a026:feee::1
			     assigned 3ffe:8271:a026:feee::/64 route.
eth0(ethernet)		   : assigned 3ffe:8271:a026:feee::2
tap0(TUN/TAP)		   : assigned 3ffe:8271:a026:feee::3
                             assigned a route of host 3ffe:8271:a026:feee::4

(all these ip addresses can be directly reached by outside perfectly).

Now the ipv6-1 host has following interfaces
eth0 (TUN/TAP actually to tap0) : assigned 3ffe:8271:a026:feee::4
                                  assigned route 3ffe:8271:a026:feee::/64

Now  from the host ipv6-1 i can ping6 3ffe:8271:a026:feee::3 fine
but NOT 3ffe:8271:a026:feee::1 ? i assume , i need to setup some sort of
relay for neighhour discovery messages for 3ffe:8271:a026:feee

i tried ip -6 neigh add proxy 3ffe:8271:a026:feee::4 dev ngc-maryo / eth0
both, but don't seems to work.

Please help.

Thanks
- basit