Subject: Comment on RFC 2485-DHCP Option for The Open Group's User Authentication Protocol

From: "Linda" <[email-masked]>
Date: Sun, 8 Sep 2002 03:30:26 +0800

In reference to RFC 2485, I would like to suggest some alternatives to the things written.
In the last section of User Authentication Protocol Option 

"URL list             A list of one or more URLs separated by the ASCII space character (0x20)."

1. Instead of ASCII space character, we should use square brackets [ ] to determine the next URL in the   sequence. Space character is not encouraged as most webservers today support space in URL.

Other ASCII characters is not suitable for implementation is it might also appear in the URL.

To lessen the burden to the client to single out the URLs, we can encapsulate each URL with square brackets, not replacing it. The url should look something like this :[http://www.yahoo.com][http://www.google.com] 

2. Port identifier includes into the consideration of showing it to the URL. By appending the port number at the end of the URL, eg: [http://www.yahoo.com:80] we can enable the UAP to detemine the port in an easier manner.

Additional comments are welcome.

Linda Lam Hooi
School of Computer Science
USM Penang,
Malaysia

---

From: "Tony Hain" <[email-masked]>
Date: Mon, 9 Sep 2002 15:05:21 -0700

see http://www.ietf.org/rfc/rfc2732.txt

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of Linda
Sent: Saturday, September 07, 2002 12:30 PM
To: [email-masked]
Cc: alan chew; [email-masked]; [email-masked];
[email-masked]; [email-masked]; [email-masked]
Subject: Comment on RFC 2485-DHCP Option for The Open Group's User
Authentication Protocol

In reference to RFC 2485, I would like to suggest some alternatives to
the things written.
In the last section of User Authentication Protocol Option 
"URL list             A list of one or more URLs separated by the ASCII
space character (0x20)."

1. Instead of ASCII space character, we should use square brackets [ ]
to determine the next URL in the   sequence. Space character is not
encouraged as most webservers today support space in URL.
Other ASCII characters is not suitable for implementation is it might
also appear in the URL.
To lessen the burden to the client to single out the URLs, we can
encapsulate each URL with square brackets, not replacing it. The url
should look something like this
:[http://www.yahoo.com][http://www.google.com] 
2. Port identifier includes into the consideration of showing it to the
URL. By appending the port number at the end of the URL, eg:
[http://www.yahoo.com:80] we can enable the UAP to detemine the port in
an easier manner.
Additional comments are welcome.

Linda Lam Hooi

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------