Subject: Re: I-D ACTION:draft-ietf-ipngwg-rfc2553bis-07.txt

From: Jack McCann <[email-masked]>
Date: Fri, 20 Sep 2002 11:35:46 -0400 (EDT)

Changes from 2553bis-06 to 2553bis-07, in response to comments
from IESG review and on mailing list:

  - section 3.3 removed the following sentence:

      The sin6_flowinfo field SHOULD be set to zero by an implementation 
      prior to using the sockaddr_in6 structure by an application on 
      receive operations.

  - section 3.10 fix typos:

      _ss_pad1       ->  __ss_pad1
      _ss_pad2       ->  __ss_pad2
      _ss_align      ->  __ss_align
      _SS_ALIGNMENT  ->  _SS_ALIGNSIZE

  - section 3.10 fix _SS_PAD2SIZE calculation for sockaddr with sa_len

  - section 4.4. delete this sentence:

      Currently net/if.h doesn't have prototype definitions for functions
      and it is recommended that these definitions be defined in net/if.h
      as well as the struct if_nameindex{}.

  - section 5.3 fix this printf

      printf("IPV6_V6ONLY set0);

  - section 6.1 reference inet_pton instead of inet_ntop in this sentence:

      If the specified address family is AF_INET6 or AF_UNSPEC, standard IPv6
      text forms described in inet_ntop() are valid.

  - section 6.1 clarify associated storage freed by freeaddrinfo
    includes storage pointed to by ai_canonname and ai_addr
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: "Bound, Jim" <[email-masked]>
Date: Wed, 25 Sep 2002 11:03:28 -0400

Pekka,

IOCTLs are not portable across many operating system API infrastructures.  the sockets are and those apis.  thats the reason.  that being said check out the appendix of the suggested macros that should exist.

/jim

> -----Original Message-----
> From: Pekka Savola [mailto:[email-masked]]
> Sent: Wednesday, September 25, 2002 9:30 AM
> To: [email-masked]
> Subject: Re: I-D ACTION:draft-ietf-ipngwg-rfc2553bis-07.txt
> 
> 
> On Fri, 20 Sep 2002 [email-masked] wrote:
> > 	Title		: Basic Socket Interface Extensions for IPv6
> [...]
> 
> This is probably a dumb question, but is there must be a 
> reason why these 
> API's don't talk at all about ioctl's etc?  For example, I 
> see no standard 
> way of obtaining (all or some) of one's IPv6 addresses, or 
> whatever else 
> was useful with SIOC*.
> 
> -- 
> Pekka Savola                 "Tell me of difficulties surmounted,
> Netcore Oy                   not those you stumble over and fall"
> Systems. Networks. Security.  -- Robert Jordan: A Crown of Swords
>