Subject: RE: Flow label draft issues & new text

From: [email-masked]
Date: Wed, 11 Sep 2002 11:08:26 +0200

Hi Jarno,

[email-masked] wrote on 11 Sep 2002:
> IP has never promised to not reorder packets. I do not
> think we need to build in any guarantees now either.

It is not a matter of having IP guaranteeing packet
sequence, but rather to keep packet reordering limited
to avoid bothering TCP too much.

I think there is a big difference between IP packets
beeing reordered by (hopefully not too frequent) route
change transcients or being reordered because a load
balancer scatters a flow on different routes on a per
packet basis.

I believe a good IP network should avoid the latter
as much as possible.

Robert

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 11 Sep 2002 15:04:21 +0200

> I believe a good IP network should avoid the latter

We all agree on this, I hope. There is nothing in the flow
label draft that affects reordering or prevents the usage
of the flow label that Margaret described, for hosts that
choose to support that usage. Can we move on? For example
to a WG last call on the flow label draft?

   Brian