Subject: RE: [rfc2462bis] relationship between M/O flags and related protocols

From: "Christian Huitema" <[email-masked]>
Date: Thu, 13 May 2004 09:05:33 -0700

> (In the followings, I'm assuming we have agreed that
> 
>   - we should clearly specify the corresponding protocols for the M/O
>     flags
>   - the protocol for the M flag is DHCPv6 (RFC3315)
>   - the protocol for the O flag is the "stateless" subset of DHCPv6
>     (RFC3736)

From an operational point of view, it makes a lot of sense to use "M" to say that stateful DHCPv6 is available, and "O" to say that the stateless subset is available. This gives a good hint to the host: they should not attempt to use stateful DHCPv6 to obtain addresses or other parameters if the M flag is not set; they may attempt to use stateless DHCPv6 to obtain other parameters if the O flag is set.

Doing otherwise leads to interoperability issues, e.g. a host attempting to use stateful DHCPv6 to obtain a configuration parameter when the local network only supports stateless operation.

-- Christian Huitema

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: JINMEI Tatuya / 神明達哉 <[email-masked]>
Date: Fri, 14 May 2004 15:05:36 +0900

>>>>> On Thu, 13 May 2004 09:05:33 -0700, 
>>>>> "Christian Huitema" <[email-masked]> said:

> Doing otherwise leads to interoperability issues, e.g. a host attempting to use stateful DHCPv6 to obtain a configuration parameter when the local network only supports stateless operation.

Apparently this comment should apply to a separate thread entitled
"the protocol for the O flag".

BTW: do you have any comments on the other parts of my proposal (for
which I'm mainly waiting in this thread)?

Thanks,

					JINMEI, Tatuya
					Communication Platform Lab.
					Corporate R&D Center, Toshiba Corp.
					[email-masked]