Subject: RE: [rfc2462bis] relationship between M/O flags and related protocols

From: "Soliman Hesham" <[email-masked]>
Date: Thu, 13 May 2004 11:46:33 -0400

> > => Stateless is a MUST according to the Node requirements. 
 > Now, if an
 > > implementation
 > > decided to use DHCP when the flags are set, then there are 
 > two cases to
 > > consider:
 > 
 > do you mean the case when the flags are NOT set?  (I talked about the
 > case where the flags are "cleared").

=> Yes, sorry.

 > 
 > And you actually meant "three" cases to consider instead of "two":-)

=> Yes ;)

 > >  a. No DHCP server. This will be discovered pretty soon.
 > >  b. DHCP exists and address is allocated
 > >  c. DHCP exists but since admin doesn't want it to be used 
 > for address
 > > allocation
 > >     it won't allocate an address. 
 > 
 > > All of those cases will render a definite outcome so there 
 > is no need to tell
 > > the 
 > > host what to do in this case. I.e. no interop issues.
 > 
 > Not sure about your intention, but a few additional clarifications:
 > 
 > Detecting non existence of DHCPv6 servers is a quite time-consuming
 > process rather than "pretty soon", at least protocol-wise.  In fact,
 > according to RFC3315, we can never "detect" the non existence since
 > MRC and MRT are both 0 for DHCPv6 solicit and information request
 > messages, which means we should try to find servers forever.
 > 

=> Ok but if a host desicdes to waste time despite the network's
recommendation
to use stateless, what can we do? Clearing the flags clearly suggests the use
of stateless. If a host goes against that then there is no guarantees that
anything
will work.

 > Also, when we are talking about the O flag, we should note that it
 > is not directly relevant to address allocation.

=> Sure, but currently there is no standard alternative to DHCP for the O
flag.

Hesham

 > 
 > 					JINMEI, Tatuya
 > 					Communication Platform Lab.
 > 					Corporate R&D Center, 
 > Toshiba Corp.
 > 					[email-masked]
 > 

========================================================
This email may contain confidential and privileged material for the sole
use of the intended recipient.  Any review or distribution by others is 
strictly prohibited.  If you are not the intended recipient please contact
the sender and delete all copies.
========================================================

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: "Christian Huitema" <[email-masked]>
Date: Mon, 17 May 2004 11:00:11 -0700

> >> Explicit support or objections are highly appreciated.  If the list is
> >> still silent, I'll start revising the document anyway.
> > I support all of your proposed changes.
> 
> Same here.

Me too

-- Christian Huitema

---

From: "Bound, Jim" <[email-masked]>
Date: Fri, 21 May 2004 23:05:44 -0400

Me too and Christian H's use of "may" update.
/jim 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Ralph Droms
> Sent: Friday, May 21, 2004 1:10 PM
> To: JINMEI Tatuya / 神明達哉
> Cc: Erik Nordmark; Christian Huitema; [email-masked]
> Subject: Re: [rfc2462bis] relationship between M/O flags and 
> related protocols
> 
> This text is fine with me, too.
> 
> - Ralph
> 
> At 09:43 AM 5/21/2004 -0700, Erik Nordmark wrote:
> > > Or, if you feel happier by mentioning changes of the M bit 
> > > explicitly, we could alternatively say
> > >
> > >      The details of how a host uses the M flag, including 
> any use of
> > >      the "on" and "off" transitions for this flag, to 
> control the use
> > >      of DHCPv6 for address assignment will be described 
> in a separate
> > >      document.
> > > (based on a previous text from Ralph)
> > >
> > > This way, we can avoid the use of the "possibly extraneous state 
> > > variable" which is internal information in the 
> implementation, while 
> > > keeping the essential idea about external behavior.
> >
> >The text above is fine with me.
> >
> >   Erik
> 
> 
LR��(�H��
躙��X��X��*o�'�~��٢�+-��b��^�笶�m��?�0�'�~���f��f��X��)ߣ���

---

From: "Bound, Jim" <[email-masked]>
Date: Fri, 21 May 2004 23:42:52 -0400

OK.  I agree too.
thanks
/jim 

> From: Erik Nordmark [mailto:[email-masked]] 
> Sent: Thursday, May 20, 2004 1:32 PM
> To: Bound, Jim
> Cc: Erik Nordmark; Christian Huitema; Ralph Droms; JINMEI 
> Tatuya / 神明達哉; [email-masked]
> Subject: RE: [rfc2462bis] relationship between M/O flags and 
> related protocols
> 
> > Just checking.  We do need the M bit for those wanting to use 
> > stateful?  Or do you not agree?
> 
> I agree with the Jinmei's definition that the M bit indicates 
> to the host that DHCPv6 for IP address configuration is 
> available on the link.
> 
> With that definition it is possible to build hosts that 
> initialize efficiently, by only trying to use DHCPv6 when the 
> router advertisements say that it is available.
> 
>    Erik
> 
> 
> 
 D� ���x �������x%��b���z���)��ڶ+�E�z�l��i����
bz���j)fj��b��?���