Subject: RE: I-D ACTION:draft-ietf-ipv6-rfc2462bis-05.txt

From: "Elwyn Davies" <[email-masked]>
Date: Wed, 18 Aug 2004 17:43:39 +0100

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] 
> Sent: 18 August 2004 17:20
> To: Davies, Elwyn [HAL02:0S00:EXCH]
> Cc: [email-masked]'
> Subject: Re: I-D ACTION:draft-ietf-ipv6-rfc2462bis-05.txt
> 
> 
> >>>>> On Wed, 18 Aug 2004 17:09:37 +0100, 
> >>>>> "Elwyn Davies" <[email-masked]> said:
> 
> > The problem is the use of the term 'global' - address 
> auto-configuration
> > will in principle work for any sort of address prefix if I 
> understand
> > correctly.
> 
> > One could use something like 'additional addresses' and 
> then give global
> > unicast addresses as an example.  This would make it clear 
> that auto-config
> > can be used for any sort of address/address prefix beyond 
> link local.
> 
> I'm afraid the phrase of "additional addresses" is a little bit vague.
> If we need a compromise, perhaps we could add something to the
> definition of "global address" in Section 2 such as:
> 
>    global address - an address with unlimited scope.  From stateless
>        address autoconfiguration's perspective, it essentially means
>        an address that has larger scope than link-local.

That would help - but then 'unlimited' and 'larger scope than link-local'
are potentially contradictory (if unique local use actually happens - and
multicast has lots of scopes in theory).  
Could we use:
    non-local address - an address which has a larger scope than link-local.

> 
> 					JINMEI, Tatuya
> 					Communication Platform Lab.
> 					Corporate R&D Center, 
> Toshiba Corp.
> 					[email-masked]
> 
--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: JINMEI Tatuya / 神明達哉<[email-masked]>
Date: Thu, 19 Aug 2004 17:25:32 +0900

>>>>> On Wed, 18 Aug 2004 17:43:39 +0100, 

>     non-local address - an address which has a larger scope than link-local.

And are you suggesting replace "global address" with "non-local
address" throughout the text?

					JINMEI, Tatuya
					Communication Platform Lab.
					Corporate R&D Center, Toshiba Corp.
					[email-masked]