Subject: RE: I-D ACTION:draft-ietf-ipv6-rfc2462bis-05.txt

From: "Elwyn Davies" <[email-masked]>
Date: Fri, 20 Aug 2004 10:22:17 +0100

Yes - there are 9 instances in the body and 1 in the abstract and non-local
would be right for all these places I believe.

Regards,
Elwyn

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] 
> Sent: 19 August 2004 09:26
> To: Davies, Elwyn [HAL02:0S00:EXCH]
> Cc: [email-masked]'
> Subject: Re: I-D ACTION:draft-ietf-ipv6-rfc2462bis-05.txt
> 
> 
> >>>>> On Wed, 18 Aug 2004 17:43:39 +0100, 
> >>>>> "Elwyn Davies" <[email-masked]> said:
> 
> >> global address - an address with unlimited scope.  From stateless
> >> address autoconfiguration's perspective, it essentially means
> >> an address that has larger scope than link-local.
> 
> > That would help - but then 'unlimited' and 'larger scope 
> than link-local'
> > are potentially contradictory (if unique local use actually 
> happens - and
> > multicast has lots of scopes in theory).  
> 
> > Could we use:
> >     non-local address - an address which has a larger scope 
> than link-local.
> 
> And are you suggesting replace "global address" with "non-local
> address" throughout the text?
> 
> 					JINMEI, Tatuya
> 					Communication Platform Lab.
> 					Corporate R&D Center, 
> Toshiba Corp.
> 					[email-masked]
> 
--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: JINMEI Tatuya / 神明達哉<[email-masked]>
Date: Fri, 20 Aug 2004 23:50:51 +0900

>>>>> On Fri, 20 Aug 2004 10:22:17 +0100, 

> would be right for all these places I believe.

Hmm, the changes are not small and could make the resulting text a bit
vague, but this time I tend to agree on the change.

This way we can (potentially) prepare for the new local address
without making an unstable reference, and the description won't be
false even if the new local address fails to be standardized.

Does anyone disagree with this change?

					JINMEI, Tatuya
					Communication Platform Lab.
					Corporate R&D Center, Toshiba Corp.
					[email-masked]

p.s. I reopened issue #267 for rfc2462bis at the issue tracker for the
record.

---

From: JINMEI Tatuya / 神明達哉<[email-masked]>
Date: Sat, 21 Aug 2004 20:12:02 +0900

>>>>> On Fri, 20 Aug 2004 23:50:51 +0900, 
>>>>> JINMEI Tatuya <[email-masked]> said:

> vague, but this time I tend to agree on the change.

On the second thought, I suspect "non-local" is still confusing...even
though we are going to define the term as "an address which has a
larger scope than link-local," one might wonder if it includes
"unique local addresses" (when standardized) in the body of the
document.

I can think of two alternatives:

1. "non-link-local addresses".  This is perhaps verbose, but the
   meaning will be clearer.  But one may still wonder if those include
   the unspecified address, etc.
2. "large-scope addresses".  On one hand, this is perhaps more vague
   than "non-link-local".  But on the other, it will clearly exclude
   the unspecified address.

Are either or both alternatives better?  Or can we simply use
"non-local"?  Or are there any other options?

					JINMEI, Tatuya

---

From: Vladislav Yasevich <[email-masked]>
Date: Mon, 23 Aug 2004 14:58:06 -0400

Jinmei

Upon re-reading the ULA spec, I noticed that ULAs are actually
of 'global' scope, so original wording is OK.  Since 2464bis
applies to global scope addresses, we are set.

-vlad

-- 
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Vladislav Yasevich		Linux and Open Source Lab
Hewlett Packard 		Tel: (603) 884-1079
Nashua, NH 03062		ZKO3-3/T07

---

From: JINMEI Tatuya / 神明達哉<[email-masked]>
Date: Tue, 24 Aug 2004 21:25:10 +0900

>>>>> On Mon, 23 Aug 2004 14:58:06 -0400, 
>>>>> Vladislav Yasevich <[email-masked]> said:

> applies to global scope addresses, we are set.

Ah, good point, thanks.

While I understand the concern that future readers might wonder
whether the "global" includes ULA, I agree that we can move forward
with the current text, at leat at the moment.

					JINMEI, Tatuya