Subject: WEB Browsing with IPv6

From: "Takeo Shibata" <[email-masked]>
Date: Wed, 4 Aug 2004 23:05:32 -0700

Hi I am trying to connect WEB Server via IPv6

There are 2 machines I configured.
These two are connected via HUb so I am trying to 
connect by Link Local Address starting with fe80::

PC1:
WindowXP Professional + IIS + IE6.0

PC2:
Linux Fedora + Apache + Mozilla

PC3:
Win2003 + IIS

>From PC1 to PC2
I can sucsessfully ping6 (ping6 fe80::xx:xx:xx:xx%ITF)
>From PC2 to PC1
I can sucsessfully ping6 (ping6 -I eth0 fe80::yy:yy:yy:yy)

>From IIS on PC1, I cannnot see the WEB page by IE6.0.
I can see it useing IPv4.
By telneting like
telnet fe80::xx:xx:xx:xx%ITF
then I input 
GET / HTTP/1.1
........

I get the response i n HTML string.

>From PC2 to PC1, I cannnot use telnet with IPv6
I do not know what command should to use for IPv6 for Linux Fedora
and I would like to know which Brawser&OS combination can see the contents

>From PC1 to PC3,
I cannot connect to the port 80n with IPv6.
(Apache can accept the IPv6 and IIS on Win2003 not)

According to the Document, Window2000 accept URL like http://[IPv6]
But for Window2003, WIndowXP cannot do this.

>From PC2 to PC1
I edit the HOSTS file and try to connect.
But I cannnot.

Could somebody give me tips?

Thank you 

Tak

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: JINMEI Tatuya / 神明達哉<[email-masked]>
Date: Tue, 10 Aug 2004 22:01:40 +0900

>>>>> On Wed, 4 Aug 2004 23:05:32 -0700, 
>>>>> "Takeo Shibata" <[email-masked]> said:

> Could somebody give me tips?

(I must apologize in advance that this is not really a direct tip, but
there seems to have been no other response, so...)

First, most of the issues are implementation specific, for which
[email-masked] is not very appropriate place to discuss.  Perhaps
[email-masked] is a better place (though it's not very active).

Secondly, if you are not very much familiar with IPv6, I'd recommend
not to begin with link-local addresses for end-user applications like
web.  Just assign global addresses and play with them.

					JINMEI, Tatuya
					Communication Platform Lab.
					Corporate R&D Center, Toshiba Corp.
					[email-masked]