Subject: RE: SHOULD or MAY for invoking DHCP services using M/O flags

From: [email-masked]
Date: Sun, 22 Aug 2004 08:13:08 +0300

> I disagree with this wording.  In particular, the Solicit/...
> exchange is *not* limites to address configuration.  The
> Information-Request/Reply message exchange is not
> "Stateful DHCPv6".  "the DHCPv6 Server" might be misleading
> as there can be more than one DHCPv6 server.
> 
> I don't think the purpose of the exchanges need to be
> mentioned.  I think the following would suffice:
> 
> M = ON means configuration information is available from a DHCPv6 service
> through Solicit/Advertise/Request/Reply or Solicit/Reply (if Rapid Commit is
> enabled) message exchanges.
> 
> O = ON means configuration information is available from a DHCPv6 service
> through Information-request /Reply message exchanges.

I tend to side with Ralph's text.

John

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: "Bound, Jim" <[email-masked]>
Date: Sun, 22 Aug 2004 02:25:06 -0400

I like Ralph's text also.
/jim 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of [email-masked]
> Sent: Sunday, August 22, 2004 1:13 AM
> To: [email-masked]; [email-masked]
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: RE: SHOULD or MAY for invoking DHCP services using M/O flags
> 
> 
> > Information-Request/Reply message exchange is not "Stateful 
> DHCPv6".  
> > "the DHCPv6 Server" might be misleading as there can be 
> more than one 
> > DHCPv6 server.
> > 
> > I don't think the purpose of the exchanges need to be mentioned.  I 
> > think the following would suffice:
> > 
> > M = ON means configuration information is available from a DHCPv6 
> > service through Solicit/Advertise/Request/Reply or 
> Solicit/Reply (if 
> > Rapid Commit is
> > O = ON means configuration information is available from a DHCPv6 
> > service through Information-request /Reply message exchanges.
>

---

From: "Bound, Jim" <[email-masked]>
Date: Sun, 22 Aug 2004 02:29:02 -0400

I believe Brian's suggestion is congruent with Ralphs text also.
/jim 

> Behalf Of Brian Haberman
> Sent: Friday, August 20, 2004 11:06 AM
> To: Tim Chown
> Cc: [email-masked]
> Subject: Re: SHOULD or MAY for invoking DHCP services using M/O flags
> 
> Tim Chown wrote:
> 
> > On Fri, Aug 20, 2004 at 10:34:39AM +0300, 
> [email-masked] wrote:
> > 
> >>Following the discussions, it isn't entirely clear to me 
> why we could 
> >>need to open this issue.  I think that there is concensus 
> for keeping 
> >>it as is (as described in Christian's mail).
> >>
> >>Am I missing something?
> > 
> > 
> > My impression is that the discussion stems from the newly reached 
> > consensus (since the original semantics were defined in 
> 2462) that M=1 
> > implies that
> > RFC3315 functionality is available and O=1 implies that RFC3736 
> > functionality is available.  With RFC3736 being a subset of 
> RFC3315, 
> > it is thus on first glance "odd" that you can have M=1, 
> O=0, when M=1 
> > implies RFC3736 support is there, as a subset of RFC3315.
> 
> I would like to see the wording reflect the concept that M=1 
> indicates that DHCPv6 Solicit, Advertise, Request, and 
> Response are available and O=1 indicates that Info-Request 
> and Info-Response are available.  That way, the flags are not 
> tied to an RFC but rather to a functionality offered by the 
> administrative authority.
> 
> Regards,
> Brian
>