Subject: draft rfc2461-bis - state diagram Neighbor Cache

From: Grubmair Peter <[email-masked]>
Date: Wed, 25 Aug 2004 19:16:21 +0200

In the state diagram in RFC2461-bis 
in Appendic C, page 79, the event of receiving
a NA with solicitated = 1 and Override = 0
in state DELAY is not handled.
To my understanding the same treatment as in 
state STALE or PROBE has to be applied.
To me it also seems, that the state DELAY can
be treated to equal to PROBE, only the start of timer in
state STALE has to use another timing value as
starting the timer uppon timeout in PROBE state.
In my model entering the PROBE state does not 
send NS, but only starts the delay timer.
This can be done without changing behavior, maybe 
state DELAY should be dropped.
Best regards
   Peter

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: "Soliman Hesham" <[email-masked]>
Date: Wed, 25 Aug 2004 14:36:44 -0400

> state DELAY should be dropped.

=> Thanks for the comment. It's probably an unnecessary
change to make at this stage (i.e. removing DELAY). 
At the same time, you're only required to present
the required behaviour to outside nodes, so you you're
not required to name your variables/states as described
in 2461/bis. 
The state diagrams were not changed from 2461 so 
I'll look into the state diagram in the Appendix and 
see what can be done. I'll register this as an issue. 

Hesham

 >    Peter

===========================================================
This email may contain confidential and privileged material for the sole use
 of the intended recipient.  Any review or distribution by others is strictly
 prohibited.  If you are not the intended recipient please contact the sender
 and delete all copies.
===========================================================