Subject: RE: I-D ACTION:draft-ietf-ipv6-rfc2462bis-05.txt

From: "Elwyn Davies" <[email-masked]>
Date: Wed, 18 Aug 2004 17:09:37 +0100

The problem is the use of the term 'global' - address auto-configuration
will in principle work for any sort of address prefix if I understand
correctly.

One could use something like 'additional addresses' and then give global
unicast addresses as an example.  This would make it clear that auto-config
can be used for any sort of address/address prefix beyond link local.

Regards,
Elwyn

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] 
> Sent: 18 August 2004 16:33
> To: Davies, Elwyn [HAL02:0S00:EXCH]
> Cc: [email-masked]'
> Subject: Re: I-D ACTION:draft-ietf-ipv6-rfc2462bis-05.txt
> 
> 
> >>>>> On Wed, 18 Aug 2004 15:57:00 +0100, 
> >>>>> "Elwyn Davies" <[email-masked]> said:
> 
> >> First, let's just forget "local use" addresses here 
> (whatever you mean
> >> by this).  Those are not in the scope of rfc2462bis.
> 
> > I was thinking of the new unique local use addresses (as per
> > draft-ietf-ipv6-unique-local-addr-05.txt).
> 
> Yes, I know.
> 
> > There seems no reason why these sorts of prefixes shouldn't be
> > auto-configured.
> 
> If we did that, we'd encounter a document dependency issue:
> considering the fact RFC3513 (address architecture) is a normative
> reference (which I think is reasonable), we'd also need to refer to
> the unique-local-addr document as a normative reference, which does
> even not yet become an RFC and is actually causing a discussion.
> 
> I don't think it wise to make a dependency on such a (still) stale
> document, particularly because we are trying to recycle rfc2462bis as
> a draft standard.
> 
> If we (some day) succeed to complete the unique-local-addr
> specification, we can simply say there that "stateful address
> autoconfiguration can be performed for the unique-local address just
> like global addresses".
> 
> 					JINMEI, Tatuya
> 					Communication Platform Lab.
> 					Corporate R&D Center, 
> Toshiba Corp.
> 					[email-masked]
> 
--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: JINMEI Tatuya / 神明達哉<[email-masked]>
Date: Thu, 19 Aug 2004 01:20:15 +0900

>>>>> On Wed, 18 Aug 2004 17:09:37 +0100, 

> can be used for any sort of address/address prefix beyond link local.

I'm afraid the phrase of "additional addresses" is a little bit vague.
If we need a compromise, perhaps we could add something to the
definition of "global address" in Section 2 such as:

   global address - an address with unlimited scope.  From stateless
       address autoconfiguration's perspective, it essentially means
       an address that has larger scope than link-local.

					JINMEI, Tatuya
					Communication Platform Lab.
					Corporate R&D Center, Toshiba Corp.
					[email-masked]