Subject: Re: RE: Ping6 Problem with link local address

From: Takeo Shibata <[email-masked]>
Date: Tue, 03 Aug 2004 18:38:16 -0700

Hi Christina

Thank you for your great advise.
It works!

BTW, I just configured the IPv6 on my Linux PC.
It shows fe80::xxxxx/64
So it says that scope is /64 instead of
%1, or %2 ...

And from Linux, I successfullty ping6 to Win2003 and
WinXP.
This may sound basic, but could you tell me how to ping6 to
the local-link ipv6 with scope representation /64?
(Other word, how can I translate /64 to % format?)

Thank you.

Tak

----- Original Message -----
From: Christian Huitema <[email-masked]>
Date: Tuesday, August 3, 2004 4:45 pm
Subject: RE: Ping6 Problem with link local address

> You need to specify the scope identifier in addition to the link 
> local address. The "ipconfig" command will document addresses in 
> the format:
> 
> IP Address. . . . . . . . . . . . : fe80::204:23ff:fe4a:f8c7%7
> 
> The indicator "%7" is the scope identifier of your link (your 
> system may use a different value). You should then use this in the 
> ping command, as in:
> 
> ping fe80::xxxxx%7
> 
> -- Christian Huitema
> 
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of
> > Takeo Shibata
> > Sent: Tuesday, August 03, 2004 4:17 PM
> 

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: Wang Xin 王 昕 <[email-masked]>
Date: Wed, 4 Aug 2004 10:11:29 +0800

Hi Takeo Shibata,

    As we know an IPv6 node can have many interfaces and many IPv6 address at the same time.

   The ping6 command though Windows XP, "ping fe80::xxxxx%7" , %7 means interface index
   
   So  as the same way in linux, the Ping6 command should be " ping6 -I eth0 fe80::xxxxxx ", try this one to touch your neighbor. good luck!

Best Regards
 
    Wang Xin  王 昕
 
R & D Engineer
BUPT-BII NGN R&D Center
BII Group
Tel :  +86-10-62283000
Mobile :   +86 13911230391
Email :    [email-masked]

---

From: Suresh Krishnan <[email-masked]>
Date: Tue, 3 Aug 2004 22:08:55 -0400 (EDT)

Hi Takeo,
  You can do one of the following on linux

you can do 

ping6 -I <interface_name> destn
(or) 
ping6 destn%<interface_name>

For Example:
ping6 -i eth0 fe80::xxxx (or) ping6 fe80::xxxx%eth0

assuming the interface you are using is eth0.

Cheers
Suresh

---

From: Felipe Alfaro Solana <[email-masked]>
Date: Mon, 09 Aug 2004 20:31:03 +0200

> (Other word, how can I translate /64 to % format?)

AFAIK, Linux doesn't support *BSD %n syntax for interfaces. Instead, use
the following format:

ping6 -I <interface_name> <local_link_address>

For example:

ping6 -I eth0 fe80:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX