Subject: Ping6 Problem with link local address

From: Takeo Shibata <[email-masked]>
Date: Tue, 03 Aug 2004 16:16:35 -0700

Hi, I try to implement the simple ipv6 intranet
among the pcs within the same network.
So I use the link local address starting with fe80::

The environment is the following
PC1 - WinXP SP1 
PC2 - Win2003Server with Port Filtering(TCP) 

Symptom
Both PC can ping6 to itself.
But when those pc try to ping6 to the other pc.
It is rejected.
All the other PCs including router does not accept IPv6.
But those pcs are connected via a HUB.

When I try to ping6 to other the following error
ping6 fe80::xxxxx NG 
ping6 -s fe80::xpxxxx fe80::2003xxxx 

Parameter problem. 
Specify correct scope-id or use -s to�@specify source address

Could somebody give me tips,
Thank you

Tak

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: "Christian Huitema" <[email-masked]>
Date: Tue, 3 Aug 2004 16:45:43 -0700

You need to specify the scope identifier in addition to the link local address. The "ipconfig" command will document addresses in the format:

IP Address. . . . . . . . . . . . : fe80::204:23ff:fe4a:f8c7%7

The indicator "%7" is the scope identifier of your link (your system may use a different value). You should then use this in the ping command, as in:

ping fe80::xxxxx%7

-- Christian Huitema

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Takeo Shibata
> Sent: Tuesday, August 03, 2004 4:17 PM
> To: [email-masked]
> Subject: Ping6 Problem with link local address
> 
> Specify correct scope-id or use -s to@specify source address
>

---

From: "Takeo Shibata" <[email-masked]>
Date: Tue, 3 Aug 2004 22:35:15 -0700

Hi ALL

Thank you very much for HELP.
I understand that
For Windows, the interface name specified by %IFNAME
For Linux, it is specified followed by -I option.

But thank you for your helps.!

Tak