Subject: (no subject)

From: [email-masked]
Date: Tue, 03 Jan 2006 22:14:18 -0600 (CST)

Hi John, please see my comments in-line:

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of John
Spence
Sent: Monday, January 02, 2006 12:23 PM
To: [email-masked]
Subject: Are privacy extensions, RFC 3041,defined for non global-scope
addresses?

I re-read the document, and it certainly focuses on the privacy
needs of global-scope addresses.  I did not find a place where it
said it was not defined for ULA or link-local scope addresses.

-> AFAICS, RFC 3041 deals only with global-scope addresses. The stated goals (2-4) explicitly refer to global-scope addresses.

Is that the intent - not defined for non global-scope addresses?
Or I am reading that into it?

-> I think it's reasonable to conclude the mechanism defined in RFC 3041 is not defined for non global-scope addressses. ULAs to my knowledge didn't exist at the time 3041 was written (RFC 3041 in January 2001, RFC 4193 not until October 2005). Even though there is an extant draft meant to update 3041 [draft-ietf-ipv6-privacy-addrs-v2-04.txt], it has yet to become an RFC itself.

-> If by some stretch RFC 3041 was meant for link-local scope addresses, it seems that would be suboptimal. At least as often as the temp link-local unicast address changed, the node would have to (un)subscribe to the corresponding solicited-node multicast group(s). That could lead to reduced performance. I'd also wonder about the affect temporary link-local addresses would have on a router's neighbor cache, and/or any connectivity dependent upon the accuracy of cache entries... How might this affect ND itself (not a leading question BTW)?

Thanks.

-> Best regards,

Tim Enos
1Sam16:7

----------------------------------------------------
John Spence, CCSI, CCNA, CISSP
Native6, Inc.
IPv6 Training and Consulting
[email-masked]
----------------------------------------------------

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: "Christian Huitema" <[email-masked]>
Date: Wed, 4 Jan 2006 00:19:43 -0800

Hosts are not supposed to make any distinction between ULA and global
scope addresses. Hosts autoconfigure ULA addresses if the RA advertises
and ULA prefix. Thus, hosts that are programmed to generate RFC 3041
addresses for global scope addresses will do the same for ULA.

> From: [email-masked] [mailto:[email-masked]] On Behalf
Of
> [email-masked]
> Sent: Tuesday, January 03, 2006 8:14 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: (no subject)
> 
> From: [email-masked] [mailto:[email-masked]] On Behalf
Of
> John
> -> AFAICS, RFC 3041 deals only with global-scope addresses. The stated
> goals (2-4) explicitly refer to global-scope addresses.
> 
> -> I think it's reasonable to conclude the mechanism defined in RFC
3041
> is not defined for non global-scope addressses. ULAs to my knowledge
> didn't exist at the time 3041 was written (RFC 3041 in January 2001,
RFC
> 4193 not until October 2005). Even though there is an extant draft
meant
> to update 3041 [draft-ietf-ipv6-privacy-addrs-v2-04.txt], it has yet
to
> become an RFC itself.
> 
> -> If by some stretch RFC 3041 was meant for link-local scope
addresses,
> it seems that would be suboptimal. At least as often as the temp link-
> local unicast address changed, the node would have to (un)subscribe to
the
> corresponding solicited-node multicast group(s). That could lead to
> reduced performance. I'd also wonder about the affect temporary
link-local
> addresses would have on a router's neighbor cache, and/or any
connectivity
> dependent upon the accuracy of cache entries... How might this affect
ND
> itself (not a leading question BTW)?
> 
> Thanks.
> 
> -> Best regards,
> 
> Tim Enos
> 1Sam16:7
>