Subject: RE: Checksum in IPv6 header

From: Alex Conta <[email-masked]>
Date: Fri, 01 Feb 2008 08:09:02 -0500

I am not seeing the problem. 
 
The "non-secure IPv6 link" you're mentioning is a "virtual link", over a
"real" physical link. The "real" physical link, the "real" L2, provides
the error detection, which uncovers packet errors in the IPv6 tunnel
packets, like on any other IPv6 packet.

-----Original Message-----
From: Manfredi, Albert E [mailto:[email-masked]] 
Sent: Thursday, January 31, 2008 3:09 PM
To: Alex Conta
Cc: [email-masked]
Subject: RE: Checksum in IPv6 header
 [....] 

  _____  

From: Alex Conta [mailto:[email-masked]] 
Sent: Thursday, January 31, 2008 12:50 PM
To: 'Rahim Choudhary'; Templin, Fred L; 'Fred Baker'
Cc: [email-masked]
Subject: RE: Checksum in IPv6 header

The reason is IPsec tunnels, where encrypted packets are tunneled
through a non-secure IPv6 link. In such cases, you can't count on L2
checksums when going across the tunnel boundaries. Or did I miss part of
that recent thread?
 
Bert

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: http://www.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: "Manfredi, Albert E" <[email-masked]>
Date: Fri, 1 Feb 2008 15:36:08 -0500

But there's no reason to believe that the L2 is the same as you enter
the tunnel. You're going through a router, often to a different link
layer. The L2 overhead is stripped off and replaced.
 
Bert

________________________________

	From: Alex Conta [mailto:[email-masked]] 
	Sent: Friday, February 01, 2008 8:09 AM
	To: Manfredi, Albert E
	Cc: [email-masked]
	Subject: RE: Checksum in IPv6 header

	The "non-secure IPv6 link" you're mentioning is a "virtual
link", over a "real" physical link. The "real" physical link, the "real"
L2, provides the error detection, which uncovers packet errors in the
IPv6 tunnel packets, like on any other IPv6 packet.

		-----Original Message-----
		From: Manfredi, Albert E
[mailto:[email-masked]] 
		Sent: Thursday, January 31, 2008 3:09 PM
		To: Alex Conta
		Cc: [email-masked]
		Subject: RE: Checksum in IPv6 header
		 [....] 

________________________________

			From: Alex Conta [mailto:[email-masked]] 
			Sent: Thursday, January 31, 2008 12:50 PM
			To: 'Rahim Choudhary'; Templin, Fred L; 'Fred
Baker'
			Cc: [email-masked]
			Subject: RE: Checksum in IPv6 header

		The reason is IPsec tunnels, where encrypted packets are
tunneled through a non-secure IPv6 link. In such cases, you can't count
on L2 checksums when going across the tunnel boundaries. Or did I miss
part of that recent thread?
		 
		Bert

---

From: Alex Conta <[email-masked]>
Date: Wed, 06 Feb 2008 21:50:10 -0500

Yes, the L2 header is replaced at the end of each L2 segment/hop. The L2
error detection will do the job - discard and report erroneous packet -
on each L2 segment/hop. 
One or more L2 segments/hops may correspond to one IP hop, so a packet
error detection and discard on any of the L2 segments/hops will be
equivalent to the IP hop error detection and discard. 
 
Alex 
 
 -----Original Message-----
From: Manfredi, Albert E [mailto:[email-masked]] 
Sent: Friday, February 01, 2008 3:36 PM
To: Alex Conta
Cc: [email-masked]
Subject: RE: Checksum in IPv6 header

Bert

  _____  

 

-----Original Message-----
From: Manfredi, Albert E [mailto:[email-masked]] 
Sent: Thursday, January 31, 2008 3:09 PM
To: Alex Conta
Cc: [email-masked]
Subject: RE: Checksum in IPv6 header
 [....] 

  _____  

 
Bert