Subject: [Ipoverib] IPoIB link address

From: Vandana Rao <[email-masked]>
Date: Mon, 22 Sep 2003 14:31:13 -0700

Hi,

In the IP encapsulation draft , section 6.1.2, it is indicated that the 
Q_Key used should be that of the
broadcast-GID. Which broadcast GID should be used? Specifically, if the
IPv4 and IPv6 broadcast GIDs are assigned different Q_keys, which Q_Key
should be used?

The issue with potentially allowing different Q_Key values for the 2 GIDs 
is that 2 separate QPs will have to
be allocated for IPv4 and IPv6 traffic respectively and will require the 
IPoIB driver to keep track of upper layer protocols.
If everyone agrees that this is a problem, there are 2 ways to address the 
issue:
1) Require the 2 broadcast GIDs to have the same attributes such as Q_key, 
MTU etc.
or
2) Create a single broadcast GID to define the link.

-Vandana

_______________________________________________
IPoverIB mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipoverib

---

From: "bill" <[email-masked]>
Date: Mon, 22 Sep 2003 16:04:31 -0700

Vandana,

This issue has been discussed in private amongst the authors for a few
days now.  Any chance I can get an opinion from you on your preferences
between 1/2 (and why).  I'd like to get this nailed soon so we can
FINALLY get some forward progress on standards

Bill

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Vandana Rao
Sent: Monday, September 22, 2003 2:31 PM
To: [email-masked]
Subject: [Ipoverib] IPoIB link address

Hi,

The issue with potentially allowing different Q_Key values for the 2
GIDs 
is that 2 separate QPs will have to
be allocated for IPv4 and IPv6 traffic respectively and will require the

IPoIB driver to keep track of upper layer protocols.
If everyone agrees that this is a problem, there are 2 ways to address
the 
issue:
1) Require the 2 broadcast GIDs to have the same attributes such as
Q_key, 
MTU etc.
or
2) Create a single broadcast GID to define the link.

-Vandana

_______________________________________________
IPoverIB mailing list
[email-masked] https://www1.ietf.org/mailman/listinfo/ipoverib