Subject: Re: [IPP] Registration request for attributes from "Wi-Fi Peer-to-Peer Services Print (P2Ps-Print) Technical Specification v1.1" for PCLm

From: "Kennedy, Smith (Wireless & Standards Architect)" <[email-masked]>
Date: Thu, 6 Sep 2018 16:57:23 +0000

Hi Mike,

Answers to your questions below. If we are good with my resolutions, I will resend the request in an approvable state.

Smith

> On Aug 28, 2018, at 4:46 PM, Michael Sweet <[email-masked]> wrote:
> 
> Smith,
> 
> > On Aug 28, 2018, at 3:20 PM, Kennedy, Smith (Wireless & Standards Architect) <[email-masked]> wrote:
> > 
> > Greetings,
> > 
> > HP Inc. requests the registration of 5 IPP attributes defined in the "Wi-Fi Peer-to-Peer Services Print (P2Ps-Print) Technical Specification v1.1" relating to the PCLm document format definition therein. The "Wi-Fi Peer-to-Peer Services Print (P2Ps-Print) Technical Specification v1.1" is one of the files in the "Wi-Fi Peer-to-Peer Services Technical Specification Package v1.2" available here: https://www.wi-fi.org/file/wi-fi-peer-to-peer-services-technical-specification-package-v12
> > 
> > These are the attributes to be registered with accompanying section numbers from the source specification where they were defined:
> > 
> > Job Template Attributes:
> > ---------------------------------
> > 
> > 3.12.4 pclm-raster-back-side (keyword)
> > This Job Template attribute specifies the bitmap coordinate system for
> > the back side of duplex sheets and the following keyword values are
> > defined:
> > 
> > +---------+------------------+-------------------+
> > | KEYWORD | LONG EDGE ORIGIN | SHORT EDGE ORIGIN |
> > +---------+------------------+-------------------+
> > | Normal  | top-left         | top-left          |
> > | Rotated | bottom-right     | top-left          |
> > | Flipped | bottom-left      | top-right         |
> > +---------+------------------+-------------------+
> 
> Keyword values need to be lowercase to be registered...

No problem - let's change it to this:

+---------+------------------+-------------------+
| KEYWORD | LONG EDGE ORIGIN | SHORT EDGE ORIGIN |
+---------+------------------+-------------------+
| normal  | top-left         | top-left          |
| rotated | bottom-right     | top-left          |
| flipped | bottom-left      | top-right         |
+---------+------------------+-------------------+

> Also, is this really a Job Template attribute? How does a Client know which coordinate system to use for a given Printer?

Nope, this was my mistake. This "pclm-raster-back-side" attribute is a Printer Description attribute.

> 
> > 3.12.8 pclm-source-resolution (resolution)
> > This attribute specifies the source resolution of the current job.
> > Resolution is specified in dots-per-inch.
> 
> I'm not sure how I feel about forcing the units - the resolution syntax supports both dots-per-inch and dots-per-centimeter...
> 
> (not that it matters for the registration - the Printer will tell the Client which values it will support...)

That's fine, we can remove that line from the registration.

> 
> > Printer Description Attributes
> > ---------------------------------
> > 
> > 3.12.9 pclm-source-resolution-supported (1setOf resolution)
> > This attribute enumerates the printer’s supported source resolutions
> > (specific to PCLm). Specifies the resolution or range of source
> > resolutions supported by the printer. The return value(s) shall be in
> > dots-per-inch. Typically, a printer will produce better resolution and
> > perform better when the source and printer resolution are equal.
> 
> See above.

Will resolve as for palm-source-resolution.

> 
> > 3.12.10 pclm-strip-height-preferred (integer)
> > This attribute specifies the preferred strip height for the printer for
> > jobs that have PCLm document format.
> 
> Height in pixels/lines, right?

No, height as defined in palm-strip-height-supported - preferred strip height = page height / pclm-strip-height-preferred

> 
> > 3.12.11 pclm-strip-height-supported (1setOf integer)
> > This attribute specifies the strip/swath height that the printer
> > requires. If non-zero, the Strip Height shall be a power of 2 and shall
> > not be less than 16. The strip height is specified in source space
> > coordinates. This attribute is only required for PCLm jobs. Strip height
> > is relative to page i.e. if 16 means strip height is = page length/16.
> 
> "Source space coordinates" == "pixels/lines"?
> 
> > A return value of 0 indicates that the entire page should be delivered to
> > the printer as a single strip, e.g. strip height is equal to the page
> > height, resulting in a strip count of 1.

A strip height of 1 also produces the same result.

> > 
> > The default for a printer shall be 16.

As we discussed, this line can be removed from the registration.

> > 
> > 
> > Cheers,
> > Smith
> > 
> > /**
> > Smith Kennedy
> > Wireless & Standards Architect - IPG-PPS
> > Standards - IEEE ISTO PWG / Bluetooth SIG / Wi-Fi Alliance / NFC Forum / USB-IF
> > Chair, IEEE ISTO Printer Working Group
> > HP Inc.
> > */
> > 
> > 
> > 
> > _______________________________________________
> > ipp mailing list
> > [email-masked]
> > https://www.pwg.org/mailman/listinfo/ipp
> 
> _________________________________________________________
> Michael Sweet, Senior Printing System Engineer

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet <[email-masked]>
Date: Thu, 06 Sep 2018 17:07:40 -0400

Smith,

I think we’ll be good with the changes, go ahead and post an update and I’ll get it into the PWG registry for review.

Sent from my iPhone

> On Sep 6, 2018, at 12:57 PM, Kennedy, Smith (Wireless & Standards Architect) <[email-masked]> wrote:
> 
> Hi Mike,
>