Subject: [IPP] MIB objects as IPP attributes

From: William Wagner via ipp <[email-masked]>
Date: Wed, 11 Sep 2019 23:08:40 -0400

This is probably just me being very rusty, but several of the new MIB originated attributes in the System spec have we wondering  how they would be used, particularly when querying attributes that are part of a MIB table. For example, a query of log id would result in an integer response, which may refer to one of the 10 power log entries  retained.  Will a query of  an element in a power log entry (e.g., power-state-message) refer to the log entry identified in the log id response ? How does one query elements in other power log entries?

Sorry if I am being thick. Bill Wagner

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet via ipp <[email-masked]>
Date: Thu, 12 Sep 2019 10:18:22 -0400

Bill,

I believe the "power-log-col" attribute retains the same organization as the Power Log Group in 5106.4.  The "log-id" member attribute corresponds to the LogID element, "power-state" to PowerState, and so forth.  The collection syntax groups these member attributes together so that we don't need "parallel arrays" like we do for some of the other MIB-derived attributes ("printer-alert" and "printer-alert-description", for example), so the Nth value in "power-log-col" corresponds to the Nth group in the PowerLog group in XML or SNMP - it's a 1-to-1 mapping.

(Ira: It looks like we never registered any of the values in PWG 5106.4 with IANA...)

> On Sep 11, 2019, at 11:08 PM, William Wagner via ipp <[email-masked]> wrote:
> 

________________________
Michael Sweet