Subject: Re: [IPP] Xerox has reviewed the IPP System Service v1.0 and has comments

From: "Kennedy, Smith \(Wireless & Standards Architect\) via ipp" <[email-masked]>
Date: Wed, 11 Sep 2019 14:54:12 +0000

Thank you Alan for your detailed review and response!

Smith

/**
    Smith Kennedy
    Chair, IEEE ISTO Printer Working Group
    HP Inc.
*/

> On Sep 11, 2019, at 8:52 AM, Sukert, Alan <[email-masked]> wrote:
> 
> The following are my comments against IPP System Service v1.0:
> The [ACPI] reference in 15.1 does not appear elsewhere in the document.
> The [DSP1027] reference in 15.1 does not appear elsewhere in the document.
> The [IEEE1284] reference in 15.1 does not appear elsewhere in the document.
> The [IEEE1621] reference in 15.1 does not appear elsewhere in the document.
> The [ISO10175-1] reference in 15.1 does not appear elsewhere in the document.
> The [PWG5100.1] reference in 15.1 does not appear elsewhere in the document. The text does reference [PWG5100.11], so I wonder if the reference in 15.1 is incorrect.
> The [PWG5107.2] reference in 15.1 does not appear elsewhere in the document. Also, the associated link for this reference in 15.1 does not work.
> The [STD66] reference in 15.1 does not appear elsewhere in the document.
> For the [STD92] reference in 15.1, the link may be to the proper document but it doesn’t track with the title in 15.1. 15.1 lists"Internet Printing Protocol/1.1", STD 92, June 2018” but the document the link points to has “Internet Printing Protocol/1.1: Encoding and Transport”, is dated January 2017 and is not labeled STD92.
> [ISO10646] is mentioned in Section 12 but is not listed in any of the reference sections in 15.
> [PWG5100.SYS] is mentioned in Section 14 but is not listed in any of the reference sections in 15.
> Not sure this is an issue or not, but I couldn’t reach the link for the [REJUVENATION] reference in 15.2.
> This one is a nit – For the [UNISECFAQ] reference in 15.2, the title in 15.2 says “Unicode Consortium “Unicode Security FAQ”, November2016” but the actual title in the referenced link is “Unicode Consortium “Unicode Security Issues FAQ”, November2016”.
> This may be OK, but in 2.4 on line 517 the https://www.iso.org/standard/18191.html <https://protect-us.mimecast.com/s/rpp1CADo5oTNqGL5muGUOLZ?domain=iso.org> link takes you to ISO/IEC 10175-1:1996. Is that the document you wanted to point to here?
> 
> I checked all the references in Section 15 but didn’t check if all the references in the body of the document were listed in Section 15; I will try to do that later if I can get some spare time.
> 
> Alan Sukert
> Product Security Specialist
> Xerox Research and Development/ Product Security and Development Process Controls
> Xerox Certified Green Belt
> [email-masked]| <mailto:[email-masked]%7C> tel 585.427.1413
> MS 0111-03A | 800 Phillips Road | Webster, NY 14580 USA

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Ira McDonald via ipp <[email-masked]>
Date: Thu, 12 Sep 2019 20:56:06 -0400

Forwarding to IPP list for open record

---------- Forwarded message ---------
From: Sukert, Alan <[email-masked]>
Date: Wed, Sep 11, 2019 at 10:52 AM
Subject: Xerox has reviewed the IPP System Service v1.0 and has comments
To: [email-masked] <[email-masked]>, Ira McDonald ([email-masked]) <
[email-masked]>, Paul Tykodi <[email-masked]>, Michael Sweet <
[email-masked]>
Cc: Kennedy, Smith (Wireless & Standards Architect) <[email-masked]>

   1. The [ACPI] reference in 15.1 does not appear elsewhere in the
   document.
   2. The [DSP1027] reference in 15.1 does not appear elsewhere in the
   document.
   3. The [IEEE1284] reference in 15.1 does not appear elsewhere in the
   document.
   4. The [IEEE1621] reference in 15.1 does not appear elsewhere in the
   document.
   5. The [ISO10175-1] reference in 15.1 does not appear elsewhere in the
   document.
   6. The [PWG5100.1] reference in 15.1 does not appear elsewhere in the
   document. The text does reference [PWG5100.11], so I wonder if the
   reference in 15.1 is incorrect.
   7. The [PWG5107.2] reference in 15.1 does not appear elsewhere in the
   document. Also, the associated link for this reference in 15.1 does not
   work.
   8. The [STD66] reference in 15.1 does not appear elsewhere in the
   document.
   9. For the [STD92] reference in 15.1, the link may be to the proper
   document but it doesn’t track with the title in 15.1. 15.1 lists "Internet
   Printing Protocol/1.1", STD 92, June 2018” but the document the link points
   to has “*Internet Printing Protocol/1.1: Encoding and Transport”, is
   dated January 2017 and is not labeled STD92.*
   10. [ISO10646] is mentioned in Section 12 but is not listed in any of
   the reference sections in 15.
   11. [PWG5100.SYS] is mentioned in Section 14 but is not listed in any of
   the reference sections in 15.
   12. Not sure this is an issue or not, but I couldn’t reach the link for
   the [REJUVENATION] reference in 15.2.
   13. This one is a nit – For the [UNISECFAQ] reference in 15.2, the title
   in 15.2 says “Unicode Consortium “Unicode Security FAQ”, November2016” but
   the actual title in the referenced link is “Unicode Consortium “Unicode
   Security Issues FAQ”, November2016”.
   14. This may be OK, but in 2.4 on line 517 the
   https://www.iso.org/standard/18191.html link takes you to *ISO/IEC
   10175-1:1996*. Is that the document you wanted to point to here?

I checked all the references in Section 15 but didn’t check if all the
references in the body of the document were listed in Section 15; I will
try to do that later if I can get some spare time.

Alan Sukert

Xerox Research and Development/ Product Security and Development Process
Controls

[email-masked]| tel 585.427.1413