Subject: [IPP] Excerpt from PWG JDFMAP on "imposition-template"

From: Ira McDonald via ipp <[email-masked]>
Date: Thu, 12 Sep 2019 16:51:15 -0400

Hi,

This text from PWG JDFMAP gives a pointer to the right area of CIP4 JDF
for imposition handling.

Rick Yardumian and I will do some further research into the referenced CIP4
JDF ExternalImpositionTemplate (to see if there's a useful list of
keywords,
such as 'booklet').

4.1.12 ImpositionTemplate

PWG PJT Mapping: ImpositionTemplate

JDF defines the ExternalImpositionTemplate in section 8.55 of [CIP4JDF],
which contains the FileSpec element, which contains the UserFileName
attribute (user-friendly file name), which can be mapped to the PJT
ImpositionTemplate element (keyword of ‘None’ or ‘Signature’ or
site-specific name) defined in [PWG5100.3]. The PJT ImpositionTemplate
element interacts in an implementation-specific manner with the PJT
NumberUp element and PJT XImage and YImage layout elements.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Co-Chair - TCG Metadata Access Protocol SG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
PO Box 221  Grand Marais, MI 49839  906-494-2434
_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet via ipp <[email-masked]>
Date: Fri, 13 Sep 2019 08:00:14 -0400

Ira,

In reading both this section of JDF and section 6.2.18 (which provides the explicit imposition definition in JDF and the Layout element for specifying things), it looks like there isn’t a stand, well-defined list of imposition templates. Indeed, even the examples seem to focus on 2-up, saddle-stitched booklet templates/signatures and letterhead/cover letter applications. Definitely a process-based approach (place input page 1 *here* on the front side of output page 1, etc.) and not something I think we want to reproduce in IPP.

I know we want a booklet template, but what other imposition templates/signatures are common in production?

I can imagine some marketing communication applications (business cards, postcards, etc.) where the same content is repeated on the front and  back sides (and is cut after printing) although we might need to define a keyword format like ‘same-up_COLS_ROWS_WIDTHxHEIGHTunits’ to specify the layout, e.g.:

- ‘same-up_4_3_2x3.5in’ for business cards
- ‘same-up_2_2_3.5x5in’ for US postcards
- ‘same-up_2_2_105x148in’ for A6 postcards

This at least would offer a path to convert from IPP to JDF layout elements...

Thoughts?

____________________
Michael Sweet

> On Sep 12, 2019, at 4:51 PM, Ira McDonald via ipp <[email-masked]> wrote:
> 
> Hi,
> 
> JDF ExternalImpositionTemplate (to see if there's a useful list of keywords, 
> such as 'booklet').
> 
> JDF defines the ExternalImpositionTemplate in section 8.55 of [CIP4JDF], which contains the FileSpec element, which contains the UserFileName attribute (user-friendly file name), which can be mapped to the PJT ImpositionTemplate element (keyword of ‘None’ or ‘Signature’ or site-specific name) defined in [PWG5100.3]. The PJT ImpositionTemplate element interacts in an implementation-specific manner with the PJT NumberUp element and PJT XImage and YImage layout elements.
> 
> Cheers,
> - Ira
>

---

From: Ira McDonald via ipp <[email-masked]>
Date: Fri, 13 Sep 2019 13:46:28 -0400

Hi Mike,

I agree with your summary and proposed approach.

Cheers,
- Ira

On Fri, Sep 13, 2019 at 8:00 AM Michael Sweet <[email-masked]> wrote:

> Ira,
>
> In reading both this section of JDF and section 6.2.18 (which provides the
> explicit imposition definition in JDF and the Layout element for specifying
> things), it looks like there isn’t a stand, well-defined list of imposition
> templates. Indeed, even the examples seem to focus on 2-up, saddle-stitched
> booklet templates/signatures and letterhead/cover letter applications.
> Definitely a process-based approach (place input page 1 *here* on the front
> side of output page 1, etc.) and not something I think we want to reproduce
> in IPP.
>
> I know we want a booklet template, but what other imposition
> templates/signatures are common in production?
>
> I can imagine some marketing communication applications (business cards,
> postcards, etc.) where the same content is repeated on the front and  back
> sides (and is cut after printing) although we might need to define a
> keyword format like ‘same-up_COLS_ROWS_WIDTHxHEIGHTunits’ to specify the
> layout, e.g.:
>