Subject: [IPP] EPX: "feed-orientation" attribute orphaned

From: ISTO-PWG Internet Printing Protocol workgroup discussion forum via ipp <[email-masked]>
Date: Mon, 14 Mar 2022 11:32:38 -0400

All,

I'm going through the IPP registry and CUPS sources (to make sure that everything is up-to-date and in sync) and noticed that the "feed-orientation" attribute has gone missing from the current EPX draft.  From the original PWG 5100.11:

7.1 feed-orientation (type3 keyword)

The OPTIONAL "feed-orientation" Job Template attribute specifies the media edge which is fed into the print engine from the paper tray. Long-edge-first is the preferred method of feeding media to attain the fastest printing speed. Certain media will have adverse effects when fed from a certain direction; for instance, some labels will peel off in the paper path when fed long-edge-first, but not when fed short-edge-first. The feed orientation also may allow the job to be finished in more acceptable ways; for instance, a stationary finishing stapler may provide a preferred stapling location when the media is fed short-edge-first.

When this attribute is specified, the printer selects media that has already been loaded in the requested orientation. If the media is not currently loaded in the requested orientation, the job may enter the 'processing-stopped' state with a "job-state-reason" of 'resources-are-not-ready'.

Standard keyword values are:

Keyword

'long-edge-first'

'short-edge-first'

Now, if I go back through the archives then it looks like we had decided to make this attribute obsolete rather than bring it into the new-and-improved 5100.11 - mainly because feed orientation is determined by the input tray. But right now "feed-orientation" and the corresponding -default and -supported attributes are not mentioned in the obsolete section nor can they be found as current attributes...

________________________
Michael Sweet

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: ISTO-PWG Internet Printing Protocol workgroup discussion forum via ipp <[email-masked]>
Date: Mon, 14 Mar 2022 15:44:16 +0000

Hi Mike,

I will add all of those to the obsolete sections in the next draft of IPP Enterprise Printing Extensions v2.0.

Cheers,
Smith
---
Smith Kennedy
[email-masked]

On Mar 14, 2022, at 9:33 AM, ISTO-PWG Internet Printing Protocol workgroup discussion forum via ipp <[email-masked]> wrote:

All,

Keyword

'long-edge-first'

'short-edge-first'

________________________
Michael Sweet

---

From: ISTO-PWG Internet Printing Protocol workgroup discussion forum via ipp <[email-masked]>
Date: Mon, 14 Mar 2022 18:09:21 +0000

Quick editorial question: I have separate sections for Obsolete Attributes and Obsolete Values. The only entries I currently have in the latter are those values that are obsolete for attributes that are not obsolete. If that is fine, then I'll simply add "feed-orientation" / "feed-orientation-default" / "feed-orientation-supported" to the Obsolete Attributes section and be done?

> On Mar 14, 2022, at 9:44 AM, Kennedy, Smith (Wireless & IPP Standards) <[email-masked]> wrote:
> 
> Hi Mike,
>

---

From: ISTO-PWG Internet Printing Protocol workgroup discussion forum via ipp <[email-masked]>
Date: Mon, 14 Mar 2022 14:30:06 -0400

Smith,

You also need to add the (obsolete) entries in the registry sections.

> On Mar 14, 2022, at 2:09 PM, ISTO-PWG Internet Printing Protocol workgroup discussion forum via ipp <[email-masked]> wrote:
> 
> Signed PGP part

________________________
Michael Sweet

---

From: ISTO-PWG Internet Printing Protocol workgroup discussion forum via ipp <[email-masked]>
Date: Mon, 14 Mar 2022 18:34:49 +0000

Ye

> On Mar 14, 2022, at 12:30 PM, ISTO-PWG Internet Printing Protocol workgroup discussion forum via ipp <[email-masked]> wrote:
> 
> Signed PGP part
> Smith,
> 

Yep, got that, and so you responding as you did makes me think I need to do both the attributes and the values in the IANA registry. But do I need to list the keywords in the Obsolete Values section too?

> 
> 
>> On Mar 14, 2022, at 2:09 PM, ISTO-PWG Internet Printing Protocol workgroup discussion forum via ipp <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Signed PGP part

---

From: ISTO-PWG Internet Printing Protocol workgroup discussion forum via ipp <[email-masked]>
Date: Mon, 14 Mar 2022 15:14:29 -0400

Smith,

> On Mar 14, 2022, at 2:34 PM, ISTO-PWG Internet Printing Protocol workgroup discussion forum via ipp <[email-masked]> wrote:
> ...

No, it is enough to list the attribute as obsolete.  No sense listing the values twice when *all* of the values for the obsolete attributes are going away too...

________________________
Michael Sweet