Subject: RE: [ippm] OWDP coding proposal

From: "Geib, Ruediger" <[email-masked]>
Date: Mon, 14 May 2001 11:49:15 +0200

Hello Ben,

Would

> 1) an arbitrary length packet train schedule  
> 2) a packet train probability distribution 
> 3) an average inter-packet train interval 

allow to code a dual Poisson distribution (e.g. train length poisson distributed, inter arrival time Poisson distributed) in a simple manner? I guess not.

I'm also not sure whether you could easily extend it to distributions which are harder to describe than trains and an inter train rate. 

I recognize that there's got to be a compromise between simplicity and usefulness. 

Regards, Rüdiger
_______________________________________________
ippm mailing list
[email-masked]
http://mailhost.advanced.org/mailman/listinfo/ippm

---

From: Steven Van den Berghe <[email-masked]>
Date: Mon, 14 May 2001 12:37:05 +0200

Hi all,

These are just some personal thoughts on the OWDP-control protocol. If you feel they go to far and complicate things too much, just ignore them.

We need indeed find the right balance between simplicity (from an implementation point of view), current usefulness and future usefulness. My feeling is that
these objectives are achieved by allowing a flexible extensibility of the control-side of the protocol:
  - allow to generalize by adding for instance TLV's
  - don't impose the implementation of any of the TLV's so one can have the choice between a "light-weight" and a "full-option" implementation.

Next to the profile definition, other areas i see, where extensibility might be a nice thing to have are:
  - result description (say for instance that we just want to keep min/max/avg results instead of packet-sequences to avoid wasting storage space)
  - type-P-packet definitions (cf my  previous mail)

I know it might endanger the idea of having a universal measurement infrastructure as offered by the "ping"-way, but implementing some basic TLVs and
ignoring all the rest shouldn't complicate things too much.

Regards,
Steven

--
Steven Van den Berghe
[email-masked]
Workgroup Broadband-Networks
Department Information Technology
Ghent University - Belgium
Phone:  +32 (0)9 267 35 86 | Fax  :  +32 (0)9 267 35 99
*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*
The faulty interface lies between the chair and the
keyboard.

*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*

---

From: Ben Teitelbaum <[email-masked]>
Date: Mon, 14 May 2001 07:25:29 -0400

> allow to code a dual Poisson distribution (e.g. train length poisson distributed, inter arrival time Poisson distributed) in a simple manner? I guess not.

Right. But, you could fake it with a pseudo-Poisson packet train schedule. 

> I'm also not sure whether you could easily extend it to distributions which are harder to describe than trains and an inter train rate.

The only way to achieve full generality, is to install an explicit test packet
schedule in the session-sender, which my proposed approach can support. I
don't claim to support full generality in an efficient way, but the hook is
there. The idea was to offer a solution that is general enough to describe
efficiently the distributions that the WG currently finds important, while
offering generality and extensibility.

Cheers,

-- 

                         ,,,

                        `o-o-  
                          <    Benjamin Teitelbaum
                           -   Advanced Network & Services, Inc.
                           .   Internet2
_______________________________________________
ippm mailing list
[email-masked]
http://mailhost.advanced.org/mailman/listinfo/ippm