Subject: Re: [ippm] bandwidth measuring/estimating

From: "Allen B. Downey" <[email-masked]>
Date: Fri, 22 Jun 2001 10:58:38 -0400 (EDT)

> In first order, I'd think that this is very simple to calculate: all
> programs measure RTT as a function of number of bytes sent, then determine
> the slope of this line by fitting it to a straight line, the bandwidth is
> then 1/slope (Byte/sec).   All fitting methods can also give error
> estimates on the slope and this can be easily turned into an experimental
> error on the bandwidth.
> 
> Since this is all very simple, I'm surprised that none of the tools do
> this, can anybody explain why or did I overlook something?
> 
	All fitting methods give error estimates that are based
	on assumptions about the errors that are, in this case,
	not true.

	clink uses a nonparametric technique to estimate error
	bounds, and it does report them.

	But getting better error estimates is definitely high
	on the list of prorities for current work.

	Cheers,
	Allen

_______________________________________________
ippm mailing list
[email-masked]
http://mailhost.advanced.org/mailman/listinfo/ippm

---

From: "Henk Uijterwaal (RIPE-NCC)" <[email-masked]>
Date: Fri, 22 Jun 2001 17:08:52 +0200 (CEST)

> 	on assumptions about the errors that are, in this case,

Allan,

What assumptions and why?

Henk

> 	on the list of prorities for current work.

------------------------------------------------------------------------------
Henk Uijterwaal                    Email: [email-masked]
RIPE Network Coordination Centre     WWW: http://www.ripe.net/home/henk
Singel 258                         Phone: +31.20.5354414
1016 AB Amsterdam                    Fax: +31.20.5354445 
The Netherlands                   Mobile: +31.6.55861746  
------------------------------------------------------------------------------

As long as you don't tell your friends how I played the hand,
then I won't tell my friends how you defended it.                 (Anonymous)