Subject: [ippm] Measure the delay jitter of video stream over MPLS network?

From: Jing Shen <[email-masked]>
Date: Sat, 09 Jun 2001 22:39:59 +0800

Hi:

Execuse me for my stupid question, but I really need help
on this question.

I've just setup a little test bed with MPLS & QoS enabled.
I want to measure the effect of QoS enabled MPLS channel
on video streams. I hope the test should be as simple as possible.

I've download a little tool named mpeg_video
which is a mpeg-1 decoder. I place the mpeg-1 files
on one end of the testbed(linux)  and mpeg-1 decoder on the other
end ( Solaris box). The decoder use NFS to fetch the content to play.
After reading the source code of the mpeg-1 decoder I find I
can just record the start and stop time of each frame, while I want to
measure the delay and delay jitter of each stream. And, I don't know if
there
is a free tool  can be used to generate a  graph of jitter-frame
relationship
from raw data.

Is there any person would like to do me a favor on this question?

Thanks a lot .

Regards

James Shen

_______________________________________________
ippm mailing list
[email-masked]
http://mailhost.advanced.org/mailman/listinfo/ippm

---

From: "Jizhong (Jim) Wu" <[email-masked]>
Date: Sun, 10 Jun 2001 11:31:20 +1000

Hi James,

What's the transport protocol you used? If you use RTP, the 'time stamp'
may be helpful.

Jim

--
=================================================================
Jim Wu                                 [email-masked]
School of Computer Sci. & Eng.         FAX:   +61 2 9385 5995
The University of New South Wales      Tel:   +61 2 9385 4358
UNSW SYDNEY, NSW 2052                  http://www.cse.unsw.edu.au/~jimw
Australia
=================================================================