Subject: [ippm] on metrics to be registered

From: "Cole, Robert G (Bob), ALASO" <[email-masked]>
Date: Wed, 20 Nov 2002 09:42:36 -0500

IPPM Metrics Doc ver.01 notes/questions:

Emile,

I think the registry is potentially a useful device.  I have
one set of comments.

E.g., the metrics for one-way delay and round trip contain
reference to delay, delayPoissonStream,
delayPercentile, delayMedian, delayMinimum, 
delay inverse percentile, etc.

These seem to fall into four types of items registered:

singleton-metric, e.g., delay
sample-metric, e.g., delayPoisson
statistical metric, delayMedian
ambiguous metrics, e.g., delayPercentile

Of the MIBs I am familiar with in, e.g., RMONMIB,
they need reference only to singleton-metrics because
the 'sample' is given or defined and 'statistics' are
hard coded.

Also, the first three type require only a single object
to point to the metric, while the ambiguous statistical
metrics require additional information
on the MIB to clarify the ambiguity.

It is not clear to me that you want to register
statistical metrics.  Even if you do, should the 
ambiguous statistical metrics be removed?

Finally, would it make sense to disassociate the
sample-metrics from the registration of the statistic?
This might simplify the registration process.

Thanks,

Bob Cole

_______________________________________________
ippm mailing list
[email-masked]
http://mailhost.advanced.org/mailman/listinfo/ippm

---

From: "STEPHAN Emile FTRD/DAC/LAN" <[email-masked]>
Date: Fri, 22 Nov 2002 00:47:08 +0100

Hi,

The RMON WG requested that the IPPM metric registry should be specified
outside the IPPM REPORTING MIB document.

The framework of this administrative task is simple: the registry
provides an identifier for all the metrics standardized. So all
standardized metrics are treated equally.

Bob said "> ambiguous metrics, e.g., delayPercentile":
It is not in the scope of this document to have an opinion on the fact
that a metric is ambiguous metrics or not.

regards
Emile

> -----Message d'origine-----
> De : Cole, Robert G (Bob), ALASO [mailto:[email-masked]]
> Envoye : mercredi 20 novembre 2002 15:43
> A : [email-masked]
> Objet : [ippm] on metrics to be registered
> 
>

---

From: "Cole, Robert G (Bob), ALASO" <[email-masked]>
Date: Fri, 22 Nov 2002 09:55:13 -0500

Hi Emile,

The whole intent of the metric registry was to
provide a pointer to unambiguously defined metrics.
If a MIB object defined thru the registry points to
percentile, how do I interprete the value?  Is it a 95%,
a 90%, an 87% ....

Thanks,
Bob

> -----Original Message-----
> From:	STEPHAN Emile FTRD/DAC/LAN [SMTP:[email-masked]]
> Sent:	Thursday, November 21, 2002 11:47 PM
> To:	[email-masked]
> Subject:	RE: [ippm] on metrics to be registered
> 
> Hi,
>

---

From: "STEPHAN Emile FTRD/DAC/LAN" <[email-masked]>
Date: Mon, 25 Nov 2002 09:26:58 +0100

Hi Bob,

At large each metric needs pecific parameters. The percentile is only a
parameter of the delayPercentile measure.

regards
Emile

> Envoye : vendredi 22 novembre 2002 15:55
> A : STEPHAN Emile FTRD/DAC/LAN; [email-masked]
> Objet : RE: [ippm] on metrics to be registered
> 
> 
> Hi Emile,
> 
> > From:	STEPHAN Emile FTRD/DAC/LAN 
> [SMTP:[email-masked]]

---

From: "Cole, Robert G (Bob), ALASO" <[email-masked]>
Date: Mon, 25 Nov 2002 09:22:10 -0500

Emile,

Well, I guess I do not understand.  E.g., what parameters are needed
by the median or the variation?

Thanks,
Bob

> Sent:	Monday, November 25, 2002 8:27 AM
> To:	[email-masked]
> > > http://mailhost.advanced.org/mailman/listinfo/ippm> 
> > 
>