Subject: [ippm] [e2e] [Fwd: State of MPLS deployments today]

From: Robert Raszuk <[email-masked]>
Date: Thu, 03 Oct 2002 12:23:31 +0200

Kava,

> first of all I should mention that MPLS deployment is far from being done (I
> don't think that it has been deployed even in a large network operator) and
> I largely suspect that it will never be deployed in a large scale to be the
> primary backbone technology !!!!

Would you mind sharing with me your definition of "large network
operator" ? For me operators like ATT, BT, DT, FT, TI, Level3, Worldcom,
JT, KDDI and many many more are of the size I would considered as
"large" on this planet. 

All of them are using MPLS and MPLS applications in their backbones. 

Only a very few IP purists who get high blood pressure when one next to
them says MPLS don't use it and that is also absolutely fine. 

Just one more comment:

MPLS was never intended to boost network performance but to offer a new
paradigm for various applications which benefit from not pure
traditional dst based lookup at each hop. Sure IP can emulate it as well
with tunnels, but it is obvious that in this case, when talking about
production deployements IP is catching up with applications already
offered by MPLS today in a scalable way.

Rgs,
R.

> From: Kavé Salamatian <[email-masked]>
> To: Shen Jing <[email-masked]>, [email-masked]
> Cc: [email-masked]
> Subject: RE: [ippm] [e2e] Mathematical analysis of e2e lable switching path
> Date: 03 Oct 2002 09:56:39 +0200
> 
> Dear Shen,
> 
> first of all I should mention that MPLS deployment is far from being done (I
> don't think that it has been deployed even in a large network operator) and
> I largely suspect that it will never be deployed in a large scale to be the
> primary backbone technology !!!!
> 
> >From the point of view of measurement, LSP networks should not have too much
> difference from traditional IP networks as nowadays IP routing performance
> is getting very  close to Label switching performance, meaning that the
> delay of crossing an LSP network should not be significantly larger than an
> IP network. The difference may come from a simpler  traffic engineering in
> MPLS. Meaning that we should evaluate the effect of traffic engineeringon
> performance, not the particuliar behaviour of MPLS network.
> 
> Bests
> 
> Kv
> -----Message d'origine-----
> De?: [email-masked] [mailto:[email-masked]]De la part de
> Shen Jing
> Envoyé?: dimanche 29 septembre 2002 04:28
> à?: [email-masked]
> Cc?: [email-masked]
> Objet?: [ippm] [e2e] Mathematical analysis of e2e lable switching path
> 
> 
> Hi there,
> 
> I've some question on e2e performance analysis of
> label switching path.
> 
> There has been many research on e2e performance
> analysis for IP routing. Nearly all of them take the
> model of "network of queue", and under assumpiton of
> Possion Arrival, exponential flow size etc. To my
> limited knowledge, this is not to the state of
> Internet which experiences LRD. On the other hand,
> different router archtecture must have different
> effect on transmission performance.
> As MPLS proceeds to be the primary backbone
> technology, I think there must be something new
> introduced into the e2e performance in internet.
> 
> So, I want to know, whether there is some work with
> methematical modeling of LSP networks? and, are there
> anyone would do me a favor to recommend some refrence
> book, web page, research paper or the like ?
> 
> Thank you very much.
> 
> Best regards
> 
> 
> =====
> Jing Shen
> 
> State Key Lab of CAD&CG
> ZheJiang University(YuQuan)
> HangZhou, ZheJiang Province 310027
> P.R.China
> 
> _________________________________________________________
> Do You Yahoo!?
> "发短信赢手机,快来参加雅虎巨星秀!"
> http://cn.ent.yahoo.com/star/midautumn/index.html
> 
> _______________________________________________
> ippm mailing list
> [email-masked]
> http://mailhost.advanced.org/mailman/listinfo/ippm
> 
> _______________________________________________
> ippm mailing list
> [email-masked]
> http://mailhost.advanced.org/mailman/listinfo/ippm
_______________________________________________
ippm mailing list
[email-masked]
http://mailhost.advanced.org/mailman/listinfo/ippm

---

From: Kavé Salamatian <[email-masked]>
Date: Thu, 3 Oct 2002 21:38:31 +0200

>JT, KDDI and many many more are of the size I would considered as
I was saying that today we don't have yet (or at least I have not heard of)
a full MPLS large network. I was not meaning that nobody is using MPLS in
portion of his network.

But obviously there are large full IP network that operate well (at least in
their core) and does not seem to believe to an urgent need for MPLS.

>All of them are using MPLS and MPLS applications in their backbones.
Nice for MPLS constructors

>them says MPLS don't use it and that is also absolutely fine.
It seems that the search for purity is not restricted to IPist there are
also some MPLS zeloat around :-) sorry to give you high blood pressure.

Bests

Kv

---

From: Robert Raszuk <[email-masked]>
Date: Thu, 03 Oct 2002 22:31:43 +0200

Dear Prof. Kavé Salamatian,

> a full MPLS large network. I was not meaning that nobody is using MPLS in

It is quite known that university professors are pretty much out of
touch with real networks and reality. To help you overcome this I guess
we need to step back to MPLS 101 with you and find out what "MPLS"
really means. Let me ask you a basic question - why would anyone run TDP
& LDP only in partion of his network ? That is one of few MPLS
forwarding mechanisms used very widely today across multiple world scale
providers. 

Just as a tiny reference not related to any vendor take a look at the
folowing URL and download "MPLS Unofficial List":
http://cellstream.com/MPLS_List.htm or just click on
http://www.mplsrc.com/faq3.shtml and browse to all MPLS-VPN providers.
Keep in mind that 99% of MPLS-VPN providers use TDP or LDP in their
ENTIRE backbone.

> also some MPLS zeloat around :-) sorry to give you high blood pressure.

He he he - I am not effected by this at all, I just try to make sure
that the information on the public lists are correct :). 

R.

---

From: Robert Raszuk <[email-masked]>
Date: Thu, 03 Oct 2002 23:06:18 +0200

Hi Randy,

As far as the clue part I would recommed to wait for VPRN presentation
to go public at next nanog so everybody can judge who is clufull or
clueless reg MPLS applications especially 2547bin :-).

R.

> Randy Bush wrote:
> > touch with real networks and reality.
> 
> as opposed to out of touch with manners or clue?
>

---

From: Randy Bush <[email-masked]>
Date: Thu, 03 Oct 2002 13:53:24 -0700