Subject: [ippm] iOAM drafts discussion at IPPM WG

From: Greg Mirsky <[email-masked]>
Date: Mon, 24 Sep 2018 14:53:27 -0700

Dear All,
a number of drafts that define encapsulation of iOAM data for the various
overlay networks had been presented and requested adoption by the IPPM WG.
I have one scenario to discuss:

   - all proposed encapsulations of iOAM data use the field that explicitly
   indicates the type of the payload that immediately follows the overlay
   header. In all proposals iOAM data identified either as End-to-end iOAM or
   Hop-by-hop iOAM;
   - iOAM data uses its own shim that includes the Next Protocol field. The
   value of the Next protocol field identifies the type of the payload, the
   user payload;
   - now consider the situation when a node in the overlay network that
   doesn't support iOAM receives an iOAM data, i.e., doesn't recognize iOAM
   payload types. The node will drop the iOAM data and the user packet with it.

If my analysis is correct, then here are a couple of questions:

   - how useful is the technology that requires an upgrade of the whole
   network in order to work;
   - should we return the discussion of iOAM data encapsulation in overlay
   networks to the WGs that define these overlay networks.

Regards,
Greg

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Tue, 25 Sep 2018 01:11:59 +0000

On Sep 24, 2018, at 5:53 PM, Greg Mirsky <[email-masked]<mailto:[email-masked]>> wrote:

  *   should we return the discussion of iOAM data encapsulation in overlay networks to the WGs that define these overlay networks.

No.

[and what would be the intention of this decision-revisiting exercise, besides delaying work for which there is already an agreed forward path?]

  *   how useful is the technology that requires an upgrade of the whole network in order to work;

In these general terms, are you talking about IPv6? Or MPLS LSP Ping? Or BIER? Or...?

[Hint: same answer applies]

Greg: please search for “Deployment considerations” in each of the IOAM documents.

Regards,
Greg

I hope all is well!

Best,

—
Carlos Pignataro, [email-masked]<mailto:[email-masked]>

“Sometimes I use big words that I do not fully understand, to make myself sound more photosynthesis."