Subject: [ippm] R: Virtual IETF 107 Meeting Minutes and Video uploaded

From: Cociglio Mauro <[email-masked]>
Date: Mon, 6 Apr 2020 14:29:09 +0000

Dear IPPMers.

Unfortunately, due to lack of time, we were unable to present our draft during the last interim meeting (https://tools.ietf.org/html/draft-cfb-ippm-spinbit-measurements-01).
So we would like to illustrate the content and invite the WG to feedback and comment on the mailing list.

The scope of the draft is to define a new performance measurement technique in client server protocols.
These measures can be referred as Explicit Performance Measurements, since they are carried out on a session basis and allow end-to-end information for on-path observers.
This is because the protocol itself marks packets when they are generated (unlike the current implementations of RFC8321, where the packets are marked by the network nodes).
These explicit measurements are becoming particularly important from the point of view of network operators, since many applications have already started to use encrypted protocols and this makes very difficult to perform measurements on production traffic.
In particular, in the QUIC WG, there are some proposals for using the only unencrypted byte available in the packet header.
The current discussion is about the use of 3 of these 8 bits for performance measurements.
The first bit, the so called Spin bit, has been standardized to measure the Client Server RTT (see https://tools.ietf.org/html/draft-ietf-quic-transport-27).
The measurement of packet loss is still under discussion and our draft introduces two alternatives about the usage of the additional 2 bits.
The first one is a spin-bit dependent signal and uses a single bit. The second one, described in the following linked slides, is a standalone solution based on a two bits loss signal and on alternate marking (RFC8321).
This last methodology improves the algorithm described in https://tools.ietf.org/html/draft-ferrieuxhamchaoui-quic-lossbits-03 (this draft is also investigating packet loss measurement for QUIC).

You can find the slides, we prepared for the IPPM interim meeting, at the following link: https://github.com/ietf-ippm/meeting-materials/blob/aa486f7ead28b9f55c5ef499e5c9ed33ab06daf9/ietf107-virtual/Slides/07-spinbit-measurements.pdf

Comments and suggestions are always welcome on the mailing list.

Thanks to all.

Mauro, Giuseppe, Fabio, Massimo and Riccardo

_____________________
Mauro Cociglio
Telecom italia-TIM
Via G. Reiss Romoli, 274
10148 - Torino (Italy)
Tel.: +390112285028
Mobile: +393357669751
_____________________

Da: ippm <[email-masked]> Per conto di Tommy Pauly
Inviato: giovedì 2 aprile 2020 23:42
A: IETF IPPM WG <[email-masked]>
Oggetto: [EXT] [ippm] Virtual IETF 107 Meeting Minutes and Video uploaded

Hello IPPM,

Thanks to all who participated in our meeting on Wednesday!

You can find the minutes of the meeting here: https://datatracker.ietf.org/doc/minutes-interim-2020-ippm-01-202004010800/

You can find the recording of the meeting here: https://www.youtube.com/watch?v=ZU6K43L2QXg&feature=youtu.be

Best,
Tommy

Questo messaggio e i suoi allegati sono indirizzati esclusivamente alle persone indicate. La diffusione, copia o qualsiasi altra azione derivante dalla conoscenza di queste informazioni sono rigorosamente vietate. Qualora abbiate ricevuto questo documento per errore siete cortesemente pregati di darne immediata comunicazione al mittente e di provvedere alla sua distruzione, Grazie. 

This e-mail and any attachments is confidential and may contain privileged information intended for the addressee(s) only. Dissemination, copying, printing or use by anybody else is unauthorised. If you are not the intended recipient, please delete this message and any attachments and advise the sender by return e-mail, Thanks. 

Rispetta l'ambiente. Non stampare questa mail se non è necessario.

---

From: "[email-masked]" <[email-masked]>
Date: Mon, 6 Apr 2020 18:56:41 +0000 (UTC)

IPPMers,
So sorry that we cannot have this conversation face to face.   Also, hope that you and your loved ones are safe and healthy.
I wanted to suggest that perhaps we consider PDM for this purpose.   The reasons:
1.  PDM is already client based.
2.  There is an RFC - RFC8250
3.  We have a FreeBSD implementation (which we can modify)
4.  We can create PDM v2 which will have quite a bit more real estate
5.  Since PDM is at the IP layer, it will cover all protocols, not just QUIC.
I am explicitly copying the co-authors.  We are happy to have a web based meeting to discuss collaboration.
Thanks,

Nalini Elkins
CEO and Founder
Inside Products, Inc.
www.insidethestack.com
(831) 659-8360 

    On Monday, April 6, 2020, 11:14:12 AM PDT, Cociglio Mauro <mauro.cociglio=[email-masked]> wrote:  

Dear IPPMers.

 

 

 

The first bit, the so called Spin bit, has been standardized to measure the Client Server RTT (seehttps://tools.ietf.org/html/draft-ietf-quic-transport-27).

The first one is a spin-bit dependent signal and uses a single bit. The second one, described in the following linked slides, is a standalone solution based on a two bits loss signal and on alternate marking (RFC8321)..

 
You can find the slides, we prepared for the IPPM interim meeting, at the following link:https://github.com/ietf-ippm/meeting-materials/blob/aa486f7ead28b9f55c5ef499e5c9ed33ab06daf9/ietf107-virtual/Slides/07-spinbit-measurements.pdf

 
Thanks to all.

 
_____________________
 
Mauro Cociglio
 
Telecom italia-TIM 
 
Via G. Reiss Romoli, 274
 
10148 - Torino (Italy)
 
Tel.: +390112285028
 
Mobile: +393357669751
 
_____________________

 
Hello IPPM,

 

 
Best,
 
Tommy
   
|    |
|  Questo messaggio e i suoi allegati sono indirizzati esclusivamente alle persone indicate. La diffusione, copia o qualsiasi altra azione derivante dalla conoscenza di queste informazioni sono rigorosamente vietate. Qualora abbiate ricevuto questo documento per errore siete cortesemente pregati di darne immediata comunicazione al mittente e di provvedere alla sua distruzione, Grazie. 

 Rispetta l'ambiente. Non stampare questa mail se non è necessario.  |

 _______________________________________________
ippm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ippm

---

From: "Ackermann, Michael" <[email-masked]>
Date: Mon, 6 Apr 2020 19:14:10 +0000

+1
And I would add that PDM would have additional benefits, such as

  *   Minimal overhead.
  *   Ability to turn on and off per session.
  *   More granular performance information.
  *   Diagnostic information as well as performance.

And as an operator I would like to highlight that PDM works at the IP layer and we would not need a separate tool/technology for each Layer 4 we need to support.

Thanks

Mike

From: [email-masked] <[email-masked]>
Sent: Monday, April 6, 2020 2:57 PM
To: IETF IPPM WG ([email-masked]) <[email-masked]>; Cociglio Mauro <mauro.cociglio=[email-masked]>
Cc: 'Riccardo Sisto' <[email-masked]>; Ackermann, Michael <[email-masked]>; Rob Hamilton <[email-masked]>
Subject: Re: [ippm] R: Virtual IETF 107 Meeting Minutes and Video uploaded

[External email]
IPPMers,

Thanks,

Nalini Elkins
CEO and Founder
Inside Products, Inc.
www.insidethestack.com<http://www.insidethestack.com>
(831) 659-8360

On Monday, April 6, 2020, 11:14:12 AM PDT, Cociglio Mauro <mauro.cociglio=[email-masked]<mailto:mauro.cociglio=[email-masked]>> wrote:

Dear IPPMers.

Thanks to all.

_____________________

Mauro Cociglio

Telecom italia-TIM

Via G. Reiss Romoli, 274

10148 - Torino (Italy)

Tel.: +390112285028

Mobile: +393357669751

_____________________

Da: ippm <[email-masked]<mailto:[email-masked]>> Per conto di Tommy Pauly
Inviato: giovedì 2 aprile 2020 23:42
A: IETF IPPM WG <[email-masked]<mailto:[email-masked]>>
Oggetto: [EXT] [ippm] Virtual IETF 107 Meeting Minutes and Video uploaded

Hello IPPM,

You can find the recording of the meeting here: https://www.youtube.com/watch?v=ZU6K43L2QXg&feature=youtu.be<https://www.youtube.com/watch?v=ZU6K43L2QXg&feature=youtu..be>

Best,

Tommy
[https://img.tim.it/sdr/maild/mail_dip_680x190_Banner_DISNEY_TIMVISION_LANCIO_v2.jpg]<https://on.tim.it/banner-mail-dip>
Questo messaggio e i suoi allegati sono indirizzati esclusivamente alle persone indicate. La diffusione, copia o qualsiasi altra azione derivante dalla conoscenza di queste informazioni sono rigorosamente vietate. Qualora abbiate ricevuto questo documento per errore siete cortesemente pregati di darne immediata comunicazione al mittente e di provvedere alla sua distruzione, Grazie.

Rispetta l'ambiente. Non stampare questa mail se non è necessario.
_______________________________________________
ippm mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ippm

The information contained in this communication is highly confidential and is intended solely for the use of the individual(s) to whom this communication is directed. If you are not the intended recipient, you are hereby notified that any viewing, copying, disclosure or distribution of this information is prohibited. Please notify the sender, by electronic mail or telephone, of any unintended receipt and delete the original message without making any copies.
 
 Blue Cross Blue Shield of Michigan and Blue Care Network of Michigan are nonprofit corporations and independent licensees of the Blue Cross and Blue Shield Association.

---

From: Cociglio Mauro <[email-masked]>
Date: Wed, 8 Apr 2020 06:17:29 +0000

Thanks Nalini and Michael for your emails.

Client-Server Explicit Performance Measurements seems very different from PDM.
Our aim is to monitor the performance of QUIC sessions (or TCP session):

1)     Using the 3 already defined bits in the QUIC header (and possibly 3 bits of the header of other client-server protocols)

2)     Integrating the marking of packets natively in the end points of the protocol sessions.

3)     Measuring the E2E performance with on-path observers.
( … and it works also with IPv4 as the underlying layer)

These are the strengths of the explicit performance measurements, started with the Spin Bit standardization in the QUIC protocol, that we would like to extend and improve with our draft.
Of course we are available to arrange a sort of Webex side meeting to present our proposals.
Best Regards.

Mauro

_____________________
Mauro Cociglio
TIM - CT.TA.EI
Via G. Reiss Romoli, 274
10148 - Torino (Italy)
Tel.: +390112285028
Mobile: +393357669751
_____________________

Da: Ackermann, Michael <[email-masked]>
Inviato: lunedì 6 aprile 2020 21:14
A: [email-masked]; IETF IPPM WG ([email-masked]) <[email-masked]>; Cociglio Mauro <[email-masked]>
Cc: 'Riccardo Sisto' <[email-masked]>; Rob Hamilton <[email-masked]>
Oggetto: [EXT] RE: [ippm] R: Virtual IETF 107 Meeting Minutes and Video uploaded

+1

  *   Minimal overhead.

Thanks

Mike

From: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Sent: Monday, April 6, 2020 2:57 PM
To: IETF IPPM WG ([email-masked]<mailto:[email-masked]>) <[email-masked]<mailto:[email-masked]>>; Cociglio Mauro <mauro.cociglio=[email-masked]<mailto:mauro.cociglio=[email-masked]>>
Cc: 'Riccardo Sisto' <[email-masked]<mailto:[email-masked]>>; Ackermann, Michael <[email-masked]<mailto:[email-masked]>>; Rob Hamilton <[email-masked]<mailto:[email-masked]>>
Subject: Re: [ippm] R: Virtual IETF 107 Meeting Minutes and Video uploaded

[External email]
IPPMers,

Thanks,

Nalini Elkins
CEO and Founder
Inside Products, Inc.

Dear IPPMers.

Thanks to all.

_____________________

Mauro Cociglio

Telecom italia-TIM

Via G. Reiss Romoli, 274

10148 - Torino (Italy)

Tel.: +390112285028

Mobile: +393357669751

_____________________

Hello IPPM,

Best,

Tommy