Subject: Re: [ippm] New Version for draft-wang-ippm-stamp-hbh-extensions-01

From: yanghongwei <[email-masked]>
Date: Sun, 1 Nov 2020 22:12:09 +0800

Hi Yali,

Thank you for your reply. I am willing to work with you to improve this document.
In order to measure more network parameters, such as forwarding path, buffer depth, etc., more or more flexible TLVs may be defined.

Thanks,
Hongwei.

Hongwei Yang
 
From: wangyali
Date: 2020-10-30 16:22
To: yanghongwei; ippm
Subject: RE: [ippm] New Version for draft-wang-ippm-stamp-hbh-extensions-01
Hi Hongwei,
 
Thanks for your questions and comments. Please see inline [Yali].
 
From: yanghongwei [mailto:[email-masked]] 
Sent: Friday, October 30, 2020 10:32 AM
To: wangyali <[email-masked]>; ippm <[email-masked]>
Subject: Re: [ippm] New Version for draft-wang-ippm-stamp-hbh-extensions-01
 
Hi Yali,
 
I think this is a useful solution. Hop-by-hop network measurement is very necessary in many scenarios. 
I have a few questions.
1. Why is it combined with OAM packets and how to deal with devices that do not support OAM?
[Yali] Good question. In this draft, we propose two kinds of way to measure and collect metrics per node or link. One kind of the way is taking advantage of IOAM-Trace-Type or extending IPv6 Hop-by-Hop Options header encoded in the STAMP test packets, which are examined and processed in Fast Path. Another way we proposed in this draft is timestamping and punting packet to control plane and recorded in Forward or Backward HbH Delay TLVs.
 
2. Latency, jitter, and packet loss are mentioned in the document, but link bandwidth utilization is also an important indicator. Can it also be implemented in this solution?
[Yali] Yes. I agree with your vision. I have a suggestion of extending a Link Bandwidth Utilization TLV in this draft. What do you think? I hope you would agree to join in the work on this draft. I'd be glad to welcome you as a co-author.
 
Thanks and Best Regards,
Hongwei.

Hongwei Yang
 
From: wangyali
Date: 2020-10-27 21:48
To: ippm
Subject: [ippm] New Version for draft-wang-ippm-stamp-hbh-extensions-01
Hello WG,
 
Draft about extensions to STAMP enable hop-by-hop OAM data measurement and collection has been updated, which was presented in IETF108. Questions and comments are welcome.
 
Because the performance of intermediate nodes and links that STAMP test packets traverse are invisible, to solve this problem, this draft extents optional TLVs to STAMP and inserts IOAM Trace option data in the test packets or dispatches test packets to the OAM process at OAM Endpoint.
 
In this case, the STAMP instance does not need to be configured at every intermediate node to measure the performance of intermediate nodes, which decreases the complexity of OAM in large-scale networks.
 
What do you think?
 
Best regards,
Yali

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, October 27, 2020 9:03 PM
To: wangyali <[email-masked]>; Tianran Zhou <[email-masked]>
Subject: New Version Notification for draft-wang-ippm-stamp-hbh-extensions-01.txt

A new version of I-D, draft-wang-ippm-stamp-hbh-extensions-01.txt
has been successfully submitted by Yali Wang and posted to the IETF repository.
 
Name:           draft-wang-ippm-stamp-hbh-extensions
Revision:       01
Title:          Simple Two-way Active Measurement Protocol Extensions for Hop-by-Hop OAM Data Collection
Document date:  2020-10-27
Group:          Individual Submission
Pages:          10
URL:            https://www.ietf.org/archive/id/draft-wang-ippm-stamp-hbh-extensions-01.txt
Status:         https://datatracker.ietf.org/doc/draft-wang-ippm-stamp-hbh-extensions/
Htmlized:       https://datatracker.ietf.org/doc/html/draft-wang-ippm-stamp-hbh-extensions
Htmlized:       https://tools.ietf.org/html/draft-wang-ippm-stamp-hbh-extensions-01
Diff:           https://www.ietf.org/rfcdiff?url2=draft-wang-ippm-stamp-hbh-extensions-01
 
Abstract:
   This document defines optional TLVs which are carried in Simple Two-
   way Active Measurement Protocol (STAMP) test packets to enhance the
   STAMP base functions.  Such extensions to STAMP enable OAM data
   measurement and collection at every node and link along a STAMP test
   packet's delivery path.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.
 
The IETF Secretariat

_______________________________________________
ippm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ippm

---

From: wangyali <[email-masked]>
Date: Mon, 2 Nov 2020 15:26:46 +0000

Hi Hongwei,

Glad to receive your reply.  I agree with you. We can have discussions on other TLVs extensions for more parameters needed to be measured hop-by-hop.

Best regards,
Yali

发件人: yanghongwei [mailto:[email-masked]]
发送时间: 2020年11月1日 22:12
收件人: wangyali <[email-masked]>; ippm <[email-masked]>
主题: Re: RE: [ippm] New Version for draft-wang-ippm-stamp-hbh-extensions-01

Hi Yali,

Thanks,
Hongwei.

________________________________
Hongwei Yang

From: wangyali<mailto:[email-masked]>
Date: 2020-10-30 16:22
To: yanghongwei<mailto:[email-masked]>; ippm<mailto:[email-masked]>
Subject: RE: [ippm] New Version for draft-wang-ippm-stamp-hbh-extensions-01
Hi Hongwei,

From: yanghongwei [mailto:[email-masked]]
Sent: Friday, October 30, 2020 10:32 AM
To: wangyali <[email-masked]<mailto:[email-masked]>>; ippm <[email-masked]<mailto:[email-masked]>>
Subject: Re: [ippm] New Version for draft-wang-ippm-stamp-hbh-extensions-01

Hi Yali,

Thanks and Best Regards,
Hongwei.

________________________________
Hongwei Yang

From: wangyali<mailto:[email-masked]>
Date: 2020-10-27 21:48
To: ippm<mailto:[email-masked]>
Subject: [ippm] New Version for draft-wang-ippm-stamp-hbh-extensions-01
Hello WG,

What do you think?

Best regards,
Yali

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
Sent: Tuesday, October 27, 2020 9:03 PM
To: wangyali <[email-masked]<mailto:[email-masked]>>; Tianran Zhou <[email-masked]<mailto:[email-masked]>>
Subject: New Version Notification for draft-wang-ippm-stamp-hbh-extensions-01.txt

Abstract:

The IETF Secretariat

_______________________________________________
ippm mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ippm

---

From: Giuseppe Fioccola <[email-masked]>
Date: Wed, 4 Nov 2020 09:43:14 +0000

Hi Yali, All,
I have read this document and it looks interesting.
I have a couple of comments:
- The document only describes HbH Delay TLV, what about the specification of the HbH also for packet loss?
- Regarding the IOAM Tracing Data TLV, the STAMP Session-Reflector test packet carries the IOAM tracing data back to the Session-Sender. What about extending this also for Alt Mark?

Regards,

Giuseppe

-----Original Message-----
From: ippm [mailto:[email-masked]] On Behalf Of wangyali
Sent: Tuesday, October 27, 2020 2:49 PM
To: ippm <[email-masked]>
Subject: [ippm] New Version for draft-wang-ippm-stamp-hbh-extensions-01

Hello WG,

What do you think? 

Best regards,
Yali

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Tuesday, October 27, 2020 9:03 PM
To: wangyali <[email-masked]>; Tianran Zhou <[email-masked]>
Subject: New Version Notification for draft-wang-ippm-stamp-hbh-extensions-01.txt

Abstract:

The IETF Secretariat

---

From: wangyali <[email-masked]>
Date: Tue, 10 Nov 2020 01:15:46 +0000

Hi Giuseppe,

Thanks for your suggestions and comments, all are much appreciated. Please find inline [Yali].

Thanks,

-----Original Message-----
From: Giuseppe Fioccola 
Sent: Wednesday, November 4, 2020 5:43 PM
To: wangyali <[email-masked]>; ippm <[email-masked]>
Subject: RE: New Version for draft-wang-ippm-stamp-hbh-extensions-01

Hi Yali, All,
I have read this document and it looks interesting.
I have a couple of comments:
- The document only describes HbH Delay TLV, what about the specification of the HbH also for packet loss?
[Yali] I agree with you. In the next version, I will add a section about the HbH Packet Loss TLV. 

- Regarding the IOAM Tracing Data TLV, the STAMP Session-Reflector test packet carries the IOAM tracing data back to the Session-Sender. What about extending this also for Alt Mark?
[Yali] I will mention in the next version that in addition to IOAM, other telemetry data (e.g. alternate marking) could be transmitted by STAMP optional TLV extensions. The draft will keep the option open for future augmentations. 

Regards,

Giuseppe

-----Original Message-----
From: ippm [mailto:[email-masked]] On Behalf Of wangyali
Sent: Tuesday, October 27, 2020 2:49 PM
To: ippm <[email-masked]>
Subject: [ippm] New Version for draft-wang-ippm-stamp-hbh-extensions-01

Hello WG,

What do you think? 

Best regards,
Yali

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Tuesday, October 27, 2020 9:03 PM
To: wangyali <[email-masked]>; Tianran Zhou <[email-masked]>
Subject: New Version Notification for draft-wang-ippm-stamp-hbh-extensions-01.txt

Abstract:

The IETF Secretariat

---

From: Tianran Zhou <[email-masked]>
Date: Tue, 10 Nov 2020 01:56:58 +0000

Hi Giuseppe,

>what about the specification of the HbH also for packet loss?

What does the packet loss TLV really mean? I.e., what value or information should be captured and carried in the container?

Thanks,
Tianran

-----Original Message-----
From: ippm [mailto:[email-masked]] On Behalf Of wangyali
Sent: Tuesday, November 10, 2020 9:16 AM
To: Giuseppe Fioccola <[email-masked]>; ippm <[email-masked]>
Subject: Re: [ippm] New Version for draft-wang-ippm-stamp-hbh-extensions-01

Hi Giuseppe,

Thanks,

-----Original Message-----
From: Giuseppe Fioccola 
Sent: Wednesday, November 4, 2020 5:43 PM
To: wangyali <[email-masked]>; ippm <[email-masked]>
Subject: RE: New Version for draft-wang-ippm-stamp-hbh-extensions-01

Hi Yali, All,

Regards,

Giuseppe

-----Original Message-----
From: ippm [mailto:[email-masked]] On Behalf Of wangyali
Sent: Tuesday, October 27, 2020 2:49 PM
To: ippm <[email-masked]>
Subject: [ippm] New Version for draft-wang-ippm-stamp-hbh-extensions-01

Hello WG,

What do you think? 

Best regards,
Yali

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Tuesday, October 27, 2020 9:03 PM
To: wangyali <[email-masked]>; Tianran Zhou <[email-masked]>
Subject: New Version Notification for draft-wang-ippm-stamp-hbh-extensions-01.txt

Abstract:

The IETF Secretariat

---

From: Giuseppe Fioccola <[email-masked]>
Date: Tue, 10 Nov 2020 14:54:16 +0000

Hi Tianran,
Regarding the packet loss, similarly to what you are defining for HbH Delay TLV, each node of the path could record and write down packet counters (e.g. alternate marking counts, STAMP session counts,...). In this way you can identify the intermediate node or link where loss has occurred.

Regards,

Giuseppe

-----Original Message-----
From: Tianran Zhou 
Sent: Tuesday, November 10, 2020 2:57 AM
To: wangyali <[email-masked]>; Giuseppe Fioccola <[email-masked]>; ippm <[email-masked]>
Subject: RE: New Version for draft-wang-ippm-stamp-hbh-extensions-01

Hi Giuseppe,

Thanks,
Tianran

-----Original Message-----
From: ippm [mailto:[email-masked]] On Behalf Of wangyali
Sent: Tuesday, November 10, 2020 9:16 AM
To: Giuseppe Fioccola <[email-masked]>; ippm <[email-masked]>
Subject: Re: [ippm] New Version for draft-wang-ippm-stamp-hbh-extensions-01

Hi Giuseppe,

Thanks,

-----Original Message-----
From: Giuseppe Fioccola 
Sent: Wednesday, November 4, 2020 5:43 PM
To: wangyali <[email-masked]>; ippm <[email-masked]>
Subject: RE: New Version for draft-wang-ippm-stamp-hbh-extensions-01

Hi Yali, All,

Regards,

Giuseppe

-----Original Message-----
From: ippm [mailto:[email-masked]] On Behalf Of wangyali
Sent: Tuesday, October 27, 2020 2:49 PM
To: ippm <[email-masked]>
Subject: [ippm] New Version for draft-wang-ippm-stamp-hbh-extensions-01

Hello WG,

What do you think? 

Best regards,
Yali

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Tuesday, October 27, 2020 9:03 PM
To: wangyali <[email-masked]>; Tianran Zhou <[email-masked]>
Subject: New Version Notification for draft-wang-ippm-stamp-hbh-extensions-01.txt

Abstract:

The IETF Secretariat

---

From: Chang Liu(联通集团中国联通研究院-本部) <[email-masked]>
Date: Fri, 13 Nov 2020 09:23:02 +0000

Hi Yali,

I have read the draft and have some questions.

1.What is the method by which the intermediate nodes obtain the timestamp? Hardware or Software?

It is recommended to add clarifications that the intermediate node obtain the timestamp in the same way as the STAMP sender and reflector.

2.Is it necessary that every intermediate node should support the same kind of clock source?

How to check timestamp information supported by every intermediate node in a case that the type of clock source supported by every intermediate node is different from that supported by the STAMP sender/reflector?

Thanks

________________________________
Liu Chang
China Unicom
Email: [email-masked]
Phone: +8618601102572

What do you think?

Best regards,
Yali

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, October 27, 2020 9:03 PM
To: wangyali <[email-masked]>; Tianran Zhou <[email-masked]>
Subject: New Version Notification for draft-wang-ippm-stamp-hbh-extensions-01.txt

Abstract:

The IETF Secretariat

_______________________________________________
ippm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ippm
如果您错误接收了该邮件，请通过电子邮件立即通知我们。请回复邮件到 [email-masked]，即可以退订此邮件。我们将立即将您的信息从我们的发送目录中删除。 If you have received this email in error please notify us immediately by e-mail. Please reply to [email-masked] ,you can unsubscribe from this mail. We will immediately remove your information from send catalogue of our.

---

From: wangyali <[email-masked]>
Date: Mon, 16 Nov 2020 01:47:17 +0000

Hi Chang,

Thanks for your review and commends. Please check inline [Yali].
I’m appreciated that you are interested in joining in this work.

From: Chang Liu(联通集团中国联通研究院-本部) [mailto:[email-masked]]
Sent: Friday, November 13, 2020 5:23 PM
To: wangyali <[email-masked]>; ippm <[email-masked]>
Subject: Re: [ippm] New Version for draft-wang-ippm-stamp-hbh-extensions-01

Hi Yali,

[Yali] Have been clarified in the latest version https://tools.ietf.org/html/draft-wang-ippm-stamp-hbh-extensions-02#page-5 that “Note that the source of clock synchronization, NTP or PTP, is part of configuration of the Session-Sender/Reflector or a particular test session [RFC8762].  This draft recommends every intermediate nodes to be configured to use the same source of clock synchronization.”

[Yali] This draft recommends every intermediate nodes to be configured to use the same source of clock synchronization. In the latest version, a new HbH Timestamp Information TLV is defined to query the ingress and egress Timestamp Information at every intermediate nodes along the forward path. The Timestamp Information includes the source of clock synchronization and the method of timestamp obtainment. The method of timestamp obtainment may be from control plane (e.g.  NTP) or from data plane (e.g.  PTP).

Thanks

________________________________
Liu Chang
China Unicom
Email: [email-masked]<mailto:[email-masked]>
Phone: +8618601102572

What do you think?

Best regards,
Yali

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
Sent: Tuesday, October 27, 2020 9:03 PM
To: wangyali <[email-masked]<mailto:[email-masked]>>; Tianran Zhou <[email-masked]<mailto:[email-masked]>>
Subject: New Version Notification for draft-wang-ippm-stamp-hbh-extensions-01.txt

Abstract:

The IETF Secretariat

_______________________________________________
ippm mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ippm
如果您错误接收了该邮件，请通过电子邮件立即通知我们。请回复邮件到 [email-masked]，即可以退订此邮件。我们将立即将您的信息从我们的发送目录中删除<mailto:[email-masked]，即可以退订此邮件。我们将立即将您的信息从我们的发送目录中删除>。 If you have received this email in error please notify us immediately by e-mail. Please reply to [email-masked]<mailto:[email-masked]> ,you can unsubscribe from this mail. We will immediately remove your information from send catalogue of our.