Subject: Re: [ippm] Call for adoption: draft-geib-ippm-connectivity-monitoring

From: <[email-masked]>
Date: Mon, 2 Nov 2020 08:02:37 +0000

Hi Tommy,

As author I support adoption and thank for the call for adoption.

Could you kindly repeat the call for adoption with the correctly set hyperlink (the one below links to https://tools.ietf.org/html/draft-zhou-ippm-ioam-yang-08 - at least in my Email-application).

Regards,

Rüdiger

Von: ippm <[email-masked]> Im Auftrag von Tommy Pauly
Gesendet: Freitag, 30. Oktober 2020 19:44
An: IETF IPPM WG ([email-masked]) <[email-masked]>
Cc: IPPM Chairs <[email-masked]>
Betreff: [ippm] Call for adoption: draft-geib-ippm-connectivity-monitoring

Hello IPPM,

This email starts a Working Group call for adoption for draft-geib-ippm-connectivity-monitoring. This document has been presented several times and discussed within the working group.

The document can be found here:

https://tools.ietf.org/html/draft-geib-ippm-connectivity-monitoring-03<https://tools.ietf.org/html/draft-zhou-ippm-ioam-yang-08>

Please provide your feedback on these document, and state whether or not you believe the IPPM WG should adopt this work by replying to this email. Please provide your feedback by the start of the IETF 109 meeting week, on Monday, November 16.

Best,
Tommy & Ian

---

From: Tommy Pauly <[email-masked]>
Date: Mon, 02 Nov 2020 06:16:55 -0800

> On Oct 30, 2020, at 11:43 AM, Tommy Pauly <tpauly=[email-masked]> wrote:
> 
> Hello IPPM,
> 
https://tools.ietf.org/html/draft-geib-ippm-connectivity-monitoring-03 <https://tools.ietf.org/html/draft-geib-ippm-connectivity-monitoring-03>

(Corrected link)

> _______________________________________________
> ippm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ippm

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Mon, 16 Nov 2020 01:08:29 +0000

Hi Tommy and Ian,

I'm writing to express some support for Rüdiger's draft:
    draft-geib-ippm-connectivity-monitoring

I would like to see the draft clarified in a few areas, concentrating on section 3.

Section 3, titled
"Singleton Definition for Type-P-SR-Path-Connectivity-and-Congestion"

It seems that this metric will need to represent both loss and delay to infer connectivity and congestion, starting in section 3.3.

In 3.2,
o  lambda, a rate in reciprocal seconds
and
o  DS, a constant time interval between two type-P packets
seem to specify the same stream parameter, except that lambda is usually associated with Poisson streams, and a constant time interval is for periodic streams.  Maybe both are possible, but not at the same time.

In 3.3.  Metric Units

   A sequence of consecutive time values.

There are still units missing (seconds for delay change from the average?), and loss count or loss ratio.  These two different dimensions need to be represented, and then connectivity and congestion need to be teased apart (both can cause loss).

In 3.4.  Definition,
It would be good to see  more details on the moving average, starting with a parameter in 3.2 that describes the window of the moving average, and an equation or reference for the "change point detection algorithm".

Al

From: ippm [mailto:[email-masked]] On Behalf Of Tommy Pauly
Sent: Monday, November 2, 2020 9:17 AM
To: Tommy Pauly <tpauly=[email-masked]>
Cc: IPPM Chairs <[email-masked]>; IETF IPPM WG ([email-masked]) <[email-masked]>
Subject: Re: [ippm] Call for adoption: draft-geib-ippm-connectivity-monitoring

On Oct 30, 2020, at 11:43 AM, Tommy Pauly <tpauly=[email-masked]<mailto:tpauly=[email-masked]>> wrote:

Hello IPPM,

https://tools.ietf.org/html/draft-geib-ippm-connectivity-monitoring-03<https://urldefense.com/v3/__https:/tools.ietf.org/html/draft-geib-ippm-connectivity-monitoring-03__;!!BhdT!xmoDNYcITe5jIvB-8VT1y7JYGKB_AxqsycgeMc6gSiCtEw-USfnrJ0k1Quiq$>

(Corrected link)

Best,
Tommy & Ian
_______________________________________________
ippm mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ippm<https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/ippm__;!!BhdT!xmoDNYcITe5jIvB-8VT1y7JYGKB_AxqsycgeMc6gSiCtEw-USfnrJ0nb1WfY$>

---

From: <[email-masked]>
Date: Mon, 16 Nov 2020 12:00:00 +0000

Hi Al,

thanks, I'll try to incorporate your comments for the next version. I prefer constant bit-rate measurements, so I'll remove lambda.

I'll also have a closer look at the change point detection and add some text.

Regards,

Ruediger

Von: ippm <[email-masked]> Im Auftrag von MORTON, ALFRED C (AL)
Gesendet: Montag, 16. November 2020 02:08
An: Tommy Pauly <tpauly=[email-masked]>
Cc: IPPM Chairs <[email-masked]>; IETF IPPM WG ([email-masked]) <[email-masked]>
Betreff: Re: [ippm] Call for adoption: draft-geib-ippm-connectivity-monitoring

Hi Tommy and Ian,

Section 3, titled

In 3.2,

In 3.3.  Metric Units

In 3.4.  Definition,

Al

From: ippm [mailto:[email-masked]] On Behalf Of Tommy Pauly
Sent: Monday, November 2, 2020 9:17 AM
To: Tommy Pauly <tpauly=[email-masked]<mailto:tpauly=[email-masked]>>
Cc: IPPM Chairs <[email-masked]<mailto:[email-masked]>>; IETF IPPM WG ([email-masked]<mailto:[email-masked]>) <[email-masked]<mailto:[email-masked]>>
Subject: Re: [ippm] Call for adoption: draft-geib-ippm-connectivity-monitoring

Hello IPPM,

(Corrected link)

Best,
Tommy & Ian