Subject: [ippm] Quick comment on draft-ietf-ippm-ioam-data-11

From: <[email-masked]>
Date: Tue, 5 Jan 2021 10:34:25 +0800 (CST)

Hi authors,

While updating "IOAM over BIER" draft, I noticed that in Section 8.1 of IOAM-Data draft 128 code points are defined for IOAM Option-Type Registry, nevertheless in whether draft-ietf-ippm-ioam-ipv6-options or draft-ietf-sfc-ioam-nsh, IOAM Type is an 8-bit field, could 256 code points instead of 128 code points be defined?

Best Regards,
Xiao Min

---

From: "Frank Brockners (fbrockne)" <[email-masked]>
Date: Wed, 6 Jan 2021 17:14:20 +0000

Hi Xiao Min,

the 7-bit wide registry for IOAM-Option-Types is because some protocols, like e.g. Geneve, only offer room for 7 bits.
See https://tools.ietf.org/html/draft-brockners-ippm-ioam-geneve-05#section-3
“   Type:  8-bit field defining the IOAM Option type, as defined in
      Section 7.2 of [I-D.ietf-ippm-ioam-data].  The 'C' bit MUST be set
      to zero.”

This requirement drove the change from 8 to 7 bits – back in March 2018, see:
https://github.com/inband-oam/ietf/commit/22b33b12863fa62dd80d47a00b859bce82b69e60
“IOAM-Type code point reduced from 256 -> 128 to handle encaps like Geneve where top bit in type reserved.”
(Thanks to Shwetha for digging up the reference).

Cheers, Frank

From: ippm <[email-masked]> On Behalf Of [email-masked]
Sent: Dienstag, 5. Januar 2021 03:34
To: [email-masked]
Subject: [ippm] Quick comment on draft-ietf-ippm-ioam-data-11

Hi authors,

Best Regards,
Xiao Min

---

From: <[email-masked]>
Date: Thu, 7 Jan 2021 11:33:43 +0800 (CST)

Hi Frank and Shwetha,

Thank you for the clear explanation.
Considering the IOAM-Data draft is the IOAM base document referenced by many other drafts, it would be nice if you can add some text to explain it, otherwise I suspect that the question shall be brought up again sometime.

Best Regards,
Xiao Min

原始邮件

发件人：FrankBrockners(fbrockne)
收件人：肖敏10093570;[email-masked];
抄送人：[email-masked];
日 期 ：2021年01月07日 01:14
主 题 ：RE: [ippm] Quick comment on draft-ietf-ippm-ioam-data-11

Hi Xiao Min,

      to zero.”

 

Cheers, Frank

 

Hi authors,

 Best Regards,
 Xiao Min

---

From: "Frank Brockners (fbrockne)" <[email-masked]>
Date: Thu, 7 Jan 2021 07:33:01 +0000

Hi Xiao Min,

Sure thing. We can add the explanation to the next rev.

Cheers, Frank

From: [email-masked] <[email-masked]>
Sent: Donnerstag, 7. Januar 2021 04:34
To: Frank Brockners (fbrockne) <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: Re:[ippm] Quick comment on draft-ietf-ippm-ioam-data-11

Hi Frank and Shwetha,

Best Regards,
Xiao Min
原始邮件
发件人：FrankBrockners(fbrockne)
收件人：肖敏10093570;[email-masked];
抄送人：[email-masked]<mailto:[email-masked]>;
日 期 ：2021年01月07日 01:14
主 题 ：RE: [ippm] Quick comment on draft-ietf-ippm-ioam-data-11
Hi Xiao Min,

Cheers, Frank

From: ippm <[email-masked]<mailto:[email-masked]>> On Behalf Of [email-masked]<mailto:[email-masked]>
Sent: Dienstag, 5. Januar 2021 03:34
To: [email-masked]<mailto:[email-masked]>
Subject: [ippm] Quick comment on draft-ietf-ippm-ioam-data-11

Hi authors,

Best Regards,
Xiao Min