Subject: Naive, over-general policies: RF-only, RAND-only doesn't make sense..

From: "Bob Wyman" <[email-masked]>
Date: Fri, 21 Feb 2003 12:19:22 -0500

To argue that RF is preferable is reasonable. To argue that RAND is
*never* acceptable is not reasonable. In fact, even to argue that RAND
is the minimum acceptable would not be reasonable. To understand why
this is true, you must look at the extremes... (i.e consider "extremely
'good,' 'novel,' and 'broad' patents)
    Typically, technology patents, especially software patents, apply to
some tightly defined technological domain and typically there are
alternative methods which, while they may result in less desirable
implementations than those which could be created using the patented
method, are still useful substitutes for the patented method. Rarely is
a patent on technology so fundamental, so brilliantly insightful, broad
and novel, that the monopoly granted as a result of the patent excludes
non-licensees from an entire application domain. In the language of
patent attorneys... the "market power" of most patents is limited in
scope since the technological domain controlled by the patent is rarely
coextensive with an economic product market.
    However, a small number of patents do, or could, reach the level of
being so fundamental that reasonable or acceptable solutions simply
cannot be achieved without infringement or licensing. The scope of such
patents is or would be "coextensive with an economic product market." 
    At the risk of suggesting a hypothetical... Imagine that a patent
had been granted on the base method of using public/private key pairs
rather than RSA having received a patent on just a particularly good
method for generating such keys. We would have been in a situation where
it was generally agreed that the only reasonable way to solve quite a
range of problems was to use the patented method. (Please! Don't argue
this point. Just accept it for discussion purposes...) In this case, one
could not have argued with RAND licensing of the core patent as there
would be no acceptable alternative. In fact, while we would have
complained about terms much less favorable than RAND, it still would
have been reasonable to accept them -- if they were the best we could
get. And, it would have been reasonable for the IETF to generate
standards to establish interoperability among those who licensed this
key technology. Similarly, if the BT patent on Hypertext had turned out
to be useful, we would have had the choice to accept the terms they
dictated, or not build hypertext systems. In this case, the value of
Hypertext systems would have been great enough to force us to swallow
our principles and pay whatever royalties BT demanded...
    This sort of "fundamental" patent is different from the sort of
patent that covered GIF. In that case, there were alternatives or
alternatives could be created. Boutell and others could see that what
GIF provided was a desirable result and could then create the PNG
alternative that gave, in my opinion, superior results without
infringing on the GIF patents. Certainly, when such creation of
alternatives is possible, it should be pursued. In this way, we might
even "welcome" IPR claims since they force us to be creative...
    The point of this message is simply to say that a flat,
uncompromising "no RAND" or "RF-only" policy is simply naive. It may be
a great goal to shoot for, but it isn't always possible. Fortunately,
most methods that are reasonably patented have at least acceptable
substitutes that are either known or that can be discovered.
Nonetheless, this is not always the case and should be acknowledged.
 
        bob wyman

---

From: Eric Rescorla <[email-masked]>
Date: 21 Feb 2003 09:51:50 -0800

"Bob Wyman" <[email-masked]> writes:
> key technology. 
In fact, this was the case. The original Merkle-Hellman patent
allegedly covered all of public key cryptography, and the IETF
behaved roughly as you describe.

-Ekr

-- 
[Eric Rescorla                                   [email-masked]]
                http://www.rtfm.com/
_______________________________________________
Ipr-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipr-wg

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 24 Feb 2003 10:07:15 +0100

Bob,

I couldn't have said it better. This is exactly why we evolved the current
IETF policy, and why it works (and has not stopped the open source
community from flourishing in a world that runs on IETF protocols).

  Brian

> Bob Wyman wrote:
> 
>     To argue that RF is preferable is reasonable. To argue that RAND is *never* acceptable is not reasonable. In fact, even to
> argue that RAND is the minimum acceptable would not be reasonable. To understand why this is true, you must look at the
> extremes... (i.e consider "extremely 'good,' 'novel,' and 'broad' patents)
>     Typically, technology patents, especially software patents, apply to some tightly defined technological domain and
> typically there are alternative methods which, while they may result in less desirable implementations than those which could
> be created using the patented method, are still useful substitutes for the patented method. Rarely is a patent on technology
> so fundamental, so brilliantly insightful, broad and novel, that the monopoly granted as a result of the patent excludes
> non-licensees from an entire application domain. In the language of patent attorneys... the "market power" of most patents is
> limited in scope since the technological domain controlled by the patent is rarely coextensive with an economic product
> market.
>     However, a small number of patents do, or could, reach the level of being so fundamental that reasonable or acceptable
> solutions simply cannot be achieved without infringement or licensing. The scope of such patents is or would be "coextensive
> with an economic product market."
>     At the risk of suggesting a hypothetical... Imagine that a patent had been granted on the base method of using
> public/private key pairs rather than RSA having received a patent on just a particularly good method for generating such
> keys. We would have been in a situation where it was generally agreed that the only reasonable way to solve quite a range of
> problems was to use the patented method. (Please! Don't argue this point. Just accept it for discussion purposes...) In this
> case, one could not have argued with RAND licensing of the core patent as there would be no acceptable alternative. In fact,
> while we would have complained about terms much less favorable than RAND, it still would have been reasonable to accept them
> -- if they were the best we could get. And, it would have been reasonable for the IETF to generate standards to establish
> interoperability among those who licensed this key technology. Similarly, if the BT patent on Hypertext had turned out to be
> useful, we would have had the choice to accept the terms they dictated, or not build hypertext systems. In this case, the
> value of Hypertext systems would have been great enough to force us to swallow our principles and pay whatever royalties BT
> demanded...
>     This sort of "fundamental" patent is different from the sort of patent that covered GIF. In that case, there were
> alternatives or alternatives could be created. Boutell and others could see that what GIF provided was a desirable result and
> could then create the PNG alternative that gave, in my opinion, superior results without infringing on the GIF patents.
> Certainly, when such creation of alternatives is possible, it should be pursued. In this way, we might even "welcome" IPR
> claims since they force us to be creative...
>     The point of this message is simply to say that a flat, uncompromising "no RAND" or "RF-only" policy is simply naive. It
> may be a great goal to shoot for, but it isn't always possible. Fortunately, most methods that are reasonably patented have at
> least acceptable substitutes that are either known or that can be discovered. Nonetheless, this is not always the case and
> should be acknowledged.
> 
>         bob wyman
>