Subject: Correction...The IBM PC was announced in August 1981

From: "Jim Fleming" <[email-masked]>
Date: Tue, 25 Feb 2003 06:05:02 -0600

Correction...The IBM PC was announced in August 1981

====

It is easy to lose 10 years when one sees how far the I* society has set the world back...

----- Original Message -----
From: "Jim Fleming" <[email-masked]>
To: <[email-masked]>; <[email-masked]>
Sent: Tuesday, February 25, 2003 5:51 AM
Subject: Re: Genesis of open source

> With all due respect...the open source movement was alive and well in the mid-70s.
> People mostly sat in the same room at Bell Labs making the sneaker-net the means of exchange.
> People did know what they were doing, and still do it to this day. They no longer have to sit in
> the same room, because by the end of the 70's they (we) had deployed systems such as ihnss
> to carry uucp traffic across the country. By that time, web browser technology was under development
> with color graphics, sound, etc. The IBM PC was announced in August 1991, and set the world
> back several years. The lack of leading edge graphics and audio in the early PCs spawned an entire
> industry to fix those limitations. The lack of a real O/S spawned more companies to port Uni* to the
> PCs, using open source from the mid 70's. By 1984, we had LAN-based telephones, running on
> open source Uni* platforms. The Unir Project was started in 1982, and was documented in Dr. Dobb's
> Journal. One of the early techniques attempted was to give everyone a view that they had their own
> Uni* root (shades of current day UML - User Mode Linux). One of the flaws in doing that in the early
> 80's was a bug (feature) that allowed people to change directory out of their change rooted, walled-garden
> file system. Open source allowed us to fix that, recompile and continue. People knew what they were
> doing and still know what they are doing...between 1984 and 1992 people recognized the need to move
> **away from the protocol point of view** to the **platform point of view**...you can see the difference
> by drawing two sets of rectangles...in one case side by side with a line between them...and in the other
> case above and below each other with lines showing what some call an API. In the protocol view, people
> focus on the bits and formats of the exchanges of the side-by-side boxes and lose track of the services
> and the functionality they are trying to provide...in the **platform view**...there is more of an emphasis
> on what the layers provide...the O/S and micro-kernals and device drivers become more interesting...
> ...once the layering is worked out, a variety of protocols can be used to connect them...
>
> ....between 1984 and 1992...the shift to the platform point of view...also brought with it a shift to a focus
> on **A Network of Communicating Objects** (Smalltalk...C++...C+@...Java...C#...C@T)...
>
> ...the I* society (small s...aka the Big Lie Society)...attempts to do ethnic cleansing...to rewrite history...
> ...good luck...
>
> http://www.ddj.com/articles/1993/9310/
> http://www.computer.org/software/so1991/s3073abs.htm
> http://msdn.microsoft.com/net/ecma/
>
> http://IPv8.no-ip.com
> http://www.go-mono.com/
> http://www.knoppix.com
> http://www.netfilter.org
> http://www.digium.com
> http://www.asterisk.org
> http://www.openss7.org
> http://www.zapatatelephony.org
> http://www.new.net
> http://IPv8.dyn.ee
>
> Jim Fleming
> [email-masked] Consultant
> http://www.Unir.NET
> http://www.Unir.com
> http://www.Uni%ae.com
> http://www.Uni®.com
>
>
> ----- Original Message -----
> From: "Eric S. Raymond" <[email-masked]>
> To: "John C Klensin" <[email-masked]>
> Cc: "Keith Moore" <[email-masked]>; <[email-masked]>
> Sent: Saturday, February 22, 2003 7:21 PM
> Subject: Genesis of open source
>
>
> > John C Klensin <[email-masked]>:
> > > >the idea of open source actually goes back much farther than
> > > >[the 1970s], to the days when card decks, mag tapes, and paper tapes
> > > >were freely swapped among institutions with similar kinds of
> > > >computers.  open source predated  closed source much as folk
> > > >music predated commercial music.
> > >
> > > [...] In many cases, those cards and tapes contained binaries, not source
> > > (although, in many others, source was included).  More
> > > important, in the first generation of the type of swapping to
> > > which you refer, applications were being swapped, but those
> > > applications often ran only on very proprietary,
> > > bundled-with-the-hardware, operating systems and utilities.  Was
> > > there "open source" around before there were [commercial]
> > > operating systems?  Possibly, but I'm not old enough to remember
> > > -- if you go back that far, the number of institutions around
> > > with compatible computers was not very large.
> >
> > Indeed.  In my capacity as a historian, I have considered this matter
> > in some depth.  I *am* old enough to remember, I have supplemented
> > those memories with research, and I think John's objections are
> > cogent.  I would go further and add source code being routinely
> > exchanged *over a network* as a necessary condition for the existence
> > of an "open source" culture.
> >
> > Why insist on this?  Because older methods (physical exchange of
> > tapes/disks etc.) had sufficiently high setup costs that their effect
> > on the way people did programming day-to-day was marginal.  We
> > couldn't systain anything like today's large decentralized projects
> > peer-review-centered development practice because the feedback loops
> > were too slow.
> >
> > So even if computing environments had been sufficiently homogenous
> > to support it (which they weren't) and even if it had been routine to
> > pass around source code (which it wasn't) the *communications*
> > infrastructure to support the open-source community did not come
> > into being until rather late.
> >
> > It's tempting to put the open-source community's year zero in 1969,
> > the same year Unix and the ARPANET launched.  But not until ten years
> > later (when systems programming was routinely done in HLLs and FTP
> > sites began to overhaul archive tapes as the principal means of
> > software exchange) did anything recognizably like today's open-source
> > culture emerge -- around the early USENET, as it happens.  I had been
> > watching the hacker culture evolve since 1976.  USENET made a
> > difference because (unlike the ARPANET) it didn't have even
> > theoretical restrictions on who could use it.
> >
> > A strong argument could be made that open-source development *practice*
> > began in 1984, the year Larry Wall released patch.  That was the tool
> > that made it possible for multiple diverging lines of development to
> > routinely *reconverge* -- essential to modern open-source development.
> >
> > To sum up some critical dates:
> >
> > 1961 -- birth year of today's hacker culture (PDP-1 delivered to MIT)
> > 1969 -- Unix and ARPANET launched.
> > 1979 -- USENET launched.  Network software distribution begins to
> >         seriously displace schlepping physical media around.
> > 1984 -- patch(1) invented
> >
> > We can't properly say that 1961 was the birth of the open-source
> > culture, for reasons I've already gone into.  The spirit was
> > there, in some respects, but the technology to make it into a form
> > of practice recognizably continuous with modern open source
> > didn't exist.  That technology was born in 1969 but didn't mature
> > enough to enable a widespread change in practice until after 1979.
> >
> > I'd say 1984 is too late; I, personally, was already writing and
> > distributing open-source software in a recognizably modern way by
> > mid-1982 -- but at that time it *was* a rather novel thing to be doing.
> >
> > I was hacking modes for Gosling Emacs, which dated from 1981.  I think
> > Gosmacs may well qualify as the first major project of the nascent
> > open-source community; it is the oldest piece of open-source code I am
> > aware of that has a continuous history of descendant usage to the
> > present (though it is possible that some of the earliest Berkeley Unix
> > stuff with descendant code still in use dates two or three uears
> > earlier, and I would cheerfully accept correction on this score)
> >
> > I understand the urge to project open-source development further
> > back in time and onto other creative media, but I think that's
> > a form of romantic idealism that obscures the most interesting and
> > characteristic features of the phenomenon.
> >
> > In particular, I have very little patience for the myth that modern
> > open source represents a return to some Edenic age of open-source
> > innocence before IBM unbundled its operating system or Bill Gates
> > sent the hobbyists a nasty letter or whatever.  It *wasn't the same*
> > back then; with only minor marginal exceptions, we didn't have source
> > code, we didn't have networks -- and, even if we had, we didn't
> > know what we were doing!
> >
> > Consciousness and culture make a difference.
> > --
> > <a href="http://www.catb.org/~esr/">Eric S. Raymond</a>
> > _______________________________________________
> > Ipr-wg mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/ipr-wg
> >
>

_______________________________________________
Ipr-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipr-wg

---

From: "Eric Burger" <[email-masked]>
Date: Thu, 27 Feb 2003 17:14:49 -0500

As I remember from hacking Unix in the mid 1970's, "open source", for an educational institution, cost a paltry $50,000.  At the time, I compared that to 4k-BASIC (MS).  Bell Labs expected you to copy it, so they charged enough to get something back.  MS, on the other hand, made it cheaper to buy the paper tape than it would be to copy it.

So, did anyone have "free" access to Unix source code outside of Bell Labs?  Please don't confuse your institution paying for a source license ("Well, *I* didn't pay for it") or someone stealing (I mean copying) the source.

In today's dollars, the Unix source license cost would be like asking $750,000 for a Linux source distribution.  That's far from open source...

> -----Original Message-----
> From: Jim Fleming [mailto:[email-masked]]
> Sent: Tuesday, February 25, 2003 7:05 AM
> To: [email-masked]; [email-masked]
> Subject: Correction...The IBM PC was announced in August 1981
> 
> 
> > industry to fix those limitations. The lack of a real O/S 
> spawned more companies to port Uni* to the
> > Uni* root (shades of current day UML - User Mode Linux). 
> One of the flaws in doing that in the early
> > 80's was a bug (feature) that allowed people to change 
> directory out of their change rooted, walled-garden
> > **away from the protocol point of view** to the **platform 
> point of view**...you can see the difference
> > by drawing two sets of rectangles...in one case side by 
> side with a line between them...and in the other
> > case above and below each other with lines showing what 
> some call an API. In the protocol view, people
> > focus on the bits and formats of the exchanges of the 
> side-by-side boxes and lose track of the services
> > and the functionality they are trying to provide...in the 
> **platform view**...there is more of an emphasis
> > on what the layers provide...the O/S and micro-kernals and 
> device drivers become more interesting...
> > ....between 1984 and 1992...the shift to the platform point 
> of view...also brought with it a shift to a focus
> > on **A Network of Communicating Objects** 
> (Smalltalk...C++...C+@...Java...C#...C@T)...
> >
> > ...the I* society (small s...aka the Big Lie 
> Society)...attempts to do ethnic cleansing...to rewrite history...
> > ...good luck...
> >