Subject: RE: The Law... Definition of Derivative Claims...

From: "Contreras, Jorge" <[email-masked]>
Date: Tue, 24 Jan 2006 22:22:37 -0500

I agree that the IETF's procedures regarding outbound
license rights need to be clearer.  However, I don't agree
with Larry's argument that the copyright "merger" doctrine
automatically negates the copyright in standards documents that
are intended to be implemented.  That position is certainly 
advantageous to the open source movement, but is not, in my view,
a settled or generally-accepted principle of law.  Copyright 
exists in computer code, even though the code is intended to
be executed.  There is no reason why protocols and code embedded
in standards should not also have the same level of copyright
protection.

Larry claims that this interpretation would give copyright 
"way too much power to control technology".  This, however, is a policy argument,
not a legal argument.  I am not aware that courts have yet
adopted this limiting view of copyright. 

This being said, I also disagree with Todd's position that
every implementation of a standard constitutes a derivative
work of the text of the standard.  Copyright only protects
text, not the ideas described by text (which are protectable
by patent).

Given this level of disagreement on the basic legal principles
that apply, it is doubly important that the language of the
IETF's IPR policies be as clear as possible.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf
Of Lawrence Rosen
Sent: Wednesday, January 18, 2006 7:37 PM
To: [email-masked]
Subject: RE: The Law... Definition of Derivative Claims...

> I am asserting that derivative rights are needed to republish 
> in any excerpted form other than as the 'whole enchiladas'... 
> And that if a version of the protocol is implemented using 
> those mnemonics and notations, that it will indeed violate 
> the copyright against that.

To the extent that copying an expressive piece of code is necessary for an
implementation of a functional protocol in a published standard that we
*intend* to be implemented, copyright can't prevent the copying. This is
based on the "merger doctrine," as expressed in the section of the Copyright
Act that Harald previously referenced. And when a change to that code is
required in order to achieve a functional result, that change can't be
prevented based on an exclusive right to create derivative works.

That would give long-term copyright way too much power to control
technology. The law doesn't countenance that. If you want your software
ideas not to be copied and evolved, either keep them secret or patent them;
don't expect copyright law to help you.

IETF's current procedures for in-bound and out-bound IP are not clear about
this. That's why I'm delighted that this working group is trying to clean up
those procedures.

/Larry

Lawrence Rosen
Rosenlaw & Einschlag, technology law offices (www.rosenlaw.com)
Stanford University School of Law, Lecturer in Law
3001 King Ranch Road, Ukiah, CA 95482
707-485-1242  *  fax: 707-485-1243
Author of "Open Source Licensing: Software Freedom and 
   Intellectual Property Law" (Prentice Hall 2004) 
   [Available also at www.rosenlaw.com/oslbook.htm]

_______________________________________________
Ipr-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipr-wg

---

From: "todd glassey" <[email-masked]>
Date: Tue, 24 Jan 2006 23:37:43 -0800

---SNIP---

Jorge - the IETF's processes for the creation of a Internet Standard require
two physical implementations of a protocol be built and tested for
interoperability. This requires something more than copyright licensing
period. We are not talking about the RFC republishing rights, but rather
that which are required by the Internet Standards Process.

Todd Glassey

-----Original Message-----

/Larry

Lawrence Rosen