Subject: Re: GPL and Status summary, IPR WG

From: [email-masked]
Date: Mon, 09 Jan 2006 14:47:11 +0000

The core problem is that the IP is being contributed to the IETF under the expectation that it is there for vetting, and that as such it will be allowed to be advanced in the Standards Process. Neither of which are necessarily true.

That said, if the conveyance of the IP to the IETF cannot be secured, as to what the people submitting it, get for that submission, then you may have some chance of successfully creating a set of licnse models where GPL can be respected. The obvious fix for this is to create a GPL conveyance agreement as one of the submission agreements in RCC2026... and by the way - the IETF's still posting RFC20206 as the sole document describing IETF standards process as of this morning made that the rule of the day so to speak. Check the IETF Website - RFC2026 is listed as the only standard process description as the link from the website.

Anyway, if you want people to have a GPL use model then there needs to be a GPL submission model to support that, since the entirety of the IETF's IP portfolio today was contributed for the sole purpose of vetting and use in a standards process, which is not what the IETF is allowing when it allows Debian or Sun to republish these documents outside of that Standars's development process.

Todd Glassey
 -------------- Original message ----------------------
From: Jeremy Hunsinger <[email-masked]>
> I'm  not sure why we are talking about licenses for the code.  Wasn't  
> Harald's point less about what the code is being released under, and  
> more about what it had to be compatible with?   the code has to be  
> usable in gpl'd applications, just like it has to be usable in eula'd  
> applications.   I'm not sure why we are talking about a release  
> license for this code and not talking about provisions of copyright  
> for this code.    there should be consensus in that the code as  
> released has to be universally usable and editable, but not re- 
> releasable as rfc or id after that, without specific permission.
> 
> 
> Jeremy Hunsinger
> Center for Digital Discourse and Culture
> () ascii ribbon campaign - against html mail
> /\ - against microsoft attachments
> 
> http://www.aoir.org The Association of Internet Researchers
> http://www.stswiki.org/ stswiki
> 
> 
> 
> _______________________________________________
> Ipr-wg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ipr-wg

_______________________________________________
Ipr-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipr-wg

---

From: Jeremy Hunsinger <[email-masked]>
Date: Mon, 9 Jan 2006 10:35:11 -0500

>
> Anyway, if you want people to have a GPL use model then there needs  
> to be a GPL submission model to support that, since the entirety of  
> the IETF's IP portfolio today was contributed for the sole purpose  
> of vetting and use in a standards process, which is not what the  
> IETF is allowing when it allows Debian or Sun to republish these  
> documents outside of that Standars's development process.

I'm missing some of the logic here I think.   Code does not have to  
be gpl's before it is included into a gpl application, but with the  
release of the gpl'd application the code then is gpl and has to be  
provided.  You do not have to gpl the egg in order to get a gpl'd  
chicken so to speak.  Anything that is compatible with the open re- 
release of code should be fine.   There are many possibilities for  
accomplishing that licensed or not.  As for the republishing of RFC's  
and I-D's,  isn't that more of an issue of copyright?

Jeremy Hunsinger