Subject: RE: I-D ACTION:draft-ietf-ipr-rules-update-07.txt

From: "Contreras, Jorge" <[email-masked]>
Date: Tue, 25 Jul 2006 17:01:43 -0400

All,

I thought it would be helpful to explain the rationale 
behind, and the differences between, the attached I-D 
(ipr-rules-update-07) and trust-update-00.txt that was released
on Friday.  Both are intended to update RFC 3978 to address
the creation of the IETF Trust.

trust-update-00 just substitutes "IETF Trust" for "ISOC" in 
various parts of RFC 3978.  This is intended to be the bare
minimum necessary to reflect the Trust's existence.  Otherwise,
it leaves the structure of RFC 3978 (including its warts and
problems) fully intact.  

ipr-rules-update-07 more fully implements the structure intended
to be achieved with the Trust (i.e., licenses flow from Contributors
to the Trust to IETF participants).  It also addresses some of the
(I believe) non-controversial corrections to RFC 3978 that have
been raised over the past several months by Simon J. and others.
(for example, it clarifies that the "extraction" right applies
to everyone in the world, and not just to IETF participants).

ipr-rules-update-07 does NOT attempt to solve the more controversial
issues that have been discussed in this WG.  It does not attempt
to dictate "outbound" rights, other than the rights that are
widely agreed to exist (i.e., rights for IETF participants to
operate within the IETF standards process, rights for everyone
to extract code segments, rights for everyone to translate and 
reproduce unmodified RFCs).  

It was made clear during the WG meeting in Montreal that 
something needs to be done pretty quickly to deal with the
creation of the Trust (which actually happened last December).
I am hopeful that we can achieve consensus around ipr-rules-update-07
to add the Trust into the loop and to correct some of the more
obvious problems that have been identified.  If, however, we
can't agree on even the modest corrections that are in this draft,
we really should move ahead with trust-update-00.

Jorge

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Tuesday, July 25, 2006 3:50 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: I-D ACTION:draft-ietf-ipr-rules-update-07.txt 
> 
> 
> A New Internet-Draft is available from the on-line 
> Internet-Drafts directories.
> This draft is a work item of the Intellectual Property Rights 
> Working Group of the IETF.
> 
> 	Title		: RFC 3978 Update
> 	Author(s)	: S. Bradner, et al.
> 	Filename	: draft-ietf-ipr-rules-update-07.txt
> 	Pages		: 8
> 	Date		: 2006-7-25
> 	
> This document modifies RFC 3978 "IETF Rights in Contributions" by
>    recognizing that the IETF Trust is now the proper custodian of all
>    IETF-related intellectual property rights.
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-ietf-ipr-rules-update-07.txt
> 
> To remove yourself from the I-D Announcement list, send a message to 
> [email-masked] with the word unsubscribe in 
> the body of the message.  
> You can also visit 
> https://www1.ietf.org/mailman/listinfo/I-D-announce 
> to change your subscription settings.
> 
> 
> Internet-Drafts are also available by anonymous FTP. Login 
> with the username
> "anonymous" and a password of your e-mail address. After logging in,
> type "cd internet-drafts" and then
> 	"get draft-ietf-ipr-rules-update-07.txt".
> 
> A list of Internet-Drafts directories can be found in
> http://www.ietf.org/shadow.html 
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> 
> 
> Internet-Drafts can also be obtained by e-mail.
> 
> Send a message to:
> 	[email-masked].
> In the body type:
> 	"FILE /internet-drafts/draft-ietf-ipr-rules-update-07.txt".
> 	
> NOTE:	The mail server at ietf.org can return the document in
> 	MIME-encoded form by using the "mpack" utility.  To use this
> 	feature, insert the command "ENCODING mime" before the "FILE"
> 	command.  To decode the response(s), you will need "munpack" or
> 	a MIME-compliant mail reader.  Different MIME-compliant 
> mail readers
> 	exhibit different behavior, especially when dealing with
> 	"multipart" MIME messages (i.e. documents which have been split
> 	up into multiple messages), so check your local documentation on
> 	how to manipulate these messages.
> 		
> 		
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
> 

_______________________________________________
Ipr-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipr-wg

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 26 Jul 2006 10:21:30 +0200

> the creation of the IETF Trust.

As AD, I encourage the WG to make a choice between these two
options rapidly so that we can get this part of the job done.

Speaking personally, I somewhat prefer the rules-update option
since it leaves fewer fixes for later. But if we can't rapidly
converge on this, I will certainly support the trust-update draft.

     Brian

---

From: Scott W Brim <[email-masked]>
Date: Fri, 28 Jul 2006 10:39:30 +0200

On 07/26/2006 10:21 AM, Brian E Carpenter allegedly wrote:
> Contreras, Jorge wrote:
>> All,
>>
>> I thought it would be helpful to explain the rationale behind, and the
>> differences between, the attached I-D (ipr-rules-update-07) and
>> trust-update-00.txt that was released

I also think it would be better to adopt rules-update.

swb