Subject: Re: Lawyer's advice on boilerplate in RFCs and I-Ds

From: Todd Glassey <[email-masked]>
Date: Mon, 26 Mar 2007 07:40:35 -0800 (GMT-08:00)

Brian -  Ahahahahahahah - funny.

-----Original Message-----
>From: Brian E Carpenter <[email-masked]>
>Sent: Mar 26, 2007 5:05 AM
>To: Simon Josefsson <[email-masked]>
>Cc: John C Klensin <[email-masked]>, Frank Ellermann <[email-masked]>, [email-masked]
>Subject: Re: Lawyer's advice on boilerplate in RFCs and I-Ds
>
>
>> Ah, the editing done by the RFC editor may likely be owned by the
>> Trust, yes.  (I wonder if that is in the RFC Editor contract.)
>
>It is known as "work for hire" in contractual terms, and the
>rights in such work do belong to the IETF Trust, obtained
>via ISOC or directly, since 1998.

You mean retaining the Editor to  rework or review the submission? Possibly, but that "work for hire" doesnt necessary do ANYTHING to the submission that would codify a derivative... Generally speaking Copyright's stand to original materials unless Derivatives have 10% or more new content.

So if the ISC Editor's dont rework the submission formally - and in so doing change a significant portion of the design itself, they aint doing squat really.

Hey - dont take my word - ask Jorge "formally" how much of an original work has to be formally rewritten to qualify as a 'new and derivative work' thereof...

Todd

>
>    Brian
>
>_______________________________________________
>Ipr-wg mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/ipr-wg

_______________________________________________
Ipr-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipr-wg

---

From: Simon Josefsson <[email-masked]>
Date: Mon, 26 Mar 2007 20:37:49 +0200

Todd Glassey <[email-masked]> writes:

> You mean retaining the Editor to rework or review the submission?
> Possibly, but that "work for hire" doesnt necessary do ANYTHING to
> the submission that would codify a derivative... Generally speaking
> Copyright's stand to original materials unless Derivatives have 10%
> or more new content.
>
> So if the ISC Editor's dont rework the submission formally - and in
> so doing change a significant portion of the design itself, they
> aint doing squat really.
>
> Hey - dont take my word - ask Jorge "formally" how much of an
> original work has to be formally rewritten to qualify as a 'new and
> derivative work' thereof...

That may be useful, at least as a guideline for us to determine if the
RFC editor actually have copyright claims on a particular document.  I
suspect that for some documents, the edits are too small to be
copyrightable.

One concern would be that it is not simple to determine how much
material the RFC editor contributed.  The edits between the approved
I-D and the final RFC are not only done by the RFC editor.  I don't
know of a way to access the edits made by the RFC editor for a
particular RFC.  Does anyone know if the RFC editor maintains such
paper work history?  Are all RFC editor "drafts" archived?

For comparison, the FSF practices the rule that contributions over 10
lines of "substantial material" needs a copyright assignment.  Most
likely, the rule is rather conservative, and lawyers were probably
involved that decision too.

/Simon

---

From: "todd glassey" <[email-masked]>
Date: Mon, 26 Mar 2007 11:33:51 -0700

Simon -
----- Original Message ----- 
From: "Simon Josefsson" <[email-masked]>
To: "Todd Glassey" <[email-masked]>
Cc: "Brian E Carpenter" <[email-masked]>; "John C Klensin" 
<[email-masked]>; "Frank Ellermann" <[email-masked]>; 
<[email-masked]>
Sent: Monday, March 26, 2007 11:37 AM
Subject: Re: Lawyer's advice on boilerplate in RFCs and I-Ds

> suspect that for some documents, the edits are too small to be

I dont think there are any RFC Editor (c) claims. They never rewrite more 
than 10% of the core material in the document.

> I-D and the final RFC are not only done by the RFC editor.

So the issue then is also that the original submitter loses exclusive rights 
to anything past the I-D submission too then eh? Since the work-product of 
the WG is what is edited finally by the RFC Ediror's in their reworking the 
materials submitted and obtained through Note Well.

> I don't

I bet not.

> lines of "substantial material" needs a copyright assignment.

This is specific to the Code though and not necessarily the Documentation 
that supports it. In the IETF's case the Documentation that supports the 
Code is the bulk of what it produces. So the dilemma is a pain eh?

Todd

> Most

---

From: John C Klensin <[email-masked]>
Date: Mon, 26 Mar 2007 14:50:48 -0400

--On Monday, 26 March, 2007 11:33 -0700 todd glassey
<[email-masked]> wrote:

>> That may be useful, at least as a guideline for us to
>> determine if the RFC editor actually have copyright claims on
>> a particular document.  I suspect that for some documents,
>> the edits are too small to be copyrightable.
> 
> I dont think there are any RFC Editor (c) claims. They never
> rewrite more than 10% of the core material in the document.

Todd, how would you know?

Remembering that copyright is about the mode of expression,
rather than the underlying ideas, I can recollect several RFCs
where the RFC Editor has changed significantly more than 10% of
the material ("core material" if that means "other than
boilerplace").

    john