Subject: A guide to the IETF's process documents

From: Harald Tveit Alvestrand <[email-masked]>
Date: Thu, 22 Mar 2007 09:26:33 +0100

Anyone who really wants to see all the IETF's process documents at one time 
needs to take a look at this page:

<http://www.ietf.org/IESG/content/ions/ion-procdocs.html>

This page is not normative, in the sense that a document doesn't lose 
standing because it is not listed here, but it can be useful to read it.

              Harald

_______________________________________________
Ipr-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipr-wg

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 22 Mar 2007 10:49:35 +0100

On 2007-03-22 09:26, Harald Tveit Alvestrand wrote:
> Anyone who really wants to see all the IETF's process documents at one 
> time needs to take a look at this page:
> 

And I will try to update it once in a while, so additions and corrections
are welcome.

    Brian

---

From: "todd glassey" <[email-masked]>
Date: Thu, 22 Mar 2007 13:02:46 -0700

Actually this may be more important than 'just updating once and a while' 
such that there may be a valid reason for the creation of a new 'Role' 
within the Managemement and that would be a "Manager of Disclosure 
Resources" or somesuch. The purpose of the role would be to

    1)    Define and get approval for a POLICY and PROCESS to disclose all 
components of the Participation and IP transfer framework

    2)    Work with Jorge and the IESG & Trust to integrate all of the 
process policies into that framework ands to provide a disclosure site that 
is easily navigated and understood by all participants.

My personal feeling is that this is a full time role and probably wants some 
form person assigned to it specifically.

Todd
----- Original Message ----- 
From: "Brian E Carpenter" <[email-masked]>
To: "Harald Tveit Alvestrand" <[email-masked]>
Cc: <[email-masked]>
Sent: Thursday, March 22, 2007 2:49 AM
Subject: Re: A guide to the IETF's process documents

> httFrom [email-masked] Thu Mar 22 16:05:58 2007
From: "todd glassey" <[email-masked]>
To: "Brian E Carpenter" <[email-masked]>,
	"Harald Tveit Alvestrand" <[email-masked]>
Date: Thu, 22 Mar 2007 13:02:46 -0700
Cc: [email-masked]
Subject: Re: A guide to the IETF's process documents

Actually this may be more important than 'just updating once and a while' 
such that there may be a valid reason for the creation of a new 'Role' 
within the Managemement and that would be a "Manager of Disclosure 
Resources" or somesuch. The purpose of the role would be to

    1)    Define and get approval for a POLICY and PROCESS to disclose all 
components of the Participation and IP transfer framework

    2)    Work with Jorge and the IESG & Trust to integrate all of the 
process policies into that framework ands to provide a disclosure site that 
is easily navigated and understood by all participants.

My personal feeling is that this is a full time role and probably wants some 
form person assigned to it specifically.

Todd

---

From: "todd glassey" <[email-masked]>
Date: Thu, 22 Mar 2007 15:06:10 -0700

Harald/Brian

The ION page is a really good start. It might be fun to build a graphical
timeline page to show all of the processes involved (*by RFC) in the entry
and promulgation of a standard.

As a suggestion to make this (the ION)  document more readable let me ask,
can we put links into it to the special IETF terms like "BOF" for instance.
This would make the document more complete.

Also the writing style of the document seems to be about what does and
doesn't exist rather than the process itself. The intent wasn't to be an
inventory rather than an explanation. So, If there is no description
document for that section,AFAIK  its probably better to open with something
other than "This document doesn't exist"... (just as a style commentary)

Also speaking of BOF's section 2.5 needs a pointer to BOF's as well and the
Normative pointer to the BOF listing is broken
http://www.ietf.org/internet-drafts/draft-narten-successful-bof-01.txt  as 
is the DISCUSS link as well.

I assume that is because these are both ID's and they have expired or 
somesuch.

Todd

---

From: "todd glassey" <[email-masked]>
Date: Thu, 22 Mar 2007 15:42:12 -0700

http://validator.w3.org/checklink?uri=http%3A%2F%2Fwww.ietf.org%2FIESG%2Fcontent%2Fions%2Fion-procdocs.html&hide_type=all&recursive=on&depth=&check=Check

T.

---

From: Frank Ellermann <[email-masked]>
Date: Fri, 23 Mar 2007 00:47:39 +0100

todd glassey wrote:

> the Normative pointer to the BOF listing is broken
> http://www.ietf.org/internet-drafts/draft-narten-successful-bof-01.txt

It's an informative reference.  The link is broken because
xml2rfc uses the I-D version existing at the time when it
was invoked.

The BOF I-D was updated, you can generally find the actual
version by stripping -NN.txt (here -01.txt) and asking the
tools server:

http://tools.ietf.org/html/draft-narten-successful-bof

To see if that last version of an I-D is expired look at
the date shown on its first page.  The DISCUSS draft is in
fact expired, but still available in a section for notes
written before the ION experiment started:

http://www.ietf.org/u/ietfchair/discuss-criteria.html

Probably IONs derived from I-Ds should have an URL to the
generic tools server URL for the last I-D.

Frank

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 23 Mar 2007 06:58:27 +0100

> generic tools server URL for the last I-D.

That would be an xml2rfc issue in this case.

    Brian

---

From: "todd glassey" <[email-masked]>
Date: Fri, 23 Mar 2007 08:06:37 -0700

----- Original Message ----- 
From: "Frank Ellermann" <[email-masked]>
To: <[email-masked]>
Sent: Thursday, March 22, 2007 4:47 PM
Subject: Re: A guide to the IETF's process documents

> http://tools.ietf.org/html/draft-narten-successful-bof

Agreed, but the page stiull needs to be fixed.

> the date shown on its first page

That wasnt the point - the issue was that I-D's were used as references for 
a process page without a process for permanently archiving them. So the did 
what all good I-D's do after six months and that is expire - making the 
page's links broken.

> The DISCUSS draft is in

Or possibly be granted a state where they dont expire until their are 
formally replaced with an updated Draft or a fully-blown RFC.

---

From: Frank Ellermann <[email-masked]>
Date: Fri, 23 Mar 2007 17:51:25 +0100

Brian E Carpenter wrote:
 
>> Probably IONs derived from I-Ds should have an URL
>> to the generic tools server URL for the last I-D.
 
> That would be an xml2rfc issue in this case.

I'm not sure what you mean, apparently xml2rfc will use
additional URLs on the tools server in the future, see   
<http://permalink.gmane.org/gmane.text.xml.rfc/1335>

What I meant is that IONs derived from an I-D like the
procdoc ION, the execd ION, or the AD-sponsoring ION
*_SHOULD_* have a reference to their last I-D version
(of course informative where that difference is used).

This not yet existing SHOULD could be added to 4693bis
in October.  E.g. the execd ION has already a pointer
to its predecessor in chapter 4, but not yet as link.

The AD-sponsoring ION has apparently no link or pointer
at all to its predecessor (Jari's I-D).  Ditto your
procdocs ION.  If readers don't know that there was an
I-D before the ION (with a "similar" name in the three
examples) they probably miss that part of the history.

BTW, it's perfectly legal in xml2rfc to use a link...

 <eref target=
  "http://tools.ietf.org/html/draft-lynch-execd-tasks"
 />

...almost anywhere.  Untested, that should also work:

 <eref target=
  "http://tools.ietf.org/html/draft-lynch-execd-tasks"
 > [I-D.lynch-execd-tasks] </eref>
 
Only a minor nit, it's no secret that I want the ION
experiment to be identified as successful in October.

Frank

---

From: Frank Ellermann <[email-masked]>
Date: Fri, 23 Mar 2007 18:36:00 +0100

todd glassey wrote:

 [Internet Drafts]
> the issue was that I-D's were used as references for a process
> page without a process for permanently archiving them.

That's a tricky issue because I-D authors are (obviously) free to
drop an I-D, and (not so obvious) they can also ask that their
I-Ds are removed from the tools server. 

As an example, if I'd wish to kill my "???-options" draft I can
post a dummy (void) -02, after that the -01 is eliminated from
the "official" I-D repository.

Then I could ask Henrik to remove -00, -01, and -02 from the
IETF tools servers.  Maybe Henrik could say that he'll keep the
void -02 as tombstone until it expires.

After that I could ask Google who else has a copy of this I-D,
and try to eliminate them (what fun, it's more a theoretical
option).  IIRC John said he really sometimes posts I-Ds in the 
hope that they're ignored, because he can then claim that it's
a proven bad idea.  Admittedly I can't tell where he really did
that, maybe in some very obscure corner of newtrk / pesci.

But it's clear that authors are in theory free to withdraw I-Ds,
for good, bad, or ugly reasons.

> what all good I-D's do after six months and that is expire -
> making the page's links broken.

Yes, because xml2rfc uses links to the official I-D repository,
and arguably it should do that.  The tools server repository,
or other I-D collections, might need some way to delete I-Ds on
demand of te authors.  The official repository is automagically
prepared for the worst case "withdrawal". 

Another issue, if Brian references verion 01 of the BOF I-D in
the procdoc ION this doesn't automatically imply that he's also
happy with version 02 or later.

For the two cases you found (DISCUSS and BOF):

- The expired DISCUSS I-D is actually a kind of "grandfathered"
  ION, it's IMO unnecessary to fix anything about it before the
  ION experiment is evaluated-
- The BOF reference is automatically updated to the latest I-D
  whenever the procdoc ION is updated (unless Brian decides to
  remove it)
- the procdoc I-D (before the ION) had more informative links to
  unfinished I-Ds, e.g. I-D.carpenter-ietf-disputes-00 and maybe
  also the horrorshow-rescind I-D before it unfortunately failed
  in two Last Calls.  For the ION Brian removed all references 
  to remotely "controversial" stuff, only the BOF I-D survived -
  AFAICT nobody ever said a single word against this I-D.

Frank

---

From: John C Klensin <[email-masked]>
Date: Sat, 24 Mar 2007 03:52:14 -0400

> that, maybe in some very obscure corner of newtrk / pesci.

I have never posted an I-D in the hope that it would be ignored, 
for that or any other reason.   I have posted a few in the hope 
that the ideas in them would be discussed and then soundly and 
loudly rejected.

Claiming that something is a proven bad idea on the basis of 
silence would be fairly bogus.

     john

---

From: Frank Ellermann <[email-masked]>
Date: Sat, 24 Mar 2007 17:38:57 +0100

John C Klensin wrote:

> I have posted a few in the hope that the ideas in them would
> be discussed and then soundly and loudly rejected.

I've now found one of your two articles I had in mind.  The
parts where you talked about taking expiration seriously,
and about posting intentionally controversial I-Ds were not
directly related, I didn't recall it correctly:

http://article.gmane.org/gmane.ietf.ipr/3192/match=creative

Frank