Subject: Re: Submission of XML sources

From: Fred Baker <[email-masked]>
Date: Sun, 2 Dec 2007 11:12:35 -0800

I'm going through some old mail and came across this note.

When the XML2RFC tool was built, the idea was to simplify the job of  
the document author, the job of the reviewers, and the job of the RFC  
Editor, and do so in a non-proprietary format. Many SDOs use  
Microsoft Word; this is considered somewhat anathema in the IETF  
because some common operating systems (Linux, BSD, Solaris) don't run  
the application, and because the document format changes in non- 
interoperable ways every few years. So Mrashall and company created a  
means to do so in an interoperable (any XML editor will do, or in a  
pinch any text editor).

Sending in the output of the tool makes something that folks can  
read; so does the Microsoft Word-based tool, nroff, and others.  
However, for the RFC Editor, the XML tool allows them to directly set  
a flag and convert to RFC format with the right relevant text (for  
example to describe a BCP as opposed to an informational document).  
It also allows people to build other XML-based tools for operating on  
the document. For example, I have wondered from time to time about  
building a technical grammar/spell checker that handles the language  
used in RFCs, which contains (as all technical document series do) a  
lot of jargon. Doing that would require scanning existing documents  
for text to build the database, and starting from the "text" output  
requires direct knowledge of page headers and footers and the  
placement of ASCII Art; doing so from the XML source is trivial.

One thing I would like the ID-submission tool to do is directly  
create the .txt file when given the .xml file, to guarantee that  
there is a direct correlation between them. There is supposed to be,  
but with the present tool one could imagine a negligent poster  
posting a different version .xml than .txt. But the primary reason  
for posting the .xml is further down the document management  
pipeline. I don't see why a positive good would be a bad idea.

What about .xml file posting did you consider a bad idea?

On Nov 13, 2007, at 12:04 AM, Frank Ellermann wrote:

> Hi,
>
> I tried to figure out what the ID-submission tool does with  
> uploaded XML sources.  Apparently nothing at the moment (?)
>
> After that test I saw that the XML source has and always had a "cc- 
> by-sa" note.  In other words uploading the XML as an IETF  
> contribution was a bad idea, is that correct ?
>
> I'm not going to submit an IPR note about the differences between  
> IETF contribution and "cc-by-sa", after all it's impossible to do  
> anything else but "sa" with an XML source.
>
>  Frank
>
>
> _______________________________________________
> Ipr-wg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ipr-wg

_______________________________________________
Ipr-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipr-wg

---

From: "todd glassey" <[email-masked]>
Date: Sun, 2 Dec 2007 11:28:02 -0800

Fred
----- Original Message ----- 
From: "Fred Baker" <[email-masked]>
To: "Frank Ellermann" <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>
Sent: Sunday, December 02, 2007 11:12 AM
Subject: Re: Submission of XML sources

> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>
> When the XML2RFC tool was built, the idea was to simplify the job of  the 
> document author, the job of the reviewers, and the job of the RFC  Editor, 
> and do so in a non-proprietary format.

I like the way you put that... politiclly correct BS - I thought the idea 
was to prevent Microsoft Word from becoming a next generation acceptable 
document submisson standard, and that the IESG members did this to prevent 
the expansion of the 'evil empire'... Or at least that was what numerous 
people said to me when I proposed amending the acceptable formats some 
number of years ago... The problem is that now that OpenOffice exists that 
claim is no longer viable, and the IETF should accept .DOC submissions IMHO.

> Many SDOs use  Microsoft Word; this is considered somewhat anathema in the 
> IETF  because some common operating systems (Linux, BSD, Solaris) don't 
> run  the application, and because the document format changes in non- 
> interoperable ways every few years.

Uh... But all of those tools read and write RTF as it happens. And FWIW 
OpenOffice and its availability possibly also makes that no longer relevant 
since it operates on all of the platforms named.

> So Mrashall and company created a  means to do so in an interoperable (any 
> XML editor will do, or in a  pinch any text editor).
>
> Sending in the output of the tool makes something that folks can  read; so 
> does the Microsoft Word-based tool, nroff, and others.

i.e. OpenOffice for instance too.

> However, for the RFC Editor, the XML tool allows them to directly set  a 
> flag and convert to RFC format with the right relevant text (for  example 
> to describe a BCP as opposed to an informational document).

Something that proper templates in any of the editor based tools would also 
do.

> It also allows people to build other XML-based tools for operating on  the 
> document. For example, I have wondered from time to time about  building a 
> technical grammar/spell checker that handles the language  used in RFCs, 
> which contains (as all technical document series do) a  lot of jargon. 
> Doing that would require scanning existing documents  for text to build 
> the database, and starting from the "text" output  requires direct 
> knowledge of page headers and footers and the  placement of ASCII Art; 
> doing so from the XML source is trivial.
>
> One thing I would like the ID-submission tool to do is directly  create 
> the .txt file when given the .xml file, to guarantee that  there is a 
> direct correlation between them. There is supposed to be,  but with the 
> present tool one could imagine a negligent poster  posting a different 
> version .xml than .txt. But the primary reason  for posting the .xml is 
> further down the document management  pipeline. I don't see why a positive 
> good would be a bad idea.
>
>> I tried to figure out what the ID-submission tool does with  uploaded XML 
>> sources.  Apparently nothing at the moment (?)
>>
>> by-sa" note.  In other words uploading the XML as an IETF  contribution 
>> was a bad idea, is that correct ?
>>
>> I'm not going to submit an IPR note about the differences between  IETF 
>> contribution and "cc-by-sa", after all it's impossible to do  anything 
>> else but "sa" with an XML source.
>>
>>  Frank
>>
>>
> -----BEGIN PGP SIGNATURE-----
>
> iD8DBQFHUwOjbjEdbHIsm0MRAjD8AJwLbls48U1FGkMunoO+R9gAs98RLgCfcUD3
> KofWplS27tVPStWE2EKzfD0=
> =H53u
> -----END PGP SIGNATURE-----
>

---

From: "Frank Ellermann" <[email-masked]>
Date: Sun, 2 Dec 2007 21:24:50 +0100

Fred Baker wrote:

> any XML editor will do, or in a pinch any text editor

In a pinch "roll your own awk2xml" might be simpler
than "roll your own xxx2rfc", I've not yet tested it.
 
> One thing I would like the ID-submission tool to do is
> directly create the .txt file when given the .xml file

Yes, of course that works only if all external files are
either integrated (I guess that's what "xml output" does)
or public (e.g. bibxml files).  

> I don't see why a positive good would be a bad idea.

Some potential traps and pitfalls were discussed by John
and others on the general list a week ago.  

It could be a bad idea if the source contains "private"
comments (XML or cref).  Untested, there might be also
a difference between a "standalone" source referencing
specific versions of drafts, or a source with public
bibxml references resulting in current versions of the
drafts.  The latter isn't guaranteed to be stable, but
I typically consider this as feature.

> What about .xml file posting did you consider a bad idea?

I only observed that I tested the upload feature under
"note well" rules, and later saw that my XML source has 
"CC-BY-SA" in a comment.  Allegedly even Wikipedia will
allow CC-BY-SA soon, this WG here is a pocket of "CC-BY" 
(i.e. "share alike" not required) resistance.

It was a theoretical issue, in practice I don't see how
anybody could "steal" XML sources for "non-share-alike"
(proprietary, not limited to commercial) purposes.

A more practical question was about the purpose of the
XML upload in addition to the TXT upload, when that can
cause hard to detect discrepancies.

One of the many xml2rfc features I like and use is the
<date /> element without attributes resulting in "today",
but of course "today" isn't a stable property, it will
differ from the corresponding TXT after about 12 hours.

 Frank

---

From: Russ Housley <[email-masked]>
Date: Sun, 02 Dec 2007 15:29:52 -0500

Fred:

The only concern that I see here is boilerplate change.  The 
Secretariat server will of course have the latest and greatest, but 
the author may not be aware of some change, especially if they run 
xml2rfc on their own machine.  The could lead to a situation where an 
author unknowingly agrees to something based on the revised boilerplate.

Russ

At 02:12 PM 12/2/2007, Fred Baker wrote:
>there is a direct correlation between them.

---

From: Fred Baker <[email-masked]>
Date: Sun, 2 Dec 2007 13:05:55 -0800

On Dec 2, 2007, at 12:29 PM, Russ Housley wrote:

> xml2rfc on their own machine.  The could lead to a situation where  
> an author unknowingly agrees to something based on the revised  
> boilerplate.

of course. But the author selects what boilerplate he wants - he says  
he is operating under 'ipr="full3978"' or whatever. If that isn't  
predictable, yes, we have a problem. But I thought it was pretty  
predictable.

---

From: Fred Baker <[email-masked]>
Date: Sun, 2 Dec 2007 13:07:23 -0800

On Dec 2, 2007, at 12:24 PM, Frank Ellermann wrote:

> "CC-BY-SA" in a comment.

I just compared my xml source for a recent ID with the one that is  
presented at the IETF site. The uploaded file displays no changes.

Where did the CC-by-SA come from?

---

From: "Frank Ellermann" <[email-masked]>
Date: Sun, 2 Dec 2007 23:08:36 +0100

> Where did the CC-by-SA come from?

It's in the XML source, I added it years ago.  I put the XML
source on public Web servers, in a version where adding two
hyphens would result in a "private draft" for discussions
outside of the IETF (and also without any annoying legalese):

<!-- no I-D - >
<?rfc private="Creative Commons License:    Attributions + ShareAlike" ?>
<?rfc header="Interim draft" ?>
<?rfc footer="draft-ellermann-news-nntp-uri-09" ?>
<! - no I-D -->

s/- >/-->/ and s/<! -/<!--/ would result in a private draft.

 Frank