Subject: [IPsec] Question about DH retry for IKEv2

From: Gaurav Poothia <[email-masked]>
Date: Fri, 17 Dec 2010 18:05:07 +0000

Hello,

Re: Part of RFC 5996 Sec 1.2 that talks about DH retry in the case initiator guesses the wrong DH group in SA INIT

It's not clear to me whether the expectation is for the second  SA INIT attempt (this time with the DH group hinted at by peer) can start afresh with a new IKE cookie pair (message ID 1)
OR
If it must retain the existing cookie pair (message ID 2)

AFAICT either way is acceptable since both achieve the same end. The former seems slightly easier.
Pls correct me though if one approach is strictly the right way. If so then why.

Thanks

---

From: Yoav Nir <[email-masked]>
Date: Sat, 18 Dec 2010 18:11:07 +0200

Hi Gaurav.

In IKEv2, we don't call them cookies any more, but IKE SPIs. Since you're initiating, you start with just the initiator IKE SPI (not a pair), and the message ID for the first message is zero, not 1.

IKE SA INIT messages always have message ID zero. I would bet that many implementations rely on this. So you should really use a new initiator IKE SPI.

Yoav

On Dec 17, 2010, at 8:05 PM, Gaurav Poothia wrote:

Hello,

It’s not clear to me whether the expectation is for the second  SA INIT attempt (this time with the DH group hinted at by peer) can start afresh with a new IKE cookie pair (message ID 1)
OR
If it must retain the existing cookie pair (message ID 2)

Thanks
<ATT00002..txt>

---

From: Gaurav Poothia <[email-masked]>
Date: Sat, 18 Dec 2010 17:49:14 +0000

Thanks Yoav for your response.
Yes I was off by one wrt the message IDs.

New IKE SPI sounds reasonable to me too.

Gaurav

From: Yoav Nir [mailto:[email-masked]]
Sent: Saturday, December 18, 2010 9:41 PM
To: Gaurav Poothia
Cc: [email-masked]; Brian Swander; Gabriel Montenegro
Subject: Re: [IPsec] Question about DH retry for IKEv2

Hi Gaurav.

Yoav

Hello,

Thanks
<ATT00002..txt>