Subject: complication in ikev2

From: Ravi <[email-masked]>
Date: Wed, 26 Mar 2003 19:09:29 +0530

May I know why ikev2 should listen on both 500 and 4500.?What purpose does
      it solve? In my view, we are complicating the protocol and implementation by doing
      this. 
      If both IKEv1 and IKEv2 exist (most probably they exist as separate processes
      or tasks and it is easy if we let IKEv1 and V2 exist separately), ikev1 can listen
      on port 500 and ikev2 listen on 4500.

      On the initiating side, if it has both v1 and v2, first it can try contacting the
      responder with port 4500 i.e. IKEv2. If it does not get response in certain
      duration, it can assume that IKEV2 is not supported by the responder and it can
      fallback onto the ikev1 which sends packets onto port 500.

      Also implementation wise it makes it easy and ikev1 and ikev2 can come from
      two different vendors and typically TCP/IP stacks don't allow two sockets 
      listening on same port.

-- 

The views presented in this mail are completely mine. The company is not 
responsible for whatsoever.
------------------------------------------------------------------------
Ravi Kumar CH
Rendezvous On Chip (i) Pvt Ltd
Hyderabad, India
Ph: +91-40-2335 1214 / 1175 / 1184

ROC home page <http://www.roc.co.in>

---

From: Antonio Forzieri <[email-masked]>
Date: Thu, 27 Mar 2003 15:04:43 +0100

Ravi ha scritto:
> May I know why ikev2 should listen on both 500 and 4500.?What purpose 
> does it solve? In my view, we are complicating the protocol and 
> implementation by doing this. If both IKEv1 and IKEv2 exist (most 
> probably they exist as separate processes or tasks and it is easy if we 
> let IKEv1 and V2 exist separately), ikev1 can listen on port 500 and 
> ikev2 listen on 4500.
Agreed. I state this in a previous message, and I was given this response
[COPY&PASTE BEGIN]
=> nothing but the current draft wording suggests that IKE_SA_INIT
always runs over UDP 500. This should be fixed.
[COPY&PASTE END]

[SNIP]

-- 
------------------------------------------------
Antonio Forzieri
CEFRIEL - Politecnico di Milano
Tesista Area E-Service Tecnologies
Tel: 02-23954.334 - email: [email-masked]
ICQ# 177683894
------------------------------------------------