Subject: ISAKMP and SSL

From: Ibrahim <[email-masked]>
Date: Wed, 30 Apr 2003 19:50:01 +0200

Hi all,
When I read RFC 2408 they described ISAKMP as a generic key management
protocol for all security protocols but till now the large deployment of
ISAKMP was only with IPSEC
My question is, can we use it with SSL/TLS?
The goal of this issue is to add new services in SSL/TLS (identity
protection, attribute certificate passing for access control schemes,
non-repudiation…).
Thank you in advance
Ibrahim

--
____________________________________________________
Ibrahim HAJJEH
Ecole Nationale Supérieure des Télécommunications
Departement Informatique et Réseaux
Tél.:+33 01 45 81 71 06     Fax.: +33 01 45 81 31 19
46 rue Barrault, 75634 PARIS cedex 13

---

From: Stephen Kent <[email-masked]>
Date: Wed, 30 Apr 2003 17:40:50 -0400

>protection, attribute certificate passing for access control schemes,

SSL/TLS has its own, tightly couple key management protocol, so it 
would not be appropriate to try to use ISAKMP.

---

From: Eric Rescorla <[email-masked]>
Date: 30 Apr 2003 14:49:24 -0700

> protection, attribute certificate passing for access control schemes,

The basic answer here is no.

TLS has its own key management scheme and really isn't designed
to have pluggable key management. That said, with respect to your
specific desired security services:

(1) You can get identity protection for TLS in a number of ways,
    none quite as good as you would get with IPsec.

    (a) do an initial anonymous DH exchange and then do the
	ordinary handshake. This still allows an active attacker
	to get both identities.

    (b) do an initial cert-based exchange (this exposes the
	server's identity) and then rehandshake to have the
	client identify.
 
    (c) combine the above two techniques :)

(2) TLS has an extensions mechanism so you could use that to
    pass around attribute certificates.

(3) ISAKMP doesn't really offer non-repudiation either, so you
    wouldn't get any benefit from melding it with TLS.

-Ekr
	
-- 
[Eric Rescorla                                   [email-masked]]
           Web Log: http://www.rtfm.com/movabletype

---

From: Mark Baugher <[email-masked]>
Date: Wed, 30 Apr 2003 15:49:23 -0700

At 05:40 PM 4/30/2003 -0400, Stephen Kent wrote:
>SSL/TLS has its own, tightly couple key management protocol, so it would 
>not be appropriate to try to use ISAKMP.

I think the confusion comes from the fact that the ISAKMP RFC says it could 
be applied to TLS.

Mark