Subject: RE: CALL FOR DISCUSSION: DHCP over IKE vs Configuration Payload

From: Gregory Lebovitz <[email-masked]>
Date: Mon, 21 Apr 2003 08:08:17 -0700

> > > Lately, I've been wondering if we can't just add an optional
> > > DHCP CP payload type.  Not sure if that would make everybody
> > > happy or make everybody mad.
> > > 
> > 
> > That is what Darren Dukes and I proposed in the doc we 
> wrote and presented
> > in SF. Send a DHCP server addr in CP along w/ IP and 
> DNS/WINS (if needed)
> > and do the rest of the DHCP extensions via INFORM in 
> protected by CHILD-SA.
> 
> no, that's not the same thing.
> 

care to clarify?

---

From: Bill Sommerfeld <[email-masked]>
Date: Mon, 21 Apr 2003 11:21:13 -0400

> > > That is what Darren Dukes and I proposed in the doc we wrote and
> > > presented in SF. Send a DHCP server addr in CP along w/ IP and
> > > DNS/WINS (if needed) and do the rest of the DHCP extensions via
> > > INFORM in protected by CHILD-SA.

A "dhcp cp payload type" would carry DHCP inside CP inside IKE, not
send a referral to a DHCP server.

						- Bill