Subject: Peer liveliness

From: Ravi <[email-masked]>
Date: Fri, 18 Apr 2003 10:35:54 +0530

Hi,
  I was going through several drafts related to peer liveliness. But, some of practical
  problems faced in actual deployment may not be solved by these proposals.
  INITIAL_CONTACT Notification : It indicates that the Peer was dead and cameback.
  DPD:  Checks the liveliness of the peer.
  I feel, we require interoperable solution to check liveliness of SA ie Dead Peer SA detection
 (DPSD). 
  DPD specification can be enhanced to achieve this.
  Protocol-ID and SPI fields can be made mandatory.
  Protocol-ID can be ESP/AH/IKE.
  SPI : In case of IKE, it could be cookies and in case of ESP/AH, it is SPI (inbound SA's SPI
       on the peer).
  If peer is not dead, but SAs were deleted either due to temporary failure OR due to 
  restarting of some processes in the system can be detected with this mechanism.
  Does this makes sense? If so, I can contribute text to this effect.
Regards,
Ravi

-- 

The views presented in this mail are completely mine. The company is not 
responsible for whatsoever.
------------------------------------------------------------------------
Ravi Kumar CH
Rendezvous On Chip (i) Pvt Ltd
Hyderabad, India
Ph: +91-40-2335 1214 / 1175 / 1184

ROC home page <http://www.roc.co.in>

---

From: "Darren Dukes" <[email-masked]>
Date: Mon, 21 Apr 2003 14:27:46 -0400

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Ravi
> Sent: Friday, April 18, 2003 1:06 AM
> To: [email-masked]
> Subject: Peer liveliness
> 
> 
>  Hi,

I believe INVALID_SPI does what you are looking for.  If I receive an INVALID_SPI notify via an IKE SA I know to delete the SA and traffic will bring up a new one.  

Darren

> The views presented in this mail are completely mine. The company 
> is not responsible for whatsoever.
> 
> 
> Ravi Kumar CH
> ROC home page

---

From: suren <[email-masked]>
Date: Wed, 23 Apr 2003 11:38:27 -0700

Hi Ravi,
     It is good idea to find out whether the peer SA is dead or not. I 
support this and
     would like to see some draft in this regard.
Suren

At 10:35 AM 4/18/2003 +0530, Ravi wrote:

>----------
><http://www.roc.co.in>ROC home page
>