Subject: IANA template document

From: Michael Richardson <[email-masked]>
Date: Tue, 16 Dec 2003 18:44:01 -0500

-----BEGIN PGP SIGNED MESSAGE-----

While going through IKEv2-11 to extract IANA tables, I noticed the following
errors in the IANA Considerations:

missing from the table is:
	*  IKEv2 Identification Types
	*  IKEv2 Certification Payload Format
	*  IKEv2 Notification Payload Type

listed in the table are:
       Error types
       Status types

which are in fact Notification Payload types, and share the same table.
My list is:

   IKEv2 Payload Types
   IKEv2 Transform Types
        IKEv2 Encryption Transform Values
	IKEv2 Pseudo-ramdom Function Transform Values
	IKEv2 Integrity Algorithm Transform Values
	IKEv2 Diffie-Hellman, ECP and EC2N Transform Values
	IKEv2 Extended Sequence Numbers Transform Values
   IKEv2 Identification Types
   IKEv2 Certification Payload Format
   IKEv2 Authentication Method
   IKEv2 Notification Payload Type
   IKEv2 IPComp Transform IDs
   IKEv2 Security Protocol ID
   IKEv2 Traffic Selector Types
   IKEv2 Configuration request types
   IKEv2 Configuration attribute types

I have suggested that the IKEv1 payload type registry have types 33-63 be
marked as reserved. 

The following types are missing any guidance as to amending formula, and
have no private use space.

   IKEv2 Identification Types
   IKEv2 Traffic Selector Types

The document is at:
    http://www.sandelman.ca/SSW/ietf/ipsec/ikev2/draft-ietf-ipsec-ikev2-iana-00.txt

]       ON HUMILITY: to err is human. To moo, bovine.           |  firewalls  [
]   Michael Richardson,    Xelerance Corporation, Ottawa, ON    |net architect[
] [email-masked]      http://www.sandelman.ottawa.on.ca/mcr/ |device driver[
] panic("Just another Debian GNU/Linux using, kernel hacking, security guy"); [

---

From: Michael Richardson <[email-masked]>
Date: Tue, 16 Dec 2003 20:52:45 -0500

>>>>> "Michael" == Michael Richardson <[email-masked]> writes:
    Michael> which are in fact Notification Payload types, and share the same
    Michael> table.  My list is:

  I added two just now.

    IKEv2 Exchange Types
    IKEv2 Transform Types/IKEv2 Transform Attribute Types