Subject: H.323 protocols

From: Chris James <[email-masked]>
Date: Tue, 17 Nov 1998 10:48:59 -0800 (PST)

Hi,

Thanks to a lot of suggestions, I purchased the
H.323 spec from the ITU site.  After skimming
it I noticed it goes into gatekeepers, MCs, 
Multipoint, etc.  

I am interested in what protocols H.323 runs.  
There is a little snippet (3 pages) in section 
C.4 of the spec.  

If I understand it right, H.323 does not
include any protocol definitionss.  It mentions 
RTP and RTCP but those are seperate RFCs.  Is it
correct in saying H.323 is not a layer 
such as UDP, TCP but is more of an architecture?  

Chris

_________________________________________________________
DO YOU YAHOO!?
Get your free @yahoo.com address at http://mail.yahoo.com

---------
This message came from the IETF IPTEL Working Group Mailing List.

---

From: Leonid Yegoshin <[email-masked]>
Date: Tue, 17 Nov 1998 15:00:58 -0800

>From: Chris James <[email-masked]>
>

   Be carefull to copy protocol itself from ITU books.
This year I tryed to create working program on the base of
ASN.1 specifications of H.323 from ITU books.
It did not work with any products like NetMeeting etc.
   It had started a work after I retreived ASN.1 specs from

       ftp://standard.pictel.com/avc-site/

and use it.

   The problem is in PACKED encoding of ASN.1 specs. If ITU groups
change specs a bit (add yet another parameter) and number of parameters
in structure exceeds yet another 2**N boundary then decoder can't decode
this structure.
   And ITU spec was incompatible (for H323 ver 1 at least).

		       - Leonid Yegoshin.
---------