Subject: RE: protocol name?

From: [email-masked] (Patrice Calhoun)
Date: Mon, 13 Sep 1999 08:32:19 -0700

well my 2 cents, for what it's worth is to change it. The problem is that there are too
many protocols that make use of gateways, this being just one of them. Having an acronym
such as GLP does not specifically state what service the gateway is providing, could be
IPSec (security gateway), NAT (address translation gateway), etc...

I certainly won't fight to change the name, but people should understand that "gateway"
is an abused term, and the proposed name "GLP" certainly does not even remotely state
that it has anything to do with IP telephony gateways.

PatC
>No
>
>Brian
>
>> -----Original Message-----
>> From: Jonathan Rosenberg [mailto:[email-masked]]
>> Sent: Monday, September 13, 1999 10:08 AM
>> To: Ward, Jon
>> Cc: [email-masked]'; iptel
>> Subject: Re: protocol name?
>> 
>> 
>> Before we get too many suggestions of names with neat 
>> acronyms, I'd like
>> to discuss the more important question - do people want to see it
>> changed from GLP? If so, we can then begin to discuss names.
>> 
>> My personal preference is to keep GLP, since (1) the 
>> framework document
>> calls it GLP, and its about to become an RFC, (2) its been 
>> called GLP up
>> till now and thats what people know it as. I agree its not 
>> the greatest
>> name, but its not too far off.
>> 
>> So, please, before throwing out more name suggestions - do people feel
>> it should be changed?
>> 
>> -Jonathan R.
>> 
>> "Ward, Jon" wrote:
>> > 
>> > Is there a "Gateway Information Protocol"?
>> > 
>> > Jon Ward
>> > Blue Cross / Blue Shield of Florida
>> > 532 Riverside Drive (HOC-9T), Jacksonville, FL  32200
>> > Voice: +1 (904) 791-6057  Fax: +1 (904) 357-8357
>> > 
>> > -----Original Message-----
>> > From: Hussein F. Salama [mailto:[email-masked]]
>> > Sent: Sunday, September 05, 1999 12:01 PM
>> > To: iptel
>> > Subject: protocol name?
>> > 
>> > Folks,
>> > 
>> > As you know, Matt Squire, Jonathan Rosenberg, and I are 
>> working together
>> > on a draft for the "gateway location problem." We're facing the
>> > question: what to name this new protocol? We have the following
>> > proposals:
>> > 
>> > 1. Call it GLP (gateway location protocol). This is the 
>> name currently
>> > used in the framework document, and everybody recognizes 
>> what it means.
>> > However, it does not capture all the fact that the protocol 
>> does more
>> > than just gateway location. It can find the entire route for the IP
>> > segment of a call (the route may exist of multiple hops), 
>> and it can be
>> > used to distribute policies between domains (carriers) on 
>> how to handle
>> > voice calls.
>> > 
>> > 2. More representative names could be: call routing 
>> protocol (CRP) or
>> > call routing  information protocol (CRIP) or may be voice routing
>> > protocol (I don't like limiting the protocol to routing voice only).
>> > 
>> > Any opinions on why to prefer one name over the others? Any creative
>> > suggestions for other names? :-)
>> > 
>> > Hussein
>> > 
>> > --
>> > Hussein F. Salama
>> > Cisco Systems
>> > Mail Stop SJC6/3, 170 W. Tasman Drive, San Jose, CA 95134
>> > Voice: +1 (408) 527-7147, Fax: +1 (408) 527-1714
>> > 
>> > ---------
>> > This message came from the IETF IPTEL Working Group Mailing List.
>> > 
>> > Blue Cross Blue Shield of Florida, Inc., and its subsidiary and
>> > affiliate companies are not responsible for errors or 
>> omissions in this e-mail message. Any personal comments made 
>> in this e-mail do not reflect the views of Blue Cross Blue 
>> Shield of Florida, Inc.
>> > 
>> > ---------
>> > This message came from the IETF IPTEL Working Group Mailing List.
>> 
>> -- 
>> Jonathan D. Rosenberg                       Lucent Technologies
>> Member of Technical Staff                   101 Crawfords Corner Rd.
>> High Speed Networks Research                Holmdel, NJ 07733
>> FAX:   (732) 834-5379                       Rm. 4C-526
>> EMAIL: [email-masked]
>> URL: http://www.cs.columbia.edu/~jdrosen
>> 
>> ---------
>> This message came from the IETF IPTEL Working Group Mailing List.
>> 
>
>---------
>This message came from the IETF IPTEL Working Group Mailing List.

---------
This message came from the IETF IPTEL Working Group Mailing List.

---

From: "Ronald Hirst" <[email-masked]>
Date: Tue, 14 Sep 1999 11:37:02 -0700

Greetings,

As suggested, perhaps a change would be more specific to an IP telephony gateway. A few of
my graduate texts define Gateways in general as interfaces between two or more dissimilar
networks in the OSI model. Here are a couple of the text definitions:

"A gateway enables the exchange of information between very dissimilar subnetworks. It is
generally used to link a subnetwork based on a proprietary architecture with a subnetwork
that conforms to the OSI architecture. Because a gateway links two totally incompatible
architectures, all seven layers of the OSI model and the complete set of protocols for the
proprietary architecture are incorporated in the gateway device. Because the conversion
takes place at the application layer, the gateway must contain both the OSI version and
the proprietary version of any application that is linked across the two subnetworks."
(Networks in Action, by Keen and Cummins, 1994, pp. 290-91)

"Gateways connect two or more LANs that use the same or different (usually different) data
link and network protocols. They may connect the same or different types of cable.
Gateways operate at the network layer, and sometimes at the application layer as well.
Gateways forward only those messages that need to go to other networks. Gateways translate
one network protocol into another, translate data formats, and open sessions between
application programs, thus overcoming both hardware and software incompatibilities. ...
More complex gateways even take care of such tasks as code conversion. ... A gateway may
be a stand-alone microcomputer with several NICs and special software, a front end
processor connected to a mainframe computer, or even a special circuit card in the network
server. Each of these three basic types of gateways --- network-to-network,
system-to-network, and system-to-system --- solves a specific interconnection problem."
(Business Data Communications and Networking,  by Fitzgerald and Dennis, 1996, pp. 338-39)

Regards,

Ron Hirst
MSAF Executive Director
tel   +1 805 964 0240
fax  +1 805 692 1905
email [email-masked]
http://www.msaf.org

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Patrice
Calhoun
Sent: Monday, September 13, 1999 8:32 AM
To: [email-masked]
Subject: RE: protocol name?

PatC

---------

---------