Subject: nesting of switch statements

From: "Kam Lee" <[email-masked]>
Date: Fri, 17 Dec 1999 21:52:55 PST

Does CPL allow the nesting of string-switch'es and time-switch'es?

thanks
kam
______________________________________________________
Get Your Private, Free Email at http://www.hotmail.com

---------
This message came from the IETF IPTEL Working Group Mailing List.

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 21 Dec 1999 00:39:57 -0500

Sure. You can do something like:

<string-switch field="from">

   <string is="sip:[email-masked]">

        <string-switch field="to">
            
            <string is="sip:[email-masked]">

               <proxy/>
 
            </string>

        </string-switch>

   </string>

</string-switch>

-Jonathan R.

-- 
Jonathan D. Rosenberg                       200 Executive Drive
Chief Scientist                             Suite 120 
dynamicsoft                                 West Orange, NJ 07052
[email-masked]                     FAX:   (732) 741-4778
http://www.cs.columbia.edu/~jdrosen         PHONE: (732) 741-7244
http://www.dynamicsoft.com

---------