Subject: RE: TRIP

From: James Yu <[email-masked]>
Date: Tue, 28 Dec 1999 16:24:34 -0600

Vance,

Thanks for the explanation.  

The key questions now are whether overlap signaling (e.g., Feature Group-D
over Multi-Frequency facility) is still used somewhere and if used where the
digit collection/enbloc signaling is performed in the existing SCN.  

If overlap signaling is still used (someone please confirm this and indicate
where it is still used) and a call is to be routed from the originating SCN
to the Internet, I guess that the originating GW (SCN-Internet)probably has
to perform the digit collection/enbloc signaling function so that overlap
signaling does not propagate further into the Internet and/or the
destination GW/SCN.  Otherwise, some entities in the Internet must perform
that function.

James

> -----Original Message-----
> From: Vance Shipley [mailto:[email-masked]]
> Sent: Tuesday, December 28, 1999 3:59 PM
> To: James Yu; 'Jonathan Rosenberg'
> Cc: John Mainwaring; Mark Foster; [email-masked];
> [email-masked]
> Subject: RE: TRIP
> 
> 
> 
> James Yu writes:
> }
> }  Overlap dialing probably happens often for international 
> calls where the
> }  switch in the originating country don't know much about 
> the numbering plan
> }  of the destination country.  The criteria to begin 
> processing the received
> 
> Actually no.  The ITU recommendation Q.767 "Application of 
> the ISDN user part
> of CCITT Signalling System No. 7 for international ISDN 
> interconnections" is
> used today on the International Plane between countries 
> public telephone
> networks.
> This recommendation defines how ISUP signaling is to be 
> applied toward the
> application of international gateway interconnections to 
> other countries
> gateways.
> 
> Q.767 does not allow for overlap signaling.  If the local 
> serving office switch
> for the originating subscriber uses overlap signaling to 
> speed up call routing
> then an intermediate switch, or the gateway switch itself, 
> will gather up all
> the digits and send the call forward enbloc.
> 
> Overlap signaling is not used in ANSI ISUP at all.  Overlap 
> signaling was used
> in the days of in band signaling to speed up the delays 
> caused by the relatively
> long duration of the tones used.  One area where it was 
> almost always used was
> in fact international calls.  In the case of FGD signaling in 
> North America when
> an international call was presented the country code was sent 
> first using
> <KP>CC<ST> so that the switch could begin route selection and 
> grab an outgoing
> route while the rest of the digits where pulsed in.  This 
> becomes unnecessary
> when ISUP signaling is used.
> 
> In my mind overlap signaling should never be generated but 
> may have to be
> supported
> when received.  The receiving switch must buffer the received 
> digits until it
> decides
> that all have been received and then forward the call enbloc. 
>  There are two
> methods
> the switch may use to recognize when all digits have been 
> received.  The best is
> when
> the switch has an accurate view of the dialing plan(s).  It 
> would know that
> country
> code XX, city code YYY requires exactly 7 digits in the 
> subscriber number and
> when it
> received all 12 digits it would forward the call enbloc.  If 
> it never received
> enough
> digits it would eventually time out and release the call with 
> a cause code
> indicating
> "address incomplete".  The second method simply applies an 
> inter digit timer and
> maximum
> number of digits.  Digits are buffered until either the 
> maximum expected are
> received,
> the inter digit delay timer expires or an end-of-dial digit 
> is recognized (e.g.
> <ST>
> or '#').  These methods are generally both used where some 
> dial plans are
> recognized
> (e.g. North American Plan) and the rest use the time out.
> 
> 	-Vance
> 
> 
> 

---------
This message came from the IETF IPTEL Working Group Mailing List.

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 28 Dec 1999 17:59:30 -0500

We've discussed this on the list. Several folks pointed out that
European systems support overlap, and it was decided that it was not
reasonable to mandate the originating gateway to do digit collection to
convert this to en-bloc, although it could be optionally done.

-Jonathan R.

-- 
Jonathan D. Rosenberg                       200 Executive Drive
Chief Scientist                             Suite 120 
dynamicsoft                                 West Orange, NJ 07052
[email-masked]                     FAX:   (732) 741-4778
http://www.cs.columbia.edu/~jdrosen         PHONE: (732) 741-7244
http://www.dynamicsoft.com

---------