Subject: RE: Optimistic DAD _again!_

From: "Soliman Hesham" <[email-masked]>
Date: Thu, 19 Feb 2004 19:58:25 -0500

Nick, 

I think optimistic DAD is a very useful (and essential)
tool for mobile nodes in multiaccess links (e.g. WLANs) since 
it eliminates a major delay component. So I'd support this 
draft for a std track RFC. 

I'm also surprised that this work is not addressed in DNA
as I thought it'd be in the heart of the DNA charter. But
regardless, it needs to be done if we want MIPv6 to be useful
in WLANs.

Hesham

 > -----Original Message-----
 > From: [email-masked] [mailto:[email-masked]]On 
 > Behalf Of Nick
 > 'Sharkey' Moore
 > Sent: Thursday, February 19, 2004 3:52 AM
 > To: [email-masked]
 > Subject: Optimistic DAD _again!_
 > 
 > 
 > Hi IPv6ers,
 > 
 > 	You might recall some time ago I stirred up some interest
 > in my Optimistic DAD draft, which seeks to eliminate DAD delay
 > without significantly increasing the risk involved in address
 > collision.  In the meantime it's picked up a couple of independant
 > implementations[1] and a couple of conference publications[2].
 > 
 > 	It was debated fairly thoroughly in MobileIP WG, 
 > (I presented the idea to the WG in San Francisco[3]) but
 > has since been judged to be outside the scope of that group,
 > as it is applies to any situation needing fast address 
 > configuration, not just MobileIP.
 > 
 > 	IPv6 WG seems the proper place for it to be developed
 > further, and I'd like to open it up for debate here with the
 > aim of moving it towards standardization.
 > 
 > The latest version is:
 > 	<draft-moore-ipv6-optimistic-dad-04.txt>
 > ... and it's _still_ only 13 pages long.
 > 
 > Please let me know what you think ... and if there's enough
 > interest maybe we can discuss it further at Seoul.
 > 
 > -----Nick 'sharkey' Moore.
 > 
 > 
 > [1] One by our team at Monash, one by Ed Remmel of Elmic Systems
 > [2] See <http://bluesky.zoic.org/sharkey/> for refs ...
 > [3] ... and for slides from these presentations.
 > -- 
 > Nick Moore, Resarch Fellow        | <[email-masked]>
 > Monash University CTIE	          | 
<http://www.ctie.monash.edu.au/ipv6/>
Australian Telecommunications CRC |
<http://www.telecommunications.crc.org.au/>

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: Jari Arkko <[email-masked]>
Date: Fri, 20 Feb 2004 09:18:28 +0200

I support work on optimistic DAD. I would propose
it to be taken up by the IPv6 WG. Not as a part of
the 2462bis effort but separately.

I would also note that optimistic DAD is useful for
anything that expects a fast attachment time or
frequent movements, not just MIPv6 but also HIP
and MOBIKE.

I believe the reason it was not taken up by the DNA
group was not that they did not want it, but rather
that it was felt that the expertise resides more in
the IPv6 WG.

--Jari

---

From: "Nick 'Sharkey' Moore" <[email-masked]>
Date: Fri, 20 Feb 2004 18:54:42 +1100

> the 2462bis effort but separately.

Thanks Jari, Hesham, James for your interest ... I
hope we'll get a chance to discuss in the WG.

> frequent movements, not just MIPv6 but also HIP

Yep, that's part of the reason it was felt that it was
outside the scope of MobileIP.  Applies even to
nodes which do not care about getting traffic redirected
to them but merely want to send datagrams in a timely
manner.

> that it was felt that the expertise resides more in

Yep.  There is some overlap with DNA ... after all, we
are both trying to do things very quickly and with minimal
signalling.  But DNA is being kept to a very tight focus
(which is probably a good thing).

IPv6 WG is where Optimistic DAD must sink or swim!

-----Nick 'sharkey' Moore  (quietly optimistic)