Subject: Re: Optimistic DAD _again!_

From: Gregory Daley <[email-masked]>
Date: Sun, 29 Feb 2004 21:43:54 +0900

Hi Jinmei, 

There is other work in this area.

Some of it is interesting to the new DNA WG.

----- Original Message -----
From: JINMEI Tatuya / GyRCP0BMQEMjOkgbKEI= 
<[email-masked]>
Date: Sunday, February 29, 2004 3:21 pm
Subject: Re: Optimistic DAD _again!_

> >>>>> On Mon, 23 Feb 2004 21:36:19 +0900, 
> >>>>> "S. Daniel Park" <[email-masked]> said:
> 
> >> One fundamental question that I remember is whether optimizing DAD
> >> really makes much sense while there are other kinds of delays 
> such as
> >> random delay (up to 1 second) for the first RS and random delay at
> >> routers before responding to an RS.  Without addressing the
> >> fundamental question(s), we'd simply restart similar divergent
> >> discussions, waisting lots of energy and time without seeing 
> progress.
> > So, one draft was proposed to clarify what you indicate and I 
> posted it
> > on the IPv6 mailing list.
> > http://www.ietf.org/internet-drafts/draft-park-dna-ipv6dadopt-
> requirement-02.txt 
> 
> Thanks for the pointer, I've read the draft.  Unfortunately, it only
> covers the delay for the first RS, and not others (e.g., the delay at
> routers before responding to RSs).  I respect the effort of you guys,
> but I'd rather want to see a comprehensive scenario before introducing
> additional mechanism to solve a part of the entire issues.

There are a couple of different ideas for tackling these
delays.

The RA response delay (0-500ms) is handled in:

draft-mkhalil-ipv6-fastra
(recently expired, available on watersprings).

We've got implementations and papers on this. 
and can supply further information about this at need.
It's a simple idea: just eliminate the delay.
It works as expected.

The RS delay is currently under study.
The main reason this delay was originally
included in the spec is to protect the network
and other signalling from packet loss and catastrophic
delay.

I'm currently testing with a simulation of up to 30
wireless hosts changing 802.11 base station at the same time.
this is WIP, but I'll see if I have any preliminary
results to show before the end of IETF.

So the work is being done, but not necessarily in IPv6 WG.

Greg

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: PARK SOO HONG <[email-masked]>
Date: Sun, 29 Feb 2004 13:13:28 +0000 (GMT)

>additional mechanism to solve a part of the entire issues.

As Greg pointed out in his response, RA delay is not issue in this thread
for

DAD Optimization and I made a "RQ4: Router Modifications"
of this consideration

although it is not enough...

Regards

Daniel (Soohong Daniel Park)

Mobile Platform Laboratory. SAMSUNG Electronics