Subject: Re: Move forward with scoped literal URI format?

From: [email-masked]
Date: Mon, 4 Apr 2005 11:08:23 -0700 (GMT-07:00)

If the browers recognizes and parses the [] I still do no understand why we just do not use % instead of _ and be done with it. Are we saying that escapable characters can make up part of the zone? If not then there does not appear to be a problem and if so, then don't allow.

--kc

-----Original Message-----
From: 
	JINMEI Tatuya / ???? <[email-masked]>
Sent: Apr 4, 2005 12:33 AM
To: Bill Fenner <[email-masked]>
Cc: [email-masked]
Subject: Re: Move forward with scoped literal URI format?

2. then the browser parser parses the entire URL and extracts
   "v6.fe80::1_de0" and (the trailing) "/" by recognizing "[" and "]"
   as delimiters.

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: "Li, Qing" <[email-masked]>
Date: Fri, 29 Apr 2005 00:44:07 -0700

> 
> So, I guess the appropriate next step for this work is to 
> make consensus on this, which mostly equals to my question -1:
> 
>   -1. are we okay with forcing URL/URI parsers to understand the
>       detailed semantics of the scoped address syntax and to strip the
>       zone ID (+ delimiter) part by itself for the reason because the
>       parsers would already need to do some extra work for the special
>       syntax?
> (slightly modified based on the discussion so far)
> 

   I modified our URL parser to recognize and parse a URL of the form
   http://[v6.fe80::1_fxp0]:8081/readme.txt

   The additional code is straightforward based on my own
   implementation experience. So my answer to the above question
   is a "yes".  

   I chose the "_" as the delimiter and as a few other have noted, 
   this character disappears in my mail client.

   While testing with Firefox, interestingly enough Firefox appears to 
   be the only browser that allows IPv6 address in the HTTP Proxy
setting,
   but the browser actually puts 
   "GET http://[fe80::2b0:d0ff:fe25:689%4]/readme.txt HTTP/1.1
    HOST: [fe80::2b0:d0ff:fe25:689%4]"
   on the wire. I've filed a bug against it.

   -- Qing

---

From: "Li, Qing" <[email-masked]>
Date: Fri, 29 Apr 2005 00:49:12 -0700

> 
> > I don't understand this use case.  Assuming I have a router 
> > and it's manual says type in 
> > http://<some-link-local-address><some-delimiter>de0/
> > 
>

	I guess in that case that would be a doc error from
	that vendor. I would expect the doc to say something like
	http://<some-link-local-addr><the-delimiter><"name of your nic">

> 
> A very sophisticated user might know about scopes and be able 
> to add an appropriate zone id in some cases, but for the 
> general user, this is well beyond what can be reasonably expected.
> 
> So I don't see how literals with zone ids play a useful part 
> of simplifying config, as in the home router config case.
> 

	I guess a general user that has little understanding of 
	zone id is probably not going to be able to config that 
      home router correctly... So IMHO the simplication in config
	would apply to many but not all, as you say, thus justifying
	its usefulness.

	-- Qing