Subject: Re: Anycast support in draft-ietf-ipv6-addr-arch-v4-02.txt

From: Mark Andrews <[email-masked]>
Date: Thu, 07 Apr 2005 14:41:54 +1000

One of my collegues pointed out I wasn't clear enough.

	The restictions on using a anycast address as a packet
	source definitely need to be relaxed.

	Mark
--
Mark Andrews, ISC
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE: +61 2 9871 4742                 INTERNET: [email-masked]

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: "Manfredi, Albert E" <[email-masked]>
Date: Thu, 14 Apr 2005 18:02:33 -0400

Seems logical to me as well. If multicast is a specialized and complicated topic worthy of a separate RFC, I can easily accept that anycast should be given equal rights.

Bert

> -----Original Message-----
> From: Bob Hinden [mailto:[email-masked]]
> 
> Rob,
> 
> >Anycast is complicated, and the complications are not specific to
> >IPv6.  It really would be doing the world a favor if the IPv6 WG were
> >to get rid of the language in the IPv6 address architecture doc that
> >places IPv6-specific restrictions on anycast, then let the GROW WG
> >handle the general anycast problem.
> 
> OK, I think this makes sense.
> 
> The proposal is then to remove the following text from the 
> end of Section 
> 2.6 the document:
> 
>     There is little experience with widespread, arbitrary use 
> of Internet
>     anycast addresses, and some known complications and hazards when
>     using them in their full generality [ANYCST].  Until more 
> experience
>     has been gained and solutions are specified, the following
>     restrictions are imposed on IPv6 anycast addresses:
> 
>        o An anycast address must not be used as the source 
> address of an
>          IPv6 packet.
> 
>        o An anycast address must not be assigned to an IPv6 host, that
>          is, it may be assigned to an IPv6 router only.
> 
> This would mean we would not try to describe the general issues with 
> anycast usage in the document.  I agree this makes sense 
> because the issues 
> are not specific to IPv6, there is now a body of experience 
> with anycast 
> usage, and the GROW working group is working in this area.
> 
> Is everyone else OK with this proposed change?
> 
> Bob