Subject: Re:Re: [ipv6] Request for your comments: draft-jian-ipv6-meaheader-00

From: zhangjian 24185 <[email-masked]>
Date: Tue, 25 Oct 2005 11:14:04 +0800

Hi Malone,

Sorry for reply so late.
IPMP is a measruement protocol that provides measurement methodology for IPv4 and IPv6.
Measurement information is carried message body.
This draft only provides a extended header used to carry on the measurement information.
It does not define the measurement methodology. So everyone can develop the measurement
methodology based on this extended header. They can define new measurement options as needed.
Also, IPMP can provides a new IPv6 measurement methodology base on this extended header.

***************************************************************************************
Declaration:
This email and any files transmitted with it are confidential and intended solely for 
the use of the individual or entity to whom they are addressed. If you have received 
this email in error please notify the sender. Any offers or quotation of service are 
subject to formal specification. Errors and omissions excepted.  Please note that any 
views or opinions presented in this email are solely those of the author and do not 
necessarily represent those of Huawei Technologies Co. Ltd..  Finally, the recipient 
should check this email and any attachments for the presence of viruses.  
Huawei Technologies Co. Ltd. accepts no liability for any damage caused by any 
virus transmitted by this email.
**************************************************************************************

----- 原邮件 -----
从: David Malone <dwmalone=[email-masked]>
日期: 星期四, 十月 20日, 2005 下午4:38
主题: Re: [ipv6] Request for your comments: draft-jian-ipv6-meaheader-00

> On Wed, Oct 19, 2005 at 05:36:48PM +0800, zhangjian 24185 wrote:
> > Dear all,
> > 
> > I have submitted the draft, draft-jian-ipv6-meaheader.The purpose
> > of this document is to introduce a measurement header. Measurement
> > header is a new type of IPv6 extended header used for network
> > measurement. The information needed by measurement carried in
> > measurement header. The parameters can be calculated based on these
> > information.
> 
> It would probably be useful to say how your measurement protocol
> relates different from other proposals, like:
> 
> 	http://watt.nlanr.net/AMP/IPMP/
> 
> (there's a draft and other information there). You seem to cover
> similar ground, though there are some interesting differences.
> 
> 	David.
> 

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: zhangjian 24185 <[email-masked]>
Date: Tue, 25 Oct 2005 14:14:15 +0800

Thanks for your comments. Sorry for so late to reply.

> As long as you imagine that this is only used between consenting 
> adults in private experiements, this would be an OK approach. (As 
> such 
> it might or might not need to be published in the IETF, but if 
> you'd 
> want to do so, direct submission to the RFC-editor for either 
> informational or experimental RFC might be best.)
> 
> On the other hand, if you are interested in wider applicability, 
> you 
> should probably seriously evaluate the different tradeoffs where 
> you 
> want to perform the measurements.  Using an extension header might 
> be 
> a very awkward place to do that, and might interfere with a lot of 
> other operational things (like firewalls).  Just using an upper-
> layer 
> protocol could possibly do the job.
Yes, using an upper-layer protocol could do the job. But for extended 
measurement header, combined with upper-layer protocol, we can finish
the measurement without interrupt the service. So we think it is worthy
to wider applicability.
 
> Note that only (certain) hop-by-hop options are expected to be 
> inspected by intermediate nodes.  This header type has a subtype 
> "this 
> message header need to be processed hop-by-hop".  This has an 
> architectural issue, but again, if you want to use this for very 
> limited measurements only, feel free..
Yes, the hop-by-hop option is only used for measurements.

----- 原邮件 -----
从: Pekka Savola <[email-masked]>
日期: 星期三, 十月 19日, 2005 下午11:46
主题: Re: [ipv6] Request for your comments: draft-jian-ipv6-meaheader-00

> On Wed, 19 Oct 2005, zhangjian 24185 wrote:
> > I have submitted the draft, draft-jian-ipv6-meaheader.The 
> purpose of 
> > this document is to introduce a measurement header. Measurement 
> > Would you mind give me some comments?
> 
> You use the standard TLV format, good.
> 
> As long as you imagine that this is only used between consenting 
> adults in private experiements, this would be an OK approach. (As 
> such 
> it might or might not need to be published in the IETF, but if 
> you'd 
> want to do so, direct submission to the RFC-editor for either 
> informational or experimental RFC might be best.)
> 
> On the other hand, if you are interested in wider applicability, 
> you 
> should probably seriously evaluate the different tradeoffs where 
> you 
> want to perform the measurements.  Using an extension header might 
> be 
> a very awkward place to do that, and might interfere with a lot of 
> other operational things (like firewalls).  Just using an upper-
> layer 
> protocol could possibly do the job.
> 
> Note that only (certain) hop-by-hop options are expected to be 
> inspected by intermediate nodes.  This header type has a subtype 
> "this 
> message header need to be processed hop-by-hop".  This has an 
> architectural issue, but again, if you want to use this for very 
> limited measurements only, feel free..
> 
> (I didn't really review the spec, I just looked at the parts which 
> are 
> most likely to be problematic.)
> 
> -- 
> Pekka Savola                 "You each name yourselves king, yet the
> Netcore Oy                    kingdom bleeds."
> Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings
>

---

From: Geraldine Texier <[email-masked]>
Date: Wed, 26 Oct 2005 14:39:32 +0200

> In your previous mail you wrote:
> 
>    Yes, it is strongly discouraged to define new extension. But if it
>    is necessary, it should not be forbidden.
> 
> => good summary: now you have to prove a new extension header is really
> necessary!
> 
>    So it may be better to organize the informations to an extended
>    header, if it is necessary.  It not only simplify the processing of
>    program, but also improve the efficiency of program.
> 
> => I don't buy the argument: the processing of an option is not so more
> expensive than the processing of an extension header. The only real
> difference between options and extension headers is the length of an
> option is more limited...

which is well suited for measurement since it is necessary to limit the 
interference of the measurement data transported within the packet in 
order to have a relevent measurement.

We developped an IPv6 measurement infrastructure based on the 
utilization of Destination options. It works well and, since we only 
transport the sending timestamp, we don't need a special extension.

I'll be happy to collaborate.

Best Regards,
Geraldine Texier

> I propose to only ask for a (or a few) measurement option types,
> leaving the internal layout to private experiments... Note a RFC
> is needed to get an official option type.
> 
> Regards
> 
> Francis.Dupont at enst-bretagne.fr
> 
> ipv6 at ietf.org

-- 
Geraldine TEXIER

GET/ENST Bretagne - RSM Department
2 rue de la Châtaigneraie - CS 17607
35576 Cesson Sevigné Cedex- France
Tel: +33 299 127 038 - Fax: +33 299 127 030