Subject: [ipv6] Request for your comments: draft-jian-ipv6-meaheader-00

From: zhangjian 24185 <[email-masked]>
Date: Wed, 19 Oct 2005 17:36:48 +0800

Dear all,

I have submitted the draft, draft-jian-ipv6-meaheader.The purpose of this document is to introduce a measurement header. Measurement header is a new type of IPv6 extended header used for network measurement. The information needed by measurement carried in measurement header. The parameters can be calculated based on these information.

Would you mind give me some comments?

Best reagrds,

Jian Zhang
Huawei Technologies

***************************************************************************************
Declaration:
This email and any files transmitted with it are confidential and intended solely for 
the use of the individual or entity to whom they are addressed. If you have received 
this email in error please notify the sender. Any offers or quotation of service are 
subject to formal specification. Errors and omissions excepted.  Please note that any 
views or opinions presented in this email are solely those of the author and do not 
necessarily represent those of Huawei Technologies Co. Ltd..  Finally, the recipient 
should check this email and any attachments for the presence of viruses.  
Huawei Technologies Co. Ltd. accepts no liability for any damage caused by any 
virus transmitted by this email.
**************************************************************************************

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: Pekka Savola <[email-masked]>
Date: Wed, 19 Oct 2005 18:46:48 +0300 (EEST)

On Wed, 19 Oct 2005, zhangjian 24185 wrote:
> I have submitted the draft, draft-jian-ipv6-meaheader.The purpose of 
> this document is to introduce a measurement header. Measurement 
> header is a new type of IPv6 extended header used for network 
> measurement. The information needed by measurement carried in 
> measurement header. The parameters can be calculated based on these 
> information.
>

You use the standard TLV format, good.

As long as you imagine that this is only used between consenting 
adults in private experiements, this would be an OK approach. (As such 
it might or might not need to be published in the IETF, but if you'd 
want to do so, direct submission to the RFC-editor for either 
informational or experimental RFC might be best.)

On the other hand, if you are interested in wider applicability, you 
should probably seriously evaluate the different tradeoffs where you 
want to perform the measurements.  Using an extension header might be 
a very awkward place to do that, and might interfere with a lot of 
other operational things (like firewalls).  Just using an upper-layer 
protocol could possibly do the job.

Note that only (certain) hop-by-hop options are expected to be 
inspected by intermediate nodes.  This header type has a subtype "this 
message header need to be processed hop-by-hop".  This has an 
architectural issue, but again, if you want to use this for very 
limited measurements only, feel free..

(I didn't really review the spec, I just looked at the parts which are 
most likely to be problematic.)

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings

---

From: David Malone <dwmalone=[email-masked]>
Date: Thu, 20 Oct 2005 09:38:57 +0100

On Wed, Oct 19, 2005 at 05:36:48PM +0800, zhangjian 24185 wrote:
> Dear all,
> 
> I have submitted the draft, draft-jian-ipv6-meaheader.The purpose
> of this document is to introduce a measurement header. Measurement

It would probably be useful to say how your measurement protocol
relates different from other proposals, like:

	http://watt.nlanr.net/AMP/IPMP/

(there's a draft and other information there). You seem to cover
similar ground, though there are some interesting differences.

	David.

---

From: Francis Dupont <[email-masked]>
Date: Sat, 22 Oct 2005 18:22:48 +0200

In your previous mail you wrote:

=> a new extension header is likely to be problematic today because
many boxes on paths look at the contents of packets (even they should
not at the exception of the header, the hop-by-hop option header and
routing headers where they are intermediate destinations). So in fact
the definition of new extension headers is strongly discouraged.

BTW I can't see why you need a new extension header: some options,
in the hop-by-hop option header for hop-by-hop measurements and in
the destination option header for other cases, should do the job and
option types encode the behavior for unrecognized options, the mutability,
etc. We use here a measurement option without problems (I can give
some pointers to our measurement people).

Regards

[email-masked]