Subject: Bootsrap mecanism new PIM Neighbor

From: "António Amaral" <[email-masked]>
Date: Thu, 01 Dec 2005 23:15:50 +0000

Dear All,

After draft-ietf-pim-sm-bsr-05.txt there is a section

----
3.5.  Unicasting Bootstrap Messages to New and Rebooting 
Routers

To allow new or rebooting routers to learn the RP-Set 
quickly, when a
Hello message is received from a new neighbor, or a Hello 
message with a
new GenID is received from an existing neighbor, one 
router on the LAN
unicasts a stored copy of the Bootstrap message for each 
admin scope
zone to the new or rebooting router.
(....)
--------

What is the motivation for this behaviour? With a common 
bootstrap message new router also learn the RP-Set 
quickly, am I right?
In my opinion when a new router placed on the LAN sends a 
PIM Hello message, one router on the LAN could simply send 
a bootstrap message and new router also learn the RP-Set 
quickly.

Thanks in advance
Best Regards

AA
--------------------------------------------------------
    António Manuel Nunes C. Amaral
    Instituto de Telecomunicações - Pólo de Aveiro
    Campus Universitário
    3810-193 AVEIRO - PORTUGAL
    Telef. 234 - 377900
    Fax. 234 - 377901
    e-mail: [email-masked]
    Telef. directo. 234 - 377906
---------------------------------------------------------

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: Stig Venaas <[email-masked]>
Date: Sat, 3 Dec 2005 22:56:55 +0100

> a bootstrap message and new router also learn the RP-Set 

That's what happens. The text in bsr spec, does exactly what
you write above. When a new router send a PIM hello, an
existing router may unicast a BSM to it.

Stig