Subject: RE: Fragment Header

From: "Vishwas Manral" <[email-masked]>
Date: Mon, 5 Dec 2005 01:38:30 -0800

Hi Radhakrishnan,

I think that having a fragment header does not mean that it is a fragment. The document for SIIT RFC2765, in Section 3 states that: -

"Also, when the IPv4 sender does not perform path MTU discovery the translator MUST always include an IPv6 fragment header to indicate that the sender allows fragmentation.  That is needed should the packet pass through an IPv6-to-IPv4 translator."

That is why I think that having a fragment header does not mean that it is a fragment. It just signals the equivalent of the DF bit in case the packet is translated to IPv4.

Thanks,
Vishwas
________________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Radhakrishnan.S
Sent: Friday, November 25, 2005 7:32 AM
To: [email-masked]
Subject: Re: Fragment Header

That said; how should the case where we have the fragment header and both the Fragment Offset and the M flag is 0 be treated?
=> The one and only fragment.  :-) Doesnt make sense unless u want to test the reassembling capability of the receiver of the fragments. The presence of a fragment header is used in NAT-PT IPv4->IPv6 to indicate that the packet is fragmentable. (case where DF bit is NOT set in IPv4 header).

Why do we need the M flag in the "fragment header" at all for IPv6? Having the fragment header itself would tell it's a fragment and would distinguish between the first fragment and a non-fragment.
=> M flag is used to distinguish last frag from others!!!! Its used for identifying the last frag when computing the length during reassembly. 

Vishwas Manral wrote: 
Hi folks,
 
I have a doubt regarding the fragment header. Why do we need the M flag in the "fragment header" at all for IPv6? Having the fragment header itself would tell it's a fragment and would distinguish between the first fragment and a non-fragment.
 
In IPv4 we did not have a fragment header, so the M flag was logical to have for distinguishing the first and a non fragment.
 
That said; how should the case where we have the fragment header and both the Fragment Offset and the M flag is 0 be treated?
 
Thanks,
Vishwas

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: Doo Timbir <[email-masked]>
Date: Mon, 5 Dec 2005 09:40:38 +0000 (GMT)

Vishwas,
   
  It appears our reasoning is in the same direction.I definitely think likewise too!
   
  Sincerely,
  Doo Timbir.

Vishwas Manral <[email-masked]> wrote:
  Hi Radhakrishnan,

Thanks,
Vishwas

Vishwas Manral wrote: 
Hi folks,

 
 
Thanks,
Vishwas

		
---------------------------------
  Win a Yahoo! Vespa NEW - Yahoo! Cars has 3 Vespa LX125s to be won Enter Now!

---

From: "S.Radhakrishnan" <[email-masked]>
Date: Mon, 05 Dec 2005 15:40:10 +0530

yes, right. thats what i meant too. :-) the purpose is only for indication.

"the presence of a fragment header is used in NAT-PT IPv4->IPv6 to *indicate that the packet is fragmentable."

*the error i made is "NAT-PT IPv4->IPv6" which should have been "NAT-PT IPv6->IPv4". error regretted! :-)

regards
radhakrishnan*
*