Subject: how to select the sender ipv6 address from the list of ipv6 address assinged to the interace

From: "Anjali Gajendragadkar" <[email-masked]>
Date: Tue, 20 Nov 2007 16:04:28 +0530

The interface of my linux machine show three addresses
1. Static IPv6 address
2. Statless autoconfigured IPv6 address (using RA)
3. Link local address

when i initiate a ping from this machine static address is selected as
the source for the ping command
is there a way to change source address used?

regards
Anjali

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: "Erik Kline" <[email-masked]>
Date: Tue, 20 Nov 2007 09:39:30 -0800

"man ping6"?

       -I interface address
              Set  source address to specified interface address. Argument may
              be numeric IP address or name of device. When pinging IPv6 link-
              local address this option is required.

That's a capital "i", fwiw.  YMMV.